[ROM][OFFICIAL][pioneer][12] LineageOS 19

Search This thread


Oct 15, 2018
Even if Lineage will sort out the 19.1 (when?), you can choose divest OS Mobile. The xa2 is listed there and people are using it with divest. Nobody is forced to choose another device, and nobody has to stop using the xa2 when there are no more security updates for our device. Unfortunately divest os is not well known like iodeOS/etc/etc. I use divest with my nexus 7 wifi (2013) and appreciate it very much; privacy and security is highly considered. Every month you get still a security update and CVE´s are fixed. But again: without the work of LUK1337 that would not be possible for the xa2 and I still enjoy and appreciate LUKs lineage 19 on my phone.
  • Like
Reactions: Guttergorm


Senior Member
May 25, 2017
Last edited:


Nov 6, 2021
Sony Xperia X
Sony Xperia XA2
Wouldn't that affect ability to multitask?
I don't think so... I downclocked my processor some week ago at 500-750Mhz with Adiutor ( I was changing the governor to "performance" only with FL Studio, Guru Video Maker or to read a big HD movie with a lot of compression, that's was to economise energy ). Then I'had updated Iodé Os to 3.4-2 ( lineage Os 19.1 - android 12 ), the update unroot my phone and it's still working blocked at the low range of frequency ( governor = powersave ) ,because adiutor only workn rooted mode.
That's why I've limited the process at first and it's still good. Anyway I don't do a lot of multitasking with my phone, I don't have GAFAM aps runing in background.


Senior Member
Jan 1, 2010
That's the reason, why I'm building LOS17.1 for pioneer by myself as "UNOFFICIAL", month by month to have the latest security level of the OS. This is running much smoother as 19.1 on this old device (and I don't need any of the gimmicks in LOS18 or LOS19).

Thx for sharing ur rom build. gonna try it today after i read how to flash sony phones.
any thing not working or known issues on ur LOS17.1 rom? calls camera bluetooth etc.
i haven't mod any android phone for years, and hoping this will be my first rom after like 6 years since samsung note 4 and note 3.
thx for sharing this. gonna mod za2 and give it to my brother and then buy used zx2 compact for my self. which i hope it will be perfect for me. my hands is small and big phones slip from my hands so often that i stopped buying expansive phones. but since i tried sony xa 2 last year. man this is a brick phone. it endured the abuse i did to it.
but the zx2 compact is even better since i really wished to have a good phone but smaller size and wasnt aware there is any beside the asus zen phone and iphone mini


Oct 26, 2022
I use this ROM, for 4 moths. I am impressed. Support is unpaid. Work of developers big. Cool!
I hope Iodé will stay constant, until next generation drop-down opposite to this bringing-back..

Is there a simple way to replace radio signal drivers? Stock ROM (Android 8 - Orange) has it 2x times better.. :rolleyes:
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 13

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project, with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS GitHub organization. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review. You can also view the changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel, or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    @samhhmobil Are you providing your personal built here at xda?
    @Guttergorm --- if you need it... here's my latest personal unofficial build:


    I think, this is not the right thread, because this here is for 19.1 (and you'll get an unofficial 17.1 there...)
    Does SMSs, Wi-Fi and other stuff work also without GApps or is it required to install it?
    Is the ROM still under development?
    Thank You in advance.
    Everything you asked for works absolutely fine without any issues.
    You don't need gApps for that.

    I can't say how active the developers are, but an update was released just yesterday (16.04)
    Thanks a lot @LuK1337
    I've got one issue with TWRP, but I don't know if this is related to my dirty flash or some issue with TWRP itself:
    I've tried to update the second/other partition of the A/B, but on trying to boot to TWRP with fastboot command, TWRP does not recognize the encryption and shows weird folders and files.
    I was using the latest version of TWRP (2.6.1_9)
    [...]Has anyone tried to go to TWRP after updating?
    You're right, since installing LOS 19.1, TWRP (even the newest one, but the older ones too) cannot decrypt the user data.

    Bit confused and wondered if I am I right in thinking I should use these instructions to upgrade from 18.1. Never upgraded a phone quite this new before. :)
    I would recommend that you start from scratch i.e. reset the phone, clear everything and start