• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][pioneer][8.1] LineageOS 15.1

Search This thread

Nikiz

Senior Member
Feb 14, 2014
221
74
26
Kauhajoki
I have a problem.. None of the custom ROMs seem to work anymore after reflashing the stock firmware. I can flash the ROM boots fine, but when I unlock the screen, SystemUI crashes and the phone locks up for a while and reboots. Stock ROM works fine.

The phone is the H4113 variant. (1312-4159 CDA, Nordic)
I used LineageOS 15.1 for a while before switching back to the stock firmware. However, XperiFirm didn't have the CDA version I had. I flashed the (1312-8863, Nordic) 50.1.A.13.123 / R14A instead with newflasher.

Everything seems fine, the stock ROM works as it should.

However, none of the custom ROMS seems to work anymore. SystemUI crashes after unlocking the screen, sometimes before the lock screen shows up. The phone is unresponsive for a while and then it reboots. I tried LineageOS 15.1, AOSPExtended 5.7, AOSPExtended 6.2 and Resurrection Remix 7. Each ROM behaved similarly. I was unable to get any logcat logs, because I can't get to settings.

I have tried reflashing the stock firmware several times without any effect. I tried flashing Sony oem binaries with fastboot. I tried reflashing a different stock firmware (1312.1454 Central Europe) 50.1.A.13.123 / R8A. Nothing seems to make any difference. Any ideas?
 

LuK1337

Recognized Developer
Jan 18, 2013
8,479
16,948
Samsung Galaxy S III I9300
Moto G 2014
I have a problem.. None of the custom ROMs seem to work anymore after reflashing the stock firmware. I can flash the ROM boots fine, but when I unlock the screen, SystemUI crashes and the phone locks up for a while and reboots. Stock ROM works fine.

The phone is the H4113 variant. (1312-4159 CDA, Nordic)
I used LineageOS 15.1 for a while before switching back to the stock firmware. However, XperiFirm didn't have the CDA version I had. I flashed the (1312-8863, Nordic) 50.1.A.13.123 / R14A instead with newflasher.

Everything seems fine, the stock ROM works as it should.

However, none of the custom ROMS seems to work anymore. SystemUI crashes after unlocking the screen, sometimes before the lock screen shows up. The phone is unresponsive for a while and then it reboots. I tried LineageOS 15.1, AOSPExtended 5.7, AOSPExtended 6.2 and Resurrection Remix 7. Each ROM behaved similarly. I was unable to get any logcat logs, because I can't get to settings.

I have tried reflashing the stock firmware several times without any effect. I tried flashing Sony oem binaries with fastboot. I tried reflashing a different stock firmware (1312.1454 Central Europe) 50.1.A.13.123 / R8A. Nothing seems to make any difference. Any ideas?
Join my irc channel, maybe I'll have some ideas.
(see my signature)
 

xperiaf

Senior Member
Dec 1, 2018
226
6
in fact, i thought that 15.1 is better Design than 16.0 ( for UI ).

more directly, i pretty love Oreo UI design instead of Pie.

for me, i cannot understand what Google's design-preference is. Big Round ..?

awsl.

Sent from my Sony Xperia XZ1 using XDA Labs
 

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • IMS
    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][8.1] LineageOS 15.1, ROM for the Sony Xperia XA2

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2018-06-19
    Last Updated 2019-11-01
    10
    ~ https://review.lineageos.org/218506 ~

    Starting from tuesday pioneer is officially supported device. Because official builds are signed with different key you'll have to wipe data before switching to them unless you feel smart enough to follow https://wiki.lineageos.org/signing_builds.html#using-a-script.

    Also since this change ~ https://review.lineageos.org/219073 you no longer have to care about firmware on slot 'B' :3
    10
    So here's what I did for now:
    - LA.UM.6.2.r1-10300-sdm660.0 -> merged,
    - Call recording -> merged @ https://review.lineageos.org/222506,
    - Power-off alarms -> doesn't work at all,
    - Headset mic -> fixed @ https://review.lineageos.org/223191,
    - HW keymaster×gatekeeper -> https://review.lineageos.org/223180 and https://review.lineageos.org/223184,
    - ANT+ -> won't work.

    I'll let you know when I decide to re-enable builds.
    8
    How to flash latest firmware

    [ protip: Currently Lineage builds depend on latest 8.0 firmware (50.1.A.13.123), they will not boot up on 50.2.A.0.* or newer ]

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - kernel_X-FLASH-ALL-18AE_0x00.hash
    - kernel_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?