• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][OFFICIAL][pioneer][9] LineageOS 16.0

Search This thread
Feb 22, 2015
5
0
When I do search in the settings for "high touch" I see the option for high touch sensitivity but it's not actually in the settings? Is it disabled or something to where we can't use it?
 
Feb 22, 2015
5
0
High touch sensitivity.

uk6RUDn.png
 

malerocks

Senior Member
Mar 6, 2018
434
102
I haven't tried installing lineage thru official twrp since the version 3.2.3-0 failed, i just used lineage twrp, i guess I'll try the official tomorrow for flashing
Could by my ignorance but I don't think there is anything called as lineage TWRP. It's just TWRP. Lineage of course recommends it as the recovery of choice but they don't have a special version.
 

davidhozic

Senior Member
Nov 18, 2017
430
68
So you just admitted to be using oldest 3.2.3 out there...

No...
I only tried installing lineage thru 3.2.3-0 and when it failed i didn't try agan, soon after i downloaded the latest twrp I assumed it'd be the same and just didn't bother trying.

---------- Post added at 04:46 PM ---------- Previous post was at 04:21 PM ----------

Could by my ignorance but I don't think there is anything called as lineage TWRP. It's just TWRP. Lineage of course recommends it as the recovery of choice but they don't have a special version.

By "lineage twrp" i mean the "twrp-3.2.3-0-pioneer-lineage" modified by Luk
 

LuK1337

Recognized Developer
Jan 18, 2013
8,453
16,868
Samsung Galaxy S III I9300
Moto G 2014
Is there anyone who has working VoLTE on my official builds? If so what carrier×country are you in?
Someone sent me screenshot that it supposedly works for them and I was 100% sure it was broken lol.

protip: You can check if VoLTE is registered by "calling" *#*#4636#*#* then Phone information -> ~ 3 dots ~ -> IMS Service Status; if it says that Voice over LTE is "Available" then it's working.
 

mirco_pa

Senior Member
Oct 19, 2012
417
135
Is there anyone who has working VoLTE on my official builds? If so what carrier×country are you in?
Someone sent me screenshot that it supposedly works for them and I was 100% sure it was broken lol.

protip: You can check if VoLTE is registered by "calling" *#*#4636#*#* then Phone information -> ~ 3 dots ~ -> IMS Service Status; if it says that Voice over LTE is "Available" then it's working.
Not available here in that menu. I'm in Italy and I'm using Iliad as mobile carrier.
 

iHusky

Senior Member
Mar 5, 2012
559
49
32
Mikołów
Is there anyone who has working VoLTE on my official builds? If so what carrier×country are you in?
Someone sent me screenshot that it supposedly works for them and I was 100% sure it was broken lol.

protip: You can check if VoLTE is registered by "calling" *#*#4636#*#* then Phone information -> ~ 3 dots ~ -> IMS Service Status; if it says that Voice over LTE is "Available" then it's working.

Carrier: Play Country:poland

Not working
 

davidhozic

Senior Member
Nov 18, 2017
430
68
Is there anyone who has working VoLTE on my official builds? If so what carrier×country are you in?
Someone sent me screenshot that it supposedly works for them and I was 100% sure it was broken lol.

protip: You can check if VoLTE is registered by "calling" *#*#4636#*#* then Phone information -> ~ 3 dots ~ -> IMS Service Status; if it says that Voice over LTE is "Available" then it's working.

The magisk module enables the setting for it but i don't think my carrier supports it
 

moroi

Senior Member
Aug 5, 2018
51
7
Is there anyone who has working VoLTE on my official builds? If so what carrier×country are you in?
Someone sent me screenshot that it supposedly works for them and I was 100% sure it was broken lol.

protip: You can check if VoLTE is registered by "calling" *#*#4636#*#* then Phone information -> ~ 3 dots ~ -> IMS Service Status; if it says that Voice over LTE is "Available" then it's working.

Voice over LTE: Unavailable
this is Vodafone, Romania
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][9] LineageOS 16.0, ROM for the Sony Xperia XA2

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2018-08-30
    Last Updated 2020-02-28
    14
    How to flash latest firmware

    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    7
    @Marteng69 here is what i did -> i was stucked on pie + flickering screen (model h3113):

    1. i used emma (https://developer.sony.com/develop/open-devices/get-started/flash-tool), just install and run it, boot your phone in flash mode (vol down + usb connect = green light). then the app will recognize your phone (assuming you have drivers installed) and give you phone info. on the right side download and flash offered firmware (at the moment there is the uk oreo one, download it and you'll have it in case it's replaced with pie). flash the complete firmware (the "Software Update Content Erase" image) and reboot after flashing completed

    2. boot the phone, let it boot up for a few minutes then turn it off with holding power + vol up for a few secs (let it vibrate 3 times to make sure it's off)

    3. then boot it in fastboot mode (vol up + usb connect = blue light) and then via cmd run "fastboot boot 1d66175c6ce8e04865d041cbcac8ba3013a02b1e.img" (please check your exact .img name)

    4. that's it, the phone should boot (normal looking) twrp and then reboot your phone and... say thanks to @LuK1337 ;)
    7
    Hello Luk,

    are you going to develop LineageOS 17 for this Device?

    Until 50.2.* kernel source is out I'm not planning to do anything.

    btw see https://talk.sonymobile.com/t5/Kernel/50-2-A-0-400-kernel-source/td-p/1390917 ^^
    6
    Yes, 2.4 works fine. I'm 100% sure that 5GHz used to work tho, but nevermind. At least now I have hotspot working lol

    ...yeah I booted some old ass kernel HEAD and it works there. Looks like i'm going to have fun time finding the change that broke it...

    EDIT: Should be working again in next builds ^.^