• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][OFFICIAL][pioneer][9] LineageOS 16.0

Search This thread

cryofmankind09

New member
Aug 10, 2013
3
0
Titanium backup issue

With recomended root and su app the Titanium Backup lose root access after time, don`t know why and don`t know how to restore. Titanium Backup recquires Magisk, so need to one more rooting
 

wtflawlxd

Member
Sep 4, 2014
28
8
Device: H3113 - Italy
I've successfully installed LineageOS on my new XA2, following these steps:

  • Original stock system OTA upgrade to 50.2.A.0.400.
  • Unlocked bootloader following sections 2 and 4 of this guide.
  • Flashed LineageOS following from point 10 to the end of this guide, using twrp-3.3.1-3-pioneer.img and lineage-16.0-20191117-nightly-pioneer-signed.zip.

I report them here because I've found a lot of posts asking how to start.
Thank you to all the developers that contributed :D
I've noticed that compass does not work.
Is post #698 still relevant? I don't have root, so I've tried using adb root while in TWRP. However, /mnt/vendor is empty, even though I've mounted it in TWRP. Do I have to install root or is there another way to do what's written in #698 from TWRP?
Code:
pioneer:/ # ls -l /system/persist
lrw-r--r-- 1 root root 19 2009-01-01 00:00 /system/persist -> /mnt/vendor/persist
pioneer:/ # ls -l /mnt/vendor
total 0
My mistake, after a couple reboots it works fine, I did not run any command. However, would someone be so kind to explain why what I did was wrong? I have another question: why does TWRP says data is encrypted? How does it work? I had another phone that worked differently.
 
Last edited:

Xotni

New member
Dec 22, 2019
2
0
Hello,

I just bought a Sony XA2 for my girlfriend (mainly because it is not too big and it has lineage OS support).

But I have an issue while installing opengapps : I follow every step of the tutorial, but after installing lineage OS (via adb sideload) it seems that TWRP has been overridden. When I try adb reboot sideload I get a lineage OS recovery, and sideloading my opengapps gets me a code 70 (insufficient system partition, from my search).

On my other phone (also on Lineage OS), I always have TWRP which has a more features than the lineage OS one (for instance, resizing system partition :) ). What do I need to do in order to keep TWRP? I have tried to re-flash TWRP over lineage OS but I was not successful (bootloop).

Thanks a lot!
 
Last edited:

inestion

Senior Member
Jun 19, 2012
216
42
Hello,

I just bought a Sony XA2 for my girlfriend (mainly because it is not too big and it has lineage OS support).

But I have an issue while installing opengapps : I follow every step of the tutorial, but after installing lineage OS (via adb sideload) it seems that TWRP has been overridden. When I try adb reboot sideload I get a lineage OS recovery, and sideloading my opengapps gets me a code 70 (insufficient system partition, from my search).

On my other phone (also on Lineage OS), I always have TWRP which has a more features than the lineage OS one (for instance, resizing system partition :) ). What do I need to do in order to keep TWRP? I have tried to re-flash TWRP over lineage OS but I was not successful (bootloop).

Thanks a lot!

After flashing the ROM you should reboot to bootloader and then "fastboot boot twrp.img" again, don't use the lineage recovery
 

size43

New member
Aug 18, 2017
4
0
Recently `fastboot boot twrp.img` has stopped working for me (I used twrp for backup). Could that be caused by one of the OTA updates? Last time it worked was 14th of December.

Fastboot now just says `remote: Command not supported` for boot and getvar.

Edit: Problem solved, don't use USB3 ports. I was just using the right ports by chance up until now.
 
Last edited:

cxantia

Member
Jan 20, 2020
13
0
Sony Xperia Z5 Compact
OnePlus X
Hi, i have a Xerria XA2 Model H3113 with the lineage-16.0-20200118-nightly-pioneer-signed.zip installed.
I can't play mp3 or mp4 files ("the Device dont't support that files" comes from the APP). I lost my TA patition at unlock the bootloader.
Is it posible, that i must have the TA partion with the keys to play such files?
Best Regarts from Gernay
 

xperiaf

Senior Member
Dec 1, 2018
226
6
Hi, i have a Xerria XA2 Model H3113 with the lineage-16.0-20200118-nightly-pioneer-signed.zip installed.
I can't play mp3 or mp4 files ("the Device dont't support that files" comes from the APP). I lost my TA patition at unlock the bootloader.
Is it posible, that i must have the TA partion with the keys to play such files?
Best Regarts from Gernay

what's your media player? try change one.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][9] LineageOS 16.0, ROM for the Sony Xperia XA2

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2018-08-30
    Last Updated 2020-02-28
    14
    How to flash latest firmware

    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    7
    @Marteng69 here is what i did -> i was stucked on pie + flickering screen (model h3113):

    1. i used emma (https://developer.sony.com/develop/open-devices/get-started/flash-tool), just install and run it, boot your phone in flash mode (vol down + usb connect = green light). then the app will recognize your phone (assuming you have drivers installed) and give you phone info. on the right side download and flash offered firmware (at the moment there is the uk oreo one, download it and you'll have it in case it's replaced with pie). flash the complete firmware (the "Software Update Content Erase" image) and reboot after flashing completed

    2. boot the phone, let it boot up for a few minutes then turn it off with holding power + vol up for a few secs (let it vibrate 3 times to make sure it's off)

    3. then boot it in fastboot mode (vol up + usb connect = blue light) and then via cmd run "fastboot boot 1d66175c6ce8e04865d041cbcac8ba3013a02b1e.img" (please check your exact .img name)

    4. that's it, the phone should boot (normal looking) twrp and then reboot your phone and... say thanks to @LuK1337 ;)
    7
    Hello Luk,

    are you going to develop LineageOS 17 for this Device?

    Until 50.2.* kernel source is out I'm not planning to do anything.

    btw see https://talk.sonymobile.com/t5/Kernel/50-2-A-0-400-kernel-source/td-p/1390917 ^^
    6
    Yes, 2.4 works fine. I'm 100% sure that 5GHz used to work tho, but nevermind. At least now I have hotspot working lol

    ...yeah I booted some old ass kernel HEAD and it works there. Looks like i'm going to have fun time finding the change that broke it...

    EDIT: Should be working again in next builds ^.^