• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][OFFICIAL][pioneer][9] LineageOS 16.0

Search This thread

axxx007xxxz

Senior Member
Jul 1, 2014
1,278
821
World
Are there plans to use aosp camera libs (camera2 api with raw or however you refer to them)? I am planning to buy this phone, and the ability to use google camera with hdr+ would really push me away from xiaomi.
Having a decent stock ROM should be enough to make you switch from XiaoMi. :p
Also you get a fully working LineageOS maintained by one of its head developers!
 

infixremix

Senior Member
Jan 12, 2017
895
388
Are there plans to use aosp camera libs (camera2 api with raw or however you refer to them)? I am planning to buy this phone, and the ability to use google camera with hdr+ would really push me away from xiaomi.
There are better cameras out there. I have made cameras my self. Where I've increased sharpness and hdr scale. The only thing u really loose out on is portrait mode.
 
  • Like
Reactions: JOVICAMPEK

JOVICAMPEK

Senior Member
Oct 23, 2012
70
19
There are better cameras out there. I have made cameras my self. Where I've increased sharpness and hdr scale. The only thing u really loose out on is portrait mode.
I don't really care about portrait mode. I didn't quite understand you, are you saying you modded the camera in this rom for better hdr, or have you made camera apps which I can download separate? And one last question, does anyone know if Sony aosp from Sony open devices source support gcam? Nothing says it doesn't, but I'd like to know. I'd prefer to have a choice, aosp with gcam or lineage with stock cam.
 

SGS3_0

Senior Member
Mar 17, 2014
258
62
Megastructure
How to install Magisk on this rom? I'm kinda new with A/B phones.
Just install as "zip-installer" from TWRP. As usual.
The installer Magisk has a script that checks the active slot.
Part of script code for example:
Code:
mount_partitions() {
  # Check A/B slot
  SLOT=`getprop ro.boot.slot_suffix`
  if [ -z $SLOT ]; then
    SLOT=_`getprop ro.boot.slot`
    [ $SLOT = "_" ] && SLOT=
  fi
:good:

---------- Post added at 05:27 PM ---------- Previous post was at 05:00 PM ----------

And one last question, does anyone know if Sony aosp from Sony open devices source support gcam? Nothing says it doesn't, but I'd like to know. I'd prefer to have a choice, aosp with gcam or lineage with stock cam.
There is a separate topic about SonyAOSP.
Lineage OS and SonyAOSP has different hmmm... camera "drivers". In the first case, it is used from stock rom firmware. In the second, Sony provides a special version that contains various restrictions.
More info on the Sony website.
But at the moment there is no actuality information, coz SonyAOSP had new smartphones - XZ2\3 and new Android version - P and new kernel -4.9 whith new sw-bin...
Answering your question:
In SonyAOSP GCam will work, the version that I posted in this topic earlier, but not all functions will work and in general the quality of the photo will be inferior to LineageOS.
(in SonyAOSP 8.1 didnt work camera2api\HAL3 & hdr+)
 
Last edited:
  • Like
Reactions: JOVICAMPEK

xperiaf

Senior Member
Dec 1, 2018
226
6
seems that the rom have a issue in Stock Camera, feels it's a little messed bug, after all there is no better api than stocks' for us to use ...
 

xperiaf

Senior Member
Dec 1, 2018
226
6
It's like the 15.1:
*Lineage dosn't work dual sim together - only separatly: or only 1st or only 2nd, or 1st if both sim inserted
+ it's got a bug - if inserts the 2nd slot and it works, then reinsert in the 1st - cellular won't works , till factory reset.
I cant remember wh 15.1 los build they works together
need logs?
but sim-menu works wh 1+2 sims together!

---------- Post added at 08:27 PM ---------- Previous post was at 08:10 PM ----------

can u do animations speed faster as default.0.8-0.5x for example?

> "I cant remember wh 15.1 los build they works together"
> but sim-menu works wh 1+2 sims together"

what does `wh` mean ?
 

xperiaf

Senior Member
Dec 1, 2018
226
6
bug report:

settings > system > status bar > network traffic monitor

it not work, even if there is data flowed, you'll never see a monitor displayed in status bar.
 

ilyabauer

Member
Dec 3, 2018
27
1
Can't install LineageOS 16 - "System not found" error after reboot

Hi guys,
This is my first ROM im trying to install.
So after booting to TWRP i install(flash) latest LineageOS 16 zip (downloaded from thread) and after I shutdown my XA2 and tried to boot into TWRP -> but recovery from lineageOS showed off and after that i got emidietly thrown out of there are phone restarts. Does this LineageOS animation and shows:
"
Android Recovery
...
...
Can't load Android system. Your data may be corrupt. If you continue get this message, you may perform a factory reset and erase all user data stored on this device.
> Try Again
> Factory data reset
"
After about 3-5 "try again" it boots into old system.
What am i doing wrong?
 

LuK1337

Recognized Developer
Jan 18, 2013
8,450
16,863
Samsung Galaxy S III I9300
Moto G 2014
Hi guys,
This is my first ROM im trying to install.
So after booting to TWRP i install(flash) latest LineageOS 16 zip (downloaded from thread) and after I shutdown my XA2 and tried to boot into TWRP -> but recovery from lineageOS showed off and after that i got emidietly thrown out of there are phone restarts. Does this LineageOS animation and shows:
"
Android Recovery
...
...
Can't load Android system. Your data may be corrupt. If you continue get this message, you may perform a factory reset and erase all user data stored on this device.
> Try Again
> Factory data reset
"
After about 3-5 "try again" it boots into old system.
What am i doing wrong?

wipe data lol.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 36
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][9] LineageOS 16.0, ROM for the Sony Xperia XA2

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2018-08-30
    Last Updated 2020-02-28
    14
    How to flash latest firmware

    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    or
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    7
    @Marteng69 here is what i did -> i was stucked on pie + flickering screen (model h3113):

    1. i used emma (https://developer.sony.com/develop/open-devices/get-started/flash-tool), just install and run it, boot your phone in flash mode (vol down + usb connect = green light). then the app will recognize your phone (assuming you have drivers installed) and give you phone info. on the right side download and flash offered firmware (at the moment there is the uk oreo one, download it and you'll have it in case it's replaced with pie). flash the complete firmware (the "Software Update Content Erase" image) and reboot after flashing completed

    2. boot the phone, let it boot up for a few minutes then turn it off with holding power + vol up for a few secs (let it vibrate 3 times to make sure it's off)

    3. then boot it in fastboot mode (vol up + usb connect = blue light) and then via cmd run "fastboot boot 1d66175c6ce8e04865d041cbcac8ba3013a02b1e.img" (please check your exact .img name)

    4. that's it, the phone should boot (normal looking) twrp and then reboot your phone and... say thanks to @LuK1337 ;)
    7
    Hello Luk,

    are you going to develop LineageOS 17 for this Device?

    Until 50.2.* kernel source is out I'm not planning to do anything.

    btw see https://talk.sonymobile.com/t5/Kernel/50-2-A-0-400-kernel-source/td-p/1390917 ^^
    6
    Yes, 2.4 works fine. I'm 100% sure that 5GHz used to work tho, but nevermind. At least now I have hotspot working lol

    ...yeah I booted some old ass kernel HEAD and it works there. Looks like i'm going to have fun time finding the change that broke it...

    EDIT: Should be working again in next builds ^.^