[ROM][OFFICIAL][pioneer][9] LineageOS 16.0

Search This thread


Senior Member
Mar 27, 2020
Motorola Edge 30
Rom has the same parameters like actually LoS 17.1 :)
Original stock Rom takes about 1,9 GB !


  • IMG_20200629_130411.jpg
    169 KB · Views: 181
Last edited:


Jul 1, 2019
Hey! I'd just like to thank whoever updated the installation instructions on the Lineage wiki!

I was one of the people whose phone got irreversibly bricked. In the meantime, I bought another phone with a broken screen and transplanted the motherboard. I am very happy to see that the installation instructions don't contain the risky step of switching slots anymore and now also contain the copy partition step, which was missing before. Kudos!

Top Liked Posts

  • There are no posts matching your filters.
  • 36

    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][9] LineageOS 16.0, ROM for the Sony Xperia XA2

    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2018-08-30
    Last Updated 2020-02-28
    How to flash latest firmware

    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Turn off your phone, hold vol up and plug in the USB cable, the screen should be off and blue LED lit.
    6. Enter this command: `fastboot getvar current-slot`, it should return something like this:
    current-slot: _b
    Finished. Total time: 0.001s
    7. Now switch to the opposite slot by entering command: `fastboot set_active a` if the current slot is `_b` or `fastboot set_active b` if its `_a`, you should see this:
    Setting current slot to 'a'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    Setting current slot to 'b'...
    OKAY [ 0.012s]
    Finished. Total time: 0.014s
    8. Unplug usb cable and repeat steps: 3, 4
    9. Profit?
    @Marteng69 here is what i did -> i was stucked on pie + flickering screen (model h3113):

    1. i used emma (https://developer.sony.com/develop/open-devices/get-started/flash-tool), just install and run it, boot your phone in flash mode (vol down + usb connect = green light). then the app will recognize your phone (assuming you have drivers installed) and give you phone info. on the right side download and flash offered firmware (at the moment there is the uk oreo one, download it and you'll have it in case it's replaced with pie). flash the complete firmware (the "Software Update Content Erase" image) and reboot after flashing completed

    2. boot the phone, let it boot up for a few minutes then turn it off with holding power + vol up for a few secs (let it vibrate 3 times to make sure it's off)

    3. then boot it in fastboot mode (vol up + usb connect = blue light) and then via cmd run "fastboot boot 1d66175c6ce8e04865d041cbcac8ba3013a02b1e.img" (please check your exact .img name)

    4. that's it, the phone should boot (normal looking) twrp and then reboot your phone and... say thanks to @LuK1337 ;)
    Hello Luk,

    are you going to develop LineageOS 17 for this Device?

    Until 50.2.* kernel source is out I'm not planning to do anything.

    btw see https://talk.sonymobile.com/t5/Kernel/50-2-A-0-400-kernel-source/td-p/1390917 ^^
    Yes, 2.4 works fine. I'm 100% sure that 5GHz used to work tho, but nevermind. At least now I have hotspot working lol

    ...yeah I booted some old ass kernel HEAD and it works there. Looks like i'm going to have fun time finding the change that broke it...

    EDIT: Should be working again in next builds ^.^