[ROM][OFFICIAL][R] LineageOS 18.1 for Xiaomi Mi 10T / Mi 10T Pro / Redmi K30S Ultra [apollo/apollopro]

Search This thread


Senior Member
Oct 29, 2013
updated today to latest ROM (lineage-18.1-20220423-nightly-apollon-signed.zip), latest EEA FW (fw_apollo_miui_APOLLOEEAGlobal_V13.0.2.0.SJDEUXM_f939ac44da_12.0.zip) and latest NikGapps Core.
So far so good... voice over wifi and 4G calls still not active.
update :
seems the battery drain is higher than on previous versions
sometimes does not wake up with finger unlock, I have to try several times or even press the power button before it detects fingerprint.
the wifi seems unstable (wifi logo disappears periodicly for a few seconds, xiaomi wifi router which is stable). The wifi is turned when the phone display is off (my pc "kde connect" does not detect the phone when display is off)

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Thanks a lot for this. Can you share a link for the skkk TWRP?

    Find there for Apollo. It works for Android 11 and 12
  • 30

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    - Ramisky
    - SebaUbuntu

    Recommended firmware


    Flashing instructions


    Happy modding!
    prosby přidat game turbo a herní centrum :)
    can't you write in English ?
    If everyone uses its native language it is going to be a huge mess...
    Hello. Running the latest build on my Mi 10T Pro and everything is smooth as heck. Way better than any custom ROM I've tried and even better than Xiaomi.EU.
    But my only issue with it is that in the Play Store > Settings > About > Play Protect certification, it's listed as "Device is not certified". Because of this, I can't download some of my banking apps via the Play Store and some other apps. I don't want to sideload APKs. I contacted Play Store support about it and they couldn't help me. My Google Services Framework Android ID has already been registered so I should be certified.
    Do yours indicate the same and how have you been able to resolve this? Much help would be appreciated. Thanks.View attachment 5362653
    This basically means your device currently doesn't pass safetynet.

    Fortunately this is quite easy to fix. Follow these steps:
    1. FIrst of all you need to root using Magisk.
    2. Then you need to install Magisk module "Universal SafetyNet Fix" and "MagiskHide Props Config".
    3. Install any Terminal of your choice from the Google Play store.
    4. Open Terminal, type "su" (without quotes), grant SuperUser permissions.
    5. Type "props" (again without quotes), select "1 - Edit device fingerprint".
    6. Select "f - Pick a certified fingerprint".
    7. Select "30 - Xiaomi"
    8. Select either "27 or 30" (which is either 10t or 10t pro).

    Follow the onscreen instructions then reboot, make sure that google play services is currently checked in Magisk hide and you should be golden.

    Already tried it and it still was only at 90hz show me a screenshot or get outta my posts
    Quit it. You're just embarrassing yourself. At least have some decency. There was absolutely no need for you to be rude especially not randomly 😂
    And obviously I wouldn't use force 90hz you sound so dumb and take me for a fool?
    And yet it works just fine for all of us but you.. :LOL: