• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][R] LineageOS 18.1 for Xiaomi Mi 10T / Mi 10T Pro / Redmi K30S Ultra [apollo/apollopro]

Search This thread
So I installed lineage OS 18.1 on my xiaomi mi 10t apollo. Got to say I was not happy with the fact that you can't even change the display to 144 HZ it's locked at 90 HZ. Which seems dumb considering that was one of the selling points on this phone
This isn't true, it works at 144hz just fine.

Make sure to turn on "smooth display" option under display settings. "option says 90hz but it's actually 144hz.

To make sure you're running at 144hz you can check "show refresh rate" under developer options. Also do not use "force 90hz option as that will disable 144hz.
 
This isn't true, it works at 144hz just fine.

Make sure to turn on "smooth display" option under display settings. "option says 90hz but it's actually 144hz.

To make sure you're running at 144hz you can check "show refresh rate" under developer options. Also do not use "force 90hz option as that will disable 144hz.
Already tried it and it still was only at 90hz show me a screenshot or get outta my posts
 
Already tried it and it still was only at 90hz show me a screenshot or get outta my posts
Try again don't act dumb.
Screenshot_20210726-091420_Settings.png
 

@retutal

Senior Member
Jun 17, 2016
61
31
PH
Honor 6X
Xiaomi Mi 10T / 10T Pro
Already tried it and it still was only at 90hz show me a screenshot or get outta my posts
Quit it. You're just embarrassing yourself. At least have some decency. There was absolutely no need for you to be rude especially not randomly 😂
Screenshot_20210726-204109_Settings.png
 

Attachments

  • Screenshot_20210726-204109_Settings.png
    Screenshot_20210726-204109_Settings.png
    178.8 KB · Views: 27

TheJags

Senior Member
Nov 16, 2017
57
5
This basically means your device currently doesn't pass safetynet.

Fortunately this is quite easy to fix. Follow these steps:
1. FIrst of all you need to root using Magisk.
2. Then you need to install Magisk module "Universal SafetyNet Fix" and "MagiskHide Props Config".
3. Install any Terminal of your choice from the Google Play store.
4. Open Terminal, type "su" (without quotes), grant SuperUser permissions.
5. Type "props" (again without quotes), select "1 - Edit device fingerprint".
6. Select "f - Pick a certified fingerprint".
7. Select "30 - Xiaomi"
8. Select either "27 or 30" (which is either 10t or 10t pro).

Follow the onscreen instructions then reboot, make sure that google play services is currently checked in Magisk hide and you should be golden.

Enjoy!
Somehow I'm still getting "Device not certified" (in Play store > About). I used LineageOS in-built Terminal (which you can enable inside developer options). My device is 10T Pro India version.

I followed the steps you've detailed with "MagiskHide Props Config". Though after selecting "30 - Xiaomi", I selected "29 10T Pro (Europe)" as it was the only option with "10T Pro".

Repeated twice with the same result. Any idea how to troubleshoot or what am I missing in here ? Many thanks in advance.
 
Last edited:

@retutal

Senior Member
Jun 17, 2016
61
31
PH
Honor 6X
Xiaomi Mi 10T / 10T Pro
Somehow I'm still getting "Device not certified" (in Play store > About). I used LineageOS in-built Terminal (which you can enable inside developer options). My device is 10T Pro India version.

I followed the steps you've detailed with "MagiskHide Props Config". Though after selecting "30 - Xiaomi", I selected "29 10T Pro (Europe)" as it was the only option with "10T Pro".

Repeated twice with the same result. Any idea how to troubleshoot or what am I missing in here ? Many thanks in advance.
Happened to me. Reboot your phone. Then Force stop the Play Store and clear data.
 

whatsek

Senior Member
Nov 5, 2009
274
80
Thanks for the quick reply.

Reboot, force stopped the Play Store, cleared cache, and data... still getting "Device is not certified".

Even tried applying fingerprint again, and repeated the steps, though still getting same message.
Make sure you don't have any other fingerprints selected. I tried it before and had also a pixel fingerprint active. When I removed all, and selected xiaomi, then Mi 10t pro Europe, after a reboot is worked.
 

TheJags

Senior Member
Nov 16, 2017
57
5
Make sure you don't have any other fingerprints selected. I tried it before and had also a pixel fingerprint active. When I removed all, and selected xiaomi, then Mi 10t pro Europe, after a reboot is worked.
Many thanks for the reply.

Did you mean "Reset fingerprint" by "remove all"? Because I can't find any option to "Remove or Remove all".

Reset, reboot, picking new fingerprint, reboot... did not help. I don't know what am I missing here?

Here are complete steps: Repeated twice, first time with LineageOS terminal and then with Terminal (TermOnePlus) from F-Droid.

Terminal > su > props > "1 - edit device fingerprint" > "r - reset fingerprint" > reboot >

Terminal > su > props > "1 - edit device fingerprint" > "f - Pick a certified fingerprint" >

"30 - Xiaomi" > "29 - 10T Pro (Europe) > reboot > Play store > clear cache and clear storage >

Still getting "Device is not certified".
 

whatsek

Senior Member
Nov 5, 2009
274
80
Many thanks for the reply.

Did you mean "Reset fingerprint" by "remove all"? Because I can't find any option to "Remove or Remove all".

Reset, reboot, picking new fingerprint, reboot... did not help. I don't know what am I missing here?

Here are complete steps: Repeated twice, first time with LineageOS terminal and then with Terminal (TermOnePlus) from F-Droid.

Terminal > su > props > "1 - edit device fingerprint" > "r - reset fingerprint" > reboot >

Terminal > su > props > "1 - edit device fingerprint" > "f - Pick a certified fingerprint" >

"30 - Xiaomi" > "29 - 10T Pro (Europe) > reboot > Play store > clear cache and clear storage >

Still getting "Device is not certified".
Reset should be fine, I also selected boot stages 1 and 2, maybe this will help?
 
Somehow I'm still getting "Device not certified" (in Play store > About). I used LineageOS in-built Terminal (which you can enable inside developer options). My device is 10T Pro India version.

I followed the steps you've detailed with "MagiskHide Props Config". Though after selecting "30 - Xiaomi", I selected "29 10T Pro (Europe)" as it was the only option with "10T Pro".

Repeated twice with the same result. Any idea how to troubleshoot or what am I missing in here ? Many thanks in advance.
Make sure you're using MagiskHide.
 

whatsek

Senior Member
Nov 5, 2009
274
80
Okay, after Resetting again, I clicked on Boot stage, and it's asking:

Boot stage > 1 > Current boot stage for fingerprint is: Default.

Do you want to change it to:

post-fs-data or late_start service?

Many thanks.
In have:

MagiskHide Props Config v5.4.0
by Didgeridoohan @ XDA Developers

=====================================
Edit device fingerprint (active)
=====================================

Change boot stage for the device fingerprint
or security patch date props.

Pick an option below.

1 - Device fingerprint (default).
2 - Security patch date (late_start service).
b - Go back e - Exit
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    any feedback on this update ?
    working well without any error or problem. battery sot also good too. dont worry. recommended to update
    1
    Which gapps is recomended for LineageOS?
    Hi, I am using "Nikgapps" which works fine and is totally configurable (subset to install)
    1
    Hello @SebaUbuntu !

    Thanks for your work and share.

    I have a question : in which moment do you use the firmware during the installation of lineage ?
    Beacause on the official website i saw nothing about it ?
    Thanks for your help and your share ;)

    Take care.
    1
    Sorry, I am kind of new to this. What do you mean by cust? Google pointed in the direction of magisk, is that what you mean?
    or just install this firmware before flashing lineage os
    1
    Thank for your help @CV-Aurora !
    I try it and i 'll be back in 3 days with my internet connection of **** ;)

    Thanks for all your help and your quick answer ;)

    Yesterday i try to flash this one :

    apollo_global_images_V12.5.2.0.RJDMIXM_20210708.0000.00_11.0_global

    Do I have to reflash and go back or I can directly resume the installation with the tutorial on the official site of lineage?
    Thanks in advance ;)

    @CV-Aurora
  • 26
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Maintainers
    - Ramisky
    - SebaUbuntu

    Recommended firmware
    V12.1.3.0.RJDMIXM

    Downloads
    Here

    Flashing instructions
    Here

    Sources
    LineageOS

    Happy modding!
    8
    prosby přidat game turbo a herní centrum :)
    can't you write in English ?
    If everyone uses its native language it is going to be a huge mess...
    5
    Hello. Running the latest build on my Mi 10T Pro and everything is smooth as heck. Way better than any custom ROM I've tried and even better than Xiaomi.EU.
    But my only issue with it is that in the Play Store > Settings > About > Play Protect certification, it's listed as "Device is not certified". Because of this, I can't download some of my banking apps via the Play Store and some other apps. I don't want to sideload APKs. I contacted Play Store support about it and they couldn't help me. My Google Services Framework Android ID has already been registered so I should be certified.
    Do yours indicate the same and how have you been able to resolve this? Much help would be appreciated. Thanks.View attachment 5362653
    This basically means your device currently doesn't pass safetynet.

    Fortunately this is quite easy to fix. Follow these steps:
    1. FIrst of all you need to root using Magisk.
    2. Then you need to install Magisk module "Universal SafetyNet Fix" and "MagiskHide Props Config".
    3. Install any Terminal of your choice from the Google Play store.
    4. Open Terminal, type "su" (without quotes), grant SuperUser permissions.
    5. Type "props" (again without quotes), select "1 - Edit device fingerprint".
    6. Select "f - Pick a certified fingerprint".
    7. Select "30 - Xiaomi"
    8. Select either "27 or 30" (which is either 10t or 10t pro).

    Follow the onscreen instructions then reboot, make sure that google play services is currently checked in Magisk hide and you should be golden.

    Enjoy!
    4
    Already tried it and it still was only at 90hz show me a screenshot or get outta my posts
    Quit it. You're just embarrassing yourself. At least have some decency. There was absolutely no need for you to be rude especially not randomly 😂
    Screenshot_20210726-204109_Settings.png
    4
    And obviously I wouldn't use force 90hz you sound so dumb and take me for a fool?
    And yet it works just fine for all of us but you.. :LOL: