[ROM][OFFICIAL][R] LineageOS 18.1 for Xiaomi Mi 8 Lite [platina]

Search This thread

9Lukas5

Senior Member
Dec 14, 2010
3,816
2,017
near Stuttgart
@persona78 So in conclusion that would mean, if one forgets to change this again after an update, the system would re-encrypt the storage on boot which I would only recommend for testing device, but not a daily driver. Would you agree?

[...]
even when i choose like 2g or 3g - there is no label on mobile data (nothing shows - H or 3G etc.)

But reception itself is shown? If so, what does it say under "Settings/About Device/Sim State" for your active Sim Slot?
- is the provider correct?
- is there a type for the network given?

L
 

persona78

Senior Member
Apr 12, 2013
2,407
1,208
@persona78 So in conclusion that would mean, if one forgets to change this again after an update, the system would re-encrypt the storage on boot which I would only recommend for testing device, but not a daily driver. Would you agree?



But reception itself is shown? If so, what does it say under "Settings/About Device/Sim State" for your active Sim Slot?
- is the provider correct?
- is there a type for the network given?

L
Yes, only for testing...
 

persona78

Senior Member
Apr 12, 2013
2,407
1,208
Hi!
I let you here some tools to work on ROM.

First One is Brottli (files ROM format) to Ext4, like it say change from brottli format to ext4 format as example system.new.dat.br and system.transfer.list to system.ext4
Brottli_Dat_to_EXT4.zip

Second on ( the one i use more to extract files from ext4 format images) 7z_Ext4_Imgextractor, for this tool you need to extract, enter in work folder, right click on 7z.exe, compatibility and select execute as administrator or it will not work properly.
7z_Ext4_Imgextractor.zip

Third, is the same as 7z_Ext4_Imgextractor.zip but i only use is 7z_Ext4_Imgextractor.zip doesn´t work. Some times extract with a few errors...
Ext4_Imgextractor.zip

And the last one, is a Update.zip, inside you will find system and vendor folders, inside that folder you can paste a directory/file as you find inside the extract image, example if the file is in vendor/etc, you need to create/paste etc directory inside vendor...
Important Only works with directory with 755 permission and files with 644 permission!!!!! You need to know what you are doing...
update.zip

I hope this tools helps you.
 

mickiewicz

Senior Member
May 27, 2012
96
11
@persona78 So in conclusion that would mean, if one forgets to change this again after an update, the system would re-encrypt the storage on boot which I would only recommend for testing device, but not a daily driver. Would you agree?



But reception itself is shown? If so, what does it say under "Settings/About Device/Sim State" for your active Sim Slot?
- is the provider correct?
- is there a type for the network given?

L
after clean flash of todays version (installend via lineage recovery, with latest firmware and NikGapps basic):

Screenshot_20210422-224827_Settings.png


there is no sign of mobile transfer, like you see, but the sim card and provider is correct.

Screenshot_20210422-224848_Settings.png


when i change prefered network type to ONLY LTE - it seems disconected:

Screenshot_20210422-224951_Settings.png


and when i change it back to other low-transfer network (like GSM only, then WCDMA) and then to LTE/WDMA i get a H+ connection (so its only 3G), but that H+ connection dissapeard after few minutes.

Screenshot_20210422-225113_Settings.png


it seems like a problem with my provider (?), but i used to flash earlier versions of yours lineage (like in march, when it wasn't official yet) and then my LTE transfer worked.
i'm out of ideas how to fix that :)

so now i'm gonna back to xiaomi.eu rom again.

any ideas?
 

9Lukas5

Senior Member
Dec 14, 2010
3,816
2,017
near Stuttgart
[...]
when i change prefered network type to ONLY LTE - it seems disconected
[...]
and when i change it back to other low-transfer network (like GSM only, then WCDMA) and then to LTE/WDMA i get a H+ connection (so its only 3G), but that H+ connection dissapeard after few minutes.
[...]

Wow, that's some frustrating situation :/

it seems like a problem with my provider (?), but i used to flash earlier versions of yours lineage (like in march, when it wasn't official yet) and then my LTE transfer worked.
i'm out of ideas how to fix that :)

If you say in earlier builds of this rom it worked fine, is that still the case?
E.g. if you just flash an older build you know worked before over your current setup, do you get your connection back?

For instance: I'm running a homebrew build from these sources from the 8th of March 23rd April, not the latest official build available.

any ideas?

Not really, sorry :/

L
 
Last edited:

mickiewicz

Senior Member
May 27, 2012
96
11
(...)
If you say in earlier builds of this rom it worked fine, is that still the case?
E.g. if you just flash an older build you know worked before over your current setup, do you get your connection back?
(...)
today i've tried to flash an old version (08.03 - like you), it was a clean flash with all wipes and format data - mobile data doesn't work on it. i made some flashes via lineage recovery and unofficial orange fox, with and without firmware, with and without gapps - everytime the results are the same - my mobile data not working.
i don't know what have changed (like i said - i was useing 08.03 version before), now i really don't have a clue what more can i do :)

so, once again, i'm going back to xiaomi.eu rom (on which mobile data works normally).
 

9Lukas5

Senior Member
Dec 14, 2010
3,816
2,017
near Stuttgart
[...]
now i really don't have a clue what more can i do :)

so, once again, i'm going back to xiaomi.eu rom (on which mobile data works normally).

Yeah I'm sorry for you.
Maybe something changed on your provider side :/

Did you try to use the other Simslot/remove, clean enter sim card again.
And if you have a sim card from another provider at hand, is it working with that?

L
 

mickiewicz

Senior Member
May 27, 2012
96
11
Yeah I'm sorry for you.
Maybe something changed on your provider side :/

Did you try to use the other Simslot/remove, clean enter sim card again.
And if you have a sim card from another provider at hand, is it working with that?

L
i had remove sim card and put it again - after pin-code there is no change.
once i even flash whole rom without sim card and put it in after - same result (also change sim slot do not help)
i do not have a sim card from other provider - maybe i'll try to use one from a friend or something.
i have the same sim card for ages and on miui LTE works fine. out of ideas.
thanks for help!
 

peter.xda

Member
Feb 6, 2021
7
1
i have the same sim card for ages and on miui LTE works fine. out of ideas.
Do you have the latest Xiaomi firmware? It's V12.0.3.0.QDTMIXM and you have to (re)install it separately just in case. Do you still have mobile data with xiaomi.eu ROM? If so, check your APN settings once again and make sure the APN is marked with a bullet point.
 

persona78

Senior Member
Apr 12, 2013
2,407
1,208
i had remove sim card and put it again - after pin-code there is no change.
once i even flash whole rom without sim card and put it in after - same result (also change sim slot do not help)
i do not have a sim card from other provider - maybe i'll try to use one from a friend or something.
i have the same sim card for ages and on miui LTE works fine. out of ideas.
thanks for help!


Hmmm... I´m asking me, can be a radio problem? :unsure:

Have you installed last firmware update? You can get it HERE.
(Check if you download the right firmware before flash it with custom rom!!!)

After install last update, try Lineage again...

I really think is a radio problem, ril or something.
 

mickiewicz

Senior Member
May 27, 2012
96
11
Hmmm... I´m asking me, can be a radio problem? :unsure:

Have you installed last firmware update? You can get it HERE.
(Check if you download the right firmware before flash it with custom rom!!!)

After install last update, try Lineage again...

I really think is a radio problem, ril or something.
yes, i do flash 12.0.3 firmware everytime before flash lineage rom (i wrote about it a few times - try to flash with and without firmware).
on xiaomi.eu i don't have a problem - default after clean flash LTE appears.

when i flash i do the same things (maybe there is something not wright?):
- go to recovery (for ex. lineage recovery), do all wipes
- flash firmware, flash rom and flash Nikgapps (i try with basic and stock versions - canary and stable relases)
- reboot to system - recovery appears again to do a format data (i guess it's normal with this rom) and then real reboot to system
- rom is loading, i do all settups and mobile data not working
 

predragiPredrag

Senior Member
  • Jan 8, 2012
    705
    309
    yes, i do flash 12.0.3 firmware everytime before flash lineage rom (i wrote about it a few times - try to flash with and without firmware).
    on xiaomi.eu i don't have a problem - default after clean flash LTE appears.

    when i flash i do the same things (maybe there is something not wright?):
    - go to recovery (for ex. lineage recovery), do all wipes
    - flash firmware, flash rom and flash Nikgapps (i try with basic and stock versions - canary and stable relases)
    - reboot to system - recovery appears again to do a format data (i guess it's normal with this rom) and then real reboot to system
    - rom is loading, i do all settups and mobile data not working
    Did you check your access point names settings? If you can make calls and receive sms but have no mobile data it sounds like missing config for APN.
     

    mickiewicz

    Senior Member
    May 27, 2012
    96
    11
    Did you check your access point names settings? If you can make calls and receive sms but have no mobile data it sounds like missing config for APN.
    yup, APNs shows itself.
    i;ve try to modify it manually by myself (taking data form my provider's official page).
    i've try to remove APNs and add it again, change SIM slot and do it all on the second sim slot.

    today i've used a SIM card from my friend (with other provider - Orange PL) and results was the same - no mobile data (orange's APNs shows itself, but nothing changes).
    so now i know that my issue is not being caused by my provider, but i'm still out of ideas what am i doing wrong, when mobile data on xiaomi.eu rom works fine right after flashing :|
     

    predragiPredrag

    Senior Member
  • Jan 8, 2012
    705
    309
    yup, APNs shows itself.
    i;ve try to modify it manually by myself (taking data form my provider's official page).
    i've try to remove APNs and add it again, change SIM slot and do it all on the second sim slot.

    today i've used a SIM card from my friend (with other provider - Orange PL) and results was the same - no mobile data (orange's APNs shows itself, but nothing changes).
    so now i know that my issue is not being caused by my provider, but i'm still out of ideas what am i doing wrong, when mobile data on xiaomi.eu rom works fine right after flashing :|
    Hmmm that is strange, try this steps when installing.
    - Reboot to recovery
    - format data
    - copy to device firmware, LOS and gapps
    - flash firmware then LOS and in the end gapps
    - and in the end reboot to system
    It should not ask you to format data again, maybe that step is messing with your phone.
     

    mickiewicz

    Senior Member
    May 27, 2012
    96
    11
    Hmmm that is strange, try this steps when installing.
    - Reboot to recovery
    - format data
    - copy to device firmware, LOS and gapps
    - flash firmware then LOS and in the end gapps
    - and in the end reboot to system
    It should not ask you to format data again, maybe that step is messing with your phone.
    i do all of that - even more (all wipes and format data).
    on first boot it always reboot to rcovery again an reqire format data or wipe data + caches
     

    mickiewicz

    Senior Member
    May 27, 2012
    96
    11
    what recovery are you using? Maybe it is causing this strange behaviour
    honestly - i've tried all of them - lineage (with 'side adb' commands via fastboot), two different orange fox (not official ones, but made for android 11 i guess), unoffiicial twrp and pitch black.
    always full wipes and formats.
     
    Dec 29, 2015
    12
    0
    Lublin
    today i've used a SIM card from my friend (with other provider - Orange PL) and results was the same - no mobile data (orange's APNs shows itself, but nothing changes).
    so now i know that my issue is not being caused by my provider, but i'm still out of ideas what am i doing wrong, when mobile data on xiaomi.eu rom works fine right after flashing :|
    I'm on Orange PL and had the same problem, btw this problem is on every ROM on Android 11. The solution is to change the default APN from "internet" to "internetipv6" and also change the protocol to IPv6. How do you change on your network? I have no idea, for a start try changing the protocol to IPv6.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 1
      @9Lukas5
      I think you need to apply That Change every time you do factory reset after update because update Will overwrite the file you change.
    • 15
      2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

      Note: This ROM uses FBE encryption, any current existing recovery won't be able to decrypt data!

      Recommended firmware
      V12.0.3.0.QDTMIXM

      Downloads
      Here

      Flashing instructions
      Here

      Changelogs are on #2 post
      Telegram channel for updates: Here
      Telegram group for support: Here

      Sources:
      Common device tree
      platina device tree
      Xiaomi SDM660 common kernel
      Common vendor blobs

      Happy modding!
      6
      2021/04/01
      - First official build

      2021/03/08
      - Synced latest LineageOS changes
      - March 2021 security patches
      - Upstreamed kernel
      - Added DT2W support for all platina touchpanels
      - (not a bug in my previous builds, might be useful to other maintainers) Fixed charging issues after kernel upstream

      2021/02/05
      - Synced latest LineageOS changes
      - Upstreamed kernel
      - Added WireGuard support
      - Fixed some camera denials

      2020/12/20
      - First release
      6
      First official build is out 🎉
      Check #1 and #2 for infos
      2
      So I finally got time to install this. Works very nicely so far. I am getting lots of "Trust - System Security" notifications about the keys being public signed. How do I disable this?
      Settings > Privacy > Trust > Go down and uncheck all the boxes
      2
      we really cant expect nothing from an unofficial ROM, even the official ones, specially the nysa case
      probably this guy will support it for some time then dissapear or make more ROMs, but we cant expect so much about it.
      what?
      I'm actually planning to go official with LineageOS, there's no way I'll abandon this phone soon
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone