[ROM][OFFICIAL][R] LineageOS 18.1 for Xiaomi Mi 8 Lite [platina]

Search This thread

mickiewicz

Senior Member
May 27, 2012
97
11
I'm on Orange PL and had the same problem, btw this problem is on every ROM on Android 11. The solution is to change the default APN from "internet" to "internetipv6" and also change the protocol to IPv6. How do you change on your network? I have no idea, for a start try changing the protocol to IPv6.
that internetipv6 thing is probably only in Orange - i do not see any info about it on PLAY as a provider.
right now i'm on xiaomi.eu rom, LTE wrorks and in network settings i see as APN type just "internet" (nothing about ipv6) and APNs ptocol is set at "ipv4/ipv6" - all that i get automatically after a clean flash of LOS.

today i've try to flash from sd card (i ask myself - why not?), ressults are the same - i do not have mobile data on a11 roms
 
  • Sad
Reactions: Conrado da Vinci

roldev

Member
Mar 16, 2018
9
2
At first, Thanks for the great work done by the @op. And support of the community. I have some problems with my install. Hope someone can help.
  • The phone cannot be encrypted. After clean install LOS18.1 the phone is not encrypted. I tried do it manually, but after 4 hours stuck on 90%. Never finished. I have encryptable=ice in my fstab.qcom. Maybe some flash from the past altered /vendor. I do clean install: wipe all, format data, install xiaomi firmware, install LOS18.1, install gapps. Rebooting perfect but without encryption ... Somebody can help me, please?
  • Second problem. I suppose no OTA update, isn't? So every time I need to backup my ~200 apps and restore manually. Somehow backup with Titanium cannot restore the apps. Only the data. Any idea how to make reliable backup of my apps+apps settings+system setting? Thank you very much.
Sorry for my bad english.
 

9Lukas5

Senior Member
Dec 14, 2010
3,820
2,019
near Stuttgart
[...]install gapps. Rebooting perfect but without encryption ... Somebody can help me, please?

How do you know the phone is unencrypted? Does it say so under Settings->Security?
My `vendor/etc/fstab.qcom` has `fileencryption=ice` for data instead `encrypttable=ice` like yours. Maybe worth a shot?

Second problem. I suppose no OTA update, isn't?

Depends on what you mean: You of course can flash a new build over the current one without wiping & reinstalling everything. So, yes you can update.
But as we have no recovery, that supports the FileBasedEncryption(FBE) of newer Android versions, you can't make a backup before the update to be able to easily restore everything in case of the update failed.

L
 

roldev

Member
Mar 16, 2018
9
2
Thanks @9Lucas5 for your active support.

Yes, the phone shows unecrypted under Security.

My vendor/etc/fstab.qcom has encryptable=ice. Maybe was altered from xiaomi.eu which was installed before. Or installed something in the past, don't remember now. I tried to flash no-verify-force-encrypt-6.0.zip this time before install, but something goes wrong. Maybe need to install official fastboot MIUI from MyFlash to recover right vendor? I am afraid that this will lock my phone, but seems that there is option to keep it unlocked....

The phone has option to encrypt, but after more than 4h stuck on: Encrypting ... Time remaining 0:00 and never ending.

You of course can flash a new build over the current one without wiping & reinstalling everything

This is great news. I am with PBRP v2.9 which can make backup, since I still unecrypted. Thanks again for your support.
 

persona78

Senior Member
Apr 12, 2013
2,410
1,208
after clean flash of todays version (installend via lineage recovery, with latest firmware and NikGapps basic):

View attachment 5287513

there is no sign of mobile transfer, like you see, but the sim card and provider is correct.

View attachment 5287515

when i change prefered network type to ONLY LTE - it seems disconected:

View attachment 5287517

and when i change it back to other low-transfer network (like GSM only, then WCDMA) and then to LTE/WDMA i get a H+ connection (so its only 3G), but that H+ connection dissapeard after few minutes.

View attachment 5287519

it seems like a problem with my provider (?), but i used to flash earlier versions of yours lineage (like in march, when it wasn't official yet) and then my LTE transfer worked.
i'm out of ideas how to fix that :)

so now i'm gonna back to xiaomi.eu rom again.

any ideas?
Hi!

I found this Code [ Network Technologies List *#*#4636#*#* ] Use dial to insert code, in there you can select the network connection. Try to find yours.
 

mickiewicz

Senior Member
May 27, 2012
97
11
Hi!

I found this Code [ Network Technologies List *#*#4636#*#* ] Use dial to insert code, in there you can select the network connection. Try to find yours.
yep, i've tried all options there - H+ (HSPAP) is max what i can get (on my provider and an other provider via roaming also).
still no LTE :|
 

9Lukas5

Senior Member
Dec 14, 2010
3,820
2,019
near Stuttgart
@roldev did you try to completely reset your device with reflashing firmware and deleting all data?

You can download the firmware from here (flashable zip for recovery): https://xiaomifirmwareupdater.com/firmware/platina/stable/V12.0.3.0.QDTMIXM/

Attention: Backup all your data (including internal storage!) to your computer beforehand!

  • flash LOS recovery
    Code:
    fastboot flash recovery <recovery image file>
  • boot recovery
  • format /system, /cache & /data (really format /data, to remove previous encryption)
  • alternatve: use fastboot:
    Code:
    fastboot erase system
    fastboot erase cache
    fastboot erase userdata
  • flash firmware via adb sideload
  • reboot recovery (just for safety, don't know if it makes any difference^^)
  • flash rom via adb sideload
  • reboot

Normally LOS18.1 on our device should be directly encrypted on first boot with FBE, so if it doesn't show encrypted it didn't workout.

@ all: could others maybe confirm what fileencryption parameter they have in their /vendor/etc/fstab.qcom for the data entry?
@SebaUbuntu maybe you could tell what it should say, and maybe know a way how to fix such differences in the /vendor partition if my described attempt won't work out?

L
 

Ninive

New member
May 27, 2021
4
0
Hi everyone,

I just installed lineageos for microG on my 8 lite,
and I'm facing several minor issues :

- For the installation, I first installed the lineageos recovery,
but I can access it only with the "fastboot boot <name of the recovery>.img" command.
When I use on/off button + volume up, it stills boot on mi-recovery 3.0. I don't know
if this behaviour is expected or not.

- After installing Lineageos, when plugged to a Windows10 PC, the internal storage does not appear,
only the sd card is available for files transfers. Is that because of the encryption, and is
there a way to see all storages ?

- Instead of Google Play store, I want to use the Aptoide store. I managed to install it,
but it crashes everytime I try open it.

Thank you in advance for your help !
 

Ninive

New member
May 27, 2021
4
0
I'm answering to myself, in case it could help people having these issues.
It appears that I didn't properly reboot on recovery just after installing it,
so I reinstalled recovery, immediatly reboot on it using volume up + power, then reinstall
lineageos. Now works like a charm. Thanks to the community ant the op for your great work !
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @9Lukas5 , Sorry for the late replay. Thank you very much! Just followed all your steps and all worked fine.
    And of course thanks to @SebaUbuntu for these builds. Cheers!
  • 16
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Note: This ROM uses FBE encryption, any current existing recovery won't be able to decrypt data!

    Recommended firmware
    V12.0.3.0.QDTMIXM

    Downloads
    Here

    Flashing instructions
    Here

    Changelogs are on #2 post
    Telegram channel for updates: Here
    Telegram group for support: Here

    Sources:
    Common device tree
    platina device tree
    Xiaomi SDM660 common kernel
    Common vendor blobs

    Happy modding!
    6
    2021/04/01
    - First official build

    2021/03/08
    - Synced latest LineageOS changes
    - March 2021 security patches
    - Upstreamed kernel
    - Added DT2W support for all platina touchpanels
    - (not a bug in my previous builds, might be useful to other maintainers) Fixed charging issues after kernel upstream

    2021/02/05
    - Synced latest LineageOS changes
    - Upstreamed kernel
    - Added WireGuard support
    - Fixed some camera denials

    2020/12/20
    - First release
    6
    First official build is out 🎉
    Check #1 and #2 for infos
    2
    So I finally got time to install this. Works very nicely so far. I am getting lots of "Trust - System Security" notifications about the keys being public signed. How do I disable this?
    Settings > Privacy > Trust > Go down and uncheck all the boxes
    2
    we really cant expect nothing from an unofficial ROM, even the official ones, specially the nysa case
    probably this guy will support it for some time then dissapear or make more ROMs, but we cant expect so much about it.
    what?
    I'm actually planning to go official with LineageOS, there's no way I'll abandon this phone soon