• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][OFFICIAL][R][OSS] LineageOS 18.1 for POCO X3 Pro [vayu/bhima]

Search This thread

Lu5ck

Senior Member
Dec 18, 2013
237
59
For feedback. Everything works fine on the ROM except

Camera is not great and the video recorder crashed each open. Replaced with Open Camera which is working well

The Bluetooth drivers for headphones could be better. I think I can tweak about with that tho

Overall very impressed
you can download gcam from https://www.celsoazevedo.com/files/android/google-camera/
you can check out https://t.me/PocoX3ProPhotography for some gcam config xml
i think there is an app that can change your audio output but i don't know what app
 
  • Like
Reactions: HastaPasta

HastaPasta

Member
Oct 11, 2021
31
7
Hi -- I hit a problem with TWRP.

I managed to flash a new recovery TWRP onto the POCO X3 Pro so that Magisk can be installed for root.

Then there is an issue with the TWRP seeing the Data mount, had to mess about with that to get the mount working, but that created a soft brick on the ROM. So then flashed a fresh LineageOS again and got that working, but then reverted back to the same issue in TWRP, where it get issues seeing Data /system_root/. This has involved changing the file type, reformatting etc.

Anyway I'm stuck in an endless loop now if I want a rooted phone, or will have to be satisfied with an unrooted phone

If anyone know how to get around this I'm all ears.

These are the errors

Failed to mount /system_root & /system_root busy

Many thanks
 

TioCareca

Senior Member
Hi -- I hit a problem with TWRP.

I managed to flash a new recovery TWRP onto the POCO X3 Pro so that Magisk can be installed for root.

Then there is an issue with the TWRP seeing the Data mount, had to mess about with that to get the mount working, but that created a soft brick on the ROM. So then flashed a fresh LineageOS again and got that working, but then reverted back to the same issue in TWRP where is get issues seeing Data. This has involved changing the file type, reformatting etc.

Anyway I'm stuck in an endless loop now if I want a rooted phone, or will have to be satisficed with an unrooted phone

If anyone know how to get around this I'm all ears.

These are the errors

Failed to mount /system_root & /system_root busy
never got that, but try to put the magisk files in a sdcard or try otg....

you use any screen lock? if yes try to turn it off ....
 
  • Like
Reactions: HastaPasta

HastaPasta

Member
Oct 11, 2021
31
7
never got that, but try to put the magisk files in a sdcard or try otg....

you use any screen lock? if yes try to turn it off ....
Hi thanks for replying

So I just put another fresh install of LineageOS and it is working. In dev opt these are check 'stay awake' 'usb debugging' 'usb root'... plus there is no screenlock or pin etc

So in TWRP on Mount. It will not accept to mount Data - if i mess about repairing it by switching to ext2 / ext4 and repair... These work, but unfortunately crash the ROM to soft brick
 

TioCareca

Senior Member
Hi thanks for replying

So I just put another fresh install of LineageOS and it is working. In dev opt these are check 'stay awake' 'usb debugging' 'usb root'... plus there is no screenlock or pin etc

So in TWRP on Mount. It will not accept to mount Data - if i mess about repairing it by switching to ext2 / ext4 and repair... These work, but unfortunately crash the ROM to soft brick
did you booted the rom before flashing magisk?
its strange because i just flashed twrp, then lineage and i can mount data....
seems you have to use a sd or otg...


Edit: you using this https://forum.xda-developers.com/t/recovery-unofficial-teamwin-recovery-project.4269551//unread
???
 
  • Like
Reactions: HastaPasta

HastaPasta

Member
Oct 11, 2021
31
7
did you booted the rom before flashing magisk?
its strange because i just flashed twrp, then lineage and i can mount data....
seems you have to use a sd or otg...


Edit: you using thishttps://forum.xda-developers.com/t/recovery-unofficial-teamwin-recovery-project.4269551//unread
???
I cannot install magisk from TWRP because of the system_root error, which is to MOUNT Data. The process starts up fine using then fails at the end. The magisk method failed extracting the boot image too. Maybe it will have to remain unrooted. The OTG works fine
 

HastaPasta

Member
Oct 11, 2021
31
7
did you booted the rom before flashing magisk?
its strange because i just flashed twrp, then lineage and i can mount data....
seems you have to use a sd or otg...


Edit: you using this https://forum.xda-developers.com/t/recovery-unofficial-teamwin-recovery-project.4269551//unread
???
It works now

The thing i did different was sequence

After a soft brick but TWRP is fine

Format and restart back to recovery

Flash LOS ROM

Then immediately after that still in recovery (previously i did a reboot here to test the LOS)

Flash Magisk.zip

Both installed fine and when phone booted, just followed set up instructions on Magisk and rebooted and all good now

Thanks a lot for the help - makes a chunk of difference having a phone without loads of surveillance
 
  • Haha
Reactions: TioCareca

TioCareca

Senior Member
Hy!

Whats the best camera app to use one LineageOS?
 
  • Like
Reactions: Olize

HastaPasta

Member
Oct 11, 2021
31
7
What is the best keyboard please. The keyboard on LOS only has spell check for certain apps, it doesn't show in browser for example.

OpenBoard and Hacker's Keyboard are better. Curious which is best??

Thanks
 

TheJags

Senior Member
Nov 16, 2017
61
5
Is network traffic monitor available with this ROM? Couldn't find it under settings > status bar.

Thanks.
 

TheJags

Senior Member
Nov 16, 2017
61
5
It works now

The thing i did different was sequence

After a soft brick but TWRP is fine

Format and restart back to recovery

Flash LOS ROM

Then immediately after that still in recovery (previously i did a reboot here to test the LOS)

Flash Magisk.zip

Both installed fine and when phone booted, just followed set up instructions on Magisk and rebooted and all good now

Thanks a lot for the help - makes a chunk of difference having a phone without loads of surveillance

Thanks a lot @HastaPasta followed the steps and it worked out great.

Just in case if anyone comes across this:

-- Flashed TWRP
-- Reboot to TWRP recovery
-- Format data / Factory reset
-- Reboot to recovery <--- Additional step mentioned by 'HastaPasta'
-- Installed LineageOS through USB OTG; OpenGapps pico, Magisk
-- Reboot to system

Note: While installing LineageOS, I did get an error/warning:

Code:
E: Unable to decrypt FBE device
MTP enabled

Despite the error, installation and reboot to system (LineageOS) went just fine.
 

Lu5ck

Senior Member
Dec 18, 2013
237
59
Ota-ed to lineage-18.1-20211015-nightly-vayu-signed.zip
No issue.

Is network traffic monitor available with this ROM? Couldn't find it under settings > status bar.

Thanks.
You mean data limit?
Hold wifi or mobile data at status bar to go their settings
What is the best keyboard please. The keyboard on LOS only has spell check for certain apps, it doesn't show in browser for example.

OpenBoard and Hacker's Keyboard are better. Curious which is best??

Thanks
im using gboard
 

TheJags

Senior Member
Nov 16, 2017
61
5
You mean data limit?
Hold wifi or mobile data at status bar to go their settings

Thanks for the reply @Lu5ck

No, not the data limit; I meant network traffic monitor. When you enable it, you can see network traffic on the status bar.

Here's few screenshots from LineageOS for Mi 10T Pro:


NTM_2.jpg


NTM_1.jpg


NTM_3.jpg
 

Attachments

  • NTM_1.jpg
    NTM_1.jpg
    42.2 KB · Views: 16

HastaPasta

Member
Oct 11, 2021
31
7
Are there basic instructions rather than months of development comments from devs and curious people??
 

Top Liked Posts