• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][RACER]Lineage OS 17.1

Search This thread

skalogre

Member
Dec 14, 2011
40
6
It happened to me last night.:confused:

Curiously, the reboot was long and rough. Usually the reboot is is pretty fast, but for that one and one or two others, the LineageOS boot up graphic ran for a few minutes and eventually froze. The the phone rebooted and the boot up process finished that time. Shouldn't that be a clue about the cause of the random reboots?

Could we at least agree that the black screen issue has been fixed? Anybody still getting that?
😬
Would you happen to use Nova Launcher and/or have the built-in Seedvault backup setup and running, by any chance?
I suspect those two being involved.
 

Giblet535

Senior Member
Apr 4, 2012
156
52
Just a note of thanks. And one question.

I just installed it (no google spyware. yet.) and I like it. Thank you again.

The LOS camera app is a bit weak. It works, but is there a GCAM port available, or a more feature-rich app like the stock rom app?
 

officerplonk

Member
Jan 20, 2016
45
7
First - thank you to the maintainers for your work.

Does anyone else have audio problems when playing via the 3.5mm headphone jack? Audio over Bluetooth works fine, but the aux jack messes up the sound in a very strange way. When playing a song for example, the first 1sec or so sounds fine, then it's like a bandpass filter kicks in and a lot of the highs and lows get lost. The filter sometimes sweeps around a bit, and occasionally more low-end comes through but it's mostly very nasty compressed midrange. Can't find any device settings that would influence this. I disabled AudioFX completely although it was already off, and that made no difference.

If needed, I can record a sample of the output for debugging purposes.

Edit 2: I just filed a detailed bug report, so hopefully this can go through the proper channels and be addressed. https://gitlab.com/LineageOS/issues/android/-/issues/4291

Edit 1: I'm not the only one - someone on the LOS subreddit reported the exact same problem 4 months ago.
 
Last edited:

skuppej

Senior Member
Jan 5, 2013
162
41
Is there any way to get the moto edge gestures back after installing LOS? (edge panel stuff)
 

Nuub8339

New member
Aug 12, 2021
1
0
Still can't get safety net to pass tried setting the device fingerprint and the safety net fix nothing works
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    2okPze5.png

    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Introduction:

    This is the unofficial Lineage OS thread for the Motorola Edge, codename racer.

    We support all the T-Mobile, International, and Project Fi variants, as their bootloaders are unlockable, while we can't support the Verizon and AT&T variants, as their bootloaders are permanently locked.

    How to install:
    • Boot the newest lineage recovery .img from the Link (or use TWRP).
    • IF YOU ARE COMING FROM STOCK AND WANT TO INSTALL CUSTOM ROMS FOR FIRST TIME, INSTALL "Copy Partitions Zip" FROM POST #2
    • In Recovery, click "Format Data".
    • ADB sideload the newest weekly
    • Click "Reboot, then choose "Recovery", this will boot you to either Lineage Recovery or TWRP depending on your choice to install TWRP or not. It is necessary to reboot between ROM flash and GApps/Addon flash due to verity/slot-swap logic.
    • (Optionally) Flash GApps - MindTheGApps arm64 are recommended, OpenGApps are compatible with A/B as of 09102018, but I still only recommend and support MindTheGApps.
    • Reboot

    Download:
    Screenshots:
    Screenshot_20210125-225025_Trebuchet.pngScreenshot_20210125-225034_Settings.pngScreenshot_20210125-225048_LineageOS_Settings.pngScreenshot_20210125-225053_LineageOS_Settings.pngScreenshot_20210125-225100_Settings.pngScreenshot_20210125-225105_Settings.pngScreenshot_20210125-225109_Advanced_settings.pngScreenshot_20210125-225115_Advanced_settings.pngScreenshot_20210125-225203_Trebuchet.pngScreenshot_20210125-225216_Camera.pngScreenshot_20210125-225258_Trebuchet.png

    XDA:DevDB Information

    Lineage OS 17.1, ROM for the Motorola Edge

    Contributors

    erfanoabdi, @SyberHexen, @Jleeblanch, Lineage Team
    Source Code: https://github.com/LineageOS & https://github.com/moto-sm7250

    ROM OS Version: 10.x Oreo
    ROM Kernel: Linux 4.19
    ROM Firmware Required: Official Android 10

    Version Information
    Status:
    Stable
    7
    Motorola Edge (racer) Gets Official LineageOS 17.1!

    Good news as you can see in the LineageOS Wiki the Motorola Edge (racer) is now officially supported with LineageOS 17.1.
    Nice to have an other recent 2020 device added to the roster.
    Supported models
    • XT2063-2
    • XT2063-3
    Note that it may take up to 1 week for the ROM & Lineage recovery downloads to become available for this device if all goes well with the Lineage automated builder: https://download.lineageos.org/racer

    Thank you to the volunteer LineageOS maintainers @erfanoabdi, @SyberHexen, & @Jleeblanch. ↑ (ツ)
    2
    The last posts in this thread have been edited/deleted. I take this opportunity to remember where you can read the forum rules
    After reading the rules and even though you think something is against it, you should use the report button instead of create spam topics that bring nothing of value to our community.

    Thank you!
    FSadino
    1
    Happened twice to me yesterday. I have adaptive brightness on, in Livedisplay I have the automatic display mode, power consumption reduced, a 30 second screen timeout, in ambient display gestures I have pick-up and hand wave on. Nova 7 as my launcher, password/fingerprint in use.

    Display was off - the phone moved so that quick display popped on - I pressed the power button and the lock screen appeared - I pressed the power button again and the screen went blank - all well so far. I then pressed the power button again and the screen remained off while the phone was running as normal. Screen would not turn back on.

    On one occasion the above happened and I flipped the phone over and laid it down. I waited 20 or so seconds and picked the phone up and that quick notification display reappeared. I pressed the power button and the lock screen appeared - all was well. On the other occasion the screen remained off and I had to reboot.

    It doesn't always happen, sometimes it fixes itself while most times it doesn't. For me, it's always power button related.