[ROM][OFFICIAL][redfin] LineageOS 18.1

Search This thread

Namelesswonder

Senior Member
Please remove the apn you created and test this updated apn configuration, so we can fix it for everyone:
Bash:
wget https://raw.githubusercontent.com/LineageOS/android_vendor_lineage/91a0b00c0fe165941827ef68489fd33e85365b41/prebuilt/common/etc/apns-conf.xml
adb root
adb remount
adb push ./apns-conf.xml /product/etc/apns-conf.xml
adb reboot

Working fine, mobile network state is connected and WiFi calling enabled. Had to reset the APN list in the Settings app to get it to pull the new config.
 
  • Like
Reactions: user602 and aleasto

klaberte

Senior Member
Jul 19, 2007
402
176
Google Pixel 5
hi, you are right - it is now disabled for me as well (20210421). probably it was enabled for the unofficial builds? i am not using bt that often.

@aleasto it seems like this was working in the unofficial builds, and then got turned off. Can you share more on what triggered it being defeated, and if there is much chance of it coming back. IIRC, this is included in the official Lineage OS 18.1.
 

Grubmi

Senior Member
Jan 26, 2011
104
50
Google Pixel 5
@aleasto it seems like this was working in the unofficial builds, and then got turned off. Can you share more on what triggered it being defeated, and if there is much chance of it coming back. IIRC, this is included in the official Lineage OS 18.1.
I think it's feature of Android 11.
 

klaberte

Senior Member
Jul 19, 2007
402
176
Google Pixel 5

YandereSan

Senior Member
Sep 1, 2013
197
85
Bug: Developer Options -> Wi-Fi scan throttling turns back on after reboot

edit: After spam toggling it a couple dozen times, it stopped turning back on after reboot. Strange.
 
Last edited:

Flappyraccoon

Senior Member
May 11, 2011
79
9
Portland
Hello, I'm coming from android 4.1 so the methods are quite different now a days I'm sure. I use android without gapps but would usually adb push libjni_latinimegoogle.so to the respective /system/lib folder after remounting the proper partition as rw. With android 11 no matter what I try, pushing lib64 libjni_latinimegoogle.so to /system/lib64, the plain lib version to /system/lib or both (this was my latest attempt) Glide remains disabled after restart.

Has the keyboard in LineageOS 18.1 been changed in some way this is no longer compatible or have any idea? When I use ls -l the files have proper permissions.

-rw-r--r-- 1 root root 1112352 2008-02-29 03:33 libjni_latinimegoogle.so

They also do not disappear after reboot. I took them from the MindTheGapps-11.0.0-arm64-20210412_124247.zip

I'm trying to look at the update-binary in MindTheGapps to see if I can understand how it works since Glide works after flashing the whole zip but scripts are not my strong suit. :X


Edit: Scratch that, razorloves informed me you push the 64bit lib to /product/lib64/ and that did the trick.
 
Last edited:
This may be a silly question but i am thinking about grabbing a cheap (as cheap as possible) used Pixel5 and play a little bit with it. I am using LOS 18.1 on a Samsung klte and Pixel 2 and Pixel 3. All good so far. The #5 has a very good camera and this is the main point for me. How good is the LOS 18.1 camera on the Pixel 5 ? I am not interested in those google services/playstore, i use my LOS phones without any google stuff or root, just the pure LOS images. Can the LOS camera compete with the native Pixel one? Thanks for any hints/replies
 

aleasto

Senior Member
Jul 15, 2012
911
2,495
Milan
If you're using SBC Dual Channel, you currently need to "Disable Bluetooth A2DP hardware offload"
Otherwise, try unpairing and pairing again your bluetooth device
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    @aleasto, apologies if this comment/question belongs somewhere else, e.g. on the gerrit, please be kind as I am a newbie on LineageOS.

    It looks like Bruno added several merges to enable this over the past few months. Then, I see a bunch of Reverts by you made in the past week.

    Q1: Did the Reverts you did cancel Bruno's earlier merges?
    Q2: Are Bruno's patches currently in, or out, of the latest weekly build?
    Q2.5: How could someone like me (clueless) confirm this?
    Q3: For someone (asking for a friend) wants to study the entire patch set for Lineage OS 18.1 that adds SBC HD, can I assume the starting point would be: https://review.lineageos.org/q/topic:"eleven-bt-sbc-hd-dualchannel"+(status:eek:pen OR status:merged)
    Q4: Is there lingo or a term to describe the entirety of the changes shown in the link of Q3?

    Thank you!

    Ken
    A1: I had uploaded the reverts while we were still discussing wether we would be able or not to fix the issues caused by this feature (was not tested well enough in the first place). After a supposed fix was found, I've abandoned the reverts meaning they never made it into a build.

    A2: The original patches are in, plus the earlier mentioned fix.

    A3: https://review.lineageos.org/q/topic:"eleven-bt-sbc-hd-dualchannel"+(status:eek:pen OR status:merged) is indeed the right place to look at. There's also an engineering blog post authored by the same person that introduced the functionality: https://lineageos.org/engineering/Bluetooth-SBC-XQ/

    A4: Not sure what you mean. A "topic" of changes perhaps? A "feature bringup" series of commits?

    After the supposed fix was merged and made it into a public build and more people than just me and few others could test it, we found out it was broken in specific scenarios (still not 100% sure but i believe it's when the a2dp sink only supports SBC). The same day a solution to this was found, effectively reverting the other fix and applying a better one; it's now merged and will be included in the next build. You can find all the history in your link.
    3
    Looks like I've found a fix, pending more testing but we'll hopefully make it in time for the next build.
    3
    Latest version of gcam? Can you try astro mode? I have problem with astro, after that it will crash on any mode. Only latest version 8.2.400
    Can reproduce, assessing if it's fixable...
    2
    Unlikely. The issue most likely is with the sink (the car head unit).
    Everyone's car suddenly stopped working on May 27th? :p

    The fix has been merged and will be included in the next build.
    2
    How i can install magisk on this?
    You can rename magisk APK to ZIP and sideload through ADB, then as far as I remember you can do the full install from the installed manager.
  • 34
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. LineageOS does still include various proprietary hardware-specific code.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Informations :
    • This ROM uses source built kernel, kernel modules, boot kernel modules (vendor_boot) and vendor image.
    • This ROM bundles the latest firmware so you don't have to worry about updating firmware beforehand.
    • To use the eSIM you need to install GApps
    Instructions :
    • Download the latest recovery image and rom zip
    • Boot to bootloader
    • fastboot flash boot boot.img
    • Boot to recovery
    • Format data
    • Flash LineageOS zip
    • Optionally flash any addons:
      • Advanced > Reboot to recovery
      • Flash the addons
    • Reboot
    See https://wiki.lineageos.org/devices/redfin/install for more detailed instructions​

    Downloads :
    Reporting Bugs
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/* (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved.

    Known Issues
    • On the first boot, you might be presented the message "SIM Manager has crashed". You can safely ignore it.
    Contributors
    aleasto
    The LineageOS Team

    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 11
    11
    New build out
    The final checkups before official rolls out.
    We've also managed to remove the need for flashing vendor_boot.img so now the install instructions are back in line with other pixels.
    11
    New build out
    Enable Adaptive Sound, Live Captions, Now Playing, Screen Attention pixel features.
    These all work without gapps, and all process data offline.
    11
    New build out
    • Feb 2021 security patch
    • Update modem firmware from the T-Mobile factory images to enable 5G Standalone.
      Google only did this for T-Mobile images (RQ1C.210205.006), but it doesn't seem to negatively affect non T-Mobile users, thus I'm including it in the generic build (RQ1A.210205.004 based).
    10
    Bluetooth HD Audio fixed in the next build