• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][OFFICIAL][sake][11] LineageOS 18.1

Search This thread

ZVNexus

Recognized Developer
Feb 23, 2016
1,067
1,707
Tempe, AZ
I'll give my detailed feedback below , hope other ones with similar issues will complete:
- with Oneplus Buds, BT 5.0 codec AAC/SBC => everything works fine
- with Xiaomi Flipbuds Pro, BT 5.2 codec AAC/SBC/Aptx Adaptive => listening to Spotify, Apple Music, New Pipe, voice messages on Signal/Whatsapp/Wechat works fine with every codec (Aptx Adaptive is the one chosen by default once buds are connected tho). Leaving voice messages works fine. However calling (or videocall) using phone or messaging app makes the app bug/crash. Even when I force AAC/SBC in dev options
That's unfortunate but considering I make calls over Bluetooth on a daily basis and I've never had an issue so I can't reproduce, and without logs I can't look into it.
 

Anghirrim

Senior Member
Apr 29, 2011
1,080
239
Google Nexus 5
Google Pixel 3a
Hello,

First of all, thanks a lot for your work. That's super nice to see LOS on such a recent phone.


A friend of mine is considering to buy a Zenfone 8 but wants to run /e/ OS on it.

As it is based on LOS4microg, i can easily build it (it's ongoing).

Question is now, can we use LOS recovery to flash /e/ on the Zenfone 8? Or he'll have to use TWRP?

Just asking this because I saw your warning about not using TWRP when possible.

Thanks!
 
  • Like
Reactions: NisseGurra

jaalai

Member
Sep 18, 2021
16
12
ASUS ZenFone 8
Reporting here 2 minor "bugs":
- i'm using a full black background and on the home screen, the very top of the screen (2mm) is lighter, not pitch black same as the rest of the background. It seems that the notification bar graphical effects are always here even when the bar isn't pulled down. Can observe this only in a pitch black room without lights !
- I feel like the dual-speakers are not balanced same as stock. In Newpipe, the earpiece speaker seems louder than the main bottom one.
 

jaalai

Member
Sep 18, 2021
16
12
ASUS ZenFone 8
Last edited:

vishnu350

Member
Jul 2, 2019
10
13
Tried latest nightly+root, no gapps. Works brilliantly. Battery life is excellent.

Issues that I found (and some solutions):
1) Mobile data + roaming doesn't work. May need to tweak build.prop?
2) Mobile data + custom DNS doesn't work. Solution:
Manually select APN in network settings.
3) Phone is permanently in 120Hz adaptive mode. Do this via adb to drop it to 60hz if u want battery life (or 90, 120)
settings put system peak_refresh_rate 60
settings put system min_refresh_rate 60

4) Always-on display is always kinda bright, doesn't scale with screen brightness setting (unless brightness turned all the way to 0). AOD is also always in 120Hz, which is odd.
5) Invoking the "remount" command in the shell (for RW permissions on system,vendor,etc) works. But it causes the phone to take an extra 2-3 mins to boot up, and at the end it complains about trebuchet before asking you to kill it.
 
Last edited:

vishnu350

Member
Jul 2, 2019
10
13
For those with the ramdump issue, I may have a clue to what is going on. This is my 2 cents.

Based on the zentalk forums, I had a suspicion it has something to do with the charging controller chip on the phone. So I adventurously tried the magisk "advanced charging controller" module. After a few minutes of installation, boom. The phone froze and then ramdump. It was plugged into the PC (for adb) and was charging. I did a hard 20s reset and it went away, rebooted back into good old LineageOS again.

My advice: Stay away from cheap chargers or high current chargers, even the one from Asus. I suspect it may be causing the chip to switch to high current charging mode, and something burns out. I doubt everyone is in the same QC issue boat (I do still think this is a rare problem), but dont risk it if this is your daily driver. Get a good old "slow", low current charger (1-2 Amps) from the last generation of phones and stick with that.
 

Blumi511

Member
Sep 19, 2021
25
8
ASUS ZenFone 8
For those with the ramdump issue, I may have a clue to what is going on. This is my 2 cents.

Based on the zentalk forums, I had a suspicion it has something to do with the charging controller chip on the phone. So I adventurously tried the magisk "advanced charging controller" module. After a few minutes of installation, boom. The phone froze and then ramdump. It was plugged into the PC (for adb) and was charging. I did a hard 20s reset and it went away, rebooted back into good old LineageOS again.

My advice: Stay away from cheap chargers or high current chargers, even the one from Asus. I suspect it may be causing the chip to switch to high current charging mode, and something burns out. I doubt everyone is in the same QC issue boat (I do still think this is a rare problem), but dont risk it if this is your daily driver. Get a good old "slow", low current charger (1-2 Amps) from the last generation of phones and stick with that.
Thanks for the advice. Actually put that up as a single thread maybe? There are lots of people who could learn sth from that
 

qb74

Senior Member
Dec 2, 2016
171
50
For those with the ramdump issue, I may have a clue to what is going on. This is my 2 cents.

Based on the zentalk forums, I had a suspicion it has something to do with the charging controller chip on the phone. So I adventurously tried the magisk "advanced charging controller" module. After a few minutes of installation, boom. The phone froze and then ramdump. It was plugged into the PC (for adb) and was charging. I did a hard 20s reset and it went away, rebooted back into good old LineageOS again.

My advice: Stay away from cheap chargers or high current chargers, even the one from Asus. I suspect it may be causing the chip to switch to high current charging mode, and something burns out. I doubt everyone is in the same QC issue boat (I do still think this is a rare problem), but dont risk it if this is your daily driver. Get a good old "slow", low current charger (1-2 Amps) from the last generation of phones and stick with that.
Lovely to hear this finding!
I've been considering buying a small, 120hz flagship phone and the ramdump issue was hindering me from getting it.
Any recommendations which charger to buy? Do you perhaps own the equipment to test if this is the case and find precise amps needed for a brick (and what exactly it bricks first?)
Iirc, ramdump doesn't seem to specifically be related to one particular issue for all devices (it apparently varies from device to device, as I've seen people mention their phones just dying while using it) so is there any way you could find someone who has a ramdumped phone to verify these findings? I'd love reading an expansion of this topic, in a separate thread! Thank you!
 
Last edited:

modpunk

Recognized Contributor
Oct 14, 2011
1,718
6,634
Sony Xperia XZ1 Compact
Samsung Galaxy S10
For those with the ramdump issue, I may have a clue to what is going on. This is my 2 cents.

Based on the zentalk forums, I had a suspicion it has something to do with the charging controller chip on the phone. So I adventurously tried the magisk "advanced charging controller" module. After a few minutes of installation, boom. The phone froze and then ramdump. It was plugged into the PC (for adb) and was charging. I did a hard 20s reset and it went away, rebooted back into good old LineageOS again.
Interesting. Would be nice if you could download the ramdump and extract the kernel logs.

However the device normally checks the battery health to prevent it from overheating and reduces the charging current. I've fixed checking the battery status, see https://review.lineageos.org/c/LineageOS/android_device_asus_sake/+/316995
 

Meepaco

Senior Member
Apr 3, 2019
54
7
For those with the ramdump issue, I may have a clue to what is going on. This is my 2 cents.

Based on the zentalk forums, I had a suspicion it has something to do with the charging controller chip on the phone. So I adventurously tried the magisk "advanced charging controller" module. After a few minutes of installation, boom. The phone froze and then ramdump. It was plugged into the PC (for adb) and was charging. I did a hard 20s reset and it went away, rebooted back into good old LineageOS again.

My advice: Stay away from cheap chargers or high current chargers, even the one from Asus. I suspect it may be causing the chip to switch to high current charging mode, and something burns out. I doubt everyone is in the same QC issue boat (I do still think this is a rare problem), but dont risk it if this is your daily driver. Get a good old "slow", low current charger (1-2 Amps) from the last generation of phones and stick with that.
ACC causes ramdump when it reaches the stop charging %. I don't think the kernel supports it much, it doesn't detect any charging switches for whatever reason.

I should also say: Device has finicky behavior while charging. There is a continuous very high pitched sound coil whine while charging plugged it into a tabletop lamp. Plugged into a 12w adapter there is a pulse of this same sound before going silent. (Have not tried oem brick.) Sound seems to be coming from the adapter. No other device causes this.
 

vishnu350

Member
Jul 2, 2019
10
13
Interesting. Would be nice if you could download the ramdump and extract the kernel logs.
Any idea which partition would the ramdump log be in? If you can point the path to me, maybe ill try to pull it out from recovery mode? When it happened I instinctively pulled out the USB cable and held the power button down, without thinking about eventually posting it here. Sorry. I didn't want to risk anything so I went to recovery and wipe+reflashed LineageOS.

However the device normally checks the battery health to prevent it from overheating and reduces the charging current. I've fixed checking the battery status, see https://review.lineageos.org/c/LineageOS/android_device_asus_sake/+/316995
I think the battery was 100%, and the phone was cold, not even barely warm. No sim/radio, GPS/bluetooth/nfc disabled, no Gapps, almost zero apps installed. Even the screen brightness was set to low. Only WiFi, magisk, and maybe the default browser was open. It was a fresh LineageOS install. So the only reasonable conclusion is the Magisk ACC module script did something to directly/indirectly induce the ramdump.

In the Zentalk forums, most of the guys who RMA the phone got the motherboard PCB replaced, with not much explanation from Asus. The best explanation was one guy who was told that there was something wrong with the USB charging port. Also, there seem to be a couple of guys with working phones who have charging issues with aftermarket high amp chargers.
 
  • Like
Reactions: qb74

modpunk

Recognized Contributor
Oct 14, 2011
1,718
6,634
Sony Xperia XZ1 Compact
Samsung Galaxy S10
Tried latest nightly+root, no gapps. Works brilliantly. Battery life is excellent.

Issues that I found (and some solutions):
1) Mobile data + roaming doesn't work. May need to tweak build.prop?
2) Mobile data + custom DNS doesn't work. Solution:
Manually select APN in network settings.
3) Phone is permanently in 120Hz adaptive mode. Do this via adb to drop it to 60hz if u want battery life (or 90, 120)
settings put system peak_refresh_rate 60
settings put system min_refresh_rate 60

4) Always-on display is always kinda bright, doesn't scale with screen brightness setting (unless brightness turned all the way to 0). AOD is also always in 120Hz, which is odd.
5) Invoking the "remount" command in the shell (for RW permissions on system,vendor,etc) works. But it causes the phone to take an extra 2-3 mins to boot up, and at the end it complains about trebuchet before asking you to kill it.
1) I can confirm that roaming doesn't work. I will look into it.
2) What kind of DNS server did you use, just a normal one? DoH DoT?
3) There is no way that you can change it in Settings, maybe worth to open a LineageOS feature request.
4) The AOD brightness is a fixed value, there is no way to change it.
5) I don't think Andorid is designed here that you mount these partitions RW at all. Normally you have dm-verity which would stop booting as soon as you modify anything on the partition.
 
  • Like
Reactions: chrisrevoltes

modpunk

Recognized Contributor
Oct 14, 2011
1,718
6,634
Sony Xperia XZ1 Compact
Samsung Galaxy S10
Tried latest nightly+root, no gapps. Works brilliantly. Battery life is excellent.

Issues that I found (and some solutions):
1) Mobile data + roaming doesn't work. May need to tweak build.prop?
Actually, would it be possible to get logcat from a data roaming which doesn't work. I wonder if this is property issue or an AVC denial.
 

vishnu350

Member
Jul 2, 2019
10
13
1) I can confirm that roaming doesn't work. I will look into it.
2) What kind of DNS server did you use, just a normal one? DoH DoT?
3) There is no way that you can change it in Settings, maybe worth to open a LineageOS feature request.
4) The AOD brightness is a fixed value, there is no way to change it.
5) I don't think Andorid is designed here that you mount these partitions RW at all. Normally you have dm-verity which would stop booting as soon as you modify anything on the partition.
1) Will work on a logcat for you with a roaming sim toggled on/off. Will pm when I get something.
2) I was trying with DoH. But I think for some reason Lineage doesn't pick the correct APN, selecting it manually in the network settings solved the issue.
4) I found one way. AOD brightness seems to be same throughout, except when the screen brightness goes all the way to 0: settings put system screen_brightness 0
When it is 0, the AOD brightness is somewhat dim. Anything higher than this and AOD reverts back to its usual brightness.
 

Fatso

Senior Member
Apr 3, 2006
67
9
Wroclaw
ASUS ZenFone 8
Any idea how to force Google Pay to work with Lineage?

Ok, and a little feedback from my side.
After google backup recovery, system was crashing every time i've connected phone to the charger - it was no difference if it was wall charger of cable to computer/android auto. Ram Dump every time, and every time stuck in Ram Dump.
 
Last edited:

jaalai

Member
Sep 18, 2021
16
12
ASUS ZenFone 8
I just had a ramdump and was able to reproduce it: last nightly, hotpost ON, LTE, not charging the phone, downloading a big file on my Windows PC at around 3 Mo/sec. After several minutes => ramdump. Did that already 3 times, exact same behavior. (no logcat sorry !)
 
  • Like
Reactions: qb74

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    It's just a HUGE thanks message to the LineageOS and XDA developers who helped me getting it on my new phone.
    No Google, pure AOSP experience is a very very comfortable experience for me, it's a peace of mind.
    THANK YOU !
    2
    Oh no, I'm living in a country where Google doesn't exist + my point of using LOS is not to have Google :) However I use bank apps without any pb.

    Fair enough. 😅 I guess that's the main reason for most LOS users. Thanks for your reply!
    1
    Im a bit old so im used to this being called nightly and stable, is there somewhere i can follow along to see when i can use this as my daily driver?
    1
    Im a bit old so im used to this being called nightly and stable, is there somewhere i can follow along to see when i can use this as my daily driver?
    Just for info, I'm using it as a dail since the 1st nightly and it's very stable.
    Only major issue I have is the impossibility of calling when using earbuds with aptx adaptive bluetooth codec. The rest is super fine, or very minor.
    1
    Are you using GPay and banking apps and stuff that requires passing SafetyNet? Are you rooted? I would like to switch at some point to LOS but GPay became my primary source of payment, so I don't want to risk losing it.
    Oh no, I'm living in a country where Google doesn't exist + my point of using LOS is not to have Google :) However I use bank apps without any pb.
  • 24
    2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. A direct link to kernel sources can be found here. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    Download:

    Reporting Bugs:
    • DO NOT report bugs if you're running a custom kernel or you installed Xposed.
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless.)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.
    10
    Can i ask you guys whic happs do you use for camera? does the LOS build lose in terms of camera quality? really hyped about this as i got my ZF8 today.
    Right now it's just Camera2 but I intend to look into shipping ASUS Camera tonight instead.
    9
    Can't tell as I can't make the LED work, even after several factory resets :(
    I've fixed the LED for notifications, see https://review.lineageos.org/q/topic:sake-led
    8
    hey ZVNexus, thanks for your work. I use your first no gms build. Wehre can i find the new one? Only GMS now?
    A lot of people use LOS without google apps....

    Thanks and best wishes
    I don't have the bandwidth to upload both so I just upload what I personally use. Officials come out starting around Friday, so those will be without GMS and have a regular upload schedule.
    6
    I'm using it daily for 2 weeks:
    ++
    no Ramdump (05-2021 batch)
    better fluidity compared to stock
    very stable
    battery improvement compared to stock (not huge)
    no Google :)

    --
    can't use BT earbuds with aptx codec during calls from phone or app (Signal, Whatsapp, Wechat), but all listening functions works well (spotify, new pipe, vocal messages, etc...). works fine with AAC/SBC earbuds.
    can't use the LED notification (works for ZVNexus tho)
    The LED works for battery stuff, not notifications. When the next weekly build rolls out this will resolve the issue: https://review.lineageos.org/c/LineageOS/android_device_asus_sake/+/318068