Development [ROM][OFFICIAL][sake][12.1] LineageOS 19

Search This thread

emc02

Senior Member
Jul 4, 2010
238
70
Vienna
I was testing again with a very cold phone (near the AC) and got on 3D Mark nearly the same values as expected. Maybe the throttling is on LOS on lower Temps.

Did anyone try LOS with custom kernels like that?
 
  • Like
Reactions: alekksander

alekksander

Senior Member
Nov 1, 2016
56
7

I was testing again with a very cold phone (near the AC) and got on 3D Mark nearly the same values as expected. Maybe the throttling is on LOS on lower Temps.

Did anyone try LOS with custom kernels like that?
Wondering same thing. Not only in matter of performance, but overall exoerience los+kirisakura.
 

Xt1d36

New member
Apr 28, 2019
3
0
ASUS ZenFone 8
Anyone know a working call recorder? I tried the magisk modules for axet, BCR, and SKVALEX but I can't get them working. Unless there's something obvious that I am missing. It's been a long time since I've needed to use one of these.
 

MadDogMaddux

Senior Member
Oct 15, 2010
433
70
Well I swore I wasn't going to flash another ROM after my HTC ONE, but here I am. 🤦

19.1 onboard my Zenfone and working great! Thanks guys.

Two requests:
- does anyone know if we can get the ASUS camera back? Flash the original APK or anything?
- Similarly, I used the stock Zenfone long enough to REALLY dig the keyboard it came with. Does anyone have a way to get that back within Lineage?

Thanks again to the devs who are collabing on this!
 
Last edited:

Adaoh

Senior Member
Jun 13, 2021
147
68
ASUS ZenFone 8
Well I swore I wasn't going to flash another ROM after my HTC ONE, but here I am. 🤦

19.1 onboard my Zenfone and working great! Thanks guys.

Two requests:
- does anyone know if we can get the ASUS camera back? Flash the original APK or anything?
- Similarly, I used the stock Zenfone long enough to REALLY dig the keyboard it came with. Does anyone have a way to get that back within Lineage?

Thanks again to the devs who are collabing on this!
I am not sure about the camera app, I already tried and it did not work, but did not do further digging. Anyways I would recommend Wichaya's Gcam, it takes better pictures anyway. For the keyboard, the one it originally comes with is Gboard!
 

alekksander

Senior Member
Nov 1, 2016
56
7
does anyone have a problem with inconsistent display brightness over this rom? not sure if my unit is faulty or something about LOS, but i never noticed it over stock. to check if You have this issue go to security settings and try to add fingerprint – the moment i touch sensor and it lights up whole background dims down.
 

MadDogMaddux

Senior Member
Oct 15, 2010
433
70
I am not sure about the camera app, I already tried and it did not work, but did not do further digging. Anyways I would recommend Wichaya's Gcam, it takes better pictures anyway. For the keyboard, the one it originally comes with is Gboard!
Thanks, I'll check out Gcam!

Also, holy heck, GBoard is now internally skinnable? Sweet!

@Adaoh thanks for the good words! I'm running GCam right now and it rocks!
 
Last edited:

alekksander

Senior Member
Nov 1, 2016
56
7
does anyone have a problem with inconsistent display brightness over this rom? not sure if my unit is faulty or something about LOS, but i never noticed it over stock. to check if You have this issue go to security settings and try to add fingerprint – the moment i touch sensor and it lights up whole background dims down.
back to stock → went to fingerprint settings and screen dims only at first finger touch, next the touches doesn't cause screen dim as it stays slightly dimmed. probably energy managing. i consider this to be a LOS bug. this is 100% reproducible on my unit. can someone pls confirm?

edit: seems it's correlated with screen refresh rate, and for some reason it acts differently under LOS despite toggling similar settings. quite weird, and still not sure how does this relate to hardware – i'm sure it does somehow, because when i set display to 120hz and to display refresh rate in top corner this 120 number dims slightly on unlock screen when sensor lights up. that doesn't seem right…

edit2:
with hard 120hz and androids toggable „lower screen brightness” set on it will still change color. without lowering brightness (by that extra quick tile setting only, as brigthness slider doesn't affect this in any config) it will remain colors and all screen areas 100% consistent. case solved… if someone can confirm :) my unit is made in china and i can relate only to chinese units. (made in indonesia screens are different (too sharp and too bright) and i prefere cn ones.)
 
Last edited:

MadDogMaddux

Senior Member
Oct 15, 2010
433
70
Hey all, I've been searching and haven't seen this: Is there a way to make the lockscreen icon (the padlock in a circle) invisible? I've got everything set up really nicely, would just like that to dissappear. Thanks in advance!
 

tafarelli

Senior Member
May 21, 2012
90
16
Installed yesterday - working mostly fine BUT:
whatsapp, viber, google duo calls sound is quite distorted - as if it is not receiving sound very well so I can't fully understand person I am speaking to (sound quality on calls is very bad but also some words are not passing through at all).
Does anyone else have this issue and, of course:), is there a fix?
Tx

Edit - I think it was because of L speed magdisk module - will test more
 
Last edited:

alekksander

Senior Member
Nov 1, 2016
56
7
Installed yesterday - working mostly fine BUT:
whatsapp, viber, google duo calls sound is quite distorted - as if it is not receiving sound very well so I can't fully understand person I am speaking to (sound quality on calls is very bad but also some words are not passing through at all).
Does anyone else have this issue and, of course:), is there a fix?
Tx

Edit - I think it was because of L speed magdisk module - will test more
is it over wi-fi? if so i noticed unwanted slow downs on wifi performance that might cause it. however i'm not able to fully reproduce it.
 

MadDogMaddux

Senior Member
Oct 15, 2010
433
70
Ok, maybe I'm just dumb.

But I can't find any changelog info on n the monthly Lineage updates. I mean, I found a lineage changelog website, but at least on my phone it was basically inop.

Maybe I'm just old, but whenever I got an OTA update of VenomROM or Warm, it came with a changelog. I'm not even that tech savvy, but I still like to read it.

Any help here?


Nothing to see here, I figured it out.
 
Last edited:

Mykemonster

Member
Apr 18, 2018
6
0
Hello everyone, do any of you fail to double tap to wake without having the allways on display active? It takes a long time to detect touches with the screen off.
 

Mobe1969

Senior Member
Apr 4, 2013
188
28
53
Brisbane
Xiaomi Mi 10T Lite
Just wondering specifically on the model numbers. In Australia there are two, the 128 and 256GB units, as with the US, both ZS590KS prefixed though (ZS590KS-2A052WW and ZS590KS-2A052WW). I've noted above that it installs on the EU model so wondering if the "ZS590KS" is that is just the suitable prefix. I expect that the American models are both prefixed ZS590KS, but would have sub model numbers like the Australian ones.
 

MadDogMaddux

Senior Member
Oct 15, 2010
433
70
Pretty sure mine is Taiwanese, 12/256 but it is just listed as zs590ks on the box. Same with my wife's, which is an 8/256.

From what I was seeing on the ASUS website, the only model officially sold in the USA was the 8/128 model.

The important thing, though, is that they are all supported by the same LineageOS build.
 

Mobe1969

Senior Member
Apr 4, 2013
188
28
53
Brisbane
Xiaomi Mi 10T Lite
Pretty sure mine is Taiwanese, 12/256 but it is just listed as zs590ks on the box. Same with my wife's, which is an 8/256.

From what I was seeing on the ASUS website, the only model officially sold in the USA was the 8/128 model.

The important thing, though, is that they are all supported by the same LineageOS build.
Yes I guess so. Looking on eBay I guess you caused that different colors have different models too.
 

HyperCriSiS

Senior Member
Nov 23, 2010
404
84
Samsung Galaxy S7
ASUS ZenFone 8
Hi,

just wanted to update from LOS 18 to 19 but I even can't get into the recovery.
I did a factory reset, flashed new vendor boot image and try to boot into recovery.
Then RAM dump :(

What am I doing wrong?

Thanks and regards,
Hyper

//EDIT:
I had to flash the RAW image to get it working again.
Now I have Bootloop until it says the device can't be trusted and will not boot.

//EDIT:
I have reverted to LOS 18 now, which works well. Something is wrong with LOS 19 :confused:
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Pretty sure mine is Taiwanese, 12/256 but it is just listed as zs590ks on the box. Same with my wife's, which is an 8/256.

    From what I was seeing on the ASUS website, the only model officially sold in the USA was the 8/128 model.

    The important thing, though, is that they are all supported by the same LineageOS build.
  • 27
    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. A direct link to kernel sources can be found here. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    Download:
    Reporting Bugs:
    • DO NOT report bugs if you're running a custom kernel or you installed Xposed.
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless.)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues.
    9
    Put up a new build with some things resolved, notably SELinux is now Enforcing.

    I also switched from stock's prebuilt NXP NFC stack to the open source stack. Anyone who is able to make payments with Google Pay or something like that, let me know if it works.

    Added a vendor_dlkm partition to hold vendor kernel modules so you can flash a different vendor regardless of the kernel situation as the modules are no longer held there.

    Enabled automatic brightness by default.

    Fixed night light by correct PIxelworks device detection.

    Switched from QTI BT to AOSP BT until it gets merged.
    7
    New builds are out, audio fixed along with other stuff.
    6
    Put out a new GMS and GMS-less build today, an absolute ton of changes. Go try them out. Notably, the entire display doesn't go to max brightness when using fingerprint anymore. Support for FOD on AOD added too, all thanks to @demon000. Tons of initial Setup Wizard changes, especially for non-GMS users.
    6
    Put out a new build, forgot list of changes. Try it out. Put up both GMS and non GMS this time.