[ROM][OFFICIAL][TREBLE][X72X][11.0.X] LineageOS 18.1 for LeEco Le Pro3

Search This thread
Oct 27, 2012
31
7
OnePlus 8
i have 2 devices on both same problem-is there any partition problem?

edit:
so i solved the problem while first installed lineage 17.1 unofficial - bootet up and configured ready.
than back to recovery and installed lineage18.1 + mindthegapps

than it worked

thanks for help
I ran into this issue recently where it would reboot to the recovery while loading. MindtheGApps didn't work. OpenGApps nano didn't work. The only one that worked was basic FlameGApps. (https://sourceforge.net/projects/flamegapps/)

@mosimchah Is there an advantage/disadvantage of one installer over another?
 

mosimchah

Senior Member
Dec 7, 2014
4,211
9,480
LeEco Le Pro3
ASUS ROG Phone 3
I ran into this issue recently where it would reboot to the recovery while loading. MindtheGApps didn't work. OpenGApps nano didn't work. The only one that worked was basic FlameGApps. (https://sourceforge.net/projects/flamegapps/)

@mosimchah Is there an advantage/disadvantage of one installer over another?
Mindthegapps worked fine when I tested it, flame gapps is a great option too though, there are differences though, they are different projects, it's hard to say if one is definitively better than another
 
  • Like
Reactions: thundercracker

thorsen83

Senior Member
Nov 23, 2010
60
6

minimax222

New member
Sep 2, 2021
4
2
Overall, the best stable rom for this device. Good work, thanks.
1. Will be better (for my taste) replacing this ugly "recents" with an miui style.
2. Can you implement "skip screen lock" (including after restart) option ? For unlock device by fingerprint.
Thanks
 

panos196

Senior Member
Feb 6, 2018
169
17
Hello !!! when I do a total of 2-3 reboots I put the pin on the phone but it does not open I can not make calls or see messages, we only accept calls, applications do not open
 

kot2202

Senior Member
Dec 26, 2017
54
3
On my x727 on
Code:
lineage-18.1-20211120-nightly-zl1-signed
I have really low volume during call. I tried editing mixer_paths_tasha.xml
Code:
    <ctl name="RX0 Digital Volume" value="92" />
    <ctl name="RX1 Digital Volume" value="92" />
    <ctl name="RX2 Digital Volume" value="92" />
    <ctl name="RX3 Digital Volume" value="92" />
    <ctl name="RX4 Digital Volume" value="92" />
    <ctl name="RX5 Digital Volume" value="92" />
    <ctl name="RX6 Digital Volume" value="92" />
    <ctl name="RX7 Digital Volume" value="92" />
    <ctl name="RX8 Digital Volume" value="92" />

    <ctl name="DEC0 Volume" value="92" />
    <ctl name="DEC1 Volume" value="92" />
    <ctl name="DEC2 Volume" value="92" />
    <ctl name="DEC3 Volume" value="92" />
    <ctl name="DEC4 Volume" value="92" />
    <ctl name="DEC5 Volume" value="92" />
    <ctl name="DEC6 Volume" value="92" />
    <ctl name="DEC7 Volume" value="92" />
    <ctl name="DEC8 Volume" value="92" />
    
    <path name="voice-handset">
        <path name="handset" />
          <ctl name="RX0 Digital Volume" value="95" />
    </path>
these are my new values, games and music got normal volume now but calls didn't change so I think I missed something
 
Last edited:

panos196

Senior Member
Feb 6, 2018
169
17
Good morning!!! sometimes when someone picks up my phone it rings once and closes, if it does it 3 times the mobile opens it you go to put what pin but it does not unlock ... and I have to flash the rom from the beginning ..
 

lopez37

Member
Nov 18, 2011
22
5
Hi all! First of all, many many many Thanks Mosimchah for keeping this rom and this phone alive. I have the zl0 and the fingerprint sensor doesn't work if the phone is encrypted and Secure boot is in use.

Is this a known issue? Is there any way to fix it? I bought it to use it as work phone so Secure boot is needed to use the work profile.

Thank you once again.

EDIT: Let me explain what happens deeper. The fingerprint sensor works. Whenever you use the wrong finger, it let's you try again. Hoewever, when it takes a right fingerprint, the system does not leave the lockscreen and the fingerprint sensor is deactivated because the reading was already successful so for the system is not suppossed to be needed anymore. So introducing the lockscreen code becomes obligatory every time.
 
Last edited:

Joster71

Member
Oct 14, 2020
10
0
Hello, I have a zl1 and have been a long-time user of this rom with enormous satisfaction, and for this I sincerely thank the developers. I have an information to ask. I recently bought some earbuds with SOC QCC3050, which should be compatible with aptx, aptxHD and aptxAdaptive. However, I can only connect them in aptx mode, all other options (apart from SBC) are disabled. Is this a problem with the phone's SOC incompatibility or with the rom's libraries? Thanks
 

marcjero

Senior Member
May 11, 2007
177
51
Hello, I have a zl1 and have been a long-time user of this rom with enormous satisfaction, and for this I sincerely thank the developers. I have an information to ask. I recently bought some earbuds with SOC QCC3050, which should be compatible with aptx, aptxHD and aptxAdaptive. However, I can only connect them in aptx mode, all other options (apart from SBC) are disabled. Is this a problem with the phone's SOC incompatibility or with the rom's libraries? Thanks
I think the bluetooth chip is quite old (4.2). New codecs probably require bluetooth 5.0.
 
  • Like
Reactions: Joster71

marcjero

Senior Member
May 11, 2007
177
51
Anyway this rom is great. Everyting runs smooth, no bug. Banking app working without Magisk. Really good job. This phone was sold with Android 6.0. I hope LineageOS 19 will be supported soon. Just ordered a new battery for the next 5 years :)
 

retry0001-coffee

Senior Member
Oct 21, 2019
170
70
unlikely to get LOS19 support at this point. Be glad they're still maintaining 18 for now, but this device's days are numbered.
 

veda1

Senior Member
May 2, 2018
127
10
Hello

I'm trying to install the rom on my never used and new Le Eco Pro 3 ( US X727) . Have the latest TWRP already installed. But for some reason the rom isn't installing. It has been giving me error 1.

Any help in getting this resolved is highly appreciated. Thank you.

I have downloaded the rom from this site https://download.lineageos.org/zl1

Edit: I'm somewhat tech challenged so please be patient if i ask you some clarifying questions.
 

veda1

Senior Member
May 2, 2018
127
10
did you unlock the bootloader? You also will need the very last vendor update. I remember having to update something from the vendor firmware, but I don't remember where I got the files from.
HI

Yes i did unlock the boot loader. I'm thinking the same thing. Probably the firmware has to be somewhat updated before it is compatible to be flashed. Please try to remember any file location where i can get updated firmware.
 

veda1

Senior Member
May 2, 2018
127
10
For anyone that may be looking for newer firmware please check out the link posted by @retry0001-coffee above. There are some folders matching the different models so you can check if they work for you.
 

Top Liked Posts