[ROM][OTA][8.1] LineageOS 15.1 for Huawei P8 Lite 2017

Search This thread

DarkJoker360

Recognized Developer / Recognized Contributor
Oct 20, 2015
2,574
3,511
203
18
Aradeo
I don't see any reference to a "B360" version of the TWRP, so... I don't get it, but ok, and I don't get the reference of the psmart either, but thanks anyway I supose ?

I hope @DarkJoker360 can give me some solution for the pair of bugs I have, it's a bit annonying the "=" appears from time to time, opening the Google Search or just typing it on the current opened text field.. ?
Remove sys.fpnav.enabled=1 from build.prop .
 

haky 86

Recognized Contributor
Oct 5, 2012
3,425
7,460
263
Hama (Syria)
I don't see any reference to a "B360" version of the TWRP, so... I don't get it, but ok, and I don't get the reference of the psmart either, but thanks anyway I supose

I hope @DarkJoker360 can give me some solution for the pair of bugs I have, it's a bit annonying the "=" appears from time to time, opening the Google Search or just typing it on the current opened text field..

LoL, I know the solution but I'll not tell anyways xD
 
Last edited:
Oct 9, 2018
21
1
3
Quick question: is it possible to have a "scrolling screenshot" function? On stock rom you have the ability to make an extended screenshot. Is there maybe a magisk module for this, or something I can do with exposed framework? I would love that feature on this rom :)
 

Gravis92

Member
Mar 18, 2015
9
0
0
Still Bootloop

Hi everyone, I have still problem with update. Screen is freeze on first screen - step (your device has been unlocked and cant be trusted).

I try everythink on my pra-lx1, use askcussio's TWRP, and Haky's TWRP, my stock firmware b407, every solutions arent work for me :( wipe data, without wipe, reflash stock recovery and factory reset via stock recovery and every suggestion from previous post I was check... I try everythink and nothing. I had to flash back stock firmware via erecovery after every attempt :( version of rom lineage-15.1-20200717-UNOFFICIAL-hi6250.zip, clean flash without gapps, magisk doesnt work too :( In fstab i dont have forceencrypion ... I try to flash with pack 'encrypion disable' and still the same... Instalation in TWRP is correct, without errors, everytink looks fine.

Any Ideas ? :( I used AOSP and didnt have a problem with flash ... :(

Sorry for my language, I dont use translator Im in a hurry.

Thanks for help !
 
Oct 9, 2018
21
1
3
Edit: Please make sure to remove encryption before you install the rom! Go to stock rom, edit fstab.hi6250 file, remove encryption line and save file.

1. Boot into TWRP (I use askcussio's TWRP)
2. Format data
3. Reboot into TWRP
4. Wipe ART/dalvik cache, cache, data and system
5.1 Install the latest lineagueOS.zip provided by DarkJoker
5.2 Install gAPPS (I used nano, can recommend)
5.3 Install latest magisk (I used Magisk-V20.4(20400).zip)
5.4 Install Disable_Dm-Verity_ForceEncrypt_08.18.2019
6. Wipe cache and dalvik
7. Reboot system

If you have followed this guide to the letter and it didn't work, i'm afraid I cant help you :/ Please be aware that the first boot takes a long time though, about 10 minutes. Perhaps you were too impatient? You should be able to see the lineage logo during this time
 

DarkJoker360

Recognized Developer / Recognized Contributor
Oct 20, 2015
2,574
3,511
203
18
Aradeo
Hi everyone, I have still problem with update. Screen is freeze on first screen - step (your device has been unlocked and cant be trusted).

I try everythink on my pra-lx1, use askcussio's TWRP, and Haky's TWRP, my stock firmware b407, every solutions arent work for me :( wipe data, without wipe, reflash stock recovery and factory reset via stock recovery and every suggestion from previous post I was check... I try everythink and nothing. I had to flash back stock firmware via erecovery after every attempt :( version of rom lineage-15.1-20200717-UNOFFICIAL-hi6250.zip, clean flash without gapps, magisk doesnt work too :( In fstab i dont have forceencrypion ... I try to flash with pack 'encrypion disable' and still the same... Instalation in TWRP is correct, without errors, everytink looks fine.

Any Ideas ? :( I used AOSP and didnt have a problem with flash ... :(

Sorry for my language, I dont use translator Im in a hurry.

Thanks for help !
What about getting on b400 or lower and reading the steps in OP?
 

Scorpin7

Member
Sep 26, 2020
17
0
0
12 minutes - restart - and again Your device is booting now :( I dont have Idea.... I think I try every combination ... so sad :p

Also, even if you don't see the encrypt configuration file, perhaps you can try to flash the "Disable_Dm-Verity_ForceEncrypt" zip before all the process and after a fresh stock installation, then repeat all the HuaweiP8liteuser post steps from the beggining, starting with the format data. Sometimes the TWRP don't have enough permissions to see the file but is still there and all the data is encrypted (you can verify this too going to the file system from the TWRP and looking the name of the files inside the folders just after a stock installation, if the have no sense that means they are encrypted). The ForceEncrypt zip remove encryption configuration from other files too, which perhaps make the ROM to try to enter in a encrypt configuration state again even if you modify the main file (I don't know, but the creator seems very self-confident about the topic ??). Good luck :)
 

SuchSon

Member
Oct 25, 2014
5
0
21
Warsaw
I love this rom and i think is the best and the most stable of all. But i have 1 problem after few months of using:
- system size increase to 7gb :eek: Do you know why ? Or how to clean up this ? For cleaning i use SD maid pro with magisk but it can't clean the "system"

And last question:
-will be any problems if I install Xposed ?

Thanks for reply :)
8tdXzg5.jpg
 

DarkJoker360

Recognized Developer / Recognized Contributor
Oct 20, 2015
2,574
3,511
203
18
Aradeo
Any chance to fix Bluetooth LE in this rom?

There isn't a single custom ROM for P8 Lite 2017 with working Bluetooth LE (only the stock rom works), so it would be great to have one working.

Let me know if I can provide feedback or logs.
BLE should work on LineageOS 16.0 now
 

olivi25

Member
Jan 10, 2014
18
1
23
Hello i have a problem. I install for a first time. I have an error .
E3004 : this package is for device : hi6250; this device is prague.
Updater process ended with error 7
Error installing zip file '/external_sd/lineage-15.1-20201027-UNOFFICIAL-hi6250.zip
Is not compatible with p8 lite 2017?
Or i check the last build is lineage-15.1-20190718-UNOFFICIAL-prague.zip ?

Sory for my english i am french :)

EDIT I will test DarkJoker360 AOSP 10 for Huawei P8 Lite 2017
 
Last edited:

CoMiKe

Member
Apr 9, 2010
39
2
28
Hello i have a problem. I install for a first time. I have an error .
E3004 : this package is for device : hi6250; this device is prague.
Updater process ended with error 7
Error installing zip file '/external_sd/lineage-15.1-20201027-UNOFFICIAL-hi6250.zip
Is not compatible with p8 lite 2017?
Or i check the last build is lineage-15.1-20190718-UNOFFICIAL-prague.zip ?

Sory for my english i am french :)

EDIT I will test DarkJoker360 AOSP 10 for Huawei P8 Lite 2017
Hi Olivi25,

It worked fine for me with TWRP 3.4 from haky86, but I had the same issues as you with DarkJoker's TWRP 3.4.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    Hi,

    http%3A%2F%2Fwww.androidblog.it%2Fwp-content%2Fuploads%2F2018%2F02%2FLineageOS-15.1-620x311.png


    LineageOS 15.1 for Huawei P8 Lite 2017

    *** Stable Version ***

    About
    Code:
    [CENTER]LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.
    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. Lineage OS does still include various hardware-specific code, which is also slowly being open-sourced anyway.[/CENTER]

    Working
    Code:
    [CENTER]* Touchscreen
    * Adb / Mtp
    * Audio
    * Boot
    * Bluethoot
    * Internal/External storage
    * Sensors
    * Wifi  
    * RIL
    * Camera
    * Video Encoder/Decoder
    * FP Gestures(Swipe Down for notification panel)
    [/CENTER]

    Installation
    Code:
    [CENTER]* you must also have this recovery version installed :  TWRP
    * go to TWRP  and do a full wipe (system, data, cache, dalvik/art cache) !
    * install LineageOS ROM 
    * boot the rom
    * reboot in TWRP and flash gapps and root (optional)
    * reboot system
    * Enjoy !!![/CENTER]

    Update
    Code:
    [CENTER]* copy the new update of LineageOS to Internal/External Storage
    * reboot device to :  TWRP
    * wipe cache & dalvik cache
    * install the new update of LineageOS
    * reboot to System
    * reboot system
    * Enjoy !!![/CENTER]

    Download
    Code:
    [CENTER][URL="https://sourceforge.net/projects/darkjoker360-developements/files/Huawei/P10%20Lite/Oreo/LineageOS/"]LineageOS-15.1[/URL]
    [URL="https://opengapps.org/"]Gapps[/URL] 
    [URL="https://github.com/ianmacd/MagiskBuilds"]Magisk for Treble[/URL][/CENTER]


    Credits:
    @DarkDroiddev
    @phhusson
    @AndroidpaX
    @haky86
    @ezio84

    Please support my work, it's very important! Thanks
    DONATIONS

    Regards !​


    XDA:DevDB Information
    LineageOS, ROM for the Huawei P8lite/P8 Lite

    Contributors
    DarkJoker360
    Source Code: https://github.com/DarkJoker360

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Emui 8.x unlocked bootloader and TWRP
    Based On: LineageOS

    Version Information
    Status: Stable
    Current Stable Version: 15.1
    Stable Release Date: 2019-01-04

    Created 2019-01-04
    Last Updated 2019-12-12
    5
    Good news BT issues are fixed on both Android Version (O and P) !
    5
    Hello guys good news, video recording bug is finally fixed get ready for the stablest oreo build !
    5
    New LineageOS 15.1 stable update !

    https%3A%2F%2Fimg.xda-cdn.com%2F2zS0Xzc3uCosCW49VVzhs1P7L9A%3D%2Fhttp%253A%252F%252Fwww.androidblog.it%252Fwp-content%252Fuploads%252F2018%252F02%252FLineageOS-15.1-620x311.png


    Changelog
    Code:
    [CENTER]* February 2019 security patches
    * Based on LineageOS 15.1 code of 09 March 2019
    * Fixed photo with flash darker
    * Switched to Google media codecs
    * Fixed frontal camera lags on some apps EDIT: lags are reduced to the minimum on kirin 655, on kirin 659 is fully fixed
    * Added new stock media codecs[/CENTER]
    NOTE: It is better to don' t use latest magisk builds as them can maybe crash
    Check OP for more info and downloads !

    Announcement: Starting from now I want to provide security patches updates with some minor fixes to LineageOS 15.1 and I want to start with LineageOS 16.0. And yes I am dropping support of AEX,Aosp,PE and other treble roms for hi6250, maybe one day I can resume the support of them.

    5
    February build - status update for my findings on this ROM

    Here is my update with latest ROM from February (see post #290).

    Issue #1: uSD card formated as internal storage doesn't come up (mount) early enough, causing issues with missing storage
    UPDATE with new ROM build: no change with the new ROM. Since the SD card is formatted as internal storage, it is encrypted as base Android security requirement.
    I am not an Android specialist but I think the SD card (or at least part of it) is encrypted with a key that belongs to the user. I suspect that only when the user "logs on" (i.e. first unlocks the phone after power-on or reboot), will the key be made available, which is done in // with the initialization of the user session.
    Therefore, many applications set as "autostart" will not be available, or have (part of) their resources / user data unavailable, until the "mount with decryption" part of the uSD card bringup has been completed.
    So if my theory holds true, unless a significant change is made to LineageOS sources, I suspect nothing can be done.
    I guess I will simply wait for uSD card to mount after a (re)boot + unlock, and deal with a few FCs in the meantime.​

    Issue #2: Second SIM card PIN code request at boot gets killed and has to be triggered again manually
    UPDATE with new ROM build: I got frustrated with this issue in previous ROM build, I just deactivated both SIM card PIN codes. I don't know if the issue has persisted or not in the latest ROM build.​

    Issue #3: Fingerprint enrollment very difficult compared to EMUI8 (but once enrolled works flawlessly)
    UPDATE with new ROM build: I haven't had to enroll new fingerprints, so I don't know. See issue #6 below.​

    Issue #3.1: Surprising finding of '=' character when unlocking via fingerprint
    UPDATE with new ROM build: this strange behavior seems to have disappeared, nice! I haven't done anything on my side that would have solved the issue so I guess this is solved by the new ROM build itself.​

    Issue #4: No sound when playing music in default music player nor Musicolet (from Play Store)
    UPDATE with new ROM build: not tried yet. Will provide update next time I try listening to music, if anybody interested.​

    Issue #5: Local SIM card seems to be detected as foreign SIM card
    UPDATE with new ROM build: issue remains, but it is hard to characterize. Note that the issue didn't happen in EMUI8, it is something I have only had with this ROM (January build and February build).
    I have 2 SIM cards: LEBARA France and LycaMobile Switzerland.
    When I am in Switzerland, LEBARA SIM detected as roaming (OK) and LycaMobile SIM detected as roaming (NOT OK)
    When I am in France, LEBARA SIM detected as not roaming (OK) and LycaMobile SIM detected as roaming (OK)
    So there is something special about the LycaMobile Switzerland SIM/operator which LineageOS can't interpret correctly (EMUI8 did flawlessly).​

    Issue #6: NEWLY REPORTED - old EMUI8 fingerprints still able to unlock the phone and impossible to delete!
    Description: an issue found in January build already, still present with February build, is that the previously registered fingerprints (in EMUI8) still work. I have tried everything I could, including deleting fingerprint database files under /data/system/user/* (don't do that! I lost all content of SD card due to issue 1 behavior of storing per-user decryption key). Those fingerprints are not visible in the fingerprint enrollment UI, but they can successfully be used for unlocking the phone...
    Consequence: don't leave your phone locked near your ex-girlfriend if she had access to your phone previously (fingerprint enrolled) even if you have tried wiping the fingerprints, hoping that by starting over again with a different ROM and a full wipe they would disappear...​

    Issue #7: NEW - OpenGApps version
    Description: In a previous post, I explained how I had to follow an advice to flash old OpenGApps 20190913 as the recent .zip didn't detect the architecture (arm vs arm64 vs x86 & Android version) correctly. Well, that didn't work with February build and here is how I got it working (surely not the most straightforward way): when I got the notification about new February build for this ROM:
    -I installed (via menu, it rebooted in TWRP etc).
    -After reboot, phone was completely unusable (bootloop) and rebooted into Huawei's recovery (TWRP was killed by update) and asked me to Factory reset the phone, argh.
    -I flashed Askuccio's TWRP again and wiped Cache / Dalvik Cache, no better
    -I flashed OpenGApps 20190913, phone booted but was unable to start completely (no bootloop)
    -Rebooted in TWRP, wiped Cache & Dalvik Cache, flashed OpenGApps 20200215, wiped Cache & Dalvik Cache again - note that this time, recent OpenGApps installer worked, no wrong detection, which is good news!
    -Phone booted okay with lots of FC in Google Apps, but still it booted. Play Store not starting. All non-Google apps were working, but lots of FC notifications from Google Apps. In particular, Youtube and Gmail kept crashing every few seconds
    -Removed Youtube and Gmail via Settings -> Applications, less FCs, Play Store still not working, sideloaded Gmail from APKMirror, Gmail & Play Store working again
    -Had to wait a few days for Play Store updating Youtube for Youtube to work again.

    Consequence: Phone difficult to use, probably due to OpenGApps versions of some apps > previously installed updates​

    Since I got no answer or comment on my previous posts, I am not sure if in the future I will post such status information. I am not complaining, and not taking offense, but since it takes some time to write this, I may continue to do that as a service to the community (my contribution), only if it is considered useful.

    ---------- Post added at 05:12 PM ---------- Previous post was at 05:09 PM ----------

    Hi. I have a problem using your rom on PRA-LX1. Sometimes my SIM goes off and canot goes on. I have to restart phone to get SIM working again.
    Take a look at attachements. One is screenshot when it happend, second is log from network monitor app.
    Is there any simply solution to solve this problem?

    I had this when I was using dual-SIM, with PIN code on both SIM: sometimes, even after booting and logging successfully, one SIM card "disappeared" apparently without reason. Since I removed PIN code on both SIM (reducing security in case something steals my phone), both SIM cards seem to work flawlessly.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone