[ROM][P900][UNOFFICIAL] LineageOS 16.0 | Android 9.0 Pie 20200821 technical preview

Search This thread
I'm not responsible for any damage to your device of any sort.
By flashing this you take responsibility of anything that happens.
Process at your own risk!

If you want to check firmware - please make backup. Better to store all partitions, at least efs and may be modem.
I'm using pico/nano gapps.

Instructions
1. Install custom recovery
2. Download the zip(s) - firmware and Google Apps additional package (optional)
3. Full wipe all
4. Flash firmware and gapps

Work
almost all

Known Issues
- camera
- screenshots
- missed icons in trebuchet tauncher (install nova or microsoft launcher and other)

Links
LineageOS Builds
1. 20200821: init build: https://drive.google.com/file/d/19-rPOcmlYIhcoZleG4MKRROk9TXytEOe/view?usp=sharing

Gapps
https://opengapps.org

Recovery
Use official version from: https://twrp.me/samsung/samsunggalaxynotepro122exynoswifi.html

Sources
Sources: https://github.com/Lineageos
Device: https://github.com/Valera1978/android_device_samsung_v1awifi
Kernel: https://github.com/Valera1978/android_kernel_samsung_exynos5420
Vendor: https://github.com/Valera1978/android_vendor_samsung_v1awifi

Thanks
Thanks to LineageOS team
Thanks to exynos5420 team for the right kernel
 
Last edited:
Thx @Valera1978 that's great news.
Gonna test today.

Edit 6h later first impressions:
Coming from Lineage 14.1 Vanilla with TWRP 3.4.0-0.
Backed up everything, full wipe plus data format.
Installing purely the ROM with TWRP 3.4.0 led to "Error 7" 3.3.1 did the trick.
Made a reboot to check if it starts.
Noticed screen failures in form of small black bars/stripes which vanished after a few seconds when I let the screen settle.
(Appearing very often even now after full installation of everything I need.)
Rebooted to TWRP and installed BiTGapps (prefer them to opengapps as they are even smaller than pico) and Magisk.
After each flash wiped cache/dalvik of course.

Installed Nova prime (dark mode) and all my other apps.
Camera doesn't work with Lineage App (as said) but does with opencamera from f-droid.
Screenshots neither but using Quickboot is a workaround when activated in its settings.
When writing text and correcting failures the magnifier shows only a white field with now text in it even when dark mode is off.

Great work @Valera1978 will carry on testing.

Edit 18h later:
Firefox seems to have problems with it, doesn't often even open its add-on page or urls.
Lightning browser has no probs.
Only one sudden reboot until now.

Edit 24h later:
Tried to upload a pic with the screen problems but didn't work.
Mostly occuring when switching from portrait to landscape (reproducible).
Because of the Firefox problems I've tried the 79 version but starting it resulted directly in a reboot (reproducible).
 
Last edited:

yminale

Member
Feb 5, 2014
5
1
I'm surprised there aren't more responses
Can confirm TWRP 3.3.1 is the latest recovery to work. Doesn't seem to work with 3.1.1

Can't change wallpaper. Not sure why. I have to go to live wallpaper to get the default one back

Ok Google needs to be installed manually


I get security flags from SELinux and Public trust certificates. Probably because the release is so early

Overall it's not bad for a Pre-Alpha release.
 
Aug 24, 2020
6
1
First of all: an awesome thank you to Valera1978 since I was expecting a newer version than 14.1 a long time ;)
Have the same issue with the wallpaper change and some flickering in the display. Installed nova prime too but can`t close all apps in task manager only each manually single (wipe up)
I am eager for the next version and improvements :fingers-crossed: and willing to give further feedback.

THX a lot for your passion
 
Last edited:
the current version is rather a technical build for testing (public, the most stable, there were already about 40-50 internal builds for fixing bugs and checking various things).
In any way - lineage 17.1 coming soon (later today), release build done, on tests right now. And I like it much more, then technical 16.0 build.
 
i will try this process for the first time. Is there a video tutorial? thank you.
This ROM will probably not be in development any further as the brilliant dev @Valera1978 is already working on a 17.1.
About a video I don't know. Searching in YouTube might help finding out 😉
Here is a very good description which I followed from @thompatry who's ROM is very stable, has a working camera (skype) and gets regularly updated.
Download it to SD.
As he quoted install a TWRP first to exchange the stock recovery.

Easiest to do is use a windows PC with Odin version 3.13.
Battery fully loaded before starting.

1.Download TWRP 3.3.1 for v1awifi from twrp.me but choose the tar version and save it in Odin folder.
2.Get P900 into download mode (turn it off, then press buttons Pwr, home, vol- altogether).
Will give you a warning but continue with vol+.
3.Start Odin then connect P900 to PC and check in Odin if a field on the left turns blue (com+).
4.Uncheck "auto reboot" in Odin.
5.Flash TWRP 3.3.1 with Odin onto P900 putting the downloaded TWRP file in "AP" field in Odin.
When Odin says "Pass" all is fine.
6.Turn P900 off with pwr button but press afterwards directly home and Vol+ together as it automatically reboots.
Then you access the new recovery.

If you fail the Samsung recovery gets reborn and you have to repeat steps 2-6 again but that does no harm.

Save all what is possible with TWRP to external SD using Backup.
Then wipe everything in TWRP (except SD 😉), select "format data" after that.
Select install and choose the ROM from SD.
Test if system starts. Might take a while.
If you want to use Google apps, download Gapps from opengapps (choose ARM, 7.1 and pico) and save it in advance to SD.
If system starts, turn it off, restart to recovery (pwr, home, vol+) and install Gapps.
 
  • Like
Reactions: gl000008

mattgod69

Member
Jun 27, 2008
27
1
Easiest to do is use a windows PC with Odin version 3.13.
Battery fully loaded before starting.

1.Download TWRP 3.3.1 for v1awifi from twrp.me but choose the tar version and save it in Odin folder.
2.Get P900 into download mode (turn it off, then press buttons Pwr, home, vol- altogether).
Will give you a warning but continue with vol+.
3.Start Odin then connect P900 to PC and check in Odin if a field on the left turns blue (com+).
4.Uncheck "auto reboot" in Odin.
5.Flash TWRP 3.3.1 with Odin onto P900 putting the downloaded TWRP file in "AP" field in Odin.
When Odin says "Pass" all is fine.
6.Turn P900 off with pwr button but press afterwards directly home and Vol+ together as it automatically reboots.
Then you access the new recovery.

If you fail the Samsung recovery gets reborn and you have to repeat steps 2-6 again but that does no harm.

Save all what is possible with TWRP to external SD using Backup.
Then wipe everything in TWRP (except SD 😉), select "format data" after that.
Select install and choose the ROM from SD.
Test if system starts. Might take a while.
If you want to use Google apps, download Gapps from opengapps (choose ARM, 7.1 and pico) and save it in advance to SD.
If system starts, turn it off, restart to recovery (pwr, home, vol+) and install Gapps.

Hi everyone, I hope you are all safe and well.

Just a quick question, do I use the latest version of TWRP for my P900 (note pro 12.2 wi-fi). There are versions on the website which are later than the 3.3.1 version in this post. At the moment my version is 1.22, so this is really old! This was obviously installed and I did the flash to 14.1.

Like I say, at the moment, I am using LineageOS 14.1 with an old security patch level (September 19) because I cannot seem to update it. I have tried the auto update, this fails and I have also tried to manually apply but this also does not work.

I was wondering whether it was time to upgrade to version 16 or 17.

I'm not an expert on this by any means and I recall I did struggle with some error message when trying to update to I think at the time line Lineage 15.

Any comments or suggestions would be much appreciated.
 
@mattgod69 auto updater I don't use/like at all.
My suggestion is download TWRP 2.8.7-0 as zip and flash this with your TWRP. It is the latest zip released.
From that on it can use img files and you can update further to 3.3.1 or higher.
For me 3.4.0 was needed to flash @Valera1978 LOS17.1.
3.3.1-0 for LOS14.1 by @thompatry which's Vanilla (version 20201215) I use for here camera is working instead of being on LOS17.1.
 
  • Like
Reactions: mattgod69

mattgod69

Member
Jun 27, 2008
27
1
Thanks for the reply @bmwdroid, i was talking about the app which is version 1.2 (doh)... i have just booted into TWRP and i have version 3.3.1. So if you are using the same tablet as me, what would you upgrade to or would you leave it as is. Also, do you think i need to update the security patch level? Cheers and apologies if these are silly questions.
 
Thanks for the reply @bmwdroid, i was talking about the app which is version 1.2 (doh)... i have just booted into TWRP and i have version 3.3.1. So if you are using the same tablet as me, what would you upgrade to or would you leave it as is. Also, do you think i need to update the security patch level? Cheers and apologies if these are silly questions.
Mine is a P900 v1awifi.

I suppose that the app 1.2 refers to the TWRP app which I don't use and I've always read warnings to install it so I never did.
It is said that it sometimes causes problems when flashing.
And imo it's not needed anyhow.

If you need camera working for skype or else I recommend to flash the latest LOS14,1 mentioned above.
https://download.exynos5420.com/LineageOS-14.1-Deathly/v1awifi/
with the deathly adiutor built in
or
https://download.exynos5420.com/LineageOS-14.1-Vanilla/v1awifi/
which is a plain android system

The development of this LOS16 seems suspended as the dev is already working on LOS17.1 which I've tested, but as said has no working camera.
Therefore I can't say much about its stabilty but it worked with Bitgapps and Magisk for 4-5 hours until I switched back to LOS14.1.
If you want to test it: I had to upgrade TWRP to 3.4.0 to avoid "Error 7".
To go back to 14.1 I had to downgrade to 3.3.1 first.

Questions show that someone is willing to learn which should be appreciated.
 
Last edited:

mattgod69

Member
Jun 27, 2008
27
1
Mine is a P900 v1awifi.

I suppose that the app 1.2 refers to the TWRP app which I don't use and I've always read warnings to install it so I never did.
It is said that it sometimes causes problems when flashing.
And imo it's not needed anyhow.

If you need camera working for skype or else I recommend to flash the latest LOS14,1 mentioned above.
https://download.exynos5420.com/LineageOS-14.1-Deathly/v1awifi/
with the deathly adiutor built in
or
https://download.exynos5420.com/LineageOS-14.1-Vanilla/v1awifi/
which is a plain android system

The development of this LOS16 seems suspended as the dev is already working on LOS17.1 which I've tested, but as said has no working camera.
Therefore I can't say much about its stabilty but it worked with Bitgapps and Magisk for 4-5 hours until I switched back to LOS14.1.
If you want to test it: I had to upgrade TWRP to 3.4.0 to avoid "Error 7".
To go back to 14.1 I had to downgrade to 3.3.1 first.

Questions show that someone is willing to learn which should be appreciated.

Thank you for the detailed response, very helpful.

I dont really use the camera with my tablet, but i might, so its probably best to wait til 17.1 is working. The tablet is really just a browsing device i use beside my bed, its not an everyday machine.. so i am willing to try new things and play about with it.... it also does not matter if it is wiped accidentally etc.

i have to say it has been overall much better with 14.1 installed, far better than the stock OS. It is faster and more responsive.

Presumably I need new google apps etc download any new OS? If i install the latest LOS 14.1 do i also need new gapps etc? Is this OS much better than the one i have?

I do not know what Bitgapps and Magisk are?

Many thanks for all your help.... this community is great because even though i have done this a couple of times on different devices, there are long time gaps between doing it and it is still quite scary because i dont want to brick the device!
 

mattgod69

Member
Jun 27, 2008
27
1
Just looked at Magisk... is it not a good idea to have this in any event? it looks like this would be earier to install later OS like LOS17.12? Is this right?
 
@mattgod69 BitGapps are an even smaller Google Apps version than Opengapps pico.
I use them on Android Q, as opengapps weren't working properly at that time being.
I don't use Google TTS and always had to block it when using opengapps.

Magisk is an equivalent to SU which is no longer continued.
It's neede for all apps needing root like AFWall, DeviceInfo and many others.
If you or your tab are happy without there's no need flashing it.
It causes no probs when switching ROMs as long as it's a clean flash.
Even updating ROMs dirty works on mine.

If you already had LOS14.1 installed and google apps as well you don't need a newer gapps version when updating dirty as gapps get updated by Google itself.
When flashing cleanly I recommend a newer gapps version but you can use any old (designed for the specific android version) as well.
Only setting up might take longer as the gapps will be updated automatically as soon as they find an internet connection.

The newer version of LOS14.1 will imo only be different in patch level nothing else.

Hope I didn't overlook a question. 😉
 
  • Like
Reactions: mattgod69

mattgod69

Member
Jun 27, 2008
27
1
@mattgod69 BitGapps are an even smaller Google Apps version than Opengapps pico.
I use them on Android Q, as opengapps weren't working properly at that time being.
I don't use Google TTS and always had to block it when using opengapps.

Magisk is an equivalent to SU which is no longer continued.
It's neede for all apps needing root like AFWall, DeviceInfo and many others.
If you or your tab are happy without there's no need flashing it.
It causes no probs when switching ROMs as long as it's a clean flash.
Even updating ROMs dirty works on mine.

If you already had LOS14.1 installed and google apps as well you don't need a newer gapps version when updating dirty as gapps get updated by Google itself.
When flashing cleanly I recommend a newer gapps version but you can use any old (designed for the specific android version) as well.
Only setting up might take longer as the gapps will be updated automatically as soon as they find an internet connection.

The newer version of LOS14.1 will imo only be different in patch level nothing else.

Hope I didn't overlook a question. 😉

Many thanks for the message and info. i think maybe i will leave as is for a bit as the tablet is working fine at the moment.... look at this again when 17.1 is ready.....
 

mattgod69

Member
Jun 27, 2008
27
1
But I hope you will be updating the ROM to be on the latest patch level.

i think i am going to try 17.1... i think most issues have been sorted now?

i did have some questions before i do this which i have put in another post.....

Also, how do you do a dirty install... is this where the cache etc is not wiped?

would you update TWRP to 3.5.0. (the latest one). I assume this can be done from the program in recovery mode?

Many thanks for your help and advice.
 
Last edited:
.... would you update TWRP to 3.5.0. (the latest one). I assume this can be done from the program in recovery mode?...
Updating TWRP can be done with itself.
Working up- and downwards.
Just select "install" switch to "image" choose the file and select "recovery".
Afterwards reboot directly into the new recovery.
 
  • Like
Reactions: mattgod69

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    .... afterwards also twrp-3.0.2-0-viennaltexx.img
    When I try to flash one of the above images I get an error
    E3004: This is.. viennalt your device is .
    Just nothing in front of the .
    Any suggestions?
    In some descriptions I found:
    Toggle the OEM Unlock option on
    I did not find this option on my P905, Android version was 5.0.2.

    Any suggestion?
    Is LOS14.1 working on it?
    What's it saying on the back what it is?
    Hope not P905V.
    No unlock option on this device anyway.
    3.0.2-0 perhaps to old AND acc to 1st post you should use TWRP for P900.
    1
    @chilobo just noticed you're in the wrong thread.
    P900 here so don't use this TWRP in post one mentioned.
    Go there
    1
    Is LOS14.1 working on your it?
    What's it saying on the back what it is?
    Hope not P905V.
    No unlock option on this device anyway.
    3.0.2-0 perhaps to old AND acc to 1st post you should use TWRP for P900.
    I moved my answer to the appropate P905-section.
  • 8
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!

    If you want to check firmware - please make backup. Better to store all partitions, at least efs and may be modem.
    I'm using pico/nano gapps.

    Instructions
    1. Install custom recovery
    2. Download the zip(s) - firmware and Google Apps additional package (optional)
    3. Full wipe all
    4. Flash firmware and gapps

    Work
    almost all

    Known Issues
    - camera
    - screenshots
    - missed icons in trebuchet tauncher (install nova or microsoft launcher and other)

    Links
    LineageOS Builds
    1. 20200821: init build: https://drive.google.com/file/d/19-rPOcmlYIhcoZleG4MKRROk9TXytEOe/view?usp=sharing

    Gapps
    https://opengapps.org

    Recovery
    Use official version from: https://twrp.me/samsung/samsunggalaxynotepro122exynoswifi.html

    Sources
    Sources: https://github.com/Lineageos
    Device: https://github.com/Valera1978/android_device_samsung_v1awifi
    Kernel: https://github.com/Valera1978/android_kernel_samsung_exynos5420
    Vendor: https://github.com/Valera1978/android_vendor_samsung_v1awifi

    Thanks
    Thanks to LineageOS team
    Thanks to exynos5420 team for the right kernel
    5
    the current version is rather a technical build for testing (public, the most stable, there were already about 40-50 internal builds for fixing bugs and checking various things).
    In any way - lineage 17.1 coming soon (later today), release build done, on tests right now. And I like it much more, then technical 16.0 build.
    3
    Thx @Valera1978 that's great news.
    Gonna test today.

    Edit 6h later first impressions:
    Coming from Lineage 14.1 Vanilla with TWRP 3.4.0-0.
    Backed up everything, full wipe plus data format.
    Installing purely the ROM with TWRP 3.4.0 led to "Error 7" 3.3.1 did the trick.
    Made a reboot to check if it starts.
    Noticed screen failures in form of small black bars/stripes which vanished after a few seconds when I let the screen settle.
    (Appearing very often even now after full installation of everything I need.)
    Rebooted to TWRP and installed BiTGapps (prefer them to opengapps as they are even smaller than pico) and Magisk.
    After each flash wiped cache/dalvik of course.

    Installed Nova prime (dark mode) and all my other apps.
    Camera doesn't work with Lineage App (as said) but does with opencamera from f-droid.
    Screenshots neither but using Quickboot is a workaround when activated in its settings.
    When writing text and correcting failures the magnifier shows only a white field with now text in it even when dark mode is off.

    Great work @Valera1978 will carry on testing.

    Edit 18h later:
    Firefox seems to have problems with it, doesn't often even open its add-on page or urls.
    Lightning browser has no probs.
    Only one sudden reboot until now.

    Edit 24h later:
    Tried to upload a pic with the screen problems but didn't work.
    Mostly occuring when switching from portrait to landscape (reproducible).
    Because of the Firefox problems I've tried the 79 version but starting it resulted directly in a reboot (reproducible).
    2
    Thanks for the reply @bmwdroid, i was talking about the app which is version 1.2 (doh)... i have just booted into TWRP and i have version 3.3.1. So if you are using the same tablet as me, what would you upgrade to or would you leave it as is. Also, do you think i need to update the security patch level? Cheers and apologies if these are silly questions.
    Mine is a P900 v1awifi.

    I suppose that the app 1.2 refers to the TWRP app which I don't use and I've always read warnings to install it so I never did.
    It is said that it sometimes causes problems when flashing.
    And imo it's not needed anyhow.

    If you need camera working for skype or else I recommend to flash the latest LOS14,1 mentioned above.
    https://download.exynos5420.com/LineageOS-14.1-Deathly/v1awifi/
    with the deathly adiutor built in
    or
    https://download.exynos5420.com/LineageOS-14.1-Vanilla/v1awifi/
    which is a plain android system

    The development of this LOS16 seems suspended as the dev is already working on LOS17.1 which I've tested, but as said has no working camera.
    Therefore I can't say much about its stabilty but it worked with Bitgapps and Magisk for 4-5 hours until I switched back to LOS14.1.
    If you want to test it: I had to upgrade TWRP to 3.4.0 to avoid "Error 7".
    To go back to 14.1 I had to downgrade to 3.3.1 first.

    Questions show that someone is willing to learn which should be appreciated.
    1
    i will try this process for the first time. Is there a video tutorial? thank you.
    This ROM will probably not be in development any further as the brilliant dev @Valera1978 is already working on a 17.1.
    About a video I don't know. Searching in YouTube might help finding out 😉
    Here is a very good description which I followed from @thompatry who's ROM is very stable, has a working camera (skype) and gets regularly updated.
    Download it to SD.
    As he quoted install a TWRP first to exchange the stock recovery.

    Easiest to do is use a windows PC with Odin version 3.13.
    Battery fully loaded before starting.

    1.Download TWRP 3.3.1 for v1awifi from twrp.me but choose the tar version and save it in Odin folder.
    2.Get P900 into download mode (turn it off, then press buttons Pwr, home, vol- altogether).
    Will give you a warning but continue with vol+.
    3.Start Odin then connect P900 to PC and check in Odin if a field on the left turns blue (com+).
    4.Uncheck "auto reboot" in Odin.
    5.Flash TWRP 3.3.1 with Odin onto P900 putting the downloaded TWRP file in "AP" field in Odin.
    When Odin says "Pass" all is fine.
    6.Turn P900 off with pwr button but press afterwards directly home and Vol+ together as it automatically reboots.
    Then you access the new recovery.

    If you fail the Samsung recovery gets reborn and you have to repeat steps 2-6 again but that does no harm.

    Save all what is possible with TWRP to external SD using Backup.
    Then wipe everything in TWRP (except SD 😉), select "format data" after that.
    Select install and choose the ROM from SD.
    Test if system starts. Might take a while.
    If you want to use Google apps, download Gapps from opengapps (choose ARM, 7.1 and pico) and save it in advance to SD.
    If system starts, turn it off, restart to recovery (pwr, home, vol+) and install Gapps.