[ROM][PAYTON]Lineage OS 18.1

Jun 27, 2019
9
1
3
@warhead1721972 , just to check since you're using TWRP, when you switched ROMs are you wiping Dalvik, cache, data and system?

Also, are you reinstalling TWRP after flashing LOS? Because if you are, you must use the TWRP installer zip and not flash the TWRP image as that kernel isn't compatible with the ROM.
Hi, thanks for replying back. Yes, i do wipe dalvik cache, data and system before sideloading LOS. What i noticed is that LOS boots up normally if i dont flash GApps at all. Normally you flash GApps after rebooting the recovery to slot B right? If you just skip installing GApps completely, LOS works fine. But i really need some basic Playstore functionality, or i wd have used a ungoogled android anytime. Sometime back, i did flash LOS in my old Lenovo K8 Note with GApps, and it worked fine.
Just temporarily flashed ViperOS with GApps, to see if something is wrong with my handset, ViperOS works just fine. Why cant I install LOS?
Thanks for taking your time and helping me out, really appreciate the hard work yall do.
 

@vrishab

New member
Jan 26, 2020
3
0
1
First i sideload the rom zip in slot A along with TWRP and then i reboot to the recovery to set the current slot to B and then flash GApps. On flashing it, there are no errors, but on booting up the system for the first time, i get redirected to TWRP. Is something wrong with my phone?
Till now i have been using ViperOS for quite some time, until i wanted to try something new. Really wanna give LOS a try.
if you get stuck in bootloop, reboot to bootloader and type in cmd/terminal: fastboot -w and reboot
 

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@warhead1721972 I just flashed to boot the "lineage-18.1-20210211-UNOFFICIAL-payton-boot.img" and then factory reset and adb sideloaded the "copy-partitions-20200903_1329.zip" and then adb sideloaded "lineage-18.1-20210211-UNOFFICIAL-payton.zip" and then reboot to recovery and sideloaded "MindTheGapps-11.0.0-arm64-20210220_140101.zip" and I was able to sign into my Google account and finished setup and it's syncing my Google account without any bootloops.

I would recommend starting from scratch in your case though, flash a stock fbrom of your choice that is Android 9.0 (pie) as older device firmware is not supported. After that? Please try using Lineage Recovery instead of TWRP just in case for some reason that won't work for you and follow the same method I just did. (y)

Before I wanted to make recovery flashable device firmware zips but I totally bricked my payton and it was a pain to try and get blankflash going... so I only recommend fbrom flashes to ensure the device firmware is up to date
 
Jun 27, 2019
9
1
3
ive never used Lineage Recovery, where do u download it? and how to install?
What is "lineage-18.1-20210211-UNOFFICIAL-payton-boot.img "? How to install this? By sideloading or flashing thru TWRP?
Edit: I just did "fastboot boot lineage-18.1-20210211-UNOFFICIAL-payton-boot.img" and now its stuck at the moto bootlogo image.
I cant switch it off bcz believe it or not, my power button is bust. It does not work. What should i do now?
 
Last edited:

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@warhead1721972 hmm yikes! Broken power button definitely makes this more difficult... If it's stuck at the logo and your power button doesn't work? Your only real choice is to wait for the power to drain and then before you plug it in to charge then you must press and hold the volume down button so once it charges it'll just boot to bootloader
 
Jun 27, 2019
9
1
3
@warhead1721972 hmm yikes! Broken power button definitely makes this more difficult... If it's stuck at the logo and your power button doesn't work? Your only real choice is to wait for the power to drain and then before you plug it in to charge then you must press and hold the volume down button so once it charges it'll just boot to bootloader
Yup, just did that and now its in bootloader mode. Actually this happened many times before in a lot of different circumstances. Anyways, how to install the Lineage OS recovery? And how do i flash that "lineage-18.1-20210211-UNOFFICIAL-payton-boot.img "? Without having stuck in a bootloop ofc.
P.S- Thanks for not giving up on me yet :)
 

Sujanth

Senior Member
May 2, 2018
128
30
28
Heyyo, another test build is going up! The upload should be done within 30 minutes of this post and link to test builds are in the first post. lineage-18.1-20210202-UNOFFICIAL-payton contains fixes for the offline charging animation and for WiFi hotspot with WPA2 (it isn't merged yet on LineageOS, but hopefully it does before we go official on 18.1).

There is also some echo-reference changes so if someone could please test it with VoIP apps and see if there's still echo or not
I made a whatsapp call. And the quality was better than in lineagoes 17.1. At first i heard my voice twice, but only takes 5 seconds. Then it was ok. Here is the logcat.
Edit: Noticed screen flickering when i write only on plus messenger. I am on stock kernel and not installed magisk or any other mods. Also tried with gboard keyboard app, same issue. When I write on other apss, there is not such issues.
 

Attachments

Last edited:

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@warhead1721972 , well you can do fastboot flash boot for that LOS recovery boot.img and then reboot to recovery, but fastboot flash boot should have worked which is odd... For some reason my Windows 10 PC or Ubuntu Mate 20.04 wouldn't let me use fastboot, but my Chromebook and my wife's Windows 7 Notebook did work, so if you can't use fastboot command on your PC you could try a USB live boot of Windows 10 or Ubuntu 14.04 or something?

@Sujanth thanks man I'll try to review those logs when I get some spare time... I'll be on night shift out of town for two weeks, so no idea if I will get spare time soon tbh...
 
Jun 27, 2019
9
1
3
@ThE_MarD It booted up!! Google apps works fine!! What i did:
>In bootloader i booted into twrp recovery using the command-
fastboot boot *insert twrp boot image.img*
>TWRP boots, wiped everything except my external sd card
>Went to advanced settings, enabled ADB Sideload
>Sideloaded the LineageOS rom zip
>Booted to LOS to check if everything works
>Booted back to Lineage Recovery using the advanced restart feature in LOS to restart in Lineage Recovery
>Went to Update-ADB Sideload update
>Sideloaded MindTheGApps
>Rebooted into LOS and boom. I was greeted by the Google screen.

Somehow flashing GApps using TWRP doesnt work. I think this is a bug in TWRP?
Thanks @ThE_MarD for helping me out on this!!
Edit: Moto Gestures like chop chop for flashlight and twist for camera does not work in LOS?
 
Last edited:
  • Like
Reactions: ThE_MarD

Crystawth

Member
Sep 9, 2011
25
7
23
I do apologize if this is somewhat off topic, but I don't really know much about the differences between operating systems and I was wondering;

what is the fundamental difference between 17.1 and 18.1? And if I already have 17.1 installed on my device what actual legitimate reasons should I have for putting 18.1 on it?
 

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
@warhead1721972 yay! That's fantastic news! Tbh I haven't tried flashing GApps via TWRP as I always only ever tried flashing the ROM and the reboot to recovery I just let Lineage Recovery come up and then adb sideload. If you want to reboot to TWRP, maybe it would be best after the ROM flash to reboot to bootloader, confirm the slot changed and then fastboot boot TWRP?

Tbh one of my plans when I get more time is to revamp the TWRP Payton, Z01R and Zippo trees for TWRP based on Android 10...

For Moto Gestures not working for you, can you please send me logcat? There's a chance it could be something like an selinux denial maybe?

@jasonmerc glad you enjoy all the work! Lots of great community devs work on Motorola devices so it is indeed good to see them putting out lots of quality updates as they go. :)

@Crystawth , for 18.1 tbh you're only going to get the system upgrades that Android 10 bring, like the revamped power menu which is nice if you have smart home devices and the changes to the notification area. The only downside is WiFi Display (Miracast) does not work for us as we are waiting on a stock ROM release with a compatible SoC so we can kang blobs... afaik, the closest one right meow is the Nokia 3.2 but no idea when it comes out though... If you're happy with LOS 17.1? I'd recommend at least staying on there until after LOS 18.1 official comes out (no idea on that either, I just work on device trees and rarely ever touch system).
 
  • Like
Reactions: Francesco Libera

Crystawth

Member
Sep 9, 2011
25
7
23
@Crystawth , for 18.1 tbh you're only going to get the system upgrades that Android 10 bring, like the revamped power menu which is nice if you have smart home devices and the changes to the notification area. The only downside is WiFi Display (Miracast) does not work for us as we are waiting on a stock ROM release with a compatible SoC so we can kang blobs... afaik, the closest one right meow is the Nokia 3.2 but no idea when it comes out though... If you're happy with LOS 17.1? I'd recommend at least staying on there until after LOS 18.1 official comes out (no idea on that either, I just work on device trees and rarely ever touch system).
Thank you for taking the time to let me know. I do really like what I have at the moment!
 
  • Like
Reactions: ThE_MarD

Sujanth

Senior Member
May 2, 2018
128
30
28
Reddit app is crashing when using dxt kernel. That happens randomly and only sometimes. You have to use reddit for a long time to face this issue. I don't know if it is a rom issue or a kernel issue. On lineageos 17 there is no issues with dxt kernel v.3.5 uc.
And also face screen flickering on plus messenger with lineageos 17.
 

Attachments

ThE_MarD

Senior Member
Dec 10, 2014
2,792
3,265
203
Grande Prairie
Heyyo @Sujanth , please report dxt kernel bugs to the dxt kernel dev as we do not support mods on LineageOS. I tested both Reddit and plus Plus Messenger on my payton without any mods and they both work without any issues and there isn't any screen flickering so I'm chalking both bugs up to dxt kernel or any other installed mods.
 

Sujanth

Senior Member
May 2, 2018
128
30
28
Heyyo @Sujanth , please report dxt kernel bugs to the dxt kernel dev as we do not support mods on LineageOS. I tested both Reddit and plus Plus Messenger on my payton without any mods and they both work without any issues and there isn't any screen flickering so I'm chalking both bugs up to dxt kernel or any other installed mods.
Yeah, its a kernel bug with reddit crash. But facing screen flickering without dxt kernel and without any mods in los 17 and 18. But only happens on plus messenger and when i using keyboard to write. Tempory fix is to disable hw overlays in dev options, but setting get reseted after rebooting it.
 

Attachments

Last edited: