[ROM][Pie][OFFICIAL] Resurrection Remix v7.0.2 [evert]

Search This thread

Gus0

Member
Sep 29, 2013
19
3
Hi there, for those looking for the TWRP that was on the OP, I couldn´t find it but in the androidfilehost profile of the user @Jleeblanch I found one that I think was a good replacement, and so far so good, besides there was a newer version (and final BTW) of the ROM

androidfilehost.com/?w=files&flid=299643
 

Alej0hio

Member
Jul 19, 2018
26
3
Solbergelva
Thank you for the great rom, although I have an issue. When I went to school, my sim isnt recognized and I can only call emergency services. I'll try to reboot and other stuff when I'm home, since I can't do that here.
 

123adi

New member
Nov 23, 2019
1
0
the link for the twrp-3.3.0-v2-evert-jlb.img is dead... does anyone still have it? and just so i make sure, the fact that encryption is disabled means i dont have to input my password when i boot into twrp?
 
Last edited:

newwill_225

Member
Aug 18, 2014
40
2
Morning to all.
I've followed all the steps mentioned in the first post, at the moment to flash a-b partitions it shows me a lot of messages sayin that couldn found "Idk" thing an then says too many links (doing it iside twrp on the latest version available for Evert)
then i tried flashing RR Rom and when i get into system, appears a message saying: "Can't load android system. you continue to get this message, do a factory reset data and erase and reboot the device"

did i do something wrong? could any of you givme an explanation about why did this happen?
Thankyou.

Pd. I've used the reset option twice an the third it worked :D
 
Last edited:

sani23

Member
Feb 25, 2018
23
2
JIO VOLTE not working

I did as mentioned, it boots perfectly fine! But for some reason the JIO VOLTE is not working. LTE is working fine and i have internet access but cannot make a call. I even tried adding APNs but they won't work either. It does show VOLTE provsioned in "*#*#4636#*#*". If I go back to STOCK, it works fine. HELP!!!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    rrlogo.png

    Resurrection Remix P

    Code:
    [SIZE="4"]/*
     * Your warranty is now void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */[/SIZE]



    rrabout.png


    Resurrection Remix the ROM has been based on LineageOS, SlimRoms, Omni and original Remix ROM builds, this creates an awesome
    combination of performance, customization, power and the most new features, brought directly to your Device.

    Many things that in previous versions were tweaked with mods, are now included by default in the ROM so, please enjoy!
    Special thanks to the LineageOS team, Omni team, SlimRoms and of course to all the supporters.




    rrinstall.png



    Make sure you have the latest TWRP.img
    Download the latest RR-P zip and GApps zip (opengapps nano or smaller)
    fastboot boot twrp.img (NEW!! See post #2 for info on installing TWRP)
    If coming from stock for the first time, flash copy-partitions-AB.zip from second post (It takes a backup of active slot to inactive slot)
    In TWRP, choose -> Wipe -> Format data and type "yes" at the prompt (Note: this will wipe internal storage)
    Flash latest RR-P.zip
    Reboot and let the ROM boot once (it is necessary to reboot between ROM flash and GApps/Addon flash due to slot-swap logic)
    Reboot back to bootloader and fastboot boot twrp.img again
    In TWRP, choose -> Wipe -> Format data and type "yes" at the prompt (You may be able to get away with just doing a factory reset at this point, but that's on you to try)
    Flash Google Apps package (optional)
    Flash Magisk (also optional) (Note: If Magisk doesn't stick after setting up your device, fastboot boot twrp.img one last time and flash it again, no need to wipe anything)
    First boot may take up to 10 minutes.



    rrdownload.png


    ROM Download
    GApps



    rrsource.png


    Resurrection Remix Source
    Device Source
    Kernel Source
    Vendor Source



    rrthanks.png


    XDA Developers
    LineageOs Team
    Omni Team
    And Of Course To All The Supporters, Donators And Users



    rrbugs.png


    If you have a major bug to report that has not been reported already, please take the following steps to report it to us. It will save you, Team Resurrection Remix and me quite some time.

    Download the MatLog app from the Play Store.
    After downloading the MatLog app, go to the app settings, and change the log level to Debug.
    Clear all previous logs and take the exact steps to produce the error you are receiving. As soon as you receive the error (probably a force close), go straight into MatLog and stop the log recording.
    Copy and paste the entire log either to Hastebin or Pastebin
    Save the log, and copy and paste the link into the thread with a brief description of the error.



    XDA:DevDB Information
    Resurrection Remix Pie v7.0.2, ROM for the Moto G6 Plus

    Contributors
    Jleeblanch, erfanoabdi, rahulsnair, RR Team
    Source Code: https://github.com/ResurrectionRemix

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status: Beta
    Beta Release Date: 2019-02-25

    Created 2019-02-26
    Last Updated 2019-04-21
    6
    Copy partitions zip & TWRP installation info

    [size=+2]Important info, please read...[/size]

    Starting from build 20190414, encryption is disabled (temporarily) and you must clean flash
    The new TWRP version now supports decryption on Pie when booting twrp. However, I have updated TWRP to include the new magisk repacktools which allows users to download and install one twrp.img without the need of an installer zip. The reason behind releasing the ROM with encryption disabled? If you were to try to install TWRP while using an encrypted ROM, you would end up in a bootloop that would bring you back to TWRP. But, install TWRP on a ROM with encryption disabled, and everything works as expected.

    [size=+1]TWRP Installation[/size]

    -> TWRP download || twrp-3.3.0-v2-evert-jlb.img
    ->>> The twrp.img you download above will also be the same twrp.img you will install, so make sure to put a copy on your device as well
    -> Boot twrp
    Code:
    fastboot boot twrp-3.3.0-v2-evert-jlb.img
    -> In TWRP, choose Advanced / Install Recovery Ramdisk
    -> Select the twrp-3.3.0-v2-evert-jlb.img
    ->>> At this point twrp will automagically unpack your boot.img and the twrp.img, swap out the recovery-ramdisk, and repack your boot.img. When this process completes, twrp will be permanently installed.
    ->>> Always flash Magisk AFTER you've installed twrp
    -> Reboot and enjoy. You should now be able to reboot to recovery from the Power Menu!!
    DO NOT try to install twrp on an encrypted rom. You will most likely end up in a bootloop, you have been warned!

    Important
    To keep TWRP installed between ROM updates, there is a Magisk Module named "TWRP A/B Retention Script" by @osm0sis. Search for it within Magisk Manager Downloads section. You'll want to flash this script zip after each OTA has installed, but before you install Magisk to the Inactive Slot from Manager.


    [size=+1]Coming from stock?[/size]

    Make sure to flash the copy-partitions-AB.zip in twrp before you do anything else. You can download it from the attachment below...
    4
    Hi, thanks for the ROM. But i also had issues with BT calls and sound quality during phone calls, so i reverted to stock. I tried flashing the newest Pie stock firmware(reteu PPW29.116-20) and relocking the bootloader afterwards. But i had the message "This device has loaded a different operating system", and "Verity mode disabled" during boot. And the worst thing is the message "System integrity compromized" and hens - GooglePay disabled and no software updates.
    I've got a question, how to revert to stock in corect way and eable GooglePay. Wanna to sell the device.
    Is it because of when i came from stock for the first time, I flashed "copy-partitions-AB.zip" from second post?
    Hmm, Bluetooth calls are working for some, so I've been told. Anyway, if you're trying to return to stock, you need to flash the correct firmware for your device variant. The PPW29.116-20 is only for certain variants, not the "latest" update as a lot of users mistake it for. If you wanna stay on Pie, then try the 116-11 or 116-16 firmware.
    Hello, can we dirty install the update?
    Yes, absolutely. The Updater has been fixed in latest build and does support seamless updates (same as stock). I tested it last night as I was running a test build from a couple days ago.

    To successfully dirty flash, follow these steps:
    -> Boot TWRP
    -> Flash RR.zip
    -> Reboot once
    -> Boot TWRP again
    -> Flash GApps + Magisk
    -> Wipe caches and reboot
    2
    For now, if you've flashed Magisk, you can flash my Magisk module (or any module) that will help pass safetynet and show device as being certified in Play Store. This is why Google Pay doesn't work.

    I had updated some blobs and build fingerprint to match the stock Pie update, but it seems to be causing the device to fail safetynet. I will have this fixed in the next update.

    As for the fingerprint gestures always being enabled. I'm looking into this too. I'm assuming this has something to do with an overlay I added to insure the navbar was enabled on first boot (as without it, it's not). I hope to have this fixed for the next update as well.

    No problem, I won't flash Magisk if you're looking at getting it fixed I will just hang fire, it's not a much needed thing anyway, as Google Pay isn't a much needed thing for me, was just handy.

    As for the Fingerpring Gestures that's fine, it's not harmful, I just thought I'd mention it.

    I'm loving it so far, not had any problems all good.
    2
    Woks awesome, thank you dev
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone