• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][PORT][UNOFFICIAL][kenzo/kate][11] LineageOS 18 [STABLE] [25-08-2021]

Search This thread

ccarol90

New member
Oct 25, 2019
4
1
@nasim7500
Thank you for the port.

Mine is kenzo 3/32 in Singapore
9 hours uptime so far from first boot, battery consumption seems normal as compared to stock miui10 for me.

(Edited 2300h 27sep21)
Bluetooth, hotspot mobile, wifi hotspot works.
Audio is ok, headphone ok BT audio ok.
IR blaster tested ok.

Bugs encountered (im not using the modded a11 rom, no magisk, no xposed)
Some time from app switching will kick back to home page desktop (small problem no matter)
No 5ghz wifi can be detected and no option to choose band on stock rom.
EAP-SIM does not work too regardless which slot i put the sim into.

McDonald's app refuses to run as it reports rooted device.

[email protected] app refuses to load with same reasons.

Tracetogether app reports warning rooted device but allows funcions in full.
 
Last edited:

ccarol90

New member
Oct 25, 2019
4
1
After try to install this ROM, First page of phone screen show ''To start andriod device, Enter your password'' But when i try to enter my phone (password). It show Wrong password. How to solved? Please Do you know anything about password. Gave me
Formatting my data partition worked, i had same problem as you for a moment i was stumped… hat password? Haha
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    No it work but some country 5GZ WiFi not showing don't know why?
    I tried changing my wifi router 5ghz channel to lower range channel and 20mhz.
    Used wifiman app to scan for 5ghz ssids nearby, none while my chuwi hi9pro tablet sees many.

    Maybe the rom did not enable full range of wifi channel on 5ghz hence cannot see.
  • 16
    Lineage-OS.jpg





    Lineage-os 18 for Redmi Note 3 pro, ported from Mi Max by @nasim7500



    What's working:
    ----------------
    • Boot
    • Bluetooth
    • Camera / Camcorder
    • Fingerprint Sensor
    • FM Radio
    • GPS
    • RIL
    • WiFi
    • WiFi Hotspot
    • USB (ADB/MTP)
    • Video Playback
    • Touch
    • Sensors


    Bugs:
    -------
    • DT2W (if you need this then install magisk & use any kernel manager app)
    • Some hidden bug there maybe, not sure


    Installation instructions:
    ---------------------------
    • Install a compatible Recovery (orangeFox recomended)
    • Perform a NANDroid backup of your current ROM (Optional)
    • Wipe system / data / cache partitions
    • Flash ROM & Gapps then reboot
    • After boot, again reboot one more time
    • Optional: Install Magisk for Root.


    Special thanks to these guys (For help me)
    ----------
    @MrJarvis698, @trax85, @Jrchintu @Magicxavi


    Also This guy for Testting this Rom
    -----------------
    @JeSsyB007, @H39AR



    BUG FIXING FULL CREDIT: OUR GOD (Allah)



    NOTE:

    • We are not responsible for bricked devices, dead sdcard, etc
    • If you find any other bug you can tell me, I will try to fix but no promises
    • All mejor bug fixed, now enjoy!!
    • if you face rendom reboot problem then just format data partition after install this Rom, from twrp thnx to @QantivirusP & @Ardityo
    • you want selected text feature in normal version? click here
    • This is my first post in xda so if somthing i wrong then tell me
    • Still alive poor battery backup then just flash this kernel
    • chines character kernel have obb bug


    SCREENSHOTS:


    ROM Download Link:
    ------------------
    lineage-os-18.1_ported_for_kenzo_by-nasim7500 25-8-2021.zip

    FlameGApps-11.0-basic-arm64-20210822.zip



    [MODED_ROM] lineage-os-18.1_ported_for_kenzo_by-nasim7500 24-8-2021.zip





    Changelogs

    25/08/2021

    • Fixed safetynet by default thnx to @Rajat_Prime & @sairam60
    • Fixed Fingerprint won't wakeup screen
    • Fixed weak wifi signal
    • Fixed weak vibration
    • Fixed poor battery backup again (cause min cpu value set to high) thnx to @trax85
    • Obb Fixed Big Thnx to @trax85 for compiling new kernel && @alonsoj636 & @Rajat_Prime for give me the Commit file




    >>>>> MODE VERSION <<<<<

    • Gapps included
    • added selected text feature by default
    • add Solid explorer to system app thnx to @SkullMax01








    1/06/2021

    • Fixed Camera
    • Fixed Fingerprint
    • Fixed FM Radio.
    • Fixed Heaing Issue
    • fixed Poor Battery backup
    • Fixed TWRP Installation error on kenzo device thnx to @nshussain (for findout why this problem)


    Rom ported by nasim7500.


    Guys if you like my work plz press like button & support to my helper or respect him, thank you..Now Enjoy!!


    And Last i Want to say Thank you so much from my heart for All Kenzo dev for your hard & awseome Work...
    3
    Great work @nasim7500
    Just a small suggestion if you have time to work on.

    Disabling Selinux (Permissive) is very dangerous from Android 10. Any app can get permanent root permissions when it is disabled without the user knowing.

    Here is the POC in wild.


    Kindly prioritize it before anything else. Hopefully this official guide on Selinux by Lineage helps you.

    3
    Are you planning to fix Camera and Goodix FP issues? What about Face Unlock? Or it depends on new MiMax fixes? Pls update OS version & build info in your top (header) post each time you upload a new build and update its download link.
    now Camera & FP fixed bro,,,
    2
    Could you please tell me that how did you reduced the img size? I'm facing at the same error says
    update process ended with error 1.
    Install Ubuntu os on a VM, copy img file you converted over there.
    On terminal browse to location where you saved img and run commands:
    e2fsck -f -y system.img
    resize2fs -M system.img
    Copy img from Ubuntu to computer and then phone. (I used internet, couldn't understand how to copy directly)
    From recovery:
    flash system.img to system partition.
    Reboot to recovery.
    Mount system partition,
    Resize system partition.
    Install gapps.

    Dont forgot to flash boot.img to boot partition as well.

    Regards,
    2
    I dont know, is it bug or not but some apps are unable to install from google play store. Play store shows unable to install app try common fixes. I have tried everything... But still issue persists.
    apps which shows error - Call of Duty Mobile and Microsoft Office
    version: Lineage OS 18.1 (Stable new by nasim7500)
    device: Redmi note 3 32gb/ 3gb varient.
    gapps used: MindTheGapps package
    (Although I know I can download apk from internet😂.... By the way Rom is very good and better from previous version😘❤❤)