[ROM][PX5][S32F0][9.0] Malaysk ROM for PX5 MCU S32F0 RK3368 with Android 9

royalhawk2002

Senior Member
Sep 21, 2008
839
117
63
Avezzano
Thank you Ilciumbia, it finally worked. I did the following:
Changing the USB stick (still 4GB), downloading the package once again and using WIN10 iso Ubuntu to format the stick / copying the files on it.
Which of these actions was decisive, I do not know. ;-) But maybe it helps others.

First impressions:
-Nice launcher, everything works as before, even the issues:
-Auto-pairing of an iPhone does not work. At least an Android phone now pairs automatically (and I did not change anything on the phones).
-the pop up for confirming the usage of the USB stick when opening DAB-Z is still there. :-(
I hoped this to be fixed as others reported. Or is this fix only part of the full version?
I don't remember if the problem on usb was present in the lite version, but I don't have it anymore in the full
 

Jarninho

Member
Jul 29, 2020
5
4
3
The Lite function sorted the USB permission problem somewhat for me. It came back a few times, but after I sorted my battery and memory connection most of the time it was gone. Before I could pinpoint when it came back, I switched to the full version.

With the full version I immediately whitelisted the Autokit app and I have not seen the problem anymore, even after a complete power disconnect. I think it would work the same way with the Zlink app.
 

Magnolo

New member
Jan 20, 2021
1
0
11
I'm still unsure if I can use this ROM.
The instructions say Android 9 and my Erisin 8129D supposedly has Android 10.

Actually, the original ROM runs quite well.
But I can't use it to reset the steering wheel remote control and reassign it.

Would that work with the new ROM?
Is there someone here who has already had experience with it?

View attachment 5181531
Hey there @DusterTom , i ve got the same device and the same problem. Everything else seems to run fine, but steering wheel controls are not reassignable (missing something for mute...)

Yours has the exact same specs as mine. Have you tried to update the mcu or the rom from a newer origin firmware like this? > Found here in an earlier post ?

I have no clear answer for a newer rom or mcu from the seller yet.

Thx for all your effort, infos and help in advance here.
 

misiozol

Member
Mar 1, 2015
17
7
23
@Malaysk been using this for a while now in full version and have found few issues: brightness when switching car ligts goes randomly up and down ( it was doing so in stock rom as well ) was hoping it will be fixed in your rom. Additionaly changing display DPI permanently brakes all widgets as im getting only black regtangles with info in them "widget could not be loaded" resetting radio to factory does not solve issue same as setting back default DPI no luck. Can you have a look please at those issues :)
 

royalhawk2002

Senior Member
Sep 21, 2008
839
117
63
Avezzano
Hello. Here are three DSP programs.
For the green board and for the black one.
In my new Head Unit, after installing the Lite, Ihave the wrong DSP app. Which is the procedure to install the correct one ? The stock app had the interface with green color.
 

Attachments

Last edited:
  • Like
Reactions: armoredcamaro

legolas1496

Member
Dec 11, 2020
8
4
3
Today I finally installed the full version. I was only interested in fixing the USB problem and that works definitely with the full version. The lite version does not help here.
The other issue I have is not fixed even with the full version: Smartphones are not automatically pairing. And maybe this is not related to the ROM. If someone has a hint I would appreciate....
 

royalhawk2002

Senior Member
Sep 21, 2008
839
117
63
Avezzano
Today I finally installed the full version. I was only interested in fixing the USB problem and that works definitely with the full version. The lite version does not help here.
The other issue I have is not fixed even with the full version: Smartphones are not automatically pairing. And maybe this is not related to the ROM. If someone has a hint I would appreciate....
My android smartphone are always auto connecting. One of them has Android 11
 

armoredcamaro

New member
Nov 16, 2020
3
1
1
Went from yunht to Malaysk LITE to Full version:
1.) Bluetooth tethering worked perfect in the LITE version, with the FULL version when the stereo connects to tethering is auto starts Wi-Fi and disables Bluetooth tethering.
2.) Stereo doesn't see my Samsung devices Mobile Hotspot, this is probably due to hardware not software, this feature does not work in original firmware or the Malaysk LITE or FULL.
3.) DSP is not working, in LITE i installed the three dsp mentioned, nothing worked. In full mode i have only tried the one that comes with full. My original firmware DSP worked flawlessly.
4.) I also updated to the latest MCU
5.) How do i use the Custom Start-UP logo? I can get the factory ones to load no issue, i just do not know what file extension to use or how to load it onto the stereo properly i guess.
 
Last edited: