• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [Q][10] Evolution-X 4.0 for Moto Z-Griffin[TREBLE]

Search This thread

mosfet321

Senior Member
Jan 18, 2009
58
35
Aguascalientes, Mex.
Thanks to your feedback I have added some extra steps to ensure that everyone can enjoy the GSI ROM

First of all I am not the creator of this ROM-GSI I only share it in the XDA community and give all the credit to @turbolukex5
You can download and try all of his work from
https://sourceforge.net/projects/expressluke-gsis/files You can see all the work of him in https://forum.xda-developers.com/project-treble/trebleenabled-device-discussion/gsi-expressluke-built-gsis-t4003457

Evolution X 4.0 has all the extra features of the AOSP ROMs plus extra features of Evolution X and all the sweetness of the Pixel. Tested by myself, like Lineage is stable for daily use without any problem of any kind (obviously we all know that moto-mods don't work, only the moto-mod battery in default mode) when used in Moto Z. Needless to say, as you read in the title this ROM is GSI so if you want to try it you need to have Official Lineage OS 16 installed in your Moto Z before attempting to install the GSI image.

So let's go to the installation steps:

Steps when you are already in another GSI
1. Download the GSI image from https://sourceforge.net/projects/expressluke-gsis/files/EvolutionX/Ten/ARM64/A/ EvolutionX_4.0_ARM64A-10.0-20200112-2146-GSI.img.xz
2. Unzip the file to extract the system image and copy it inside your Moto Z
3. Go to TWRP and wipe Data(not internal storage) /Cache/System
4. Go to Install and change to Install image
5. Select the image of Evolution X and flash as system partition
6. Flash Magisk Canary if you want root, gapps already included
6. Reboot to System
7. Wait fist boot and enjoy Evolution X 4.0

First Install/Clean install

1. Install Official Lineage OS 16
2. Boot to Lineage 16
3. Reboot TWRP
4. Wipe System, Data, Cache, Internal Storage
5. Reboot to recovery
6. Copy Evolution X 4 GSI image to Internal storage
7. Go Install IMAGE and select as System partition
8. Flash permissiver_v4
9. Reboot to System
10. Wait first boot and enjoy Evolution X 4.0

By far the best GSI I have tested for our Moto Z

Screenshots

https://imgur.com/a/vxLkVUj

Extra Tips:
Magisk Modules
LSpeed Magisk Module for extra battery life
Magisk Dolby ATMOS Q. Although the GSI already comes with very good audio

One more:
Arnova Gcam


Android OS version: 10.0
Security patch level: January 2020
GSI author: turbolukex5
Source code: https://github.com/Evolution-X
ROM Developer: joeyhuab
ROM Kernel: Linux 3.18
ROM Firmware Required: Official Lineage OS 16
Based On: AOSP

Version Information
Status: Stable
Current Stable Version: 4.0
Stable Release Date: 2020-01-12
 

Attachments

  • Permissiver_v4.zip
    1.1 MB · Views: 275
Last edited:

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
Evolution X 4.0
Status: Stable
Current Stable Version: 4.0
Stable Release Date: 2020-01-12

Hey, thanks for the great share! :good::fingers-crossed::highfive::laugh::silly:

1. 'By far the best GSI I have tested for our Moto Z' - have you already tested havoc 3 gsi?
2. please, change this in the description "no gapps already included" it's not clear if they are included or not. simply state 'gapps included'
3. how long should one wait for boot? - for me it's on boot animation min 15 already.
3.1 currently can't pass boot animation (-05 china version of Moto Z)
4. is latest official twrp OK for flashing this image?
 
Last edited:
  • Like
Reactions: mosfet321

mosfet321

Senior Member
Jan 18, 2009
58
35
Aguascalientes, Mex.
Hey, thanks for the great share! :good::fingers-crossed::highfive::laugh::silly:

1. 'By far the best GSI I have tested for our Moto Z' - have you already tested havoc 3 gsi?
2. please, change this in the description "no gapps already included" it's not clear if they are included or not. simply state 'gapps included'
3. how long should one wait for boot? - for me it's on boot animation min 15 already.
3.1 currently can't pass boot animation (-05 china version of Moto Z)
4. is latest official twrp OK for flashing this image?

Thank you for your advice, I tried Havoc but the battery life was not ideal for me but it is still a great option. You need to use twrp-3.3.1-0 but I'm not sure if the official version works in the CN version. Already installed does not take more than 3 minutes to boot. Try to erase Data and flash Magisk.
 

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
Thank you for your advice, I tried Havoc but the battery life was not ideal for me but it is still a great option. You need to use twrp-3.3.1-0 but I'm not sure if the official version works in the CN version. Already installed does not take more than 3 minutes to boot. Try to erase Data and flash Magisk.

Yeah, official 331 works just fine.
The case is it's 2 sim phone and aosp on this phone even has no sim up.
What do you mean by erase data? - format or factory reset or wipe?
By the way, which partitions do you backup in twrp for successful full restore?
 

mosfet321

Senior Member
Jan 18, 2009
58
35
Aguascalientes, Mex.
Yeah, official 331 works just fine.
The case is it's 2 sim phone and aosp on this phone even has no sim up.
What do you mean by erase data? - format or factory reset or wipe?
By the way, which partitions do you backup in twrp for successful full restore?


I mean Wipe data partition where you have to write "yes" to wipe data. I had a similar problem when I started trying GSI everything was solved when I did a full wipe of System, Data, Cache then reboot to TWRP and install Lineage 16 afther that reboot to system and after full boot again TWRP and start to flash gsi, never had problems again when I want to try a GSI image I just do wipe cache and system and that's it :)


I do not make any backup I only make a backup copy of google that saves my contacts, photos, Wi-Fi networks, etc. and does not wipe data partition

Remember permissive and fixzygote are not needed for GSI builds made after 25th September
 
  • Like
Reactions: dimdimdim

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
I mean Wipe data partition where you have to write "yes" to wipe data. I had a similar problem when I started trying GSI everything was solved when I did a full wipe of System, Data, Cache then reboot to TWRP and install Lineage 16 afther that reboot to system and after full boot again TWRP and start to flash gsi, never had problems again when I want to try a GSI image I just do wipe cache and system and that's it :)


I do not make any backup I only make a backup copy of google that saves my contacts, photos, Wi-Fi networks, etc. and does not wipe data partition

Remember permissive and fixzygote are not needed for GSI builds made after 25th September

Will try... Later :)
 

piotriix

Senior Member
May 20, 2013
114
15
Motorola One Fusion+
There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------

2. Unzip the file to extract the system image and copy it inside your Moto Z
winrar ? 7z?
 

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------


winrar ? 7z?

winrar work pretty ok
check the consequence above by author with format via "yes" - BE SURE TO BACKUP INTERNAL STORAGE BEFORE AS IT CLEANS IT OUT.
I have the same problem as you, only can get a life long boot animation. even though aosp 210 boots up (with no ril unfortunately).
but I have not tried to do it with yes-format yet. so, if you are up to it now, would be great to know if you succeeded.
which device do you own? mine is -05 chineese 2 sim
 

Blackigor

Member
May 13, 2018
5
3
Brasília
There is no mistake.
The installation ends with the boot image evolution and nothing further happens.
I wait about 20 minutes
I even did a clean LineageOS installation and it did nothing.

---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------


winrar ? 7z?

Into the TWRP, folow these steps:

1- Go Wipe - Format Data (DON'T BOOT the System Yet)
2- Go Reboot - Recovery
3- Now you flash the System img. Be patient and wait the process. It can take 3-5 minutes, maybe more. (DON'T BOOT the System Yet)
4- Go Reboot - Recovery
5- Now go Wipe - Format Data - Boot Rom
 

piotriix

Senior Member
May 20, 2013
114
15
Motorola One Fusion+
Moto 03 reatu
Into the TWRP, folow these steps:

1- Go Wipe - Format Data (DON'T BOOT the System Yet)
2- Go Reboot - Recovery
3- Now you flash the System img. Be patient and wait the process. It can take 3-5 minutes, maybe more. (DON'T BOOT the System Yet)
4- Go Reboot - Recovery
5- Now go Wipe - Format Data - Boot Rom

I did so too.
All in all, I did a few approaches with different configurations.
 

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
Moto 03 reatu


I did so too.
All in all, I did a few approaches with different configurations.

0. Check the attached
1. Try to flash permissiver on it
2. Try to wipe data not from twrp, but from fastboot only
3. Flash can still be done via twrp
4. Please, post the result
 

Attachments

  • Screenshot_20200214-220428.jpg
    Screenshot_20200214-220428.jpg
    244.8 KB · Views: 154

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
No change.
It hangs on the start log

OKAY, THIS IS HOW I BOOT IT (EASY):
1. system, data, cache wipes
2. flash lineageos16
3. boot and pass first setup
4. boot to recovery
5. flash image
6. flash permissiver V5 - with v4 there is no ril
7. boot
boots fast, a couple of minutes.
 
Last edited:
  • Like
Reactions: piotriix

mosfet321

Senior Member
Jan 18, 2009
58
35
Aguascalientes, Mex.
0. Check the attached
1. Try to flash permissiver on it
2. Try to wipe data not from twrp, but from fastboot only
3. Flash can still be done via twrp
4. Please, post the result


Excellent step, apparently if you have never installed a GSI ROM it is absolutely necessary to flash permitsiver_v4, I have added the step and works smoothly. :good: I realized that after trying JoyUI GSI from Vegazsd, (it works but with the bugs of the camera and gsm network :crying:) and when I returned to Evolution X it only worked after flashing permissiver_4

The guide is updated and ready for everyone to enjoy the GSI on their Griffin :cool:
 
  • Like
Reactions: piotriix

piotriix

Senior Member
May 20, 2013
114
15
Motorola One Fusion+
I installed permissiver_4 before installing img. It is a pity that I did not know about v4 installation after and not before.
And all in all I still don't know if v4 is good or if you need to install v5.
I have a request if you donate something, try to follow the right order of installation because information chaos creeps in.
Thank you for the advice and best regards.
Today I will try again and if it goes wrong it fits :(
As I understand it is supposed to be pure lineageos16 without gaps and Google applications like that?
He asks now in detail not to err.
As I understand it is supposed to be pure lineageos16 without gaps and Google applications like that?
He asks now in detail not to err.

---------- Post added at 11:01 AM ---------- Previous post was at 10:31 AM ----------

I tried and it works :)
I installed permissiver_v5 and clean lineageos 16
Thank you once again
 
Last edited:

dimdimdim

Senior Member
Oct 6, 2006
1,751
257
Into the TWRP, folow these steps:

1- Go Wipe - Format Data (DON'T BOOT the System Yet)
2- Go Reboot - Recovery
3- Now you flash the System img. Be patient and wait the process. It can take 3-5 minutes, maybe more. (DON'T BOOT the System Yet)
4- Go Reboot - Recovery
5- Now go Wipe - Format Data - Boot Rom

I recommend flash permissiver v5 as my ril was back only with it. V4 doesn't help
And I think you can skip data formats if you did it once.
I did only
normal wipes,
then lineagos flash
then boot it and first setup
then straightly flash img and permissiver v5
then it boots just ok and fast

Ah, yeah, and for me it's always best idea to reboot recovery after every operation. Because here and there I've seen it may fail to properly mount some partitions depending on the situation, which leads to errors while flashing
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Thanks to your feedback I have added some extra steps to ensure that everyone can enjoy the GSI ROM

    First of all I am not the creator of this ROM-GSI I only share it in the XDA community and give all the credit to @turbolukex5
    You can download and try all of his work from
    https://sourceforge.net/projects/expressluke-gsis/files You can see all the work of him in https://forum.xda-developers.com/project-treble/trebleenabled-device-discussion/gsi-expressluke-built-gsis-t4003457

    Evolution X 4.0 has all the extra features of the AOSP ROMs plus extra features of Evolution X and all the sweetness of the Pixel. Tested by myself, like Lineage is stable for daily use without any problem of any kind (obviously we all know that moto-mods don't work, only the moto-mod battery in default mode) when used in Moto Z. Needless to say, as you read in the title this ROM is GSI so if you want to try it you need to have Official Lineage OS 16 installed in your Moto Z before attempting to install the GSI image.

    So let's go to the installation steps:

    Steps when you are already in another GSI
    1. Download the GSI image from https://sourceforge.net/projects/expressluke-gsis/files/EvolutionX/Ten/ARM64/A/ EvolutionX_4.0_ARM64A-10.0-20200112-2146-GSI.img.xz
    2. Unzip the file to extract the system image and copy it inside your Moto Z
    3. Go to TWRP and wipe Data(not internal storage) /Cache/System
    4. Go to Install and change to Install image
    5. Select the image of Evolution X and flash as system partition
    6. Flash Magisk Canary if you want root, gapps already included
    6. Reboot to System
    7. Wait fist boot and enjoy Evolution X 4.0

    First Install/Clean install

    1. Install Official Lineage OS 16
    2. Boot to Lineage 16
    3. Reboot TWRP
    4. Wipe System, Data, Cache, Internal Storage
    5. Reboot to recovery
    6. Copy Evolution X 4 GSI image to Internal storage
    7. Go Install IMAGE and select as System partition
    8. Flash permissiver_v4
    9. Reboot to System
    10. Wait first boot and enjoy Evolution X 4.0

    By far the best GSI I have tested for our Moto Z

    Screenshots

    https://imgur.com/a/vxLkVUj

    Extra Tips:
    Magisk Modules
    LSpeed Magisk Module for extra battery life
    Magisk Dolby ATMOS Q. Although the GSI already comes with very good audio

    One more:
    Arnova Gcam


    Android OS version: 10.0
    Security patch level: January 2020
    GSI author: turbolukex5
    Source code: https://github.com/Evolution-X
    ROM Developer: joeyhuab
    ROM Kernel: Linux 3.18
    ROM Firmware Required: Official Lineage OS 16
    Based On: AOSP

    Version Information
    Status: Stable
    Current Stable Version: 4.0
    Stable Release Date: 2020-01-12
    3
    Moto 03 reatu


    I did so too.
    All in all, I did a few approaches with different configurations.

    0. Check the attached
    1. Try to flash permissiver on it
    2. Try to wipe data not from twrp, but from fastboot only
    3. Flash can still be done via twrp
    4. Please, post the result
    2
    There is no mistake.
    The installation ends with the boot image evolution and nothing further happens.
    I wait about 20 minutes
    I even did a clean LineageOS installation and it did nothing.

    ---------- Post added at 10:23 AM ---------- Previous post was at 09:55 AM ----------


    winrar ? 7z?

    Into the TWRP, folow these steps:

    1- Go Wipe - Format Data (DON'T BOOT the System Yet)
    2- Go Reboot - Recovery
    3- Now you flash the System img. Be patient and wait the process. It can take 3-5 minutes, maybe more. (DON'T BOOT the System Yet)
    4- Go Reboot - Recovery
    5- Now go Wipe - Format Data - Boot Rom
    2
    i have flashed permissivier over the rom and it worked https://androidfilehost.com/?fid=6006931924117886495
    1
    Evolution X 4.0
    Status: Stable
    Current Stable Version: 4.0
    Stable Release Date: 2020-01-12

    Hey, thanks for the great share! :good::fingers-crossed::highfive::laugh::silly:

    1. 'By far the best GSI I have tested for our Moto Z' - have you already tested havoc 3 gsi?
    2. please, change this in the description "no gapps already included" it's not clear if they are included or not. simply state 'gapps included'
    3. how long should one wait for boot? - for me it's on boot animation min 15 already.
    3.1 currently can't pass boot animation (-05 china version of Moto Z)
    4. is latest official twrp OK for flashing this image?