• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][Q/R] Unofficial, optimized LineageOS 18.1 (July 10th) & LineageOS 17.1 (June 11th)

Search This thread

capt.ron

Senior Member
Aug 28, 2012
97
34
OnePlus One
Wow, super fast fix! I used the Mapmyride app for a little over 2 hours and the tracking was great but I did lose wifi somewhere along my route and it was still off when I got back home. Required a reboot to get it going again. The tracking seemed unaffected by the absence of wifi. Very nice work on the GPS issue @Tomoms!
 
  • Like
Reactions: Tomoms

kekerosberg

Member
Dec 28, 2019
18
4
It took something like 20 seconds to get a fix with 30m accuracy. This is without any Google location services (WIFI/BT/etc). I think it's pretty good for 63° N.

Beautiful work Tomoms!
 

Saison2018

Senior Member
Not sure how to troubleshoot but I hope @Tomoms will be able to guide me to help him :)
Since last two updates (2021-06-10 and 2021-06-16) I am not able to launch any videos (and to cast them on my TV) with RDS application (French Canadian version of TSN, both are private sport broadcaster).
I pay monthly fees for viewing many sports, like Formula 1, since there are no other service available in Canada.
Until latest May build (2021-05-07), everything was fine, I was able to launch direct streaming (or on-demand) and to cast it to my TV.
Since June build, I have red circle in middle of the screen (meaning "loading, please wait") but it never launch any videos.
I installed exactly same application (RDS) on another device (Samsung Galaxy Tab S5e, Android 11, security from March 1st 2021) and everything is running fine.
Hope your will have an idea, I am willing to help if i can
 

ImmortAlex

Senior Member
Jan 3, 2012
151
124
41
Novosibirsk, Siberia, Russia
No luck. Still very long TTFF.
Location: Russia, deep in Siberia.
 

Attachments

  • Screenshot_20210619-104031_GPSTest.png
    Screenshot_20210619-104031_GPSTest.png
    189.8 KB · Views: 34

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Not sure how to troubleshoot but I hope @Tomoms will be able to guide me to help him :)
Since last two updates (2021-06-10 and 2021-06-16) I am not able to launch any videos (and to cast them on my TV) with RDS application (French Canadian version of TSN, both are private sport broadcaster).
I pay monthly fees for viewing many sports, like Formula 1, since there are no other service available in Canada.
Until latest May build (2021-05-07), everything was fine, I was able to launch direct streaming (or on-demand) and to cast it to my TV.
Since June build, I have red circle in middle of the screen (meaning "loading, please wait") but it never launch any videos.
I installed exactly same application (RDS) on another device (Samsung Galaxy Tab S5e, Android 11, security from March 1st 2021) and everything is running fine.
Hope your will have an idea, I am willing to help if i can
Please capture a logcat using a computer or any logcat-saving app immediately after trying to load a video.
 

Saison2018

Senior Member
Please capture a logcat using a computer or any logcat-saving app immediately after trying to load a video.
Please find attached a zip file containing result of 3 tests :
  1. Capture all from launching application (after passing through ads, even if I paid...) and trying to launch a direct streaming
  2. Still in application, force a content refresh and tried to launch same direct streaming
  3. Still in application, force a content refresh and tried to launch same direct streaming, wait 30 seconds before stopping
I captured logcat using a computer and I always stopped streaming to let you see difference between waiting for video loading and manually stopping the process.
I really hope this will be useful. I do not do this often, I may have made mistake. Do not hesitate to ask for more test if needed.
Thanks a lot for your time and still taking care of our beloved Oneplus One.
 

Attachments

  • TESTS.zip
    535.2 KB · Views: 4
  • Like
Reactions: Tomoms

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Please find attached a zip file containing result of 3 tests :
  1. Capture all from launching application (after passing through ads, even if I paid...) and trying to launch a direct streaming
  2. Still in application, force a content refresh and tried to launch same direct streaming
  3. Still in application, force a content refresh and tried to launch same direct streaming, wait 30 seconds before stopping
I captured logcat using a computer and I always stopped streaming to let you see difference between waiting for video loading and manually stopping the process.
I really hope this will be useful. I do not do this often, I may have made mistake. Do not hesitate to ask for more test if needed.
Thanks a lot for your time and still taking care of our beloved Oneplus One.
This really looks like an application error... Was the application updated recently? Can you reflash my build from May, on which you recall you had no issues, to check if this is still the case? A dirty flash with no wipes would be enough.
 

Saison2018

Senior Member
This really looks like an application error... Was the application updated recently? Can you reflash my build from May, on which you recall you had no issues, to check if this is still the case? A dirty flash with no wipes would be enough.
Sure, I will do it and report test result.
Application was updated beginning of June. latest version was in May. If I can, I will try to test application's May version on June firmware.
This may be an application error but my other device (Samsung Galaxy Tab S5e, Android 11, security from March 1st 2021), latest version of application (from June) is running fine.
My feeling is there is something from June security, but this is only a feeling, nothing to prove it.
Will keep you posted as soon as I have done the test (dirty flash without wipes)
 

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Sure, I will do it and report test result.
Application was updated beginning of June. latest version was in May. If I can, I will try to test application's May version on June firmware.
This may be an application error but my other device (Samsung Galaxy Tab S5e, Android 11, security from March 1st 2021), latest version of application (from June) is running fine.
My feeling is there is something from June security, but this is only a feeling, nothing to prove it.
Will keep you posted as soon as I have done the test (dirty flash without wipes)
It is possible that June's patches have broken something. It has happened in the past. Please confirm that the latest version of the app works on May's build. If it does, I will remove June's patches and prepare a new build for you to test.
EDIT: BTW, in your log I have found a symptom of a small, unrelated problem that may be occurring "under the hood", and that should be trivial to fix!
 
Last edited:
  • Like
Reactions: Saison2018

capt.ron

Senior Member
Aug 28, 2012
97
34
OnePlus One
It is possible that June's patches have broken something. It has happened in the past. Please confirm that the latest version of the app works on May's build. If it does, I will remove June's patches and prepare a new build for you to test.
EDIT: BTW, in your log I have found a symptom of a small, unrelated problem that may be occurring "under the hood", and that should be trivial to fix!
Not sure if this is helpful to you guys but give it a read :

I downloaded the DRM app from Google play store and it did not show my OPO as having the Widevine capability?? Got me....
 

Saison2018

Senior Member
It is possible that June's patches have broken something. It has happened in the past. Please confirm that the latest version of the app works on May's build. If it does, I will remove June's patches and prepare a new build for you to test.
EDIT: BTW, in your log I have found a symptom of a small, unrelated problem that may be occurring "under the hood", and that should be trivial to fix!

Tests with firmware 2021-06-16:
  • Test #1: Uninstalled latest application version (2.3.0-2259004), installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #2: Upgrade to latest application version (2.3.0-2259004). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #3: Upgrade to latest application version (2.3.0-2259004). Update made from Google Play Store (do not know why there is an update).
    • Direct streaming KO
    • Video On-Demand KO
  • Test #4: Installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet. Update to latest (2.3.0-2259004) made from Google Play Store.
    • Direct streaming KO
    • Video On-Demand KO
Tests with firmware 2021-05-07:
  • Test #5: Installed latest application version (2.3.0-2259004) from Google Play Store.
    • Direct streaming KO
    • Video On-Demand KO
  • Test #6: Uninstalled latest application version (2.3.0-2259004), installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #7: Upgrade to latest application version (2.3.0-2259004). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #8: Upgrade to latest application version (2.3.0-2259004). Update made from Google Play Store (do not know why there is an update).
    • Direct streaming KO
    • Video On-Demand KO
To summarize :
  • Seems there is no link between June security and application problem
  • Application installed from downloaded APK are running fine
  • Same application version "updated" from Google Play Store causing trouble
  • I also remark some trouble with casting shortcut inside application not being available when application is installed from APK. Not sure if there is a link. If I can not launch streaming, casting is useless.
Let see if your latest finding could help.
 
  • Like
Reactions: SethGeckoXDA

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Tests with firmware 2021-06-16:
  • Test #1: Uninstalled latest application version (2.3.0-2259004), installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #2: Upgrade to latest application version (2.3.0-2259004). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #3: Upgrade to latest application version (2.3.0-2259004). Update made from Google Play Store (do not know why there is an update).
    • Direct streaming KO
    • Video On-Demand KO
  • Test #4: Installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet. Update to latest (2.3.0-2259004) made from Google Play Store.
    • Direct streaming KO
    • Video On-Demand KO
Tests with firmware 2021-05-07:
  • Test #5: Installed latest application version (2.3.0-2259004) from Google Play Store.
    • Direct streaming KO
    • Video On-Demand KO
  • Test #6: Uninstalled latest application version (2.3.0-2259004), installed previous version (2.2.4-2107012). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #7: Upgrade to latest application version (2.3.0-2259004). Installation made with APK downloaded from Internet.
    • Direct streaming OK
    • Video On-Demand OK
  • Test #8: Upgrade to latest application version (2.3.0-2259004). Update made from Google Play Store (do not know why there is an update).
    • Direct streaming KO
    • Video On-Demand KO
To summarize :
  • Seems there is no link between June security and application problem
  • Application installed from downloaded APK are running fine
  • Same application version "updated" from Google Play Store causing trouble
  • I also remark some trouble with casting shortcut inside application not being available when application is installed from APK. Not sure if there is a link. If I can not launch streaming, casting is useless.
Let see if your latest finding could help.
I think this confirms that the problem belongs to the application, but I have no idea why the version provided by the Play Store is bugged while the apks you can find on the web are not.
Where did you download the apk from? What kind of casting does the app support? Direct WiFi display without third-party hardware, or stuff such as Chromecasts & co.?
 

Saison2018

Senior Member
I think this confirms that the problem belongs to the application, but I have no idea why the version provided by the Play Store is bugged while the apks you can find on the web are not.
Where did you download the apk from? What kind of casting does the app support? Direct WiFi display without third-party hardware, or stuff such as Chromecasts & co.?
APK were downloaded from APKPure and APKMonk, because not all application versions were available on one site.
Inside application, in normal usage, I can see a button from main window or when watching a video. When selecting, I can choose near devices available. I suppose it is Chromecast since the menu/choice/experience inside application is really close to "Cast" menu inside "Settings", but I am not 100% sure.
 

sumitinhome

Senior Member
Jul 1, 2014
98
27
Not sure if this is helpful to you guys but give it a read :

I downloaded the DRM app from Google play store and it did not show my OPO as having the Widevine capability?? Got me....
This is one problem too. Many OTT apps dont work on this rom because of lack of widevine. Only live streaming works in these OTT apps, nothing else.
 
  • Like
Reactions: capt.ron

sumitinhome

Senior Member
Jul 1, 2014
98
27
man, the only thing annoying me lot is the network. it goes from 4g to edge every 5-10 minutes. I have to keep putting phone in airplane mode and back to get back 4g. I do this almost 50-60 times daily.
 

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Not sure if this is helpful to you guys but give it a read :

I downloaded the DRM app from Google play store and it did not show my OPO as having the Widevine capability?? Got me....

This is one problem too. Many OTT apps dont work on this rom because of lack of widevine. Only live streaming works in these OTT apps, nothing else.

Widevine L3 support will probably be restored in the next build. Our first maintainer pointed me to the necessary patches, so I'll implement and test them soon!
 

Saison2018

Senior Member
I think this confirms that the problem belongs to the application, but I have no idea why the version provided by the Play Store is bugged while the apks you can find on the web are not.
Where did you download the apk from? What kind of casting does the app support? Direct WiFi display without third-party hardware, or stuff such as Chromecasts & co.?
Still trying to figure out what is the real cause of my streaming and casting problem and I found something new:
I rebooted in TWRP and Wipe everything (except "USB-OTG") to be sure to start without anything from past installation. I always wiped everything and did a clean installation during all my tests.
I tried your LOS version (from 2021-05-07 and 2021-06-16) and also Official LOS (from 2021-06-24) and both versions gave me same error/behavior: I can't install any application from Google Play Store and system tells me I have to free up space. I can see in "Storage" menu that my phone has more than 50Gb of free space.
In Android, I also can't access storage from my computer when connected in USB. In TWRP, I can see my storage and copy/paste file (I did it to test differents LOS versions).
Am I stupid and I need help or do I found something strange?
Note: Before wiping everything, I had ne trouble at all to install application, only streaming problem that we were talking.

EDIT: I rolled back until your LOS version from 2021-04-08 and everything is fine, I can install applications from Google play Store and see storage when connect in USB from a computer.
 
Last edited:

Tomoms

Senior Member
Feb 15, 2014
2,498
5,967
Still trying to figure out what is the real cause of my streaming and casting problem and I found something new:
I rebooted in TWRP and Wipe everything (except "USB-OTG") to be sure to start without anything from past installation. I always wiped everything and did a clean installation during all my tests.
I tried your LOS version (from 2021-05-07 and 2021-06-16) and also Official LOS (from 2021-06-24) and both versions gave me same error/behavior: I can't install any application from Google Play Store and system tells me I have to free up space. I can see in "Storage" menu that my phone has more than 50Gb of free space.
In Android, I also can't access storage from my computer when connected in USB. In TWRP, I can see my storage and copy/paste file (I did it to test differents LOS versions).
Am I stupid and I need help or do I found something strange?
Note: Before wiping everything, I had ne trouble at all to install application, only streaming problem that we were talking.

EDIT: I rolled back until your LOS version from 2021-04-08 and everything is fine, I can install applications from Google play Store and see storage when connect in USB from a computer.
Very strange. What Gapps package did you use?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    New build available, with July's patches and some DRM fixes. Widevine L3, however, should still be not supported, please give it a try and let me know, if you can.
    2
    New build available, with July's patches and some DRM fixes. Widevine L3, however, should still be not supported, please give it a try and let me know, if you can.
    Hi @Tomoms, nice work on the 0710 new ROM. I'm going to try and attach a couple of screen shots of the DRM apps (2) I have on my phone. One indicates that Widevine L3 is now present and the other indicates that Clearkey CDM is now present (not sure if this was present on your last ROM or not as I can't remember). Hopefully this will mean something for you. The GOOD NEWS: I have a subscription service here in the US called Youtube TV. It now can play live broadcasts on my OPO which it hasn't been able to since around Jan 2021. So, whatever you did it solved a long term problem for me and hopefully for others on the forum. Hope these screen captures get loaded....Ha :>)))))
    1
    Installed yesterday without any issues above April firmware.
    Unfortunately, this did not resolve my streaming problem with my French Canadian service (called "RDS").
    Because I am really a beginner, I do not see how to help. I will wait and hope for an improvement in the future.
    Thanks a lot for your hard work.
    Unfortunately I'm clueless. I really don't know what to do to help you.

    I don't know what changed in the latest build.. But this problem of mine is completely gone in the latest build. Not a single time network changed from 4g to 2g..
    Nice to know, I wonder how it was fixed haha :)

    Updated to 07/10. All good, encryption still works fine & stable. Thanks for your ongoing work on this.
    Device gets slow caused by age... :D:p:D
    Glad to hear it's working fine :)

    Clean flash after wipe to factory and format data. ROM work fine but sim card is not recognized anymore. I removed it before flash, put back but 'no sim card' message. It's valid and I use on another phone daily.
    I suggest that you flash the latest stock CyanogenOS build. It will update your baseband & modem firmware to a known working version. Then try to flash my ROM again.
  • 88
    In this thread I'll share with you my personal builds of LineageOS 18.1 and 17.1 (older builds of 16 and 15.1 are still downloadable). This project is inspired by idprophecy's LineageOS builds, to which I want to add my favorite features and, possibly, even more optimizations and improvements.

    MAIN FEATURES
    LineageOS 18.1 features:
    • support for MicroG (signature spoofing) - read the 2nd post!
    • improved & updated libraries: sqlite, zlib, libpng, jemalloc, libvpx, libyuv
    • critical system components built with -O3 optimizations (art, SurfaceFlinger, bionic)
    • Android RunTime (ART) updates and improvements
    • several debugging & tracing instructions are removed from the system
    • SBC Dual channel bluetooth audio codec
    • in-built F-Droid Privileged Extension
    • support for OTA updates
    • several minor tweaks and improvements
    • my custom kernel (features listed below)

    LineageOS 17.1 features:
    • all C/C++ components are build with -O3/-g0 flags (maximum optimization, minimum useless debug info)
    • support for signature spoofing (= MicroG supported) - read the 2nd post!
    • in-built F-Droid Privileged Extension
    • native support for WakeBlock by @GioBozza, for more info: WakeBlock on XDA
    • several updates & improvements to internal components: skia & libjpeg-turbo (temporarily reverted), art, bionic, libpng, sqlite, zlib
    • several debugging & tracing instructions are removed from the system
    • custom Screenshot QS tile
    • deGoogling tweaks: non-Google captive portal server & SUPL server
    • support for OTA updates
    • minor miscellaneous tweaks
    • my custom kernel (features listed below)
    Kernel features:
    • built with GCC 10
    • CPU underclocking (268 MHz) & max freq. limited to 1,9 GHz by default
    • several f2fs updates
    • power-efficient workqueues
    • cpu_input_boost by Sultanxda
    • bricked hotplug replaces mpdecision
    • CPU undervolting
    • maple I/O scheduler
    • userspace LMKD replaces the old in-kernel Low Memory Killer driver
    • DDR bandwidth boost on screen wake
    • minor adjustments and tweaks
    • several code updates and security/bug fixes
    BUGS
    Also present in official LineageOS 18.1/17.1:
    • kernel panic when changing USB mode to "File transfer" - fixed in the 20200811 build & later official nightlies
    • notification/charging LED not working - fixed in the 20200811 build & later official nightlies
    • low in-call microphone if speakerphone is enabled - fixed in the 20200811 build
    • charging hiccups when using certain 3rd-party chargers/cables - fixed in the 20200912 build
    • AUX audio output not working - fixed in all builds (unofficial & official) newer than 20200826
    • wrong time on boot until connected to a network - fixed in the 20201110 build, and in official nightlies starting from 20201224
    • the Music app is quite messed up (bug is already reported on Gitlab) - fixed by the LineageOS team as of January 2021.
    • flaky GPS - fixed (or at least improved) in the 20201213 build & official 18.1 nightlies newer than 20210415
    • manual mobile network scan not working - fixed in the 17.1 20210123 build, also fixed on official LineageOS
    • NFC not working - fixed in the 20210419 build & later official nightlies
    • 5 GHz hotspot is broken - but there's a workaround here
    • weird noises while playing flac files if AudioFX's Bass option is enabled (17.1)
    Bugs that are specific to my builds:
    • encryption of f2fs-formatted /data partition is broken - fixed in the 20201028 build
    • corrupted thumbnails and weird visual artifacts in the system's color picker - fixed in the 20201028 build
    • libjpeg crashes in certain apps (NewPipe, Files, and others) - fixed in the 20201017 build
    • Telegram's (and, possibly, other apps') in-built camera not working - apparently fixed in the 20200811 build

    Changelog for LineageOS 18.1:
    July 10th:​
    • synced with LineageOS + July's patches
    • DRM fixes (Clearkey support)

    Changelog for older LineageOS 18.1 builds:
    June 16th:​
    • GPS improvements (hopefully now it'll work fine!)
    June 10th:​
    • synced with LineageOS (incl. June's security patches)
    • GPS fixes (work in progress)
    • some kernel updates and improvements
    May 7th:​
    • synced with LineageOS (w/ May's security patches)
    • updates for ART and bionic
    April 29th:​
    • synced with LineageOS
    • updated libyuv and libvpx
    • -O3 optimizations for critical system components
    • USB notifications have lower priority
    • minor miscellaneous tweaks
    April 19th:​
    • synced with LineageOS (NFC fix included)
    • GPS updates and improvements
    • touch response optimizations
    • minor tweaks and fixes
    April 8th:​
    • synced with LineageOS (w/ April's security patches + fix for display issue)
    • some kernel updates
    • lots of debugging code disabled
    • updates for jemalloc, sqlite, bionic, libcore and libpng
    March 9th:​
    • synced with LineageOS (w/ March's security patches)
    • some kernel updates
    • encryption is now working
    February 27th:​
    • synced with LineageOS
    • minor kernel updates
    February 9th:​
    • synced with LineageOS (with February's security patches)
    • some kernel fixes & updates
    • fix for the Gallery showing the previous photo instead of the new one, immediately after taking one
    Ferbuary 3rd:​
    • bootloop fix

    February 2nd:​
    • synced with LineageOS
    • WiFi hotspot fixed
    • Dynamic processing audio library
    • in-built F-Droid Privileged Extension
    • Dual-channel SBC codec for bluetooth headphones/speakers (untested, must be set in Developer Options)
    • minor tweaks to reduce memory usage (with negligible impacts on performance and/or graphic quality)
    • my custom kernel has been implemented
    January 21st:​
    • synced with LineageOS
    • updated & improved sqlite library (huge performance boost)
    • optimized zlib library
    • improvements for ART's memory usage
    • support for OTA updates
    January 6th:​
    • synced with LineageOS (January's security patches)
    January 3rd:​
    • synced with LineageOS
    • lockscreen PIN possibly fixed? Please confirm
    December 26th:​
    • fixed signature spoofing
    • synced with LineageOS
    December 21st:​
    • added support for signature spoofing (MicroG) and UnifiedNLP
    December 14th:​
    • initial build

    Changelog for LineageOS 17.1:
    June 11th:​
    • May's and June's security patches

    Changelog for older LineageOS 17.1 builds:
    April 11th:​
    • synced with LineageOS (w/ April's security patches)
    • some useless debugging stuff has been stripped off
    March 11th:​
    • synced with LineageOS (w/ March's security patches)
    • all the kernel updates I've recently implemented in 18.1
    • SBC HD bluetooth codec is actually available now
    February 6th:​
    • February's security patches
    February 2nd:​
    • in-built F-Droid Privileged Extension
    • Dynamic processing audio library
    • Dual-channel SBC codec for bluetooth headphones/speakers (untested, must be set in Developer Options)
    • some kernel updates & fixes
    • synced with LineageOS
    January 22nd:​
    • synced with LineageOS
    • manual mobile network search is fixed
    January 12th:​
    • synced with LineageOS
    • full January security patchset (2 commits were missing in the previous build)
    • some kernel fixes & improvements
    January 8th:​
    • synced with LineageOS (including January's security patches)
    January 3rd:​
    • synced with LineageOS
    • several kernel updates (including power-efficient workqueues)
    • Screenshot QuickSettings tile
    • less Google-dependant: custom captive portal & SUPL servers
    December 13th:​
    • synced with LineageOS
    • December's security patches
    • many GPS updates (it works much better now)
    December 3rd:​
    • synced with LineageOS
    • TimeKeep support
    • malloc switched to low memory configuration
    • minor power saving tweak for the eMMC chip

    DOWNLOADS
    Unified download link for both 17.1 and 18.1: SourceForge
    Unofficial MinTheGapps for Android 11 & arm, built by me (suggested): here
    Unofficial OpenGapps for Android 11 & arm (thanks to AdrianDC) (not recommended): Mega
    Older 18.1 builds are available here: AFH
    Previous 17.1 builds are available either on AFH or on MEGA (17.1) / on MEGA (18.1).
    23
    Hello! My first LineageOS 16 build works fine and even Argon kernel is working fine :)
    However, the ROM is not ready for you to use it, especially because I have to improve the kernel's implementation (currently it's very buggy and a normal user would go crazy to make it work properly). So I will not release this build, however I think that within a few days I'll get this stuff sorted and a new build will be ready!
    23
    I'm happy and proud to announce that I am now an official LineageOS maintainer for our Oneplus One!
    19
    Hello,
    I'm happy - and also a little bit proud :victory: - to inform you that I started making some small contributions to official LineageOS for bacon: I've submitted (and I'll keep submitting) some kernel bug/security fixes that got merged into our official LineageOS kernel. This way, both users of my builds and users of the official nightlies can benefit from them!
    Also, our LineageOS maintainer has fixed the LED issue, thus it'll work in the next nightly, and of course in the next build of mines too :)
    Talking about my next build, it'll come in a couple of days!
    19
    Hello guys,
    I'd like to inform you that I plan to switch to LineageOS 16 soon. I'll start by using TugaPower, to get used to the new OS and to finish setting up my building environment (I have to pull some files from LineageOS 16 before I can start building my own releases). Then I'll start sharing my own builds. Since it'll take me a while to implement in LineageOS 16 all the features and the optimizations that I've added to my 15.1 builds, the first LineageOS 16 builds will be very close to the standard LineageOS ones, but I'll gradually get to the point I've reached with Oreo.
    I might build and upload one last 15.1 build in the next days.
    I'll keep you informed :)