[ROM][R][OFFICIAL] LineageOS 18.1 for POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max [miatoll]

Search This thread


Feb 2, 2022
As I couldn't find RN9Pro in the device list I used Xiaomi Redmi Note 8 Global and now also pass SaftyNet test. I also renamed Magisk and put every app that doesn't need root on the denylist.
But I still can't find Netflix in the PlayStore. Any ideas?

Search for Redmi, not Xiaomi. If you passed attestation, clear play store and play services cache and data and restart the phone.
Yup, there is a Xiaomi and Redmi option, the Redmi one contains the RN9P.
I don't know why it's split like that, maybe because of Xiaomi's branding.


Senior Member
Jul 17, 2019
What modules and apps are you using with root?
I have to root my phone about 5 years . Is it still worthy?


Senior Member
Jul 20, 2022
Austria 🇦🇹
Is there a way to move the five icons down so that they are not so far up, I have created a picture so that you can see what I mean
Untitled Project.jpg


Senior Member
Nov 22, 2017
Videos not loading in Instagram, Facebook, Messenger after a couple of days after reboot.

Top Liked Posts

  • 1
    Now download the zip and flash this is file in the recovery and then reboot it and voila your device works perfectly in charging 😊
    Thanks but i will stick with Official one.
  • 2
    I upgraded to LoS.19.1 yestereday on Curtana without problems and following the official upgrade procedure on Lineage OS website.
    After 1 day of use everything working like expected..I tried calls, SMS, Data, Bluetooth and most of apps I was using on 18.1.

    My upgrade steps:
    Does anyone know if there are plans to fix the camera in this ROM (LineageOS 19)? The camera does not work at 64mpx and the official lineageos camera app has lag and stays blocked.
    I found this camera works good for me:
    with the config:
    It can do 16.1 mpx max.

    This one can do 64 mpx, but it's more like a fake, cause I can't really see the difference between 16.1 mpx and 64 mpx:

    Edit: MGC_8.1.101_A9_GV1zfix_snap.apk
    is too big to attach. Here's the link:
    Propably flash latest firmware with recovery from here : https://forum.xda-developers.com/t/...pro-curtana-auto-updated-daily.4096373/page-5
    Not sure if its Global or EEA.
    I will try when upgrade released. I think its the right on for global version.
    Now download the zip and flash this is file in the recovery and then reboot it and voila your device works perfectly in charging 😊
    Thanks but i will stick with Official one.
  • 21

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    Flashing instructions

    I was struggling with passing safetynet + cts in particular but in the end this seems to have worked (if anyone is sturggling with this):
    - magisk 24 + zygisk + hide magisk app
    - denylist: google play services cms + cms.unstable
    - universal safetyfix 2.2.1
    - hide props: Google Pixel 5 A11
    When I put a call on speaker, the other party does not hear me anymore. I'm sure this worked at one point, don't know when/how it broke. Anyone else with that issue?
    The problematic line is
    and it is fixed with changing it to
    Ok, then first los recovery, then lastest miui and then this rom.
    Thank you!
    no sir these are not the right steps:
    1 flash miui
    2 flash los recovery
    3 wipe from recovery
    4 flash rom
    5 flash gapps (optional)
    6 reboot and enjoy
    7 i usually flash magisk after first reboot