[ROM][R][OFFICIAL] LineageOS 18.1 for POCO M2 Pro / Redmi Note 9S / Redmi Note 9 Pro / Redmi Note 9 Pro Max [miatoll]

Search This thread

Attachments

  • Screenshot_20220924-141441_Settings.png
    Screenshot_20220924-141441_Settings.png
    139.5 KB · Views: 27

kalehrl

Senior Member
Nov 22, 2017
779
330
I'm trying to install this firmware (consider that I'm currently on Lineage 19.1 with recovery of same version). but it won't let me do that because consider that as a downgrade:




What can I do? Downgrade to Lineage 18.1 and update the firmware there?
I have the same issue but everything works fine so far with the old firmware.
 
Last edited:

kalehrl

Senior Member
Nov 22, 2017
779
330
Follow the flashing procedure for lineage 19.


You need to flash miui 13(which is built on Android 12) first

1. Flash miui 13.
2. Fastboot flash the lineage recovery
3. Boot to lineage recovery and flash OS.
It's not necessary to flash miui 13.
However, you need to flash firmware first before updating to LineageOS 19.1 recovery.
If you flash the latest recovery, you won't be able to flash the firmware.
I solved my "problem" simply by flashing LineageOS 18.1 recovery and then flashing the firmware.
Then I flashed the latest LineageOS 19.1 recovery and everything is fine.
 

kalehrl

Senior Member
Nov 22, 2017
779
330
How to get certified in the Play store? I installed universal safetynet patcher and Magiskhide props config but there is no fingerprint for Redmi Note 9s Android 12. Just 10 and 11.
 

iskynet

Member
Oct 8, 2017
6
2
Does anyone know if there are plans to fix the camera in this ROM (LineageOS 19)? The camera does not work at 64mpx and the official lineageos camera app has lag and stays blocked.
 
This cam have only 12 mp and is without qr code scan
I like this LOS19.1 a lot but I have two problems with it:

1. call recording - all of the options and apps I have tried have not worked.
2. camera as you mentioned. currently using gcam - is there something better for joyeuse (Redmi Note 9 Pro)?

xiaomi.eu roms are much slower but these 2 things work well with it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I see people seemed to have been able to bypass sanity checks. I've tried everything but it never worked. I think this may have been due to the fact that the Magisk version I used at that time was one of the first versions to have some "hacks" that were taken off byt the developer when he started to work at google... (i'm not sure about that, I think I read it here), and never found the way to get Magisk versions from before this that I could trust... Any advice?
    The latest version works just fine, but you need external modules now.
    Install the Universal SafetyNet Fix module and the MagiskHide Props Config module.

    When installed, launch a terminal app (Terminal Emulator or Termux) and type "props" (or "su props") and follow the text prompts.
    Enable "Force BASIC attestation". Then "Edit device fingerprint" and pick a certified one closest to your device (same model, Android version is negligible). Note that Xiaomi and Redmi are two different options, if you have a Redmi.
    After rebooting it should pass SafetyNet.

    For apps "detecting root" look into the "Deny List" option in the Magisk app and add it there.
    1
    Is this based on the August patch or the September patch
    I'm running this exact version and it says August 5 in the settings menu.
    1
    maybe private compute services and android system intelligence does the learning part. so, without these two won't work! this is just guess. I'm not sure!
    Might be, thanks for this. From what I gathered before Device Health Services from Gapps supposedly store the data. It always comes up if someone asks about resetting brightness data. However, I'm unable to check, being on MicroG. And for what it's worth, I neither found an alternative nor has anyone replied regarding this.

    One thing to note about your guess, the brightness does stick temporarily, leaving a custom response level for more or less a day, regardless of restarting the device or not.

    I don't know what to make of this.
    1
    It is within Magisk settings, the gear icon in the top right of Magisk's "Home" screen.
    Add it there and it should not be detectable.
    Thanks, idk how i could have missed it. I must have been tired that day. It's working now. Let's sée if it also resilves thé fact that Android auto doesn't start.
  • 23
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11.0 (R), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Downloads
    Here

    Flashing instructions
    Here

    Sources
    LineageOS
    6
    I was struggling with passing safetynet + cts in particular but in the end this seems to have worked (if anyone is sturggling with this):
    - magisk 24 + zygisk + hide magisk app
    - denylist: google play services cms + cms.unstable
    - universal safetyfix 2.2.1
    - hide props: Google Pixel 5 A11
    5
    When I put a call on speaker, the other party does not hear me anymore. I'm sure this worked at one point, don't know when/how it broke. Anyone else with that issue?
    4
    The problematic line is
    Code:
    ro.vendor.audio.sdk.fluencetype=none
    and it is fixed with changing it to
    Code:
    ro.vendor.audio.sdk.fluencetype=fluence
    3
    Ok, then first los recovery, then lastest miui and then this rom.
    Thank you!
    no sir these are not the right steps:
    1 flash miui
    2 flash los recovery
    3 wipe from recovery
    4 flash rom
    5 flash gapps (optional)
    6 reboot and enjoy
    7 i usually flash magisk after first reboot