[ROM][RAV*/SOFIA*][10][UNOFFICIAL] LineageOS 17.1

Search This thread

Psyb3rN4ut

Member
Mar 31, 2021
32
1
I restarted my laptop, which made the twrp flash actually work for some reason.

I deleted locksettings.db so I could get in without the password it wouldn't let me enter; and now my phone is in a screen that says "phone is starting..." and it doesn't seem to be getting anywhere. I can at least access the system settings.

Update: rebooted into recovery mode multiple times, locksettings.db and the shm and wal counterparts refuse to be deleted. They keep showing up no matter how many times I delete them in twrp.
thats a nice hack!!! the deletion of the locksettings.db...NICE!!!
 

Psyb3rN4ut

Member
Mar 31, 2021
32
1
What do you mean? It works for me any others here in this thread.

I suggest use Linux, not Windows you avoid unnecessarily problems. Otherwise I firstly flashed TWRP into recovery. So I updated the first post (I have TWRP 3.5.0_10_0 and it works well).
where did you get twrp?....and how do i flash it?
 

Psyb3rN4ut

Member
Mar 31, 2021
32
1
I must be missing some step, "like boot into the system without power off, or WITH power off, or not the right rom, or i have a weird model, or the stock firmware is incorrect", or something....i just used my script to reflash to stock as i posted before as i tried to redownload the rom and flash again which DID NOT WORK, i am using linux and up to date adb and fastboot. another rom like crdroid or whatever will do fine...but i really want to get this device flashed with something reasonable....otherwise it is just a paperweight, and ill need a new one. Ive NO idea where im going wrong here....ive got a linux computer, bash/python skillz, phone repair tools, screwdrivers, suction cups, glue, spudgers, clamps....whatever....just have no idea what is different in my case...how is it working for you guys and not me?
 

tcaudill01

Senior Member
May 31, 2010
137
70
Tuscaloosa
Moto G Power
I must be missing some step, "like boot into the system without power off, or WITH power off, or not the right rom, or i have a weird model, or the stock firmware is incorrect", or something....i just used my script to reflash to stock as i posted before as i tried to redownload the rom and flash again which DID NOT WORK, i am using linux and up to date adb and fastboot. another rom like crdroid or whatever will do fine...but i really want to get this device flashed with something reasonable....otherwise it is just a paperweight, and ill need a new one. Ive NO idea where im going wrong here....ive got a linux computer, bash/python skillz, phone repair tools, screwdrivers, suction cups, glue, spudgers, clamps....whatever....just have no idea what is different in my case...how is it working for you guys and not me?
I use Windows so I have zero knowledge of a Linux install. I don't use twrp but the stock recovery/fastbootd method.
I haven't read all of your posts, but do you have access to a windows pc? It may be worth your time to find a friend that will let you install from their windows pc.
Sorry I haven't gotten any more advice. Good luck.
 

Mr oua

Member
Apr 3, 2021
14
0
I'm trying to reflash the operating system on my phone since that is the only solution I'm left with, and I can't get into fastbootd. It says "fastboot: usage: unknown reboot target fastboot"

Edit: nvm, I'll just perform a regular factory reset since I just learned it will keep my os.
 
Last edited:

Psyb3rN4ut

Member
Mar 31, 2021
32
1
I'm trying to reflash the operating system on my phone since that is the only solution I'm left with, and I can't get into fastbootd. It says "fastboot: usage: unknown reboot target fastboot"

Edit: nvm, I'll just perform a regular factory reset since I just learned it will keep my os.
See my posts about flashing to stock, it works for me on linux. If you are using windows, there are instructions on the site i linked to.
 

Psyb3rN4ut

Member
Mar 31, 2021
32
1
I use Windows so I have zero knowledge of a Linux install. I don't use twrp but the stock recovery/fastbootd method.
I haven't read all of your posts, but do you have access to a windows pc? It may be worth your time to find a friend that will let you install from their windows pc.
Sorry I haven't gotten any more advice. Good luck.
Thank you for the advice, however both adb and fastboot seem to work just fine, i use them often for moving files around, updates, and installing apps. The use of windows or linux i dont think is the issue, however some devices have required windows ( or a windows app at least ) for bootloader unlocking ( ODIN ). In my experience, linux is better suited to development in general and also android, however if there is some underlying cause that you are considering that may be easier to deal with on windows, please share.
 

tcaudill01

Senior Member
May 31, 2010
137
70
Tuscaloosa
Moto G Power
Thank you for the advice, however both adb and fastboot seem to work just fine, i use them often for moving files around, updates, and installing apps. The use of windows or linux i dont think is the issue, however some devices have required windows ( or a windows app at least ) for bootloader unlocking ( ODIN ). In my experience, linux is better suited to development in general and also android, however if there is some underlying cause that you are considering that may be easier to deal with on windows, please share.
My only reason for suggesting windows is that is what I use and I know it works for me. I rarely use the linux environment so I am not sure what does and doesn't work there or what parameters may need to be set.
I'm just trying to eliminate as many variables as possible to help figure out why this won't install for you. It probably going to end up being something simple that we have overlooked.
 

sifrax

Member
Apr 24, 2015
40
12
I must be missing some step, "like boot into the system without power off, or WITH power off, or not the right rom, or i have a weird model, or the stock firmware is incorrect", or something....i just used my script to reflash to stock as i posted before as i tried to redownload the rom and flash again which DID NOT WORK, i am using linux and up to date adb and fastboot. another rom like crdroid or whatever will do fine...but i really want to get this device flashed with something reasonable....otherwise it is just a paperweight, and ill need a new one. Ive NO idea where im going wrong here....ive got a linux computer, bash/python skillz, phone repair tools, screwdrivers, suction cups, glue, spudgers, clamps....whatever....just have no idea what is different in my case...how is it working for you guys and not me?
Hi,
I'm not here every day 2 jobs and kids ;-) so the best way to reach me might be Telegram or Matrix (by PM I can share contact).
TWRP I got from Telegram group:
here
 

h0miemaru

New member
Apr 25, 2021
3
1
Moto G Power
What's up everyone. I know lineage 18 is out now. Is it possible to flash it on the moto g power? I successfully flashed 17.1 on my phone using the sideload feature of twrp. Just wondering is 18 will work. Thanks!!
 

sifrax

Member
Apr 24, 2015
40
12
What's up everyone. I know lineage 18 is out now. Is it possible to flash it on the moto g power? I successfully flashed 17.1 on my phone using the sideload feature of twrp. Just wondering is 18 will work. Thanks!!
Hi,
eventualy I'll try to update building mechanism although I'm not sure when.
 

sifrax

Member
Apr 24, 2015
40
12
OK, so I gave LOS18.1 build try one hour. Here is my result for now, any help is welcome:
Code:
[ 99% 624/626] including out/soong/late-lineage_sofiar.mk ...
[ 99% 625/626] finishing build rules ...
vendor/lineage/build/tasks/kernel.mk:122: warning: ***************************************************************
vendor/lineage/build/tasks/kernel.mk:123: warning: * Using prebuilt kernel binary instead of source              *
vendor/lineage/build/tasks/kernel.mk:124: warning: * THIS IS DEPRECATED, AND IS NOT ADVISED.                     *
vendor/lineage/build/tasks/kernel.mk:125: warning: * Please configure your device to download the kernel         *
vendor/lineage/build/tasks/kernel.mk:126: warning: * source repository to kernel/motorola/trinket
vendor/lineage/build/tasks/kernel.mk:127: warning: * for more information                                        *
vendor/lineage/build/tasks/kernel.mk:128: warning: ***************************************************************
[100% 626/626] writing build rules ...
out/build-lineage_sofiar-package.ninja is missing, regenerating...
[ 99% 627/629] initializing packaging system ...
[ 99% 628/629] including distdir.mk ...
[100% 629/629] writing packaging rules ...
Starting ninja...
FAILED: ninja: 'out/target/product/sofiar/kernel', needed by 'out/target/product/sofiar/boot.img', missing and no known rule to make it
13:29:16 ninja failed with: exit status 1

#### failed to build some targets (03:02 (mm:ss)) ####


>> [Tue Apr 27 13:29:16 UTC 2021] Failed build for sofiar
>> [Tue Apr 27 13:29:16 UTC 2021] Finishing build for sofiar
>> [Tue Apr 27 13:29:16 UTC 2021] Cleaning source dir for device sofiar
13:29:17 ************************************************************
13:29:17 You are building on a machine with 15.5GB of RAM
13:29:17 
13:29:17 The minimum required amount of free memory is around 16GB,
13:29:17 and even with that, some configurations may not work.
13:29:17 
13:29:17 If you run into segfaults or other errors, try reducing your
13:29:17 -j value.
13:29:17 ************************************************************
13:29:18 Entire build directory removed.

#### build completed successfully (2 seconds) ####
 
Last edited:

Banana_sam

Member
Mar 24, 2021
21
0
Moto G Power
Ahoy there matey's! So I just wanna say I've still been rocking the first build of this ROM that was originally posted. I haven't had any issues with it, but now I'm considering installing the new build, because something I just now realized is that locking apps doesn't work fully on the first version. When I pin lock an app it works fine when opening the app from the app drawer or homescreen. However if I open the locked app via the list of apps from androids settings menu, it opens the app with no pin needed. Is this issue fixed in the latest build?

I've got a different older phone with lineage 17.1 installed, and the app locking works fully, needing the pin every time even when opening the app from the settings menu.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Replying to my own question:

    I had installed via F-Droid, so just as an experiment I uninstalled all MicroG items, then installed it via Magisk and it works. Also, then installed Aurora Store via F-Droid and it kept failing, went to uninstall it and realized it was a 3 year-old version. Downloaded an updated version and it ran fine. Don't trust F-Droid any longer....
  • 2
    yUIn6TF.png


    Mostly copied from @asineth

    Disclaimer: You decided to flash your phone. I'm not responsible for bricking phone or data loss.

    LineageOS is a free, community built, aftermarket firmware distribution of android, which is designed to increase performance and reliability over stock android for your device.

    Downloads:
    Ziped images for suggested install:

    lineage-17.1-20210329-UNOFFICIAL-sofiar-images.zip
    sha256sum: c57d69ade235f5c76c6eea038ad29f81e522ef713ea00b89c10010a52d6cf17f

    Build for TWRP/sideload:
    lineage-17.1-20210427-UNOFFICIAL-sofiar.zip
    sha256sum: 9c2ada552cdb3ea29ffe63f175fe514daae429c1a727cd41a574e46e97f9ffe9

    lineage-17.1-20210329-UNOFFICIAL-sofiar.zip
    sha256sum: dae9ec116de163a46efea1a1316a86dfdffda625cc568109c268f255722134e4


    Last updated: 2021.04.27

    This ROM includes:
    • FDroid
    • FDroidPrivilegedExtension

    Flashing:

    I recommend GNU/Linux for this.

    1. Flash TWRP
    2. Extract the zip and open a shell with ADB and fastboot.
    3. Reboot your device into fastbootd mode.
    Code:
    fastboot reboot fastboot
    4. Flash boot, system, product, and vbmeta.
    Code:
    fastboot set_active a
    fastboot flash boot boot.img
    fastboot flash system system.img
    fastboot flash product product.img
    fastboot flash vbmeta vbmeta.img
    4. Wipe userdata.
    5CODE]fastboot -w[/CODE]

    If you are on the Moto G8/G Fast and your display cutout is misbehaving, enable your overlay like so:

    Code:
    adb shell cmd overlay enable org.omnirom.overlay.moto.rav

    Update:​

    Code:
    fastboot flash boot boot.img
    fastboot flash system system.img
    fastboot flash product product.img
    fastboot flash vbmeta vbmeta.img
    fastboot reboot

    Working:
    • Display
    • Touchscreen
    • Wi-Fi
    • Bluetooth (including audio)
    • Headphones via 3.5mm
    • Internal Speaker
    • Moto Actions
    • Calls/SMS/LTE/VoLTE on Verizon
    • GPS
    • Notification LED
    • Hotspot

    Bugs:
    • After turning hotspot off, phone reboots
    • Inbuild screen recording app broken, phone reboots

    Source:
    LineageOS
    Device tree
    Vendor tree
    Kernel tree

    Telegram:
    https://t.me/MotoG8Official

    Credits:

    XDADevDB Information
    [ROM][RAV*/SOFIA*][10][UNOFFICIAL] LineageOS 17.1, ROM for the Moto G Power


    ROM OS Version:
    Android 10
    ROM Kernel: Linux 4.x

    Version Information
    Status: stable

    Created
    2021.03.15
    Last Updated 2021.04.27
    2
    No idea how these files differ, which one do I use or how.



    No idea what this means or why is it important and listed as second most important paragraph.



    Don't know what that means.



    Don't know what `fastbootd` mode is.



    Doesn't work, after reboot the command line says "waiting for any devices". Can't continue.

    Every year I try some Android device and venture to XDA to try some custom ROMs. It never works.
    This is a very stable and well presented ROM. It is also very easy to install.
    I'm not trying to be a ****, but with all the questions you have, you obviously have no idea what you are doing! If other people are successfully installing and using a ROM and you can't, the problem is not the ROM.
    For starters, is your bootloader unlocked? If not, you need to do that before trying anything. If you don't know how, use search.
    Most of your answers are here

    "Moto G Power Guides, News, & Discussion"​

    Do your homework first and read everything you can.
    2
    New build - kernel update from Odin.
    lineage-17.1-20210329-UNOFFICIAL-sofiar-images.zip
    sha256sum: c57d69ade235f5c76c6eea038ad29f81e522ef713ea00b89c10010a52d6cf17f

    lineage-17.1-20210329-UNOFFICIAL-sofiar.zip
    sha256sum: dae9ec116de163a46efea1a1316a86dfdffda625cc568109c268f255722134e4
    1
    I downloaded and installed this yesterday. So far, I haven't encountered any issues or found anything that doesn't work. Good job!!!!
    1
    Replying to my own question:

    I had installed via F-Droid, so just as an experiment I uninstalled all MicroG items, then installed it via Magisk and it works. Also, then installed Aurora Store via F-Droid and it kept failing, went to uninstall it and realized it was a 3 year-old version. Downloaded an updated version and it ran fine. Don't trust F-Droid any longer....
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone