• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][Redmi 7A][PINE][10.0] LineageOS 17.1 [Unofficial]

Search This thread

Ferrantes

Member
Jan 5, 2021
19
4
Mobile data are not working. I reset network settings the problem is not solved
I solved it by re-flashing the Wi-FI drivers, with this: /https://forum.xda-developers.com/t/guide-how-to-fix-wifi-after-come-back-from- custom-roms-to-stock-rom. 3779040 /. I also had the same problem. Good luck, I hope it will serve you as a resolution too, otherwise I would not know how to help you. I am not an expert
 

Ævar

Member
Jan 23, 2021
6
2
*For Sharing*

Before I flash Global 10.2.5 Android 9
I wiped everything,
Cache
Data
System
Internal
Vendor

except External Storage

Then flash to downgrade to
Global 10.2.5 Android 9 using TWRP (reboot to recovery after flashing)

Flash Lineage OS 17.1
Flash Magisk
Flash Gapps (optional)

If bootloop happens or recovery loop.
Reboot to recovery then
Wipe Data
 
Last edited:
  • Like
Reactions: or.shiny

CustomROMEnthusiast

New member
Feb 18, 2021
1
0
Hello, I have a question. After installing this custom ROM for several times following all tutorials given here (I did not install gapps tho), I have encountered several problems:

1. SELinux is permissive. I did install that app that returns it to enforced after every restart, but I would like to know about some more permanent solution.
2. Even if I do put the app to be "not optimized" regarding battery usage, some of my notifications are still being shown after 30 minutes or so.
3. When I run several apps at one time, all of them suddenly close and I have to reopen them all. It disconnects me from calls and causes many other problems.

If anyone knows how I can fix these problems, please help.

Thankful in advance.
 

or.shiny

Member
Feb 12, 2014
6
2
All seems to be working with lineage_pine-userdebug 10 QQ3A.200605.001 eng.vanill.20200705.141548 test-keys rom, the whatsapp calls is working which is great! =)
Only thing I found is that magisk isn't really working. Seems to be installed but no root access whatsoever.

This is the most stable non miui rom I found. Any chance of a fix?
 
  • Like
Reactions: paf22

or.shiny

Member
Feb 12, 2014
6
2
Did you try any GSI Rom?
I tried some 64bit gsi roms, didn't manage to make them boot,
Any GSI Rom you recommend trying for a stable day to day use?

Got magisk to work now though!
I erased all data, flashed back to the 06/05/2020 version ,whatsapp calls and magisk works in this version. =D

Now if I can figure out how to save some battery life on this rom. The 03/03/2020 version gave me 3 days of phone use with one charge,with this current version I get less than a day! =p
 
Last edited:
  • Like
Reactions: paf22

or.shiny

Member
Feb 12, 2014
6
2
The applications close and open by themselves (restart)

Hello, Good evening

I have installed "lineage os-17-1" in my "Redmi 7A" and I have used the "Gapps" and "magisk".

The equipment works with an excellent performance. nevertheless the applications close and open alone frequently (they are restarted)... It is normal.. and how could I solve it?


-----------------------------------------

Hola, Buena Noche

Llevo días "lineage os-17-1" instalado en mi equipo "Redmi 7A" y he usado las "Gapps" y el "magisk".

El equipo funciona con un excelente rendimiento. sinembargo las aplicaciones se cierran y abren solas frecuentemente (se reinician).. Es normal.. y como podria solucionarlo?
I solved this by installing quickswitch magisk module and changing the default launcher (I use lawnchair)
 

souris2

New member
Apr 15, 2021
1
0
I have a few questions:
1) Vendor.img should have such size or one can change it?
2) system.new.dat.br - how to open and edit his contain?
Sorry of my english, cause it's bad/ :-(
Безымянный.png
 
The system will not allow me to set a password for the lock screen. --settings-security- screen lock-select PIN-I will put 1234 there, I will repeat to confirm, it says- ''the screen lock has already changed, enter a new screen lock.'' I press the done button and the screen lock has not been set. I can only set my finger swipe or nothing.
Im using PitchBlack custom recovery.
For example, the newest pixel experience rom doesnt have this issue.
I have no idea why this is and would appreciate any help. I also had this problem with any version of CRdroid.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 24
    https%3A%2F%2Fimg.xda-cdn.com%2FiwNWFQT0v0Ifj0t3YmF0fCG4gh0%3D%2Fhttps%253A%252F%252Fimg.xda-cdn.com%252FNEqGNs6rv5B0hFKzbB7Z_gXjqkY%253D%252Fhttp%25253A%25252F%25252Ffiles.paulfasola.fr%25252FCyanogenMod%25252FLineageOS.png



    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    HTML:
    /*
     * Your warranty is now maybe void.
     *
     * I am not responsible for bricked devices, dead SD cards, thermonuclear
     * war, or you getting fired because the alarm app failed. Please do some
     * research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     *
     */


    About project
    LineageOS 17.1 (Android 10) for Redmi 7A (pine)

    What's working :
    •Boots
    •WIFI
    •Audio
    •Sensors
    •LED
    •Hotspost
    •Bluetooth
    •Encryption
    •Camera
    •And rest things

    [UPDATE-03/03/2020]
    CHANGELOGS:

    • Fixed in call audio
    • Added support for VoLTE

    Known Bugs :
    •SElinux Permissive
    •Expanded desktop doesn't work. LineageOS team planning to remove this feature entirely.
    •APN Settings is not accessible (However, that won't cause any issues as I've included all probable APNs in my build)

    Instructions
    •Reboot to Recovery
    •Take a full backup
    •Wipe Dalvik-Cache, Cache, System, Data
    •Flash the ROM
    •Flash GApps (optional)
    •Format Data by typing "yes"
    •Flash Magisk (optional)
    •Reboot to System

    Downloads
    ROM: lineage-17.1-20200302-UNOFFICIAL-pine.zip
    GApps: Any 32 bit Gapps OpenGapps, NikGapps or BitGapps
    Recovery: PitchBlack (Optional)
    Magisk: Latest Magisk build (If you want root)



    Reporting Bugs
    DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.
    Code:
    HTML:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    Hit Thanks if you wanna support and like this project ;D Happy Flashing


    XDA-DevDB Information
    [ROM][BETA][pine][10] LineageOS 17.1, ROM for the Xiaomi Redmi 7A

    Contributors
    priyabratMI
    YaAlex
    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: AOSP
    ROM Firmware Required: MIUI v10.2.5.0 (MUST)

    Version Information
    Status: Beta

    Created 2020-02-22
    Last Updated 2020-03-03
    4
    This custom ROM looks like it could be worth a try. The first post says that MIUI v10.2.5.0 firmware is required but what if the Redmi 7A is on MIUI 11? Is that okay?

    You base firmware must be MIUI v10.2.5.0 . Otherwise, it will not boot.
    3
    Been using the rom a few hours. Performing amazing! The only real issue is with the in call audio as written, everything else works amazing. Maybe the signal is a bit lower than with miui, but that's fine. Hope the call audio issue gets fixed asap! Thank you! ?
    Update: bluetooth audio is also not working. Completely frozen video playback when bluetooth audio device is connected.
    2
    You have to downgrade. Otherwise lineage will not boot.
    2
    Just wanted to use this i love lineage,running on my zuk z2...but volte is what is have to use


    I am working on it to fix VoLTE. Please keep patience :)