General [ROM][Restore][Unbrick] Nothing OS v1.5.3(HotFix) Global/EEA Fastboot ROM(Full ROM) & boot.img & QFIL ROM (EDL)

Search This thread


Senior Member
Dec 24, 2010
Nothing Phone 1
Is fastboot.exe up to date?
If it is an older version, you may not succeed.
I recommend the package from here:

I have a wish for your lovely fastboot images.
Is it possible if you can make your system images with writable rights?
So, currently, there are read-only and mounting as rw fails.

That prevents me to use vanced youtube and things like that.


Sep 17, 2019
flash boot, vendor, run slot a, run slot b, set active slot a, set active slot b... nothing. If i flash boot and vendor and try to boot to fastboot (failed to boot into userspace fastboot). This "unbrick" "restore" isn´t working. The one thing i dont understand is that flashing Paranoid rom is easy and it boots easilly. What is wrong with my phone.


Jan 18, 2023
Nothing Phone 1
Hi! i get cyclic loading when flashing magisk_patched.img. I am using the latest version 1.5.1 hotfix. My phone is using global firmware version. Can you help me I really need root.


  • 1674173789646.png
    116.8 KB · Views: 43


Nov 15, 2014
OnePlus 6
Nothing Phone 1
Hello, I am on 1.5.0 EEA, root, bootloader unlocked, not critical.
Can someone confirm if i can update to 1.5.1 Global and after that 1.5.1 Beta 2 Hotfix Global, and use boot.img global for root?
Thanks in advance


Dec 24, 2022
How to flash Beta 2 zip with stock 1.5.1 rom ? I have flashed this stock rom , the system won't let me flash ota zips.


New member
Jan 22, 2023
I successfully flash my phone to 1.5.1, thanks!

So when I can't do OTA and local update on 1.1.6(also from fastboot ROM 1.1.6), I use this to get to 1.5.1(beta). And now I still can't locally update 1.5.1 beta(hotfix) which results in showing error 20.
My process is:
1. fastboot flash boot boot.img
2. flash slot a & b
3. download incremental pkg from 1.5.1 , use *#*#682#*#*, finally error 20.

So I was wondering which step might be related to this result. after all it's quite scary to do these whole process for each updates.
  • Like
Reactions: anuragsablia


Feb 18, 2015
same issue i facing with global version 1.1.7 cant update to 1.1.8 or 1.5 beta error 20 tried all process like adb sideload, local and ota


Nov 27, 2020
HI Guys, I may need your help on this one. I installed android beta for phone 1 latest version, via ADB...(i'mm Mac user).

everything working fine now. (phone 1 is rooted)

I'd like to install magisk on phone. however I need to get the boot.img. how do I do that. (first time) where do I downloaded? can I downloaded directly from the phone? is there any guide?


Senior Member
Jun 13, 2013
Nothing Phone 1
HI Guys, I may need your help on this one. I installed android beta for phone 1 latest version, via ADB...(i'mm Mac user).

everything working fine now. (phone 1 is rooted)

I'd like to install magisk on phone. however I need to get the boot.img. how do I do that. (first time) where do I downloaded? can I downloaded directly from the phone? is there any guide?

Hi, first, it's better to always build Magisk Patched Boot yourself for a full compatibility and future updates.
So :

1/ Take the Stock Boot img depending your actual version (i think 1.5.1 Beta + Hotfix)
2/ Copy / Past Stock boot on your device storage where you want
3/ In Magisk do : Install > "Select and Patch a File" > Select your Stock Boot > Apply
4/ Magisk have create the Magisk Patched Boot for your device in "Downloads" folder with a name like
5/ Copy / Past this Patched Boot on your Mac
6/ Enter your device in Fastboot mode / Bootloader
7/ Boot just once (instead directly flash, more safe) with your Magisk Patched Boot, this boot have Root right,
use with this command (replace by your Magisk Patched Boot name) :
fastboot boot magisk_patched-25xxx_xxXxX.img
8/ Device will boot (take a little bit more time, it's normal)
9/ Device boot normally, just back in Magisk for apply root definitively at your original boot (because actually you have only "boot" with the Patched Boot).
Magisk > Install > Direct Install (Recommanded) > Apply & Reboot

And voila ! I advise after that install Safetynet Module kdrag0n 2.4.0 if you want use Wallet and have a certified device from Google.
  • Like
Reactions: mGforCe and ayed78


Nov 27, 2020
Hi thanks.

prioblem is I open magisk app on the phone. select the image. (currently I'm latest beta 2). however last complete file is beta 1 hot fix as you said.

i select it...but the unpacking fails... I'm stuck on step one of your instruction.

Top Liked Posts

  • There are no posts matching your filters.
  • 1

    Hi Alex1911 - can you pls clarify a few things:

    1) Firstly you went to fastbootd mode (bootloader) and not the regular fastboot mode (download) Right?

    2) Your active slot was a (checked through fastboot getvar current-slot) right?

    3) You flashed in slot b (which was inactive) and then rebooted and it worked?

    4) Or you had to make slob b active (using fastboot set_active b) ?

    Confused as you wrote that "manually changed the active slot to b again"

    Many thanks
    Hello ^^

    1. I rebooted to fastbootd, via the command "adb reboot fastboot" (when your phone is booted in Nothing OS connect via USB to your Pc with ADB (Enable USB-Debugging)

    2. i did not check the slot, it would not let me check it in normal fastboot (commands locked?). use "flash-slot-b.bat" only
    a-slot is somehow not flashable even if its there.

    3. i can't clarify if it was "the inactive slot" but it worked.

    4. sorry i can't remember. I think you can change slots via fastbootd which should happen after flash.

    I hope i could clarify it for you, if not, i'm wiling to help you out.
    I try to remind how exactly i did the procedure.

    Best Regard's

    Thanks @Alex1911 for your reply.

    Is your phone bootloader unlocked?

    In my case, my phone has bootloader unlocked, I can flash to slot a without issues hence was wondering how you did the same to slot b?

    I also read that never flash to inactive slot (b in my case) without making it active else it will lead to bootloop and hence want to be sure.

    Hence asking again...

    Also what you mean, when you said "manually changed the active slot to b again"

    Thanks again for your time..

    My phones bootloader is unlocked but critical partitions is still locked -> no need to unlock

    command to change slots: fastboot set_active a or fastboot set_active b
    EDIT: Switching slots via fastbootd did not work for my

    So if you get a bootloop try to switch slot via normal fastboot, this is what i did after flashing a slot where i got a bootloop from, so you maybe can do the opposite.

    For short: if you use a fastboot rom flashed via fastboot or fastbootd it always should boot up, if not there could be a bigger Problem or you then need another solution for example: EDL.

    Best Regard's

    Finally was able to update to 1.5.2 via fastboot method

    In my case, previously has 1.5.1 beta hotfix and all updater methods were failing with Error 20

    I booted to fastboot and checked for active slot using fastboot getvar current-slot and found that slot a is active.

    So I went and flashed the fastboot package to slot b (inactive one) and then rebooted. The rom flashed well and it successfully booted.

    Rebooted back to fastboota and when I typed fastboot getvar current-slot found that slot b was active now.

    So the learning is that - for updates, ideally we need to flash to inactive slot and then it should be activated automatically.
    There's a link. Look at it.
    My issue got resolved after updating in 1.5.3. yesterday I updated it and after 24 hrs it's working fine without any Restart.
    Please confirm if the listed rom for
    Nothing Phone(1) Fastboot ROM v1.5.3
    is for global or EEA?
    Since v1.5.1, Global and EEA are integrated and common.
  • 11
    Update! : 2023/03/23 4:46 (UTC+9:00)
    Fastboot ROM and boot.img for NothingPhone(1) are now available. v1.5.3(HotFix) is available.
    Sorry for my poor English, I'm Japanese...

    News: The DSU has been restored in this version. It seems to be usable as long as it is non-root.🎉

    The content of this site has been changed because Global and EEA have merged. (Global)" section is for Global only.
    I think v1.5.1 or later can be used for all types.

    I selfishly want the EEA version.(White..!)
    I'd like to do some verification and such.

    This fastboot ROM requires 'fastboot flashing unlock' and 'fastboot flashing unlock_critical'(Option)!

    2023/02/13 0:44 (UTC+9:00)
    Add QFIL ROM (⚠EDL Command or EDL Cable V1/V2 Required)

    I haven't tried it myself; there is Firehose, so you can use it however you like.
    A friendly reminder to all regarding XDA Rule #4:

    4. Use the English language.

    We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- or or use one of your choice.

    Thank you for your cooperation.

    release v1.5.2 fastboot ROM & boot.img
    Fastboot ROM and boot.img for NothingPhone(1) are now available. v1.1.7 is available. Sorry for my poor English, I'm Japanese...

    Thx! AVB Delenda Est

    You should detail the version, only global, no EEA.
    Thanks for your work ;)
    You were integrating.
    Well, I'll change it so that we can use it in common later.