[ROM] [ROOT] [TWRP] [GUIDE] YT9216B Chinese Android Head Unit

Search This thread

DonBot18

New member
Jan 30, 2020
3
3
Monchengladbach
Dear friend,
Could you tell us where is positioned the graphic with mustang car from home page. I want to change it with a image of my brand.
Thank you!

Very simple, go to Car Settings on the left side have you some buttons for settings like Android settings scroll these buttons down and you find it.

---------- Post added at 03:39 PM ---------- Previous post was at 03:36 PM ----------

Is it compatible with hu 8227l demo ?
info: alps full 8227l_demo 8.1 Go
Build ID MRA58K
hardware ac8227l
Total memory 1GB
Storage 16 GB
Cpu 4x arm cortex-A7 1.3GHz
Mcu 3.1
Android 6.0 yt9216b_00002_V004_20190811
Display 1024*600

Hi im not the Maker of this fine stuff but i think it will works look "Android 6.0 yt9216b_00002_V004_20190811" its an YT9216B.

---------- Post added at 03:44 PM ---------- Previous post was at 03:39 PM ----------

i formatted pre-installed firmware by this link. Now the screen is all white . how to fix this problem ? Plz help ASAP , My device is YT9216B VER0.1 XY AUTO 2019-03-20 MCU 3.1

Have you try to Install the Firmware again if you didnt have flashed the Bootloader it could be work. If not you must use the Testpoint method.
 

VAMPIRUL

New member
Apr 8, 2020
1
0
8227L firmware

Hello. I just entered the forum and saw that 8227L is being discussed. I have this configuration too. You can help me with a newer firmware, maybe with Ui4, and installation instructions. There are far too many discussions, and I don't understand anything. Thank you
Android: YT9216B_00002_V004_20190830
Android os Android 9.1 XY AUTO 3.1 (8227L)
Can bus 3.0 (8227L)
DDR: 2G Flash: 16G
CPU A7 1,3Ghz x 4
Display 1024*600
MCU: 3.1 (8227L)
 

bicer79

Senior Member
Jun 7, 2016
106
5
Kıprıs
Hello. I want to change my android car unit radio app.

Is it possible to install radio application with RDS?
 

Attachments

  • ae_1585846229058.jpg
    ae_1585846229058.jpg
    191.4 KB · Views: 465
  • IMG_20200326_200850.jpg
    IMG_20200326_200850.jpg
    85.2 KB · Views: 485
  • IMG_20200326_200945.jpg
    IMG_20200326_200945.jpg
    139.9 KB · Views: 479
  • IMG_20200326_200957.jpg
    IMG_20200326_200957.jpg
    65.6 KB · Views: 435

DKee009

Member
Apr 8, 2020
5
1
And how did you managed? Can you give us some details/steps? Thank you!

I able to flash the unit using my HP steam 7 had to get a USB A to USB A cord and install the MTech drivers gotta wait awhile for it to flash/download/transfer over maybe like 45 seconds? Lol but I thought it froze a couple times u know before it actually worked ..

---------- Post added at 02:35 AM ---------- Previous post was at 02:32 AM ----------

What do you think ?
Viper4Andriod is the bomb equalizer makes my stock Kia Soul speakers sound good lol .. got issues with the original launcher but Im just about to replace it and customize the settings ..
 

Boubou.co

Senior Member
Apr 18, 2020
71
5
Sommecaise 89110
Hi all. Special thanks for the developpers

My radio is:
Android: YT9216B-00002-V004-20190826
System: 8.1go (fake 8.1 chinese)
XYAUTO : 3.1 canbus:3.0 (8227L)
MCU: 3.1 (8227L)
Reso: 1024x600
Cpu: A7 1.3Ghz x4 DDR: 1g flash: 16g
Number model: 8227L-demo
Building num: m0.AC8227L-V1.0
Kernel: 3.18.22 [email protected]#47
Patchwork level: novembre 5 2017

My unit come with knob volume button is there the same with the only push buttons ?

** i found some answer for boologo so i delete it ?
** i found some answer for can-bus so i delete it too

Tank you in advance
Sorry for my English i'M an old man in France
 
Last edited:

blongro

Member
May 23, 2015
40
2
This one is slightly debloated, stock launcher, Android bootlogo, Android bootanimation

: https://drive.google.com/open?id=1Tsfm16klrP4uBk5K8sXBvdqvHyL4df25

---------- Post added at 10:52 AM ---------- Previous post was at 10:49 AM ----------

Anyone knows which cable adapter I need for TF-SD Card?


Hello there,
I tried to install your variant and now I have a blank screen doing nothing. More, I cant flash back gouster rom.
Any advice? Thank you!
 

Boubou.co

Senior Member
Apr 18, 2020
71
5
Sommecaise 89110
Hi all.
Can you explaine me something please ?
When i try to unrar the firmware, i got all the info deleted, i just can open to see. Impossible to put on a usb-key.
I try to put it complet to a usb-key with an XYAUTO -boot but nothing happen.
I try to make like you, usbA/A but when pĺug, nothing happen anywhere. ..
 

Maro433

Member
Apr 5, 2020
15
2
yes I returned to my original firmware because in my model yt9213 does not have the hardware components as yt9216 and therefore the equalizer from this firmware does not work

i have the same problem with the control volumen the numner 1 is the same in all the configuration 10 an 30 is not make a diference and is to hig. the only solution is go back to my last firmware?? i have the same model yt9213A
 

Boubou.co

Senior Member
Apr 18, 2020
71
5
Sommecaise 89110
Hi all.

So for now i succesfull riping the firmware with Winrar5.9 without deleted ;)

So now i'm gone try to put with unzip all the files directly to the racine of the USB-Key and put a XYAUTO-Update.bin file too.
Is this proccessing correct for you?
(my PC-win10 don't see the HU instead of the all update on it, so i'm only able to do by USB-Flash-Key)

After if the Firmware update success, i'll need to put a radio.Apk with RDS and name station Editor like the McLaught radio.
Then i'll need to put an Bootanimation i've done myself ...
 
Last edited:

Boubou.co

Senior Member
Apr 18, 2020
71
5
Sommecaise 89110
HELP

Good morning all.

I'm trying to flash my firmware but it doesn't work.
I tried more configuration for the usb reader: reader or host but the result is the same.
I reboot with the small reset button and a wooden pick.

here are the pictures of my process:
1: I format the USB-KEY
2: I choose the Firmware and EXTRACT in the USB-KEY
3: I take out the XYAUTO-UPDATE.bin file from the XYAUTOPG file and I put it in the ROOT of USB-KEY.
4: I put the USB-KEY in the reader and I do RESET with the wooden pick.

I get the rebbot but no change to programming the HU and the HU turns on normally then
sets the time ...

5: when I place my USB-KEY in my PC I check the USB-KEY and I see the files "LOST.DIR and Android"?

Can you help me please
 

Boubou.co

Senior Member
Apr 18, 2020
71
5
Sommecaise 89110
Hi all.
I read and read and look at mutch and mutch page of Flash-Tool....
I made a USB 4 pin wire to plug in rear of the HU.
Now only for some second when i press the reset button the HU and the PC need to call.
Nothing more of some second.....
When i turned the Car-Key to of it style the same...:confused:

QUESTION 1/ Should i have to remove completly the HU plug wire of the HU for remove +ACC contact and +Bat memorie???????

QUESTION 2/ i'try again and again to flash the HU by using a USB-stick, like the viedo of the chinese vendor in the Russian forum...
i do all like him, but remplace the XYAUTO_UPDATE.bin and the LK.bin module, and place all in the racine of the USB-stinck
like it said in the Russian forum...
I plug my USB-stick and press reset, i saw the USB-stick do something because it have a little flashing led one it, but
it never gone to flashing mode firmware....
Should i've to take a Micro-SD and plug it to the slot of the HU instead of using a USB-stick?????

PLEASE help me, after more of 1 week for try to flashing my unit, i think i will go crazy:silly::silly:
 

eldo90

New member
Apr 30, 2020
4
0
about Hifi funtion

in my YT9216B_00002_V004_20190503 not have funtion Hifi in sound setting..
can i to turn on hifi setting in my headunit ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    H
    Hello, I am trying to flash the rom on my device and I cannot do it, I have installed the drivers in multiple ways and when I try I always have this error, it does not recognize the USB or the micro SD card and to connect it to the Flashtool it has to be with the test point.
    Is the rom compatible with my device? Thanks
  • 20
    So... how to root your device?
    how to flash twrp?

    You can use this pre-rooted firmware, with included twrp.
    -Build type is userdebug, means u can enable multi-window mode in dev settings
    -Based on latest available firmware
    -Root
    -Busybox
    -TWRP
    -HIFI enabled
    -UI1 Launcher
    -FM Radio with RDS and save manager.
    -TPMS (working with cheap chineese usb units)
    -DVB-T & SDR (required RTL2832U)
    Its backup of system i already have modified for myself.
    It means, its branded to Ford Mustang all the way.
    U can do this to get rid of that branding:
    -choose another bootlogo.
    -flash new bootanimation.
    -install stock (not modified) UI1 launcher

    To get ADB, i recommend this app:
    WiFi ADB - Debug Over Air

    Download:
    YT9216B_00002_V004_20191012_HIFI_V3.zip

    Factory settings password: 8888

    Important note: Android 8.1 Go is just chineese marketing trick, in reality this head unit has android 6.0 (api lvl 23, not 27 as 8.1 should have).
    11
    Instructions

    Prepare:
    - download and unzip archive from my first post
    - make/buy USB A male to A male cable (for photos see attachments)
    - install drivers from SP_Driver folder

    Backup:
    Just in case make backup (readback in ATC Flash Tool)
    I didnt done it, so if u want, search for guide online

    Flashing process:
    - open flash_tool.exe from ATC_Flash_Tool folder
    - select Download-Agent MTK_AllInOne_DA.bin from ATC_Flash_Tool folder
    - select Scatter-loading File AC8227L_Android_scatter.txt from Firmware folder
    - make sure PRELOADER is not checked. (There isnt any in in my fw. Just in case if u use this guide for some another fw)
    - press Download button
    - connect your USB A to A cable one side to PC, another one to your head unit. I recommend u to use that 4 pin usb port (that one with smaller plastic end), but shouldnt matter.
    - press RST button on your head unit (use some pin, paper clip or toothpick)
    -wait until flashing process ends. There should appear green message.
    - press RST button again and let yout headunit boot.
    - perform factory reset on your head unit to prevent any bugs

    Flashing process error:
    - happends sometimes
    - disconnect your cable
    - if possible, disconnect your head unit from electricity for a while
    - press download again, connect usb cable back, and press RST button.
    - check if your cable is not faulty.
    - for homemade cable try to apply some solder on cable ends, check if ends arent shorted, use tape on them, or buy original cable
    2
    folowed V4A Rom Inclusion
    So, ViPER4Android included in ROM.
    credits to ViPER520
    ViPER’s Audio Website
    ViPER’s Audio XDA Thread
    Users, use “Compatible Mode” if you plan to install other sound mods. No other sound mods included in ROM.
    2
    I saw it on my unit with this rom! I am just uploading a clean one - stay tuned :p

    This one is slightly debloated, stock launcher, Android bootlogo, Android bootanimation

    : https://drive.google.com/open?id=1Tsfm16klrP4uBk5K8sXBvdqvHyL4df25

    ---------- Post added at 10:52 AM ---------- Previous post was at 10:49 AM ----------

    Anyone knows which cable adapter I need for TF-SD Card?

    20200125_153011_small.jpg
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone