Development [ROM][S][OFFICIAL] LineageOS 19.1 for POCO X3 Pro [vayu]

Search This thread

filipecoimbra222

Senior Member
Apr 18, 2015
94
33
Thanks, my good man.
If I use TWRP as a recovery, will there be problems with Lineage OTA updates / Magisk installation? I know everything worked for Lineage 14.1 back in the day...

Also, are there any issues with returning the phone to factory firmware with MiFlash for possible warranty issues? Or is it just Fastbood, connect and flash with MiFlash...

Damn, it's been a very long time flashing stuff and having fun with this.
Nope sir. It fully supports OTA using TWRP, so no worries about it. As for the warranty, i'm not sure about that. But i'm pretty sure a simple eraseall_and_lock with MiFlash will solve that part.
 

Tomo123

Senior Member
Jan 2, 2013
682
422
@filipecoimbra222 Thank you very much, most excellent of dudes.

Another question... are all camera issues solved? Does Lineage have problems with taking pictures or video recording, that I saw were a problem in earlier builds?

Any changelogs I can follow, or updates by the maintainer?
Found it:
https://review.lineageos.org/q/sm8150
and...
https://download.lineageos.org/vayu/changes

I swear, sometimes I feel as blind as a bat and stupid as a pig in heat! Now excuse me, I will go kick my own a$$ :)
 
Last edited:

Tomo123

Senior Member
Jan 2, 2013
682
422
Bump!

Are all camera issues solved? Does Lineage have problems with taking pictures or video recording in the latest builds, that I saw were a problem in earlier builds from 2021?
 

Tomo123

Senior Member
Jan 2, 2013
682
422
I know that. My question was if the default camera was fixed. It seems it is not...
 

bavay

Member
Jul 18, 2018
9
0
I have tried for a few days to install LineageOS 18.1 on a new Xiaomi X3 pro, to no avail (only LineageOS 18.1, no other images on top of it for the moment). The bootloader is unlocked, I can boot into TWRP or Lineageos recovery without any problems, the flashing seems to got fine but it gets stuck in a bootloop (LineageOS logo animation) when booting to system. I've tried formatting the data partition before the first boot, nothing seems to help. Does anybody has any idea what I should try? (I have followed the official instructions as well as https://forum.xda-developers.com/t/...t-x3-pro-with-lineageos.4331555/post-85609095)

PS: after a few minutes, it reboots into a special mode of recovery and tells me that the boot failed, offering to try again or perform a factory reset. Nothing has helped so far...
 

k3lcior

Senior Member
Feb 23, 2011
4,698
2,279
Kraków
Moto G5
Xiaomi Poco X3 Pro
I have tried for a few days to install LineageOS 18.1 on a new Xiaomi X3 pro, to no avail (only LineageOS 18.1, no other images on top of it for the moment). The bootloader is unlocked, I can boot into TWRP or Lineageos recovery without any problems, the flashing seems to got fine but it gets stuck in a bootloop (LineageOS logo animation) when booting to system. I've tried formatting the data partition before the first boot, nothing seems to help. Does anybody has any idea what I should try? (I have followed the official instructions as well as https://forum.xda-developers.com/t/...t-x3-pro-with-lineageos.4331555/post-85609095)

PS: after a few minutes, it reboots into a special mode of recovery and tells me that the boot failed, offering to try again or perform a factory reset. Nothing has helped so far...
Redownload ROM maybe corrupted download and make sure it's for correct device, dont flash Gapps or any other mods / custom kernels to make sure they are not the cause for the bootloop.
After flashing the ROM (before rebooting to system) Format Data (format where you have to agree by typing "yes", not wipe)
 

bavay

Member
Jul 18, 2018
9
0
Redownload ROM maybe corrupted download and make sure it's for correct device, dont flash Gapps or any other mods / custom kernels to make sure they are not the cause for the bootloop.
After flashing the ROM (before rebooting to system) Format Data (format where you have to agree by typing "yes", not wipe)
I had already tried with 3 different nightlies (pure, no gapps or other mods) and it did not work. Today I saw a new nightly (20220429) and this one worked straight from the first try! Now everything works, including gapps (the version from 2022-02-15, because version 2022-04-xx did not work and also caused a bootloop).
 

Tomo123

Senior Member
Jan 2, 2013
682
422
I see many conflicting posts on the matter, so I'll ask...

Do I flash rom, GApps, Magisk, THEN format data?
Or, do I format data, THEN flash rom, GApps, Magisk?


I mean, there are like, a thousand conflicting answers on this thread alone, it's rediculous.

Does TWRP recovery for Poco X3 Pro recognize external SD cards without issues, so I can have my files on there and use them for flashing?
 

Tomo123

Senior Member
Jan 2, 2013
682
422
Just flashed LineageOS, along with GApps and Magisk. Everything works as it should, but there is one problem I am encountering...

Headphone volume during calls is too loud. Meaning, even while the call volume is on the lowest level, it can still be heard through the headphone speaker.

Basically, this:
https://gitlab.com/LineageOS/issues/android/-/issues/4331

Any solutions for the issue?! The way like it is now, there is no privacy during the call.
 

k3lcior

Senior Member
Feb 23, 2011
4,698
2,279
Kraków
Moto G5
Xiaomi Poco X3 Pro
I remember multiple people complained about this on MIUI forums aswell, i think it's just device specific how the headphone speaker is placed or something.
Maybe try some apps which lets you lower volume further.
 

Tomo123

Senior Member
Jan 2, 2013
682
422
Had the devil up my ass for the last few hours, so I decided to flash ArrowOS 11 and see if the same problem exists in there.

Nope, ArrowOS has no issues with high call volume, even on the lowest setting. In fact, on the lowest setting you can barely hear the call.

I am staying on ArrowOS until this is solved. Sad thing is that I really, REALLY wanted to use LineageOS, but having NO PRIVACY during calls is no-go for me...

Really hoping dev @SebaUbuntu looks into the issue.
 
  • Like
Reactions: yevac

yevac

Member
Jun 14, 2020
17
13
Actually now that you mention it @Tomo123 my call volume is pretty loud and I have it on lowest setting possible. It's no different if I'm using headset or just device for calls. Never thought to mention it before as its not too bad in my case. There is one elderly lady I deal with though. She speaks louder than opera singers so the phone is held at a distance during those calls!
 

Tomo123

Senior Member
Jan 2, 2013
682
422
my call volume is pretty loud and I have it on lowest setting possible.

Exactly! For me, that is a serious issue, as anyone standing near me can hear everything being spoken on the other side. And call volume is quite loud, even on lowest setting.

How come ArrowOS 11 got that fixed, but not LineageOS? It's been reported quite a while back...
 

Top Liked Posts