Development [ROM][S][OFFICIAL] LineageOS 19.1 for POCO X3 Pro [vayu]

Search This thread

aasoror

Senior Member
Jun 24, 2008
541
72
Kitchener, ON
Xiaomi Mi A2
One more question: Sometimes in this thread is mentioned also another step, sth about unlocking the current OS

Correct, actually I did mention that in my initial reply to you.
Connect the phone to your PC, verify all locks are removed then execute the following via adb
edit: had to refresh my memory about this one, it was an issue for some phones with pre lineage 18.1 builds that used hw keystore which was no longer supported going 18.1 and later, unless people removed their locks (or format data) the phone would bootloop, that reason shouldn't be a problem past 18.1 though some release notes continue to require it, I guess it's better to be safe than sorry.

Good luck
 
Last edited:
  • Like
Reactions: keypress

Eskuy

New member
Sep 25, 2022
3
1
Hi guys, the ROM is great, but I encountered one problem:

When I pair my phone with my Bluetooth earphones (Sony WI-C200), the phone is paired with the earphones successfully, but the audio only plays on the earphones for a few seconds, then it stutters and plays on the phone's speaker instead, but the Bluetooth still shows that the earphones are being paired. Definitely not earphones problem because I can use it with the other devices flawlessly, and when I try some other ROMs (PixelExperience, Arrow,...) they can still pair with it and play music without any issue, meaning that there is something wrong with the ROM, maybe something conflicted with it?

So, is there anyone else who encountered the same problem, and do you guys know how to fix it?
 

aasoror

Senior Member
Jun 24, 2008
541
72
Kitchener, ON
Xiaomi Mi A2
Hi guys, the ROM is great, but I encountered one problem:

When I pair my phone with my Bluetooth earphones (Sony WI-C200), the phone is paired with the earphones successfully, but the audio only plays on the earphones for a few seconds, then it stutters and plays on the phone's speaker instead, but the Bluetooth still shows that the earphones are being paired. Definitely not earphones problem because I can use it with the other devices flawlessly, and when I try some other ROMs (PixelExperience, Arrow,...) they can still pair with it and play music without any issue, meaning that there is something wrong with the ROM, maybe something conflicted with it?

So, is there anyone else who encountered the same problem, and do you guys know how to fix it?
No problem connecting and using BT headphones here.
Latest global firmware.
September 6 lineage build.
 

TheMrTesla

Member
Aug 22, 2021
24
8
Xiaomi Poco X3 Pro
Great Rom, just recently upgraded to Android 12.

However I'm having issues with making Screenshots, voldown + power doesn't seem to make a Screenshot, just a 1/20 chance of it working. Always lowers volume or turns screen off instead.

Is anyone else having this problem?

As of now I'm using screenshot from the power menu to make screenshots
 
  • Like
Reactions: t-ara

aasoror

Senior Member
Jun 24, 2008
541
72
Kitchener, ON
Xiaomi Mi A2
Great Rom, just recently upgraded to Android 12.

However I'm having issues with making Screenshots, voldown + power doesn't seem to make a Screenshot, just a 1/20 chance of it working. Always lowers volume or turns screen off instead.

Is anyone else having this problem?

As of now I'm using screenshot from the power menu to make screenshots
Yup I can confirm that issue, been using the screenshot on the "switch app" ovelay instead.
 
  • Like
Reactions: TheMrTesla

t-ara

Senior Member
Jan 14, 2013
103
6
I have one concern. How to add more font in font setting? Default only have 4 fonts
 

Eskuy

New member
Sep 25, 2022
3
1
No problem connecting and using BT headphones here.
Latest global firmware.
September 6 lineage build.
The funny thing is, it only happened with WI-C200, I tried others but nothing happened. I also use WI-C200 on other phones and it works flawlessly, so maybe something is wrong and the two of them conflict.
 
  • Like
Reactions: aasoror

aasoror

Senior Member
Jun 24, 2008
541
72
Kitchener, ON
Xiaomi Mi A2
I have one concern. How to add more font in font setting? Default only have 4 fonts
Haven't tested this but should work:
Find a font you like (say myfont.ttf)
Enable root debugging (dev options) then connect the phone to your PC and adb to it.
adb root adb remount adb push /system/fonts/myfont.ttf adb pull /system/etc/fonts.xml
Edit the fonts.xml file on your PC to add an entry to the new font, then push it back
adb push /system/etc/fonts.xml

Good luck!
 
Last edited:
  • Like
Reactions: t-ara

Eskuy

New member
Sep 25, 2022
3
1
My phone keeps rebooting after I update to the newest build (it works normally in the older build), now it will restart, start at the logo, and then shut down and boot into TWRP.

Is there anything I can do to fix this issue? I didn't expect this to happen, so I didn't backup anything. This is the first time it happened.
 

Nollie8969

Senior Member
Dec 31, 2016
349
70
Older is 19 ? I'm no pro, but can be anything. Wrong Gapps, Magisk module, kernel.

I had same on spoofed Nokia. After update bootloop. No spoof (ih8sn) was happy phone.
 

t-ara

Senior Member
Jan 14, 2013
103
6
Haven't tested this but should work:
Find a font you like (say myfont.ttf)
Enable root debugging (dev options) then connect the phone to your PC and adb to it.
adb root adb remount adb push /system/fonts/myfont.ttf adb pull /system/etc/fonts.xml
Edit the fonts.xml file on your PC to add an entry to the new font, then push it back
adb push /system/etc/fonts.xml

Good luck!
Does this method have to root?
why lineagos don't have change font function
 

aasoror

Senior Member
Jun 24, 2008
541
72
Kitchener, ON
Xiaomi Mi A2
Does this method have to root?
Nope, you don't need the device to be rooted, just enable "root debugging" from the dev options (so the phone won't be rooted, but your adb session from your PC would be), if your phone is rooted there are several options on the app store to easily add custom fonts (no need to go through adb or manually edit the fonts XML).

why lineagos don't have change font function

You can actually change the font on lineageOS (pick one from the presets) but you can't add a custom font from the UI, which is, IIRC, the stock behavior for AOSP.

Good luck
 
  • Like
Reactions: t-ara

yevac

Member
Jun 14, 2020
21
16
Just wanted to address a Bluetooth issue that some others seem to also encounter.

With Soundcore P3 life (latest firmware) earbuds, the connection is choppy. Every 5 mins or so, the audio cuts out entirely. Sometimes instead of audio cut out, there is a loud distortion noise (very unpleasant). This can happen with phone locked or unlocked.

I tried Soundcores advice which is to repair the buds to the device and reset them but no luck.

I then turned off 'HD Audio: AAC' and there were no drops, distortion or any issues. Its quite strange because I have several bluetooth speakers and I have never had any issue like this. Also another pair of wireless buds that work with AAC on without issue.

My vayu is running latest 19-20221007-NIGHTLY build and also NoGravity Kernel 2.2.1.

Tried the P3 life buds on a different device (gemini with lineageOS 19.1) with AAC on and it worked without any distortion or skipping. However, the gemini device did drop the connection after maybe 3 or 4 songs in an album played. Unlocking the device made the album resume.

Would logcat be any use for helping solve?

***Edit/Update***

OK so I've been listening using standard SBC codec for the past few days. Honestly, can't hear any difference. It sounds just as good to me and connection is rock solid stable, zero issues.

4 other devices work just fine with AAC enabled so it must be some weird issue with the P3 life earbuds and the vayu.

Did also enable Gabeldorsche in developer options. This seemed to make AAC connection worse. I left it enabled and it works perfect on SBC and other devices using AAC.
 
Last edited:
  • Like
Reactions: glock24 and aasoror

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi everyone, has anyone ever had trouble taking screenshots with this ROM? It is difficult for me and rarely takes the combination
    Yes in this topic, I and someone else also faced the issue. To me this occurred since 18 --> 19.1
  • 54
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 12L (Sv2), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS GitHub repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Downloads
    Here

    Flashing instructions
    Here

    Sources:
    LineageOS

    Happy modding!
    13
    Thanks for finally releasing LineageOS, but you devs are 3 months too late... ArrowOS has inadvertently stolen my heart in your absence, lol.
    Someone asked?
    10
    New update out
    10
    vayu goes LOS19.1 release
    coming soon next friday - is out now!

    thx @SebaUbuntu for your work
    8
    Thanks for finally releasing LineageOS, but you devs are 3 months too late... ArrowOS has inadvertently stolen my heart in your absence, lol.