[ROM][S][UNOFFICIAL][BETA] ShapeShiftOS 3.0 REUNICLUS for Xperia 5 II

Search This thread

SeventhRaven

Member
Feb 6, 2022
26
8
Hey, i don't know why but for me i couldn't get the commands to work. Even just fastboot set_active a didn't work.
So i just spent 3 hours unlocking oem then trining to install then it not working, corrupting the device and fixing it. Now im back on stock rom. I just wonder, why on earth did even the basic First command not work ?
Similar issue here.

What works:
Code:
fastboot set_active a
fastboot flash boot boot.img
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img
And that's about it. No way for me to flash it succesfully.

Everything else either isn't recognized as command or my usual issue of it not finding that partition (e.g. for some reason the system thinks that the system partition does not exist...maybe a driver issue? I am at a loss). But I was already stuck trying to root the phone with the stock firmware, always ending up in a bootloop despite doing every step as listed.
Any idea why those commands do not work? Did you use anything special to make them work?
 
Similar issue here.

What works:
Code:
fastboot set_active a
fastboot flash boot boot.img
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img
And that's about it. No way for me to flash it succesfully.

Everything else either isn't recognized as command or my usual issue of it not finding that partition (e.g. for some reason the system thinks that the system partition does not exist...maybe a driver issue? I am at a loss). But I was already stuck trying to root the phone with the stock firmware, always ending up in a bootloop despite doing every step as listed.
Any idea why those commands do not work? Did you use anything special to make them work?
Well for me even the "fastboot set_active a'' didnt work, and dont dream about those two ''
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img[/CODE]''

I only installed roms on my old xz1 compact and a galaxy s4, and there it was so much easier, just did everything in TWRP. I dont know what changed in that time.
 

tainhao

Senior Member
Aug 23, 2014
55
11
Project Treble
Sony Xperia 1
Similar issue here.

What works:
Code:
fastboot set_active a
fastboot flash boot boot.img
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img
And that's about it. No way for me to flash it succesfully.

Everything else either isn't recognized as command or my usual issue of it not finding that partition (e.g. for some reason the system thinks that the system partition does not exist...maybe a driver issue? I am at a loss). But I was already stuck trying to root the phone with the stock firmware, always ending up in a bootloop despite doing every step as listed.
Any idea why those commands do not work? Did you use anything special to make them work?
maybe is the driver , I have the same question, then I reinstalled the driver, and it works,
 

malik1004

Member
Dec 8, 2020
12
9
Hey, i don't know why but for me i couldn't get the commands to work. Even just fastboot set_active a didn't work.
So i just spent 3 hours unlocking oem then trining to install then it not working, corrupting the device and fixing it. Now im back on stock rom. I just wonder, why on earth did even the basic First command not work ?
Need more info on this. What did the command return?
 

tsunam111

New member
Jan 25, 2022
2
0
Hey, i don't know why but for me i couldn't get the commands to work. Even just fastboot set_active a didn't work.
So i just spent 3 hours unlocking oem then trining to install then it not working, corrupting the device and fixing it. Now im back on stock rom. I just wonder, why on earth did even the basic First command not work ?
maybe you need fastbootd?
 

SeventhRaven

Member
Feb 6, 2022
26
8
I figured out an error mine. It seems that an error with the fastboot reboot fasboot command led to a misunderstanding (for some reason it rebooted to system the first time?). This time it actually booted into the proper fastbootd menu and the installation was a success.

Now I am merely struggling to get the ROM To pass SafetyNet with microG and Magisk. But that seems to be of no avail.
Any chance you could include a version that comes with microG (or at least no gapps) and support signature spoofing? That would be much appreciated!
 

malik1004

Member
Dec 8, 2020
12
9
I figured out an error mine. It seems that an error with the fastboot reboot fasboot command led to a misunderstanding (for some reason it rebooted to system the first time?). This time it actually booted into the proper fastbootd menu and the installation was a success.

Now I am merely struggling to get the ROM To pass SafetyNet with microG and Magisk. But that seems to be of no avail.
Any chance you could include a version that comes with microG (or at least no gapps) and support signature spoofing? That would be much appreciated!
I currently have no way to build such version. I used free Oracle Cloud to build this ROM, and my trial expired a few days back. My PC is nowhere near powerful enough to compile Android. The ROM will be maintained again when I find a machine to build it on.
 

SeventhRaven

Member
Feb 6, 2022
26
8
I currently have no way to build such version. I used free Oracle Cloud to build this ROM, and my trial expired a few days back. My PC is nowhere near powerful enough to compile Android. The ROM will be maintained again when I find a machine to build it on.
Oh, that's a shame. Sadly I haven't learned any of this yet, so I got no idea how to do that myself either (nor do I know what sort of performance is needed, but a Ryzen 3600 won't cut it either).

Wishing you best luck on getting this back on track!
 

malik1004

Member
Dec 8, 2020
12
9
Oh, that's a shame. Sadly I haven't learned any of this yet, so I got no idea how to do that myself either (nor do I know what sort of performance is needed, but a Ryzen 3600 won't cut it either).

Wishing you best luck on getting this back on track!
Ryzen 3600 will suffice. You need either 8 cores or 4 with hyperthreading, 16 GB RAM and about 300 GB of disk space (I highly recommend using SSD if you don't want it to take 20 hours).
 

Jayram2000

Senior Member
Sep 14, 2015
95
21
Tampa
OnePlus 2
Sony Xperia 5 II
Ryzen 3600 will suffice. You need either 8 cores or 4 with hyperthreading, 16 GB RAM and about 300 GB of disk space (I highly recommend using SSD if you don't want it to take 20 hours).
I have Ryzen 9 5900x with 32GB of DDR4 3600 and over a TB of storage space to spare. If you provide me with build instructions I will happily run any processes you need to keep this updated.
 

ramirowski

Senior Member
Apr 14, 2012
223
42
Sony Xperia 5 II
Samsung Galaxy S21
Similar issue here.

What works:
Code:
fastboot set_active a
fastboot flash boot boot.img
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img
And that's about it. No way for me to flash it succesfully.

Everything else either isn't recognized as command or my usual issue of it not finding that partition (e.g. for some reason the system thinks that the system partition does not exist...maybe a driver issue? I am at a loss). But I was already stuck trying to root the phone with the stock firmware, always ending up in a bootloop despite doing every step as listed.
Any idea why those commands do not work? Did you use anything special to make them work?
check device manager when you enter in fastbootd and install the driver, this works for me
 

SeventhRaven

Member
Feb 6, 2022
26
8
check device manager when you enter in fastbootd and install the driver, this works for me
As mentioned earlier, I already fixed it, but thanks!
Either a driver error or it was because I didn't do the "fastboot reboot fastboot" properly when I was in fastboot, which eventually brought up a different menu (although it seems I can install on either now?). Tech is strange sometimes.
 

Awlangun

New member
Mar 16, 2018
1
0
After plugging in the headset, the headset can't make sound, but it can control the playback. My headset is OK.
 

ShiggusDiggus

New member
Feb 3, 2022
2
0
I got this rom setup and it's fantastic, but I have an issue and I wonder if anyone else is experiencing it: notifications for almost all apps simply do not work, stuff like Discord, Youtube, Twitter, Instagram, for some reason simply do not display any notification AT ALL and I wonder if anyone has some sort of solution. Was looking up if there's a fix for it and from what I seen the beta of android 12 has the same issue, so I'm wondering if this rom was built on the beta 4 version of 12? Or is it simply something on my end that's making it **** itself?
 

SeventhRaven

Member
Feb 6, 2022
26
8
I got this rom setup and it's fantastic, but I have an issue and I wonder if anyone else is experiencing it: notifications for almost all apps simply do not work, stuff like Discord, Youtube, Twitter, Instagram, for some reason simply do not display any notification AT ALL and I wonder if anyone has some sort of solution. Was looking up if there's a fix for it and from what I seen the beta of android 12 has the same issue, so I'm wondering if this rom was built on the beta 4 version of 12? Or is it simply something on my end that's making it **** itself?
Not sure, but that does sound like the Google push service is not working properly (and those services rely on that, IIRC). While the ROM seems nice, I actually switched to GSI's instead (those also get way better support).
One thing I wonder about is why it says "ShapeShiftOS is a custom-rom based on ExtendedUI that aims to provide a different user interface and experience than any other ROM on the market" looks pretty much just like vanilla Android 12 with some Pixel mods.
 

Grogros4

Member
Oct 1, 2015
38
13
Sony Xperia 5 II
Thank you for this. this forum has been a little quiet lately.
I am also looking into building roms for the device, if i hit any snags, can i contact
Hey, i don't know why but for me i couldn't get the commands to work. Even just fastboot set_active a didn't work.
So i just spent 3 hours unlocking oem then trining to install then it not working, corrupting the device and fixing it. Now im back on stock rom. I just wonder, why on earth did even the basic First command not work ?

Hey, i don't know why but for me i couldn't get the commands to work. Even just fastboot set_active a didn't work.
So i just spent 3 hours unlocking oem then trining to install then it not working, corrupting the device and fixing it. Now im back on stock rom. I just wonder, why on earth did even the basic First command not work ?

?
 

drnose

Member
Aug 9, 2018
7
4
OnePlus 8 Pro
overall excellent rom! however find nowhere to change the wallpaper and theme. Don't know if it is my problem or a bug awaiting fixation. Anyways thank you very much!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    CJiO8Bk.png

    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    About ShapeShiftOS
    ShapeShiftOS is a custom-rom based on ExtendedUI that aims to provide a different user interface and experience than any other ROM on the market.

    Download Link
    This is my first ROM and the first ROM for this device on Android 12; don't expect it to be super stable.

    Known issues / not working:
    -no 120 Hz FIXED
    -even for 60 Hz, UI is stuttery (games work fine) FIXED
    -manual APN input required for mobile data FIXED

    -currently uses prebuilt kernel
    -you tell me.

    Installation instructions:
    Unlock bootloader first!

    Code:
    //plug in USB while holding VOL+ during boot, make sure charge LED is blue
    //reboot to fastbootd:
    fastboot reboot fastboot
    //flash the ROM:
    fastboot set_active a
    fastboot flash boot boot.img
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    fastboot --disable-verity --disable-verification flash vbmeta_system vbmeta_system.img
    fastboot erase metadata // only on first install, ignore on upgrading
    fastboot delete-logical-partition product_a
    fastboot delete-logical-partition system_a // so that fastboot won't complain about disk space
    fastboot create-logical-partition product_a 0 // size is 0, will auto-resize during flash
    fastboot flash product product.img
    fastboot create-logical-partition system_a 0
    fastboot flash system system.img
    //erase userdata:
    fastboot erase userdata // also only on first install
    //boot the ROM:
    fastboot reboot

    Source:
    Vendor source
    Device tree
    Device tree (edo common)

    Changelog:

    Code:
    20220123
    -automatic APN should work now on supported carriers
    
    20220122
    -fixed 120 hz, enable in settings
    
    20220118
    -initial release
    2
    Seems like the link is dead, which is unfortunate cause I really wanted to give this a shot, does anyone have a mirror link to it?
    Fixed now - OneDrive messed up the previous link. I wouldn't use it at all, but I got 1000 GB for free, would be a shame for it to go to waste...
    1
    Thank you for this. this forum has been a little quiet lately.
    I am also looking into building roms for the device, if i hit any snags, can i contact you?
    I'm not exactly experienced, but I'll try my best to help you in case of problems. Try me on t.me/maliklbn
    1
    can anyone post some screenshots? please
    Here's a few of mine. ROM is rock solid and even passes SafetyNet with Magisk v23.4