[ROM][SM-G920F][zerofltexx] LineageOS 15.1 UNOFFICIAL for the Galaxy S6

Search This thread

Gdarkshadow

Member
Jan 6, 2018
26
5
He mentioned his s6 being broken and that he wont be working on lineageos for a while

---------- Post added at 06:11 PM ---------- Previous post was at 06:11 PM ----------

Hasnt said anything in a while so i had to ask
 

g2continuous

New member
Jul 5, 2019
3
1
Massive thanks to Sub_Zero2 et al. for extending the useful life of what's still a pretty good phone. Using the 20190608 image, essentially everything works bar the following observations:
  • Camera can be a bit temperamental at times. OpenCamera will only record video in 4K, otherwise it hangs; it's also very slow to take stills without API 2. The AOSP camera app seems less temperamental.
  • Phone encryption — tried that, got a boot loop. Later on I'll try reinstalling the stock firmware, encrypt with that, then install Lineage without wiping /data. (By comparison encryption works OK on my Tab S2, which now runs 16 but used to have 15.1.)
 

g2continuous

New member
Jul 5, 2019
3
1
bar the following observations:
OK got encryption working but had to do it by first installing an old, official 14.1 build, then encrypting the data, then installing this image.

Camera side — the pictures seem a bit softer than with stock firmware. I suppose this is because stock has some proprietary interface/special sauce post processing algorithms. (And to be fair, the results from stock scream aggressive NR and sharpening! I knew I kept the DSLR for a good reason ;) ) On balance I'm willing to trade this for recent security updates.
 

Johan132

Member
Jun 2, 2018
23
8
@Sub_Zero2 Thanks a lot for keeping the S6 alive! I just (finally) moved from Lineage OS 14 to your ROM, and my first impression is very good! With a new battery (recently replaced) I hope to get at least an additional year out of my S6 :)
 

Timmmy001

Member
Apr 14, 2019
10
1
Bug with "Do not disturb"/LED

A bug that's been around for a long time:
If the "Do not disturb" mode is used once, it can happen that the LED notification does not work properly until a restart.

Has anyone noticed this before?
 

ADB100

Senior Member
Nov 3, 2006
1,489
115
A bug that's been around for a long time:
If the "Do not disturb" mode is used once, it can happen that the LED notification does not work properly until a restart.

Has anyone noticed this before?

I think there are a few issues with the LEDs. If I leave my phone on charge for a while after it has reached 100% the LEDs stop working and don't display at all. A reboot fixes it though.
This is in my own LOS 15.1 builds as well so its an issue with the sources. I think this issue has been around since LOS 14.1.
 

Pauleberber

Member
Feb 15, 2017
15
6
APN O2 (Germany) Settings can't be set

Hello, i have the following problem, which may be rather an universal LineageOS 15.1 than a specific S6 topic: EDIT: It's even more universal even with a Handy with a stock ROM same behaviour happens. So it's not an issue with Lineage, it simply seems that somethings wrong with the SIM-Card. So after all that trouble, i can simply go to my network carrier and shout at them and than its not my problem ANYMORE! Money Back or Internet!

I can't set the APN right. If i try it through automotic SMS configuration, this configuration never appears in the settings menu, because how i found out later, Lineageos 15.1 thinks that these are invalid settings.

So i tried to do the settings manually, but if save them, they disappear again because Lineage thinks its invalid.

So i edited /etc/apn-conf.xml, went to the settings menu and restored default settings (which a.f.a.i.k. are loaded from /etc/apn-conf.xml) but again some filter or mechanism recognizes these settings as invalid, so they don't show up in the apn configuration menu.

What works is adding the official APN settings manually from https://www.o2apn.de but with another MNC Value namely 03 instead of the right 07. These Settings are accepted by lineage, but because they are wrong NO internet Data connection can be established though mobile networks, Wifi of Course works.

These MSC Settings are from E-Plus, and 2 Eplus settings are showing up, when restoring to default values. So somehow Lineage thinks its an eplus sim card, but its an o2 SIM Card. This may be can be explained by knowing that O2 and Eplus merged into one company some time ago and may be it's still the same SIM-Card, but i don't know.

So how do i force MNC Value 07 even though some ****ing filter/mechanism is saying that it's invalid and ignoring it or even preventing it from being saved.
 
Last edited:

szazs89

Member
Jun 9, 2018
32
12
Hello all anyone knows what app could I use for IR controlling TV's?

Peel?

I used this app on my SM-920F with stock nougat rom. However, since I have recently installed LOS-14.1 (U99dev), IR dies after the first action...

I would be curious how it works with this ROM...

Zsolt
 

Sub_Zero2

Senior Member
Jun 28, 2010
474
499
Sørreisa
Hey guys & gals, you should head over to the lineageos 16.0 thread: [ROM][G920/5-F-I-S-K-L-T-W8][9.0] UNOFFICIAL LineageOS 16.0
That's where the real action is going on, thanks to @enesuzun2002 and his team.
It's time to go lineage-16.0, and I'm not the one who will build it for you.
The lineageos 16.0 rom has latest security patches and even power profiles.
There are rumours of upcoming signed builds and more coming.
 
Last edited:

hfte

Member
Jun 18, 2017
14
6

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone