• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][SM-P605][10.0] Unofficial LineageOS 17.1 for lt03lte (20.03.2021) [BETA]

Search This thread
If it's essential for you to use LTE it might help not to take any but to select one of a country with the same bands/frequencies.
As I'm in Germany and a 5.0.2 DBT was existing I didn't have that problem, but I don't know where you live.
3G has been turned off here anyhow so that won't matter.
i plan on only using wifi with the device, i dont need sim or camera.
im only flashing LOS so that i can install apps that cant be installed on kitkat.
according to this is it still safe to flash any region's 5.1.1 firmware?
i read that flashing an incorrect CSC firmware can cause the device to have incorrect storage.

how did the flashing of a differnt 5.1.1 go for you?
 
Last edited:
Great News :D (FOR NOW)
I installed LOS 17.1 [lineage-17.1-20210320-UNOFFICIAL-lt03lte] on the P605 (Hong Kong). and theres no boot loop

1. I initially had the Hong Kong Variant of the Device [SM-P605_BRI_P605ZSSCQC1] which was locked at a max android version of 4.4.2 which is a problem as 5.1.1. is the minimum requirement, so i flashed the UK variant of the P605 [P605XXU1EQD1_P605BTUEQA1_P605XXU1EQB2_HOME.tar.md5] (obtained from Frija) using Odin 3.14.4
after this the device auto rebooted, i think due to a checkbox in odin, idk, and started "optimizing apps" (a samsung or android thing). i used adb reboot download to go into the download menu while this was happening, as i didnt want anything to be "set" by this optimization

2. I flashed TWRP 3.4.0. [twrp-3.4.0-0-lt03lte_20200913] from this XDA thread using Odin 3.14.4

3. i used adb reboot recovery to go into the recovery menu and i did the following
Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe

4. i moved the LOS zip into the device and i moved the GAPPs zip into the device, then in the recovery menu i did the following
add zip > select Lineage17.1 Zip
queue zip > select Gapps [open_gapps-arm-10.0-nano-20210918] obtained from here, i used ARM, android 10.0, Nano
Install > Swipe

5. i then rebooted and experienced NO boot loop, i went through the initial device setup without connecting to the internet to avoid that google setup loop that was mentioned.

6. i proceeded to install a SuperUser app, i like Magisk so i installed that.
i went into the recovery menu and installed magisk [magisk-latest-canary.apk.zip] this is an old installation image that i used for a previous device, but im guessing its the same one on the github repo.

7. after a reboot the magisk app was incomplete and tapping on it prompted to download the latest updated APK, so i connected to the internet now for the first time and updated magisk.

i hope this experience that i shared may be of use, :)
 
Last edited:
  • Like
Reactions: SamLam140330

ukadiyala

Member
Sep 18, 2009
8
1
Great News :D (FOR NOW)
I installed LOS 17.1 [lineage-17.1-20210320-UNOFFICIAL-lt03lte] on the P605 (Hong Kong). and theres no boot loop

1. I initially had the Hong Kong Variant of the Device [SM-P605_BRI_P605ZSSCQC1] which was locked at a max android version of 4.4.2 which is a problem as 5.1.1. is the minimum requirement, so i flashed the UK variant of the P605 [P605XXU1EQD1_P605BTUEQA1_P605XXU1EQB2_HOME.tar.md5] (obtained from Frija) using Odin 3.14.4
after this the device auto rebooted, i think due to a checkbox in odin, idk, and started "optimizing apps" (a samsung or android thing). i used adb reboot download to go into the download menu while this was happening, as i didnt want anything to be "set" by this optimization

2. I flashed TWRP 3.4.0. [twrp-3.4.0-0-lt03lte_20200913] from this XDA thread using Odin 3.14.4

3. i used adb reboot recovery to go into the recovery menu and i did the following
Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe

4. i moved the LOS zip into the device and in the recovery menu i did the following
Install > select Lineage14.1 Zip > Swipe

5. i moved the GAPPs zip into the device and in the recovery menu i did the following
Install > select Gapps [open_gapps-arm-10.0-nano-20210918] obtained from here, i used ARM, android 10.0, Nano

6. i then rebooted and experienced NO boot loop, i went through the initial device setup without connecting to the internet to avoid that google setup loop that was mentioned.

7. i proceeded to install a SuperUser app, i like Magisk so i installed that.
i went into the recovery menu and installed magisk [magisk-latest-canary.apk.zip] this is an old installation image that i used for a previous device, but im guessing its the same one on the github repo.

8. after a reboot the magisk app was incomplete and tapping on it prompted to download the latest updated APK, so i connected to the internet now for the first time and updated magisk.

i hope this experience that i shared may be of use, :)
So, you ultimately have just installed LOS 14.1 ( ' select Lineage14.1 Zip > Swipe ' ) as opposed to LOS 17.1??
 

ukadiyala

Member
Sep 18, 2009
8
1
What was the stock csc region that your device had? Maybe that's a deciding factor? I was in Hong Kong and switched to UK.

Also did you use the latest LOS build?
I'm using the latest version of TWRP (3.5.1) found here.

I got the UK version (5.1.1) of the official ROM flashed from here.

I had managed to get it to boot past the loop by just leaving it to sort itself out overnight. Now, I installed GAPPS as indicated in your instructions above. It is back in the loop. I'm going to let it be and see if it manages to resolve itself.

I have the HK LTE model purchased in AU. After flashing the ROM I was unable to see the IMEI on the device. The field was blank. Looks like I might need to flash the original modem image. Wonder if there is anyone here has access to it....
 
Last edited:

ukadiyala

Member
Sep 18, 2009
8
1
I'm using the latest version of TWRP (3.5.1) found here.

I got the UK version (5.1.1) of the official ROM flashed from here.

I had managed to get it to boot past the loop by just leaving it to sort itself out overnight. Now, I installed GAPPS as indicated in your instructions above. It is back in the loop. I'm going to let it be and see if it manages to resolve itself.

I have the HK LTE model purchased in AU. After flashing the ROM I was unable to see the IMEI on the device. The field was blank. Looks like I might need to flash the original modem image. Wonder if there is anyone here has access to it....
Ok, So I figured out what I needed to do to make it work.

My issues were originating from a broken GAPPS build. So I utilised the previous version.

0. Copy the LineageOS 17.1 zip and open_gapps-arm-10.0-nano-20210918 into the SDCard.

1. Reflash the original UK Firmware utilising Odin.

2. I did not let the device re-start and put it into download mode when it was rebooting.

3. I had to reflash TWRP 3.5.1 from the link mentioned earlier.

4. In TWRP I went through Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe.

5. Also Format Data from the Wipe menu. Turns out this was helping ensure the installation was clean.

6. Go back to Install > select Lineage17.1 Zip from the SD-Card > Swipe

7. Got the device to boot and configured the wifi. Then rebooted it back into TWRP.

8. Install > select open_gapps-arm-10.0-nano-20210918 Zip from the SD-Card > Swipe.

9. Once installation is finished, I cleared teh Dalvik cache and proceeded to reboot.

Its going through the app updates now. Will come back to the group with my experience.
 
Last edited:
  • Love
Reactions: user4302

SamLam140330

New member
Sep 19, 2021
1
1
Great News :D (FOR NOW)
I installed LOS 17.1 [lineage-17.1-20210320-UNOFFICIAL-lt03lte] on the P605 (Hong Kong). and theres no boot loop

1. I initially had the Hong Kong Variant of the Device [SM-P605_BRI_P605ZSSCQC1] which was locked at a max android version of 4.4.2 which is a problem as 5.1.1. is the minimum requirement, so i flashed the UK variant of the P605 [P605XXU1EQD1_P605BTUEQA1_P605XXU1EQB2_HOME.tar.md5] (obtained from Frija) using Odin 3.14.4
after this the device auto rebooted, i think due to a checkbox in odin, idk, and started "optimizing apps" (a samsung or android thing). i used adb reboot download to go into the download menu while this was happening, as i didnt want anything to be "set" by this optimization

2. I flashed TWRP 3.4.0. [twrp-3.4.0-0-lt03lte_20200913] from this XDA thread using Odin 3.14.4

3. i used adb reboot recovery to go into the recovery menu and i did the following
Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe

4. i moved the LOS zip into the device and in the recovery menu i did the following
Install > select Lineage17.1 Zip > Swipe

5. i moved the GAPPs zip into the device and in the recovery menu i did the following
Install > select Gapps [open_gapps-arm-10.0-nano-20210918] obtained from here, i used ARM, android 10.0, Nano

6. i then rebooted and experienced NO boot loop, i went through the initial device setup without connecting to the internet to avoid that google setup loop that was mentioned.

7. i proceeded to install a SuperUser app, i like Magisk so i installed that.
i went into the recovery menu and installed magisk [magisk-latest-canary.apk.zip] this is an old installation image that i used for a previous device, but im guessing its the same one on the github repo.

8. after a reboot the magisk app was incomplete and tapping on it prompted to download the latest updated APK, so i connected to the internet now for the first time and updated magisk.

i hope this experience that i shared may be of use, :)
Thank you for your sharing, you helped me as I have the same situation
 
  • Love
Reactions: user4302
I'm using the latest version of TWRP (3.5.1) found here.

I got the UK version (5.1.1) of the official ROM flashed from here.

I had managed to get it to boot past the loop by just leaving it to sort itself out overnight. Now, I installed GAPPS as indicated in your instructions above. It is back in the loop. I'm going to let it be and see if it manages to resolve itself.

I have the HK LTE model purchased in AU. After flashing the ROM I was unable to see the IMEI on the device. The field was blank. Looks like I might need to flash the original modem image. Wonder if there is anyone here has access to it....
i installed gapps soon after installing LOS, i added them as a queue on twrp. ill mention that in my post.
 
  • Like
Reactions: ukadiyala
Ok, So I figured out what I needed to do to make it work.

My issues were originating from a broken GAPPS build. So I utilised the previous version.

0. Copy the LineageOS 17.1 zip and open_gapps-arm-10.0-nano-20210918 into the SDCard.

1. Reflash the original UK Firmware utilising Odin.

2. I did not let the device re-start and put it into download mode when it was rebooting.

3. I had to reflash TWRP 3.5.1 from the link mentioned earlier.

4. In TWRP I went through Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe.

5. Also Format Data from the Wipe menu. Turns out this was helping ensure the installation was clean.

6. Go back to Install > select Lineage17.1 Zip from the SD-Card > Swipe

7. Got the device to boot and configured the wifi. Then rebooted it back into TWRP.

8. Install > select open_gapps-arm-10.0-nano-20210918 Zip from the SD-Card > Swipe.

9. Once installation is finished, I cleared teh Dalvik cache and proceeded to reboot.

Its going through the app updates now. Will come back to the group with my experience.

thats great. ill be updating my post with the4 bugs i see as well.
 
  • Like
Reactions: ukadiyala

sminatore

Senior Member
Feb 16, 2012
67
4
roma
Im sorry, it has been passed 6/7 years from my last rom. In order to install the custom ROM I have to
1) flash (with odin) the latest bootloader
2) flash the TWRP (latest recovery)
3) flash the ROM

?

I already downloaded TWRP and the ROM but where I can find the latest bootloader ?
 

sminatore

Senior Member
Feb 16, 2012
67
4
roma
It's in the latest stock.
So either you have it already or gotta install that first.
what do u mean by "last stock" ? :)

The last lineage rom? I cant find anything "selectable" (in the unpacked tar downloaded file) within the odin menu to flash the bootloader



EDIT:
here ?
 
Last edited:

temporarium

Senior Member
what do u mean by "last stock" ? :)

The last lineage rom? I cant find anything "selectable" (in the unpacked tar downloaded file) within the odin menu to flash the bootloader



EDIT:
here ?
Thus tablet is P605. Look for Android 5 (latest available) stock images for it and flash via Odin
 
  • Like
Reactions: sminatore
As far as I can see everything worked for me with installing
  1. The last TWRP from davidmueller13
  2. His last lineageos build (lineage-17.1-20210320-UNOFFICIAL-lt03lte) from this thread
  3. Instead of OpenGapps I installed NikGapps (Basic Package for Android Q)
No boot loops so far. Google login worked. Need to test the other features too, but it looks good so far.

A big thanks to @davidmueller13 for keeping our old tablet alive. I had your old lineage 7.1.2 build running for quite some time now 😁 It was time to update
 

Top Liked Posts

  • There are no posts matching your filters.
  • 22
    This is only for SM-P605 (lt03lte)! Even loading an custom recovery will irreversible trigger Knox to 0x1!

    LineageOS (former CyanogenMod) is a free, community built, aftermarket firmware distribution of Android 10 (Ten) , which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (GApps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS GitHub repo. And if you would like to contribute to LineageOS, please visit Gerrit Code Review.


    How to flash:
    -Be sure you are on 5.1.1 Bootloader and Modem (Flash 5.1.1 firmware via Odin) !
    -Flash TWRP (version 3.2.1-0 or newer needed)
    -Make Nandroid backup (optional)
    -Wipe > Advanced Wipe > select data, system, ART/Dalvik Cache, Cache, Internal Storage > Swipe
    -Install > select Lineage 17.1 Zip > Swipe
    -Reboot


    Please read full OP before posting or flashing anything. Please don't report any bugs, if you use Xposed, any mod or modified the system.




    What is working
    Wifi
    Sound
    Bluetooth
    S-Pen
    Off Charging
    ADB/MTP
    RIL
    IR
    GPS
    Open GApps
    ...



    What is not working
    Camera
    ...


    Bugs/ other things
    SELinux Permissive
    ...



    Download



    All Downloads

    Notes:
    - TWRP 3.2.1-0 or newer necessary


    Changelog:
    --Lineage--
    20210320: Synced sources, fixed GPS, fixed boot from off-charging, many small improvements [clean install recommended]
    20200207: fixed MTP/PTP, Rotation, Hotspot and Keystore, small changes [clean install recommended]
    20200205: bringup

    Credit: LineageOS Team, Maintainer and Valera1978

    Kernel Source


    XDA:DevDB Information
    Unofficial LineageOS 17.1 for lt03lte, ROM for the Samsung Galaxy Note 10.1 (2014 Edition)

    Contributors
    davidmueller13
    ROM OS Version: Android 10
    ROM Kernel: Linux 3.4.x
    ROM Firmware Required: 5.1.1 Bootloader/Modem

    Version Information
    Status:
    Beta

    Created 2020-02-05
    Last Updated 2021-02-20
    8
    New build [clean install recommended]

    Changelog:
    - Synced sources
    - fixed GPS
    - fixed boot from off-charging
    - many small improvements

    Download
    7
    New build

    New build
    [clean install recommended]

    Changelog:
    - fixed MTP/PTP, Rotation, Hotspot and Keystore
    - small changes

    Download
    3
    any fix for camera??
    Yes of course there is a fix for the camera but the guys won't provide it for some reasons. So we have to ask again and again and maybe after the thousandth question they will give it t us 😜
    1
    It's a rather large file, so keep it around in case you need to reflash to start over 😉
    @sminatore and try to get the multiple part stock ROM using samfirm_reborn (checking "binary nature") which might be more useful if, for some reason, you've gotta flash stock again.