[ROM][SM-P900][UNOFFICIAL] Lineage 17.1 | Android 10 Q | 20201221

Search This thread

dcarvil

Senior Member
Apr 20, 2016
369
146
43
Sorry for the noob quick brain isnt working right now.

For installing Magisk using the canary build for this device, when I go to install it ask for the .img to patch. Which img file are you using to patch are we to use the boot.img found in the ROM or are using something else?

Or should I be installing Magisk via recovery?

Patch boot.img, or rename Magisk.apk to Magisk.zip and install via recovery. Either method is supposed to work, but I have not tried the latest Magisk myself.
 
  • Like
Reactions: curiousrom

nsiti

Senior Member
Mar 28, 2011
257
28
48
I have tried both the 9-10 and 12-21 builds and can't get wifi to turn on. Any suggestions?

Not sure what you mean by "turn on" but I can advise that I could not get the wifi to work on 5ghz on my Ubiquiti setup. I had to set up a 2.4 ghz SSID on my access point for the tablet to connect to wifi.
 

nsiti

Senior Member
Mar 28, 2011
257
28
48
@Valera1978 my friend, any chance you can get the camera working on this ROM. Otherwise it's great but I need it to zoom and skype :) I'll gladly donate for your time and effort. Thank you for your support of this wonderful old device.
 

NeedleGames

Senior Member
Nov 22, 2014
509
633
133
github.com
Interesting stuff! But, wouldn't overclocking the CPU and GPU, result in high temperatures (etc...) thus deteriorating themselves more quickly over time?
Is this (lagging in 60fps) a problem of the actual performance of the tablet or of the rom?

Pretty sure it's the rom. I used an older version of lineage os on this tablet and it used to work fine. Kinda regret updating it now :/
 

mrgiggle

Member
Oct 15, 2016
14
4
3
First thanks for the upgrade! has anyone tried using the Xfinity streaming app, it worked with the last one but not with 14.1! also, have the issues sing 17.1 release been fully resolved. primarily camera, xfinity streaming app (very important), youtube and other video, s-pen reboots, 5ghz Wi-Fi issues? Thanks All
 

hesev

New member
Mar 17, 2021
3
0
11
Hello

I have a question:
Each time I try to either flash the newest twrp for my device (using an older version of twrp) I get the following error:


Code:
[IMAGE FLASH STARTED]
Image to flash: '/sdcard/Download/twrp.img/' (Not a directory)

This happens no matter from which directory I try to flash it and no matter if from internal or external sdcard. I can move files using the twrp file manager without any problem, so I doubt any file permissions to cause this error.

Reason why I am trying to flash the newest twrp at all, is, that when I try to flash the ROM instead, I get the following error:

Code:
Installing zip file '/external_sd/ROM/lineage-17.1-20201221-UNOFFICIAL-v1awifi.zip'
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
Warning: No file_contexts
E3004: This package is for device v1awifi; this device is .
E: unknown command [log]
Updater process ended with ERROR: 7
Error installing zip file '/external_sd/ROM/lineage-17.1-20201221-UNOFFICIAL-v1awifi.zip'
Updating partition details...
... done

I am pretty sure v1awifi is correct.
Does somebody know what may be the general issue here?
 

bmwdroid

Senior Member
Mar 8, 2014
730
234
73
Hello

I have a question:
Each time I try to either flash the newest twrp for my device (using an older version of twrp) I get the following error:
Code:
[IMAGE FLASH STARTED]
Image to flash: '/sdcard/Download/twrp.img/' (Not a directory)
.........
I am pretty sure v1awifi is correct.
Does somebody know what may be the general issue here?
Did you rename the downloaded twrp file?
Mine is named twrp-3.5.0_9-0-v1awifi.img.
Where did you get it from?

v1awifi is correct if it's a SM-P900.
 

hesev

New member
Mar 17, 2021
3
0
11
Did you rename the downloaded twrp file?
Mine is named twrp-3.5.0_9-0-v1awifi.img.
Where did you get it from?

v1awifi is correct if it's a SM-P900.
Hi,
Yes, I tried all possible ways... renaming it to twrp.img, using original name, changing the directories from which I am trying to install and so on.

I got mine from the official twrp website's download section and it has the exact same name as yours.
I for sure own the sm-p900 wifi model.

I think this may be due to the ROM that is installed now. I hardly used the tablet since more than 2 years and I somehow remember that I had to change something in a special way for the bootloader version (?) to be able to install the ROM that is installed right now.
For security reasons I just want to install something newer now that I use the tablet every once in a while.

Unfortunaletly I no longer remember the name of the custom rom I am using (I restored it from an old twrp backup). In the device settings it says

Android Version 6.0.1 (which I think, is very insecure now)
Kernel-Version 3.4.113 [email protected] #1
Fri Feb 2 19:01:04 MSK 2018

Buildnumber
MMB29K.T800XXU1CQB1 (while the "T800" part is strange for me)
 
Last edited:

bmwdroid

Senior Member
Mar 8, 2014
730
234
73
@hesev which TWRP is installed right now?
The buildnumber is really strange as when searching for it I get
Screenshot_20210317-152741.png

Might be best to flash Samsung stock (I'd prefer multiple parts ROM) via Odin and then start all over again.
Btw. mine is still on Lineage14.1 as I don't wanna miss the camera.
 

mrgiggle

Member
Oct 15, 2016
14
4
3
Hi,
Yes, I tried all possible ways... renaming it to twrp.img, using original name, changing the directories from which I am trying to install and so on.

I got mine from the official twrp website's download section and it has the exact same name as yours.
I for sure own the sm-p900 wifi model.

I think this may be due to the ROM that is installed now. I hardly used the tablet since more than 2 years and I somehow remember that I had to change something in a special way for the bootloader version (?) to be able to install the ROM that is installed right now.
For security reasons I just want to install something newer now that I use the tablet every once in a while.

Unfortunaletly I no longer remember the name of the custom rom I am using (I restored it from an old twrp backup). In the device settings it says

Android Version 6.0.1 (which I think, is very insecure now)
Kernel-Version 3.4.113 [email protected] #1
Fri Feb 2 19:01:04 MSK 2018

Buildnumber
MMB29K.T800XXU1CQB1 (while the "T800" part is strange for me)

Hi,
Yes, I tried all possible ways... renaming it to twrp.img, using original name, changing the directories from which I am trying to install and so on.

I got mine from the official twrp website's download section and it has the exact same name as yours.
I for sure own the sm-p900 wifi model.

I think this may be due to the ROM that is installed now. I hardly used the tablet since more than 2 years and I somehow remember that I had to change something in a special way for the bootloader version (?) to be able to install the ROM that is installed right now.
For security reasons I just want to install something newer now that I use the tablet every once in a while.

Unfortunaletly I no longer remember the name of the custom rom I am using (I restored it from an old twrp backup). In the device settings it says

Android Version 6.0.1 (which I think, is very insecure now)
Kernel-Version 3.4.113 [email protected] #1
Fri Feb 2 19:01:04 MSK 2018

Buildnumber
MMB29K.T800XXU1CQB1 (while the "T800" part is strange for me)
Download the ".tar" instead of the .img!
 

hesev

New member
Mar 17, 2021
3
0
11
@hesev which TWRP is installed right now?
The buildnumber is really strange as when searching for it I get
View attachment 5252575

Might be best to flash Samsung stock (I'd prefer multiple parts ROM) via Odin and then start all over again.
Btw. mine is still on Lineage14.1 as I don't wanna miss the camera.
Yeah, maybe I will give your solution a try. I am used to Linux and MacOS while I do not use Windows frequently. Is Odin Windows only?
The camera is not necessarily needed for me. I just want to use the tablet as an additional device to display tradingview charts but I dislike that Android 6 is totally vulnerable and I do not want to have my email accounts and stuff like that on such an old Android version.
 

bmwdroid

Senior Member
Mar 8, 2014
730
234
73
Yeah, maybe I will give your solution a try. I am used to Linux and MacOS while I do not use Windows frequently. Is Odin Windows only?
The camera is not necessarily needed for me. I just want to use the tablet as an additional device to display tradingview charts but I dislike that Android 6 is totally vulnerable and I do not want to have my email accounts and stuff like that on such an old Android version.
Odin is just for Windows.
You could try using a virtual Windows machine on Linux, but I wouldn't recommend that for flashing.
I don't know any other option than Odin for flashing Stock ROM files.
 

bmwdroid

Senior Member
Mar 8, 2014
730
234
73
@hesev another thing came to my mind.
Your's has a somewhat undefined state with that T800.....
Imo there's only the way to flash stock Android for P900 as only then you can be sure it has the latest (neccessary for Lineage 14 and above) P900 Bootloader from Samsung.

No answer to my question which TWRP is on it, yet.
 
Last edited:

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone