[ROM][SM-P900][UNOFFICIAL] Lineage 17.1 | Android 10 Q | 20210419

Search This thread
I'm not responsible for any damage to your device of any sort.
By flashing this you take responsibility of anything that happens.
Process at your own risk!


If you want to check firmware - please make backup. Better to store all partitions.
I'm using pico/nano gapps.

Instructions
1. Install custom recovery
2. Download the zip(s) - firmware and Google Apps additional package (optional)
3. Full wipe all
4. Flash firmware and gapps

Work
almost all

Known Issues
- camera

Links
LineageOS Builds
6. 20210419: april security patch: https://drive.google.com/file/d/1-Lxf_C_K7saHJPgzJj_tSv8J5FfPS468/view?usp=sharing
5. 20201221: december security patch: https://drive.google.com/file/d/1tYzL31kIA9dA3Cpe66h2AUD57kT9r5eY/view?usp=sharing

4. 20200910: latest sources, update kernel, huge audio update (youtube): https://drive.google.com/file/d/1hyn-Q3mkQPjVr2zOBFT2aDEFdR7kkkRJ/view?usp=sharing
3. 20200826: update mixer (mic): https://drive.google.com/file/d/1gOIimcp1rf7BvexhTSOoGURN_oDWq0nT/view?usp=sharing
2. 20200825: update cpu build settings, update power profile, huge kernel update, better clean install: https://drive.google.com/file/d/14XhE-O8Yic8tbJZPcafh8y8w23sDkFno/view?usp=sharing
1. 20200824: init build: https://drive.google.com/file/d/1r7mSz2BIeA2B0pqvUW24dOwO0FC0OWtu/view?usp=sharing

Gapps
https://opengapps.org
Platform: ARM
Android: 10.0

Recovery
Use official version from: https://twrp.me/samsung/samsunggalaxynotepro122exynoswifi.html

Root
Install latest magisk from: https://forum.xda-developers.com/apps/magisk/dev-magisk-canary-channel-bleeding-edge-t3839337

Sources
Sources: https://github.com/Lineageos
Device: https://github.com/Valera1978/android_device_samsung_v1awifi
Kernel: https://github.com/Valera1978/android_kernel_samsung_exynos5420
Vendor: https://github.com/Valera1978/android_vendor_samsung_v1awifi

Thanks
Thanks to LineageOS team
 

Attachments

  • Screenshot_20200824-161231_Trebuchet.jpg
    Screenshot_20200824-161231_Trebuchet.jpg
    125.9 KB · Views: 1,118
  • Screenshot_20200824-161241_Trebuchet.jpg
    Screenshot_20200824-161241_Trebuchet.jpg
    115.2 KB · Views: 1,118
  • Screenshot_20200824-161253_Settings.png
    Screenshot_20200824-161253_Settings.png
    89.6 KB · Views: 1,076
  • Screenshot_20200824-161258_Settings.png
    Screenshot_20200824-161258_Settings.png
    118.6 KB · Views: 1,034
  • Screenshot_20200824-161338_Settings.png
    Screenshot_20200824-161338_Settings.png
    87.8 KB · Views: 999
  • Screenshot_20200824-161351_Settings.png
    Screenshot_20200824-161351_Settings.png
    127.1 KB · Views: 1,042
Last edited:
Many thanks @Valera1978.
Cleanly flashed with Data format used the TWRP 3.3.1-0 like for LOS16, instead of 3.4.0-0 with BiTGapps and Magisk.
No more unwanted appearences on the screen when turning. :good:
When focussing on a text the field now shows the letters. :good:
Camera, as you wrote, not working at all. so what
Will carry on testing.
LOS16 will be abandoned, or not?
 

godrick15

Senior Member
Oct 27, 2013
214
15
Is there any battery efficiency improvements with these updates?

Running LOS 14 without gapps -1% per minute. Using the tablet as a remote mouse/keyboard for pc
 
Many thanks @Valera1978.
Cleanly flashed with Data format used the TWRP 3.3.1-0 like for LOS16, instead of 3.4.0-0 with BiTGapps and Magisk.
No more unwanted appearences on the screen when turning. :good:
When focussing on a text the field now shows the letters. :good:
Camera, as you wrote, not working at all. so what
Will carry on testing.
LOS16 will be abandoned, or not?

I think yes. start to the los 16 was done for several reasons:
- I had the experience of switching to the android 10 on 3 different series (exynos7870, qcom800 and qcom820) - in all cases with working android 9 it was a huge number of problems, switch to android 10 I think the most difficult in my memory
- Old device config, every new version has some problems, so it was easier to jump from working 14.1 to 16.0
- faster build :) 16 minutes on my computer for los 16 vs 26 minutes

Right now in the los 16 we have more problems, then in los 17, and i don't see any reason to spend a weeks for fix it. Better focus on los 17 for some code clean up.
 

LionheartSilver

Senior Member
Feb 11, 2013
153
88
Mexico
Many thanks @Valera1978.
Cleanly flashed with Data format used the TWRP 3.3.1-0 like for LOS16, instead of 3.4.0-0 with BiTGapps and Magisk.
No more unwanted appearences on the screen when turning. :good:
When focussing on a text the field now shows the letters. :good:
Camera, as you wrote, not working at all. so what
Will carry on testing.
LOS16 will be abandoned, or not?

Where can i find BiTGapps?
I did a clean flash, downloaded ARM GAPPS Stock and i'm having errors "updating ok google model service".
Everytime I try to use the mic the tab restarts.

Other than that it looks amazing *w*
 

jmase

Member
Apr 3, 2016
21
4
Only on P900.
After first usage and sync plus installation of some add-ons it doesn't connect any longer.
Same add-ons and sync on T325 without a problem.

It does connect, pages take time to load but nothing is rendered.

I did get a reboot when using the pen in Squid but after restart I played with Squid for a while with no problem!

BIG thanks to Valera !!!
 
Last edited:

jmase

Member
Apr 3, 2016
21
4
Don't care about a working firefox any longer as I just saw how new version looks like on other device.
So I'm gonna switch browser anyhow.

Thats why I had to modify the APK so it will not update.
The old firefox (I think) is the best browser for this tablet.
The new firefox is much worse, even for normal phones.

So a fix for whyever firefox does not render the pages would be great :)
 
  • Like
Reactions: rhricik447

LionheartSilver

Senior Member
Feb 11, 2013
153
88
Mexico
Anyone having troubles using the Mic? Everytime I try to use anything related the tab restarts o.o

Also having "updating OK Google model service" download error.
Which GApps version did you guys install?

Thanks!
 
Anyone having troubles using the Mic? Everytime I try to use anything related the tab restarts o.o

Also having "updating OK Google model service" download error.
Which GApps version did you guys install?

Thanks!
Didn't test mic yet as camera not working don't need it then.
Usually I'm using Opengapps pico but that still includes Google TTS what BiTGapps doesn't.
The latter you find in XDA.
Both ARM of course.
Don't have the link right now.
 
  • Like
Reactions: LionheartSilver

LionheartSilver

Senior Member
Feb 11, 2013
153
88
Mexico
Didn't test mic yet as camera not working don't need it then.
Usually I'm using Opengapps pico but that still includes Google TTS what BiTGapps doesn't.
The latter you find in XDA.
Both ARM of course.
Don't have the link right now.

Tried Clean Install using GApps nano, pico, micro and stock, same problem: "updating OK Google model service".
Tried using BitGapps, same problem :(

Also, mic doesn't work, restarts the tab as soon as you want to use it.
@Valera1978 congrats! it's an amazing ROM *w* everything feels smooth and fast.
Just the Mic Problem, i need it to use Microsoft Teams for calls xD

Congrats!
 
new update:
1. updated cpu config in dev tree (correct variant cortex-15 config)
2. updated power profile (and here found interesting setting in kernel to speed-up cpu freq up to 2100MHz and seem it's work)
3. updated kernel - net part, I had issues with net on start and made small fix, but now ported all net part from my msm8974 (same 3.4 kernel, but more up to date). firefox still dnw (will continue check), but at least no kernel panic

mic - this is my next priority
 
Aug 24, 2020
6
1
Feedback to built one (20200824):

- FPS drops when watching YouTube in higher than 480p (starts lagging behind audio)
- graphic bugs still exist (pixels and boxes)

Will now re-flash and try the new built ;):good:
 

Zund

Member
Feb 19, 2010
5
0
Feedback to built one (20200825):
- reboots
- wlan sporadic not working
- freeze sometimes

Feedback to built one (20200824):
youtube bug (same above)
 

Top Liked Posts