[ROM][SM-P900][UNOFFICIAL] Lineage 17.1 | Android 10 Q | 20210419

Search This thread

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
Hi. Do you know if the camera is working yet in the latest incarnation of 17.1 build? thank you
No the camera does not work.

Native camera app opens but doesn't take a photo.

Open camera shut down my tablet. Screen went black and I couldn't get the tablet to respond for 5 minutes. Forced restart did not work. Nor did trying to force to recovery.

Eventually (5 mins) I got the tablet to restart
 
  • Like
Reactions: pointbob

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
A big thank you again to the community for this work. I have a recently purchased SM-P900 with orig vers 5.0 of android. Do any of the lineage flavors work without limitations yet? I'm mainly concerned about S pen working and mic/camera for zoom purposes.....and is there any battery penalty with the lineage vers? thanks again...
Camera not working for photos.

S-Pen not working. Tablet freezes or crashes after 10 or so minutes.

Haven't tried Zoom or Skype
 
  • Like
Reactions: pointbob

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
I do recall reading in this thread that the SM-P900 will crash with S-Pen and touch. I'm using Valera's SM-P905 code and I have not had any crashing or rebooting problems caused by combination of touch and S-Pen input, or palm rejection. So far everything works the same as Lineage 14.1 or Touchwiz 5.

I'm not a developer and I don't know how to use Github beyond the instructions in the official Lineage build guides and what Valera has posted in his repo, but I'll share the files that I've modified as attachments and indicate the path where those files are from:

For fixing touch input:

android_source_code_root\frameworks\native\services\inputflinger\InputReader.cpp
android_source_code_root\frameworks\native\services\inputflinger\InputReader.h

For fixing the DualShock4 controller input lag:
android_source_code_root\system\bt\bta\include\bta_hh_api.h
Looks like great work you have done with the S-Pen fix.

Do you have a compiled ROM for the 900 that incorporates the S-Pen mods that you can share?

Thanks in advance
 

shardsx

Senior Member
Apr 23, 2013
78
18
Looks like great work you have done with the S-Pen fix.

Do you have a compiled ROM for the 900 that incorporates the S-Pen mods that you can share?

Thanks in advance
Unfortunately not. I only have enough storage to compile a P905 ROM, and I don't have a P900 to test on either.
 

pkarza

Member
Oct 30, 2010
39
1
That's a good question. Not enitrely sure. I didnt have that problem, fortunately. But here's some things to try......
  • I assume you do clean flash for 17.1 and wipe Dalvic/Cache before booting? This can prevent some "weird" behaviour.
  • I guess you're connecting to 2.4GHz network. I recall reading that 5GHz does not work (i may be corrected on that)
  • Check that there is not an IP conflict somehere
  • Toogle aeroplane mode
  • Try a static IP to see if that changes behaviour
  • Reboot your router

Hope this helps
Well, I have done all that.... no change. Strange. Not trying to log in to 5 ghz... 2.4 shows but does not authenticate. I have rebooted the router and tried a static IP.

I can log in to a neighbor's network.... but authentication problem on mine - and I can log in with lineage 14 for android 7... but not 10.


weird
 
Last edited:

pkarza

Member
Oct 30, 2010
39
1
Well, I have done all that.... no change. Strange. Not trying to log in to 5 ghz... 2.4 shows but does not authenticate. I have rebooted the router and tried a static IP.

I can log in to a neighbor's network.... but authentication problem on mine - and I can log in with lineage 14 for android 7... but not 10.


weird
*update*
I hope this helps someone else...
I changed wifi settings in the router - I deleted TKIP on WPA/WPA2 and now it is working.
 

GalaxyHenry

New member
Dec 21, 2013
4
1
www.facebook.com
Well, I have done all that.... no change. Strange. Not trying to log in to 5 ghz... 2.4 shows but does not authenticate. I have rebooted the router and tried a static IP.

I can log in to a neighbor's network.... but authentication problem on mine - and I can log in with lineage 14 for android 7... but not 10.


weird
Try to chance data consumption parameter. It works for my connection because of LTE routing
 

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
IMHO you've to format data, no dirty update. Everything works. Pen, BT. Best ROM ever.
Hi

Could you confirm if the pen is still working?

If so could you confirm specs of your device and where you sourced the Rom.

I am trying to track down why the pen works on some devices and not others.

Thanks
 
Last edited:

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
Hi

Could you confirm if the pen is still working?

If so could you confirm specs of your device and where you sourced the Rom.

I am trying to track down why the pen works on some devices and not others.

Thanks
Any feedback from the forum regarding who has a working pen, camera etc?

I dont have either (not the end of the world) but i'd like to figure out why it works for some and not others.

Thanks
 

kcfong2

Senior Member
Apr 11, 2004
276
92
ARLO problems:

@Valera1978 : Running latest posting of your ROM. The Arlo app (most current, and even versions dating back to January 2020) are installing, but when executed, the app force closes (it doesn't appear to launch). Attached is the logcat produced. The app runs fine on a Note 3 with Lineage 17.1 and 18.1, so I know it is capable of running, but apparently not on the SM-P900 platform (yet). I tried installing with both Magisk and without Magisk, same results. It was the first app I installed after installing your ROM.
 

Attachments

  • arlo logcat.txt
    804 KB · Views: 2
Any feedback from the forum regarding who has a working pen, camera etc?

I dont have either (not the end of the world) but i'd like to figure out why it works for some and not others.

Thanks
Afaik the pen will on no custom ROM have the same features as on stock for Samsung doesn't give access to drivers.
Marking, drawing, writing should always work.
Doesn't it on yours?
There seems to be an app to buy which someone wrote does offer more features.

I didn't read anywhere about a working camera on a P900 with LOS18 only with 14.1.
Did I miss something?
 

grwalker

Senior Member
Aug 21, 2014
260
43
Holzhausen
Afaik the pen will on no custom ROM have the same features as on stock for Samsung doesn't give access to drivers.
Marking, drawing, writing should always work.
Doesn't it on yours?
There seems to be an app to buy which someone wrote does offer more features.

I didn't read anywhere about a working camera on a P900 with LOS18 only with 14.1.
Did I miss something?
Hi

Yes, thanks, i realise the pen does not have the same functionality as stock ROM.

I find that when using the pen as a "pointer", (that is using it instead of my finger), the tablet freezes between 1 and 5 minutes of use.

Also using Squid app, pen works for 1-5 mins before tablet freezes.

On some occasions, the tablet reboots. However this is random.

I've done a clean flash of the rom a few times to see if that makes any difference. It doesnt. . . .

thx
 
Last edited:

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone