• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM]|SM-T520|SM-T900|[UNOFFICIAL] LineageOS 17.1 | Android 10

Search This thread

TechDriver

Senior Member
Aug 4, 2018
71
46
Podolie
I'm not responsible for any damage to your device of any sort.
By flashing this you take responsibility of anything that happens.
Process at your own risk!


Special thanks to Exynos5420 team and LineageOS for all the sources.

Use SM-T900 build at your own risk. I can't guarantee you it will work, because I have no device to test it on.

Work
Almost everything
It has pretty much the same functionality as Lineage 14.1

Known Issues
Built in mic not working
USB problems
You tell me...

Installation:
1. Flash latest official Samsung Firmware with ODIN
2. Flash latest TWRP Recovery: SM-T520 - SM-T900
3. Backup all partitions
4. Wipe Cache and Data
5. Install ROM.ZIP
6. Install latest GApps (ARM/Android10) https://opengapps.org/
7. Reboot and Enjoy
8. Optional: Install Magisk

For SM-T520 TWRP recoveries 3.1.1.0 and older will not flash this rom ending up with error 7: incompatible device.
Make sure to flash TWRP mentioned above.


Download:
SM-T520

SM-T900


I ll probably create builds with updated security and device code patches occasionally.

Enjoy fresh new Android!

Sources:
https://github.com/LineageOS (LineageOS 17.1)
https://github.com/exynos5420/ (Kernel, Device, Vendor)
 
Last edited:

Larision

Member
Aug 11, 2010
18
6
Damn!! Just installed and working.
Really good work! Thanks!!!!
i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

Thanks for rom!
 

pjotrski1000

Member
Jan 28, 2014
46
14
OnePlus X
OnePlus 6
Damn!! Just installed and working.
Really good work! Thanks!!!!
i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

Thanks for rom!
Did you install on the t520 or the t900? Did you really go back to the Samsung official build first? (I'm on t900 lineage 14.1)
 

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@TechDriver Clean flashed 17.1 over 14.1 without flashing stock on T900 using twrp-3.5.1_9-0 and it flashed great. I plugged in a headset but my Hey Google was already recorded and didn't give me any trouble. I don't know what would have happened if I hadn't plugged in the headset. Play Store does not recognize my already purchased apps. This usually means something is not right and I wonder if not flashing stock first is related to this? Can be very smooth but can be a little glitchy as well. Still experimenting and trying things. Bluetooth Keyboard and Mouse work great. Thank you for this.
 

TechDriver

Senior Member
Aug 4, 2018
71
46
Podolie
@TechDriver Clean flashed 17.1 over 14.1 without flashing stock on T900 using twrp-3.5.1_9-0 and it flashed great. I plugged in a headset but my Hey Google was already recorded and didn't give me any trouble. I don't know what would have happened if I hadn't plugged in the headset. Play Store does not recognize my already purchased apps. This usually means something is not right and I wonder if not flashing stock first is related to this? Can be very smooth but can be a little glitchy as well. Still experimenting and trying things. Bluetooth Keyboard and Mouse work great. Thank you for this.
It has probably something to do with missing play protect certification. I will try to sign device for certification but need someone with T900 who will cooperate with me. For now easiest way to avoid problem is going to browser version of play store and installing paid app to specific device from there. It should work fine. Also thanks for testing and reporting that T900 build works.
 
Last edited:
  • Like
Reactions: pjotrski1000

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@TechDriver SELinux is not enforcing. That may be why Google Play does not recognized my purchased apps. Installing purchased apps trick from Google Play on the web worked as expected. Booting tablet, it does not accept passcode on the first try, but works on second try. This is repeatable. I will be happy to be your T900 tester if you make some test builds.
 

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@TechDriver The pass code works the first time if you are not impatient and click the accept arrow before the last number changes to a dot. There is a delay and the passcode entry is laggy and you have to be patient for a few seconds. twrp-3.5.1_9-0 is able to back up and restore 17.1 with no problem.
 

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@TechDriver The first login with PIN after booting will fail. The second and future screen saver logins will work with the caveat that you are patient until the last number turns into a dot.

Pixel launcher does not work correctly with mouse clicks and has a focus graphics glitch. It works right as long as you don't click the mouse. If you click with the mouse to open a group of icons in a folder it leaves a residual grey box behind. You can see this same grey box where the PIN numbers appear on the screen saver as well. I changed to Nova Launcher and the problem improved with the grey box occurring if I open the icon folder and actually open an app but then disappearing on moving into a different folder. This is all with the exception of the PIN screen saver which causes the same grey box on both launchers. Something is not quite right with the graphics using mouse.

I mostly use this tablet with keyboard and mouse and Nova is more acceptable now. I prefer Nova Launcher anyway as it is much better at using the whole screen.

The camera is extremely basic. Open Camera seems to be an improvement. Any Google Camera port available that might work?
 

TechDriver

Senior Member
Aug 4, 2018
71
46
Podolie
Just to make things clear, I am not developer of code and not skilled enough to make changes in it. For this job, there is team exynos5420 and other cool contributors to make device sources. I use their device sources from exynos5420 and LineageOS github to build together final product... Rom.zip you install on device. I can't fix bugs, i only can wait until some contributor fixes it and I will build rom with fixes and updated security patches included.
 
First of all I want to thank you for the this ROM.
I tried this ROM with the latest TWRP version for two days and I want to inform that it is working good with some small non-conformities:
I had some random reboots and the system crashed and freezing
After rebooting there is a long time after entering the unlock pattern, sometimes it is necessary to enter the pattern several times.
I have installed ROM, gapps nano rebooted and after that install Magisk 22.1
my model is SM-T900
 
  • Like
Reactions: pjotrski1000

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@TechDriver ,Great work on this build! Never This is fully usable with Nova beta 7.0.27.
Can you provide a link for this latest Nova beta? APK mirror seems booked.

Nova 7.0.27 Works smoother and scrolling and moving icons is better. PIN screen on first login is same problem and will not work on the first try. Mouse clicks and mouse related screen painting remains an issue. If you don't use a mouse you may not notice any problems other than first login. Come to think about it, 7.1 had issues with the mouse most noticeable when I used Collabora and I had attributed it to the app.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!


    Special thanks to Exynos5420 team and LineageOS for all the sources.

    Use SM-T900 build at your own risk. I can't guarantee you it will work, because I have no device to test it on.

    Work
    Almost everything
    It has pretty much the same functionality as Lineage 14.1

    Known Issues
    Built in mic not working
    USB problems
    You tell me...

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery: SM-T520 - SM-T900
    3. Backup all partitions
    4. Wipe Cache and Data
    5. Install ROM.ZIP
    6. Install latest GApps (ARM/Android10) https://opengapps.org/
    7. Reboot and Enjoy
    8. Optional: Install Magisk

    For SM-T520 TWRP recoveries 3.1.1.0 and older will not flash this rom ending up with error 7: incompatible device.
    Make sure to flash TWRP mentioned above.


    Download:
    SM-T520

    SM-T900


    I ll probably create builds with updated security and device code patches occasionally.

    Enjoy fresh new Android!

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)
    4
    I am currently working on building lineageos-15.1 and 16.0. I see theese versions as more stable because of more developed code. I had successfully built los 16.0 multiple times but always run into bootloop. Los 15.1 is even more tricky. I run into multiple problems building it but if I will succesfully complete it and it will be stable enough I will give you link to download.
    4
    Just to make things clear, I am not developer of code and not skilled enough to make changes in it. For this job, there is team exynos5420 and other cool contributors to make device sources. I use their device sources from exynos5420 and LineageOS github to build together final product... Rom.zip you install on device. I can't fix bugs, i only can wait until some contributor fixes it and I will build rom with fixes and updated security patches included.
    3
    Damn!! Just installed and working.
    Really good work! Thanks!!!!
    i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

    Thanks for rom!
    3
    @TechDriver Clean flashed 17.1 over 14.1 without flashing stock on T900 using twrp-3.5.1_9-0 and it flashed great. I plugged in a headset but my Hey Google was already recorded and didn't give me any trouble. I don't know what would have happened if I hadn't plugged in the headset. Play Store does not recognize my already purchased apps. This usually means something is not right and I wonder if not flashing stock first is related to this? Can be very smooth but can be a little glitchy as well. Still experimenting and trying things. Bluetooth Keyboard and Mouse work great. Thank you for this.