• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM]|SM-T520|SM-T900|[UNOFFICIAL] LineageOS 17.1 | Android 10

Search This thread

xIntenso

Member
Dec 19, 2010
48
9
Hi,

Been using this ROM some 5 days, I use it mainly for reading news/tech websites and playing games like Freecell etc. So a quick report as I see bugs are now being collected

The ROM is relatively fast but I get the occasional lag/audio stutter but not too bad.

Main issues:
1) Regular crashes to Home Screen when using Chrome or Samsung Internet ( specially where the website have large content and adverts e.g. wccftech.com),
I have also had 2 crashes to reboot again when in Chrome.
2) My wallpaper (2560x1600 pixels ) always takes about a second to load, so when I switch to home screen the background is black then a second later wallpaper appears.

Plusses:
1) One game that used to crash almost everytime a video type advert was played in LOS14 now crashes slightly less often.
2) Battery life seems slightly improved (at least for me).

Thanks
Most of my problems also occur when visiting large websites, using Firefox in my case.
The flash from stock did change that from crash and reboot to temporary freezes, but I don't use my tablet all that much, so it might have been luck. I'll report back if my Tab ever reboots on me again.
 

xfiver

Member
Dec 20, 2007
37
3
@kb8no

Thanks but sorry I cannot comment on your usage, my requirements are really really basic.
I just want to surf using Chrome, I can live with crashing games.

If Chrome (or Samsung Internet) did not crash so often I would be happy with this ROM.

If xIntenso is having almost the same problem but with FireFox, it may be a graphics related problem. Usually the crashes are when the site is still loading and I am doing finger swipes - it never crashes while I am just reading.

My wallpaper is a jpg of something like the Hubble deep space photo, so it is not the stock.

After day 3 I did reinstall the ROM just in case I made a mistake ( wipes etc) but the tablet performed just as before.

One question I am not clear is, ( re your suggestion)....

Are people who started from a stock ROM having a better experience?

(Odin needs a stock ROM and I lost my stock backup some years ago)
 

xfiver

Member
Dec 20, 2007
37
3
Just eating some humble pie.....

My wallpaper lags are probably self-inflicted. I switched to a stock wallpaper and lag disappeared ( except on powering up from sleep).

I could not find the location of stock wallpapers, but my own wall paper was 3.59 Megabytes. I have the impression that the stock wallpapers are 10's of kilobytes.

Maybe the lag was the load time??
 

kb8no

Senior Member
Jan 29, 2012
1,209
300
Duluth MN
@xfiver I use the stock wallpaper that is the default on boot and do not touch it. I also disabled the lock screen to "none" as suggested which was helpful. I also changed rotate screen from the default none to the usual 3 check boxes and this seems to help the occasional portrait screen app that can't adapt to landscape. I just use my finger and disabled the mouse. With this it works better. Much rarer crashes and cold reboots from graphics. Then there still is the problem that still exists with erratic scrolling in browser type apps (Google News, Chrome, XDA) where the longer your scroll the worse it gets. Then the app force closes. I have done everything I can think of and this ROM is not up to usable needs for a daily driver. It was fun to see that it actually worked. I guess they tried really hard to get us here and doubt there will be further development.

I have abandoned this and gone back to 12.1 which works great. It does have a few mouse glitches with interpreting clicks but nothing bad happens and you can move over to the finger occasionally when you don't get what you expect. Graphics is solid and you can use whatever wallpaper you want and scrolling is smooth. 7.1 also gives you "expanded desktop" which is great when I use Citrix and gets rid of the bars which were abandoned by LOS in later ROM's. Thanks for trying with me.
 

Kooneybert

Member
Nov 18, 2015
43
6
I tested this ROM for about 3 days now. Before installation, i wiped complete internal storage and i didn't install google play stuff and did not root the device. So my experience is with a perfectly clean installation. This is what happens:

Pro:
+ pretty fast
+ camera working fine (this was a problem on my previous ROM)

Con:
- random crashes (to homescreen) in several apps
- video playback is stuttering in any app and any resolution

=> The Cons are too big for me to use this in everyday. If they were fixed, this would be a great ROM


Edit:
I just tried to switch back to Lineage 14.1 (https://forum.xda-developers.com/t/rom-7-1-x-sm-t520-unofficial-lineage-14-1-n2awifi.3538770/) but came across unexpected issues.
1) On first boot, Lineage 14.1 crashed (several apps were reported to crash, after selecting the language, android crashed aswel) and wasn't able to boot up again.
2) I reinstalled with an older TWRP version with the same result.
3) Flashed stock rom with odin (without a problem), flashed TWRP with odin, tried to install Lineage 14.1 but now, TWRP crashes as soon I tried to flash the rom zip. Repairing the file system didn't help.
4) Now I tried this Lineage 17.1 rom again and it works.

The strange thing: Lineage 14.1 worked before and I didn't see anyone commenting any problems like me. Is there any chance, Lineage 17.1 changed something that prevents me from rolling back to 14.1?
 
Last edited:
  • Like
Reactions: Ludespeed

xfiver

Member
Dec 20, 2007
37
3
@kb8no
Its a shame that you need to go back ( to I assume LOS14) , this ROM was not bad for a first issue. I do hope some developer issues further updates.

I am minimising the browser crashes by letting webpages load as much as possible before (finger) scrolling/swipes.
 
  • Like
Reactions: stanl56

c8m3r4n

Member
Sep 10, 2020
11
2
Installed fine on my sm-t520 .First I backup all partitions, then I wipe everything installed lineageOS 17.1 I didn't install opengapps felt it might be too heavy so I chose to installed instead Aurora apk from which I got my applications. Set up went well no problems playing videos through VLC player ,browser opening is smooth no problems or crashes ,battery life is better than the latest lineage OS 14.1 -Vanilla -20210413 .Good experience so far still testing.
 
  • Like
Reactions: stanl56

TechDriver

Senior Member
Aug 4, 2018
71
46
Podolie
I tested this ROM for about 3 days now. Before installation, i wiped complete internal storage and i didn't install google play stuff and did not root the device. So my experience is with a perfectly clean installation. This is what happens:

Pro:
+ pretty fast
+ camera working fine (this was a problem on my previous ROM)

Con:
- random crashes (to homescreen) in several apps
- video playback is stuttering in any app and any resolution

=> The Cons are too big for me to use this in everyday. If they were fixed, this would be a great ROM


Edit:
I just tried to switch back to Lineage 14.1 (https://forum.xda-developers.com/t/rom-7-1-x-sm-t520-unofficial-lineage-14-1-n2awifi.3538770/) but came across unexpected issues.
1) On first boot, Lineage 14.1 crashed (several apps were reported to crash, after selecting the language, android crashed aswel) and wasn't able to boot up again.
2) I reinstalled with an older TWRP version with the same result.
3) Flashed stock rom with odin (without a problem), flashed TWRP with odin, tried to install Lineage 14.1 but now, TWRP crashes as soon I tried to flash the rom zip. Repairing the file system didn't help.
4) Now I tried this Lineage 17.1 rom again and it works.

The strange thing: Lineage 14.1 worked before and I didn't see anyone commenting any problems like me. Is there any chance, Lineage 17.1 changed something that prevents me from rolling back to 14.1?
Make sure to wipe cache and system and format data before installing rom.
 

Kooneybert

Member
Nov 18, 2015
43
6
Make sure to wipe cache and system and format data before installing rom.
Okay, my post wasn't that clear. I wiped everything INCLUDING cache, system and data.

Btw, in the meantime, I reinstalled this rom again using the exact same path as before. Now, videos aren't stuttering no more. But instead, there is a 60% chance that the picture is zoomed to the top left quarter of the image...

Also, I now (succesfully) rolled back to Cyanogenmod 12.1 (Android 5.1.1). Yes, this is old ****, but for me, this seems to be the best option because it's just running faster since Android doesn't eat all of the available RAM. This Lineage 17.1 seemed to be very ram-hungry, btw. No wonder many apps suddenly close - they are lacking RAM. If anyone else is thinking about this RAM problem: if you don't install the gapps and just download the apk files from others sources, your device will have about 200-300mb more usable RAM. But this won't be enough for this Lineage 17.1 build in the current state, unfortunately.
 
Last edited:

wilkerjnc

Member
Nov 29, 2010
17
0
I installed this over Lineage 14.1, full wipe first; and it will not go past the boot screen.

Where can one get the "latest official Samsung Firmware"? I have tried a couple of spots, but they all say 'invalid' or such when attempting to flash.

Tried to reflash back to 14.1 but now that seems to be hanging.

Using the latest TWRP as well.
 

xfiver

Member
Dec 20, 2007
37
3
I advice you all to limit background processes to minimum because RAM capacity is real limiting factor on these tablets that cause lag.
@TechDriver,

Just so I have not missed something, please explain what you mean above....

Does it mean, to close any app not being used rather than allow to sleep? or is there more I can do to save RAM ... e.g. other background processes that are not so obvious?

Lack of RAM capacity makes sense, as crashes seem most frequent on websites with heavy content... but please explain anyway?
Thanks
 

Kooneybert

Member
Nov 18, 2015
43
6
@TechDriver,

Just so I have not missed something, please explain what you mean above....

Does it mean, to close any app not being used rather than allow to sleep? or is there more I can do to save RAM ... e.g. other background processes that are not so obvious?

Lack of RAM capacity makes sense, as crashes seem most frequent on websites with heavy content... but please explain anyway?
Thanks
If you take a look at developer settings (enable by pressing "build number" several times), you can find the option "limit background processes" (or kinda). There you can select, how many background processes may be active until Android will close the first ones (automatically).

But anyways, even with any app or background process open, these 2gb of RAM will feel like 256mb with Android 10.
 
Last edited:
  • Like
Reactions: xfiver

Kooneybert

Member
Nov 18, 2015
43
6
I installed this over Lineage 14.1, full wipe first; and it will not go past the boot screen.

Where can one get the "latest official Samsung Firmware"? I have tried a couple of spots, but they all say 'invalid' or such when attempting to flash.

Tried to reflash back to 14.1 but now that seems to be hanging.

Using the latest TWRP as well.
I used this one, I think:

Keep in mind that you have to flash this via Odin, not via TWRP! Afterwards, you have to flash TWRP via Odin, again.
 
  • Like
Reactions: TechDriver

wilkerjnc

Member
Nov 29, 2010
17
0
I used this one, I think:

Keep in mind that you have to flash this via Odin, not via TWRP! Afterwards, you have to flash TWRP via Odin, again.
I have the T900 12.2 Tab Pro, I try to get a firmware from that site and keep ending up on a page: "Sorry, you can't view or download this file at this time." Is there another valid repository somewhere?
 

xfiver

Member
Dec 20, 2007
37
3
@TechDriver,

Just so I have not missed something, please explain what you mean above....

Does it mean, to close any app not being used rather than allow to sleep? or is there more I can do to save RAM ... e.g. other background processes that are not so obvious?

Lack of RAM capacity makes sense, as crashes seem most frequent on websites with heavy content... but please explain anyway?
Thanks
Thanks - found the option! The back ground processes limit was set to 'standard' (i.e. 20) have now set it to 4. Let me see how it goes. Thanks again.

oops - replied to my question, meant to be in response to KooneyBert tip above.
 
Last edited:

c8m3r4n

Member
Sep 10, 2020
11
2
Hi all ,many are having problems with the new build lineage 17.1.My solution was Aurora store instead of play store through gapps, however if you need gapps then flash the pico version of gapps and limit the background processes to 4. This works well.
 
  • Like
Reactions: hamudistan

TechDriver

Senior Member
Aug 4, 2018
71
46
Podolie
@TechDriver,

Just so I have not missed something, please explain what you mean above....

Does it mean, to close any app not being used rather than allow to sleep? or is there more I can do to save RAM ... e.g. other background processes that are not so obvious?

Lack of RAM capacity makes sense, as crashes seem most frequent on websites with heavy content... but please explain anyway?
Thanks
In developer options there is switch called limit background process just select limit all or least number of processes. It will save some ram for foreground apps, but every time you switch apps they will need to reload.
 

mrduab

New member
Jun 5, 2021
2
0
I would just like to say I have installed this ROM on my SM-T900 and it runs surprisingly well! Everything is smoother and quicker and experiencing no crashes.

All I use it for is Kodi, web browsing and streaming videos.

One issue I do have is when watching video every now and then the audio freezes and buzzes for about half a second and then resumes.

I installed the latest TWRP and had to wipe all data as upgrading from a previous LOS caused it not to boot.

Is anyone else experiencing the audio blips? I've tried limiting background processes but it has no effect. If anyone could find a solution for this it would be great as we didn't have this issue on the previous LOS version.

Keep up the good work!
 

xfiver

Member
Dec 20, 2007
37
3
In developer options there is switch called limit background process just select limit all or least number of processes. It will save some ram for foreground apps, but every time you switch apps they will need to reload.

Thanks,

Both you and Kooneybert have suggested the same.. I have set background to 4 processes, (for last 2 days) but still experiencing random browser (Chrome) crashes.


I must say the tablet does feel a lot 'zippier', but occasional stutter, so sorry no new news.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!


    Special thanks to Exynos5420 team and LineageOS for all the sources.

    Use SM-T900 build at your own risk. I can't guarantee you it will work, because I have no device to test it on.

    Work
    Almost everything
    It has pretty much the same functionality as Lineage 14.1

    Known Issues
    Built in mic not working
    USB problems
    You tell me...

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery: SM-T520 - SM-T900
    3. Backup all partitions
    4. Wipe Cache and Data
    5. Install ROM.ZIP
    6. Install latest GApps (ARM/Android10) https://opengapps.org/
    7. Reboot and Enjoy
    8. Optional: Install Magisk

    For SM-T520 TWRP recoveries 3.1.1.0 and older will not flash this rom ending up with error 7: incompatible device.
    Make sure to flash TWRP mentioned above.


    Download:
    SM-T520

    SM-T900


    I ll probably create builds with updated security and device code patches occasionally.

    Enjoy fresh new Android!

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)
    4
    I am currently working on building lineageos-15.1 and 16.0. I see theese versions as more stable because of more developed code. I had successfully built los 16.0 multiple times but always run into bootloop. Los 15.1 is even more tricky. I run into multiple problems building it but if I will succesfully complete it and it will be stable enough I will give you link to download.
    4
    Just to make things clear, I am not developer of code and not skilled enough to make changes in it. For this job, there is team exynos5420 and other cool contributors to make device sources. I use their device sources from exynos5420 and LineageOS github to build together final product... Rom.zip you install on device. I can't fix bugs, i only can wait until some contributor fixes it and I will build rom with fixes and updated security patches included.
    3
    Damn!! Just installed and working.
    Really good work! Thanks!!!!
    i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

    Thanks for rom!
    3
    @TechDriver Clean flashed 17.1 over 14.1 without flashing stock on T900 using twrp-3.5.1_9-0 and it flashed great. I plugged in a headset but my Hey Google was already recorded and didn't give me any trouble. I don't know what would have happened if I hadn't plugged in the headset. Play Store does not recognize my already purchased apps. This usually means something is not right and I wonder if not flashing stock first is related to this? Can be very smooth but can be a little glitchy as well. Still experimenting and trying things. Bluetooth Keyboard and Mouse work great. Thank you for this.