• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM]|SM-T520|SM-T900|[UNOFFICIAL] LineageOS 17.1 | Android 10

Search This thread

tamis-laan

New member
Jun 14, 2021
2
0
I flashed this ROM onto my galaxy tab pro SM-T520, I had lineage os android 14.1 on there before.

When I try to download the F-droid apk, the browser crashes.

I tried downloading the F-Droid APK to the SD card using my laptop however opening the lineage os file browser also crashes.

This makes the ROM useless to me so I reinstalled lineage os 14.1.

However now I have same problem on lineage os 14.1 as well!!!!!!!

Is there some way to fix this??
 

Touz604

Senior Member
Jun 23, 2014
51
11
has anyone been able to enable encryption on this rom? When I enable it, the device reboots, ask for the decryption pin, then get stuck at the LOS logo (I let it ran overnight, just to be sure).

Thanks for the great ROM btw, it's much snappier than the previous LOS rom I was using.
 

tadkingston

Member
Mar 3, 2010
8
0
Hi. I've installed 17.1 over my old 14.1 on my 520. I managed to corrupt /data along the way but repaired it successfully with TWRP. My question is, how do you install Magisk for this build? The instructions I have found go into great detail about what *not to do* if SAR is found with a Samsung device but I can't work out what *to do*.
 

tadkingston

Member
Mar 3, 2010
8
0
Yep, that worked eventually. I had to reinstall 17.1 again but it picked up pretty much everything, except for the Google Now launcher, oddly.
I now have root. Thanks for the help.
 

Mhs11

New member
Jul 1, 2021
1
0
Hi, can anyone help me on how to get twrp 3.2., it seems links don't provide download. I think I need this one to use lineage 17.1 on the t520, right?
Thank you
Ps: can i use any odin for this or a particular version is more suitable. Many thanks from this newbie
 

VladStar

New member
Jul 7, 2021
1
0
Special thanks to Exynos5420 team and LineageOS for all the sources.

[...]

Enjoy fresh new Android!

Thank you @TechDriver for the opportunity to revive my aging Galaxy Tab 12 (SM-T900) with Lineage 17!

There are couple of things that I would like to mention:
1) Default SYSTEM partition seems to be ext2 with only 2G size - too small to fit 1.5G stock gapps. Attempts to install it via TWRP caused Error 70 (not enough space). I've pushed the "parted" via ADB, manually deleted 4 partitions (including SYSTEM), and then re-created them, with SYSTEM ext4/8G and DATA decreased by 6Gb from the original. Pain in you-know-where, I wish there was some simpler way to change, or even 6-8G by default... For those who interested - resize process is described here.
2) It turned out that the resize exercise was quite useless, as any gapps package above "pico" doesn't properly work on Lineage - it loops with the same questions (WiFI etc.) over and over again, never completing the OS configuration. Re: this link As a workaround, I've installed "pico" gapps version and then the rest from Google Play.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!


    Special thanks to Exynos5420 team and LineageOS for all the sources.

    Use SM-T900 build at your own risk. I can't guarantee you it will work, because I have no device to test it on.

    Work
    Almost everything
    It has pretty much the same functionality as Lineage 14.1

    Known Issues
    Built in mic not working
    USB problems
    You tell me...

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery: SM-T520 - SM-T900
    3. Backup all partitions
    4. Wipe Cache and Data
    5. Install ROM.ZIP
    6. Install latest GApps (ARM/Android10) https://opengapps.org/
    7. Reboot and Enjoy
    8. Optional: Install Magisk

    For SM-T520 TWRP recoveries 3.1.1.0 and older will not flash this rom ending up with error 7: incompatible device.
    Make sure to flash TWRP mentioned above.


    Download:
    SM-T520

    SM-T900


    I ll probably create builds with updated security and device code patches occasionally.

    Enjoy fresh new Android!

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)
    4
    I am currently working on building lineageos-15.1 and 16.0. I see theese versions as more stable because of more developed code. I had successfully built los 16.0 multiple times but always run into bootloop. Los 15.1 is even more tricky. I run into multiple problems building it but if I will succesfully complete it and it will be stable enough I will give you link to download.
    4
    Just to make things clear, I am not developer of code and not skilled enough to make changes in it. For this job, there is team exynos5420 and other cool contributors to make device sources. I use their device sources from exynos5420 and LineageOS github to build together final product... Rom.zip you install on device. I can't fix bugs, i only can wait until some contributor fixes it and I will build rom with fixes and updated security patches included.
    3
    Damn!! Just installed and working.
    Really good work! Thanks!!!!
    i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

    Thanks for rom!
    3
    @TechDriver Clean flashed 17.1 over 14.1 without flashing stock on T900 using twrp-3.5.1_9-0 and it flashed great. I plugged in a headset but my Hey Google was already recorded and didn't give me any trouble. I don't know what would have happened if I hadn't plugged in the headset. Play Store does not recognize my already purchased apps. This usually means something is not right and I wonder if not flashing stock first is related to this? Can be very smooth but can be a little glitchy as well. Still experimenting and trying things. Bluetooth Keyboard and Mouse work great. Thank you for this.