[ROM]|SM-T520|SM-T900|[UNOFFICIAL] LineageOS 17.1 | Android 10

Search This thread

Princeland

Senior Member
Feb 28, 2018
308
51
I need help with a question. I am on lineage os 14.1 and I would like to know if I can flash this 17.1 version directly without flashing the latest firmware by Odin since I don't have a computer. All the best!
 
I need help with a question. I am on lineage os 14.1 and I would like to know if I can flash this 17.1 version directly without flashing the latest firmware by Odin since I don't have a computer. All the best!
Afaik 14.1 already needed latest firmware I assume you can flash 17.1 directly.
Latest TWRP and of course clean wipe with "format data".
 
  • Like
Reactions: Princeland

Princeland

Senior Member
Feb 28, 2018
308
51
Afaik 14.1 already needed latest firmware I assume you can flash 17.1 directly.
Latest TWRP and of course clean wipe with "format data".
Thanks for answering friend. Do you think a format data is 100% necessary? I had thought about doing the installation with a full wipes without the format data that erases everything (internal memory too or so I understand) What would the steps be like according to you? Thanks again!
 

brk

Senior Member
May 13, 2008
454
293
Portugal
Having a problem with my SM-T520.
It was with Linage 1.41, followed the 1st post instructions ==> going back to stock, install recovery, but when I try to wipe Cache, it stops with error. Rebooting to recovery shows Cache partition as 0 MB (zero).
Any advice would be helpful.
Thanks.

Fixed.
Installed twrp-3.0.2-0, did the wipe, then upgraded recovery to twrp-3.2.3-0-n2awifi-v2 and then flashed the rom.
 
Last edited:
Thanks for answering friend. Do you think a format data is 100% necessary? I had thought about doing the installation with a full wipes without the format data that erases everything (internal memory too or so I understand) What would the steps be like according to you? Thanks again!
It may not be necessary, but as I've had often problems after upgrading or even boot loops that vanished after a full wipe including "Format Data" I always recommend that to avoid problems.
On some devices it was even necessary to switch file system to and fro to be able to get a working system.
My steps when upgrading (hopping to a higher version):
1. backup EFS/Modem, System+boot and Data in 3 steps (makes it easier to determine incorrect files)
2. wipe caches, system, data,
3. "format data" additionally
4. flash ROM
5. reboot and see if it starts
6. if it does flash Magisk.zip and Gapps (if wanted)

When keeping the version but updating I usually do 1 and 2 (without Data) as well
 
  • Like
Reactions: Princeland

Princeland

Senior Member
Feb 28, 2018
308
51
Having a problem with my SM-T520.
It was with Linage 1.41, followed the 1st post instructions ==> going back to stock, install recovery, but when I try to wipe Cache, it stops with error. Rebooting to recovery shows Cache partition as 0 MB (zero).
Any advice would be helpful.
Thanks.

Fixed.
Installed twrp-3.0.2-0, did the wipe, then upgraded recovery to twrp-3.2.3-0-n2awifi-v2 and then flashed the rom.
Hello friend, I can't find that twrp that you used to clear the cache. Could you give me a link to download it?

Thank you!
 
Having a problem with my SM-T520.
It was with Linage 1.41, followed the 1st post instructions ==> going back to stock, install recovery, but when I try to wipe Cache, it stops with error. Rebooting to recovery shows Cache partition as 0 MB (zero).
Any advice would be helpful.
Thanks.

Fixed.
Installed twrp-3.0.2-0, did the wipe, then upgraded recovery to twrp-3.2.3-0-n2awifi-v2 and then flashed the rom.
https://eu.dl.twrp.me/picassowifi/twrp-3.1.1-0-picassowifi.img.tar.html is latest version. Where did you found 3.2.3.0?
 

conan9010

Member
Dec 17, 2022
16
0
hello all, I installed Lineage 14.1 on my sm-t520, everything is ok, when I install opengapps arm 7.1 it overheats and the tablet turns off and on again...... what do I do?
 

conan9010

Member
Dec 17, 2022
16
0
Immagine 2022-12-18 092343.png
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!


    Special thanks to Exynos5420 team and LineageOS for all the sources.

    Use SM-T900 build at your own risk. I can't guarantee you it will work, because I have no device to test it on.

    Work
    Almost everything
    It has pretty much the same functionality as Lineage 14.1

    Known Issues
    Built in mic not working
    USB problems
    You tell me...

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery: SM-T520 - SM-T900
    3. Backup all partitions
    4. Wipe Cache and Data
    5. Install ROM.ZIP
    6. Install latest GApps (ARM/Android10) https://opengapps.org/
    7. Reboot and Enjoy
    8. Optional: Install Magisk

    For SM-T520 TWRP recoveries 3.1.1.0 and older will not flash this rom ending up with error 7: incompatible device.
    Make sure to flash TWRP mentioned above.


    Download:
    SM-T520

    SM-T900


    I ll probably create builds with updated security and device code patches occasionally.

    Enjoy fresh new Android!

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)
    6
    Hi,

    i did a build for my SM-T520 with the last updates, test on your own risk.

    4
    I am currently working on building lineageos-15.1 and 16.0. I see theese versions as more stable because of more developed code. I had successfully built los 16.0 multiple times but always run into bootloop. Los 15.1 is even more tricky. I run into multiple problems building it but if I will succesfully complete it and it will be stable enough I will give you link to download.
    4
    Just to make things clear, I am not developer of code and not skilled enough to make changes in it. For this job, there is team exynos5420 and other cool contributors to make device sources. I use their device sources from exynos5420 and LineageOS github to build together final product... Rom.zip you install on device. I can't fix bugs, i only can wait until some contributor fixes it and I will build rom with fixes and updated security patches included.
    3
    Damn!! Just installed and working.
    Really good work! Thanks!!!!
    i found a bit problem, starting android it loops between voice assistant and set lock for tablet. i needed connect earphones with microphone to finish voice assistant configuration and then it continued.

    Thanks for rom!