• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][SM-T580][SM-T585][UNOFFICIAL] LineageOS 14.1 | Android 7.1.2 20171231+TWRP 3.2

Search This thread

masafega

Member
Mar 17, 2016
29
3
@Valera1978
Hi, thanks for your ROM!
I found a issues with SD card, when I try to format for use as internal storage SM-T585 reboot itself and stay with black screen until I remove the SD card.
 

Credomo

Senior Member
Jul 27, 2008
58
11
Aix-en-Provence
This summer, Samsung has upgraded the SM-T580 to BRF1. All the latest tablets delivered are now BRF1. It was impossible to boot in recovery with the old TWRP (Red stripes problem). A solution has been found thanks to @ashyx

A problem still occurs apparently not due to TWRP. When you switch off/on the tablet or when the device goes to sleep mode by itself. If you try to switch on the tablet, a black screen appears. The tablet is working normally but you can't see anything: Touch is fully working (reboot possible if you know where to tap). When you reboot, everything works normally.

This problem occurs with LineageOS 14.1 and 15.1 but not with 16.0

Any solution ?
 
Last edited:

johnyb0y

Member
Mar 24, 2018
48
27
This summer, Samsung has upgraded the SM-T580 to BRF1. All the latest tablets delivered are now BRF1. It was impossible to boot in recovery with the old TWRP (Red stripes problem). A solution has been found thanks to @ashyx

A problem still occurs apparently not due to TWRP. When you switch off/on the tablet or when the device goes to sleep mode by itself. If you try to switch on the tablet, a black screen appears. The tablet is working normally but you can't see anything: Touch is fully working (reboot possible if you know where to tap). When you reboot, everything works normally.

This problem occurs with LineageOS 14.1 and 15.1 but not with 16.0

Any solution ?

I have no solution to your problem, but I wanted to ask you: What's the meaning of "BRF1"? I googled it but couldn't find any information except for a few xda ROM threads.
Is this something like a new hardware revision of the tablet?
 

Credomo

Senior Member
Jul 27, 2008
58
11
Aix-en-Provence
Hardware modification ?

I'm thinking more and more about an hardware modification on the latest tablets.
I have 100 tablets SM-T580 bought during the last 4 months. I've flashed lineageOS 14.1 with the oldest ones without any problem. But with the newest ones, I was unabled to do the same operation.

Problems :
  • TWRP encountered a graphics problem solved here
  • When LineageOS 14.1 is installed, another problem occurs. When you switch off/on the tablet or when the device goes to sleep mode by itself. If you try to switch on the tablet, a black screen appears. The tablet is working normally but you can't see anything: Touch is fully working (reboot possible if you know where to tap). When you reboot, everything works normally. It seems to be a graphics problem too.

It's not a problem of firwmare version as I could say, the problem occurs on BRB2 or BRF1 firmwares. I've searched and found something :
  • Each tablet has a serial number like this R52Kxxxxxxxx and there is some kind of incrementing
  • The problems doesn't occurs on R52K707xxxx and under
  • The problem still occurs on R52K70Kxxxx and above
This problem occurs with LineageOS 14.1 and 15.1 but not with 16.0

I'm not able to correct the problem and build a new version of LineageOS, but i need some help, thanks !
 
Last edited:

followmsi

Senior Member
Oct 10, 2013
4,119
12,445
I'm thinking more and more about an hardware modification on the latest tablets.
I have 100 tablets SM-T580 bought during the last 4 months. I've flashed lineageOS 14.1 with the oldest ones without any problem. But with the newest ones, I was unabled to do the same operation.

Problems :
  • TWRP encountered a graphics problem solved here
  • When LineageOS 14.1 is installed, another problem occurs. When you switch off/on the tablet or when the device goes to sleep mode by itself. If you try to switch on the tablet, a black screen appears. The tablet is working normally but you can't see anything: Touch is fully working (reboot possible if you know where to tap). When you reboot, everything works normally. It seems to be a graphics problem too.

It's not a problem of firwmare version as I could say, the problem occurs on BRB2 or BRF1 firmwares. I've searched and found something :
  • Each tablet has a serial number like this R52Kxxxxxxxx and there is some kind of incrementing
  • The problems doesn't occurs on R52K707xxxx and under
  • The problem still occurs on R52K70Kxxxx and above
This problem occurs with LineageOS 14.1 and 15.1 but not with 16.0

I'm not able to correct the problem and build a new version of LineageOS, but i need some help, thanks !

I'm thinking more and more about an hardware modification on the latest tablets.
I have 100 tablets SM-T580 bought during the last 4 months. I've flashed lineageOS 14.1 with the oldest ones without any problem. But with the newest ones, I was unabled to do the same operation.

Problems :
  • TWRP encountered a graphics problem solved here
  • When LineageOS 14.1 is installed, another problem occurs. When you switch off/on the tablet or when the device goes to sleep mode by itself. If you try to switch on the tablet, a black screen appears. The tablet is working normally but you can't see anything: Touch is fully working (reboot possible if you know where to tap). When you reboot, everything works normally. It seems to be a graphics problem too.

It's not a problem of firwmare version as I could say, the problem occurs on BRB2 or BRF1 firmwares. I've searched and found something :
  • Each tablet has a serial number like this R52Kxxxxxxxx and there is some kind of incrementing
  • The problems doesn't occurs on R52K707xxxx and under
  • The problem still occurs on R52K70Kxxxx and above
This problem occurs with LineageOS 14.1 and 15.1 but not with 16.0

I'm not able to correct the problem and build a new version of LineageOS, but i need some help, thanks !

Pls test kernel from here ..

https://drive.google.com/drive/mobi...XT-Af3sUCJKP55bJeSNO2uqul?sort=13&direction=a

Pls use Oreo (NEW) kernel from August 25th and test on lineage-15.1 .. Install via twrp and reboot.

Just to exclude (older) kernel as reason for the problem you describe ..
 
  • Like
Reactions: Credomo

Credomo

Senior Member
Jul 27, 2008
58
11
Aix-en-Provence
Pls test kernel from here ..

https://drive.google.com/drive/mobi...XT-Af3sUCJKP55bJeSNO2uqul?sort=13&direction=a

Pls use Oreo (NEW) kernel from August 25th and test on lineage-15.1 .. Install via twrp and reboot.

Just to exclude (older) kernel as reason for the problem you describe ..

Thanks for your message!
What I've done on new and old models :
  • Install TWRP : twrp_3.2.3-1_sm-t580_29918.zip
  • TWRP : Format data
  • TWRP : Install LineageOS15.1 : lineage-15.1-20180501-UNOFFICIAL-gtaxlwifi.zip
  • TWRP : Wipe -> Reboot -> LineageOS 15.1 works fine except the problem described
  • TWRP : Install oreo-kernel-gtaxlwifi-20180825_NEW.zip
  • TWRP : Wipe -> reboot
And then, my tablet goes on bootloop, nice try ;o)
 
Last edited:

followmsi

Senior Member
Oct 10, 2013
4,119
12,445
Thanks for your message!
What I've done on new and old models :
  • Install TWRP : twrp_3.2.3-1_sm-t580_29918.zip
  • TWRP : Format data
  • TWRP : Install LineageOS15.1 : lineage-15.1-20180501-UNOFFICIAL-gtaxlwifi.zip
  • TWRP : Wipe -> Reboot -> LineageOS 15.1 works fine except the problem described
  • TWRP : Install oreo-kernel-gtaxlwifi-20180825_NEW.zip
  • TWRP : Wipe -> reboot
And then, my tablet goes on bootloop, nice try ;o)
Pls install the 64-bit ROM from here ..

https://forum.xda-developers.com/showpost.php?p=77676692&postcount=50

Using new kernel too.

Better now ?
 

followmsi

Senior Member
Oct 10, 2013
4,119
12,445

For testing this "famous" T580XXU3BRF1 release .. I did merged kernel sources into exisiting oreo/pie sources.
Maybe I will have to use the kernel sources for new TWRP version too.

Just to see how it looks like.
https://github.com/followmsi/android_kernel_samsung_exynos7870/tree/T580XXU3BRF1

Compiled a test kernel ..
oreo-kernel-gtaxlwifi-20181004_T580XXU3BRF1.zip

I did flash onto 32-Bit Lineage-16.0 .. boots fine .. but wifi is not working.
Maybe stock ROM is using new wifi kernel module .. needs to be replaced in boot.img

Anyway .. this was a quick test .. not sure if it helps to determine the root cause of your problem.

Interesting topic .. pls let us know your testing results.

Cheers
 

OccsE

Member
Jan 29, 2006
41
4
Would anyone help? I have a dead Samsung Galaxy Tab A 2016 (10.1, LTE) which does not work.
Do you think I can raise it with a flash element?
Unfortunately, I can't enter recovery mode either.
It just works so much that you can see my pc
 

Top Liked Posts