[ROM][SM-T580][SM-T585][UNOFFICIAL] LineageOS 16 for Galaxy Tab A (2016)

Search This thread

rafmal808

New member
Aug 6, 2018
4
0
Thanks for the ROM!

It works great on my SM-T580 except for the encryption. After I enable encryption and reboot, it gets stuck on a black screen after inputing my PIN. I thought the OS was just going through the initial encryption process, but I left it for 4-5 hours and it was still stuck. Force-rebooting did not help either. I ended up re-installing the ROM without encryption this time.
 

Klaerchen

Senior Member
It works great on my SM-T580 except for the encryption. After I enable encryption and reboot, it gets stuck on a black screen after inputing my PIN. I thought the OS was just going through the initial encryption process, but I left it for 4-5 hours and it was still stuck. Force-rebooting did not help either. I ended up re-installing the ROM without encryption this time.
I use my SM-T585 with encryption. I can't imagine, what might be different with your setup. Sorry.
 

Mfizz

Member
Oct 27, 2012
17
2
Any update on the sound issues? My problem is that sound through headphones works but not through the speakers. Clearing dalvik/art and cache doesn't do anything. Mine has been like this since first boot.

I am using T585
 

jonnyhh

Member
Jun 28, 2017
35
14
Any update on the sound issues? My problem is that sound through headphones works but not through the speakers. Clearing dalvik/art and cache doesn't do anything. Mine has been like this since first boot.

I am using T585
Boot into recovery, shutdown from recovery. Restart into recovery, start the system from there. That's how I feel when I have no sound.
 

Mfizz

Member
Oct 27, 2012
17
2
My tablet randomly crashed and reeboted. Is there anyway I can check what was cause of this crash and rebot?
 
Im having a problem with netflix. While watching maybe around 3 mins or so it suddenly goes back to tje netflix home screen. Safetynet check also failed.

BUt having said that, everything else was fantastic.

MY method of instalation of this Rom is clean install. Using magisk 24 right now.

Hope anyone can help.
 

MikeN68

Member
Jan 22, 2013
35
4
HP Touchpad
Nexus 7
Klaerchen,
I know you and everyone here is aware of the sound issue and as I continually failed to get mine working I have reluctantly migrated to CRDroid 18.1 which is OK, but battery and overall response is not as good.
I keep checking back here to see if the sound issue has been fixed but am disappointed each time and wonder if this something that the other guys like followmsi or TALUAtXDA could maybe assist with or have you already reached out for help with it?
It seems 16 is the perfect Lineage version for the 580 and subsequent builds are all less responsive.
Thanks for all your work.
 

Klaerchen

Senior Member
Klaerchen,
I know you and everyone here is aware of the sound issue and as I continually failed to get mine working I have reluctantly migrated to CRDroid 18.1 which is OK, but battery and overall response is not as good.
I keep checking back here to see if the sound issue has been fixed but am disappointed each time and wonder if this something that the other guys like followmsi or TALUAtXDA could maybe assist with or have you already reached out for help with it?
It seems 16 is the perfect Lineage version for the 580 and subsequent builds are all less responsive.
Thanks for all your work.
I'm sorry that you have persistent problems with sound. Frankly speaking I have absolutely no idea, what might be the reason for the "muteness" of some tablets. My T585 happens to loose sound very rarely, and then one or a couple of reboots/power down/ups remove the problem.

And responsiveness of newer Androids (TALUAtXDA and follomsi)? I just tried the LOS 19.0 by followmsi and it has a very good standby time (about 16 days with few screen on time) and it is responsive as always. I did not yet try the LOS18.1 but I would not expect much different result.

So I will still continue building LOS16 with the LineageOS updates (there was no official 2022-02-05 tag in February, therefor no new build in February) for some time, but I think it will sooner or later reach its EOL with respect to security.

Regards,
Klaerchen
 

cHECKjAM

Senior Member
Aug 28, 2015
112
12
Any update on the sound issues? My problem is that sound through headphones works but not through the speakers. Clearing dalvik/art and cache doesn't do anything. Mine has been like this since first boot.

I am using T585

Boot into recovery, shutdown from recovery. Restart into recovery, start the system from there. That's how I feel when I have no sound.

Exactly the same issue here with T585 and latest version of lineage. Just installed today, basically fresh install and directly no sound from speakers. But works with headphone..

Had a few months older install before and it all worked fine..
 

cHECKjAM

Senior Member
Aug 28, 2015
112
12
Just read through last couple of pages and notice sound problems are common unfortunately.
Does anyone know what build I can safely install to get sound back on speakers?

Security updates are not as important as I will be using the tab for offline video viewing only..
Thanks!

Update:
Installed lineage-16.0-20200917-achalmgucker-gtaxllte-signed
sound works immediately now
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    New builds (date 2022-05-06) are up with security patch level of 2022-03-05. See first post for more info.
    And remember, it's always a good idea to do a TWRP backup before installation.

    Although all patches of LOS 16 with the topic of "P_asb_2022-04" (April-fixes) are included, it still shows patchlevel 2022-03-05.
    Well, we'll see, how long LineageOS team will backport the Android fixes to LOS 16.
    2
    That change would be placebo, I highly, highly doubt it was what got sound working again. That property (persist.vendor.audio.fluence.voicecall) is only read (by blobs) on devices with Qualcomm chipsets on which a proprietary feature called Fluence is used (Notice that name in the property. Don't know what it does, and there's a lack of information on it, only guess is that it does some type of in-call audio processing in hardware.), so it would've started working again for a different reason.


    Agree.

    We had similar problems about 3 years ago with the Sony Shinano series ( Z2, Z3, Z3C ) , with LOS 15 and 16. Mic and loudspeaker were without function in calls with enabled Google Assistant voice recognition, it could be fixed by editing 4 props, and one value was the " fluence " value. If i remember correct " normal " system sounds were not affected. I'm very inactive in the Z3/Z3C thread atm, but if interested go the thread and search for the keyword " fluence " for some explanations.

    Edit:

    Brain works again. 😂

    If i'm not wrong the fluence values reduce background noise in calls...
    2
    Hi

    First of all thanks to klaerchen for all the effort and the rom.
    I had after last release issues with my speakers on T585. No sound over the speakers.
    And no fix after some power off and restart sessions. But this has fixed my problem:
    Add "persist.vendor.audio.fluence.voicecall=false" (Without quotes ofc) in the file build.prop located in /system
    Simplest way for me was editing using root essentials, app, which has own editor for build.prop (https://play.google.com/store/apps/details?id=com.superthomaslab.rootessentials) , but root required for it
    Recomm. : be careful and make backup(s) before editing
    Found at: https://www.reddit.com/r/LineageOS/comments/anhdp7 Ihope, it can help other users - it was working for me

    BR
    M.

    PS: the entry was completly missed in the file build.prop I added it and now the sound works again on my 585
    2
    I had after last release issues with my speakers on T585. No sound over the speakers.
    And no fix after some power off and restart sessions. But this has fixed my problem:
    Add "persist.vendor.audio.fluence.voicecall=false" (Without quotes ofc) in the file build.prop located in /system
    That change would be placebo, I highly, highly doubt it was what got sound working again. That property (persist.vendor.audio.fluence.voicecall) is only read (by blobs) on devices with Qualcomm chipsets on which a proprietary feature called Fluence is used (Notice that name in the property. Don't know what it does, and there's a lack of information on it, only guess is that it does some type of in-call audio processing in hardware.), so it would've started working again for a different reason.
  • 29
    This is LineageOS 16 for both versions (LTE and WiFi-only) of the Samsung Galaxy Tab A (2016).

    All work for this ROM was done by @Valera1978 - I only did the builds based on the current LineageOS sources to make the security fixes available for this nice ROM. So all thanks may go to @Valera1978.
    You find all discussion to this ROM in @Valera1978's thread here: https://forum.xda-developers.com/galaxy-tab-a/development/rom-lineageos-15-1-64bit-20180920-t3845016

    Downloads:
    Latest builds from 2022-05-06 with security patch level 2022-03-05.
    The builds can be found here:
    SM-T585: https://www.androidfilehost.com/?w=files&flid=307678
    SM-T580: https://www.androidfilehost.com/?w=files&flid=307673

    Migrate-script: https://www.androidfilehost.com/?fid=2188818919693800974
    (unzip before use, identical script for both SM-T580 and SM-T585)

    Please make a complete backup with TWRP of your current ROM and data, in case anything might go wrong!

    The builds are signed with release keys!

    If you want to install this ROM over an existing installation of another author's Lineage-OS (build with test-keys), then you first should run the 'migration-achalmgucker.sh' script with the argument 'official', to ensure compatibility to my build with release-keys.

    And if you want to move from this ROM to another author's ROM, then it might be good to run the 'migration-achalmgucker.sh' script with the argument 'unofficial' to return to test-keys.
    Please carefully read this information from LineageOS: https://wiki.lineageos.org/signing_builds.html
    Or you do a factory reset before starting with this ROM. (You will lose of course all your data!)

    Further updates of this ROM can be done directly without data loss, no special migration necessary.

    Gapps
    https://opengapps.org
    Android 9.0
    Platform: ARM64

    Root
    Can be done with Magisk.

    Sources
    LOS16: https://github.com/Lineageos
    Kernel: https://github.com/Valera1978/android_kernel_samsung_exynos7870
    Device-Tree: https://github.com/Valera1978/android_device_samsung_gtaxlwifi & https://github.com/Valera1978/android_device_samsung_gtaxllte
    Vendor: https://github.com/Valera1978/android_vendor_samsung_gtaxlwifi & https://github.com/Valera1978/android_vendor_samsung_gtaxllte

    Thanks
    Thanks to @Valera1978 for the great adaption of LOS16 to SM-T58x
    Thanks to the LineageOS team
    7
    New builds (date 2021-08-10) are up with security patch level of 2021-08-05. See first post for more info.
    And remember, it's always a good idea to do a TWRP backup before installation.
    7
    New builds (date 2021-10-17) are up with security patch level of 2021-10-05. See first post for more info.
    And remember, it's always a good idea to do a TWRP backup before installation.

    Sorry for my long absence, I have been a bit busy. Will be present again in the future!

    And a word to the sound problems: I also have the problem, that after update or restart of the tablet the sound is gone. However, rebooting, clearing cache helps after some time, and then sound is good again. It's sad, but I have no idea how to fix that.
    6
    New builds (date 2021-02-09) are up with security patch level of 2021-02-05. See first post for more info.
    And remember, it's always a good idea to do a TWRP backup before installation.
    6
    New builds (date 2021-01-30) are up with security patch level of 2021-01-05. See first post for more info.
    And remember, it's always a good idea to do a TWRP backup before installation.

    The bootloop-problem with the first builds from 2021-01-14 came from a kernel panic and was only present on tablets with encrypted memory (as far as I know).