[ROM][SM-T825][UNOFFICIAL] LineageOS 15.1 | Android 8.1 20180719

Search This thread

mister_uaila

Member
Dec 2, 2013
21
2
I noticed that Spen is not working properly due to something's wrong with the implementation of the palm rejection feature. I wanna go back to stock samsung. How? I tried using ODIN to flash the latest official firmware but it doesn't work. Always an error.. please help. Thanks. I use my tab in writing notes

What kind of error do you get?
Did you select (in Odin) all the needed parts from the official firmware to be written?
Since you wrote "latest official firmware" I assume you went with 8.0, correct?
 
  • Like
Reactions: Biosystematics

VVombat

Senior Member
Oct 6, 2012
52
14
I noticed that Spen is not working properly due to something's wrong with the implementation of the palm rejection feature. I wanna go back to stock samsung. How? I tried using ODIN to flash the latest official firmware but it doesn't work. Always an error.. please help. Thanks. I use my tab in writing notes

Be sure to use at least version Odin3 v3.13.1 for the newest firmware. I had some issues too and it was because I tried to use Odin3 v3.12.10 . GL!
 
  • Like
Reactions: Biosystematics
Nov 17, 2012
5
0
What kind of error do you get?
Did you select (in Odin) all the needed parts from the official firmware to be written?
Since you wrote "latest official firmware" I assume you went with 8.0, correct?

yes, I selected all the needed parts and yes.. i went back to 8.0 (lineage OS is based on 8.1)

---------- Post added at 08:07 AM ---------- Previous post was at 08:06 AM ----------

Be sure to use at least version Odin3 v3.13.1 for the newest firmware. I had some issues too and it was because I tried to use Odin3 v3.12.10 . GL!

okey. I didn't know that.. thank you for the help. I think I have the older ODIN version.

---------- Post added at 08:07 AM ---------- Previous post was at 08:07 AM ----------

Be sure to use at least version Odin3 v3.13.1 for the newest firmware. I had some issues too and it was because I tried to use Odin3 v3.12.10 . GL!

okey. I didn't know that.. thank you for the help. I think I have the older ODIN version.
 

wwwutz

New member
Dec 10, 2017
3
0
Berlin
boot loop on rev05 hardware

I'm getting into a boot loop after installing with TWRP. I suspect some changes 'new' hardware revision Rev05, since I have an older T825 running fine without problems.

Could someone have a look at the logs ?

gist.github.com/wwwutz/18043837a9ff4b10ee1a71a69dedc073

(no link due to new user karma)

If any more info is needed, I've got my hands on it :cool:

Peter
 

alexeyp

Senior Member
Sep 28, 2015
67
11
Here is my experience with installing TWRP and this ROM.
1) Installed fresh Samsung Oreo image. Installed TWRP. Got TWRP working, but boot loop if try to boot the system.
2) Re-installed Samsung Oreo image. Copied this ROM and google apps on SD card. Installed TWRP. Got TWRP working. Installed this ROM and google apps. Got working system.
Wins:
- Phone does work. That's a major step forward.
- I didn't notice any battery problems.
Problems/not working:
- Boot loop if try using Samsung image with TWRP. Tried several combinations, like installing Samsung image then TWRP, or installing TWRP then Samsung image without BL..
- TWRP can't backup. Shows error messages 'unable to mount data', and reports backup failed.
- VOIP apps (tried Zoiper and Mizudroid) have one-way audio, as it was with phone earlier. The microphone on the tablet works, but other party doesn't hear anything.
 

wwwutz

New member
Dec 10, 2017
3
0
Berlin
I'm getting into a boot loop after installing with TWRP.

SOLVED.

OK, the issue was a combination of TWRP and 7.1 Samsung Stock. Any combination ended in a boot loop. No Lineage ROM involved.

We then burned latest 8.0.0 Oreo Samsung Stock image ( XXU1BRE2 in our case), booted ( for testing ) and followed the instructrions TWRP/dmverity/Lineage/gapps.

Worked like a charm, took us 4 days to dig into it.

Anyways: SM-T825 bootloop ? Install latest Stock ROM and try again. Got mine from updato.com, don't know how trustwhorty they are. idc :cool:
 

rubenschaap

New member
May 7, 2013
1
0
@Valera1978 The links to the sources aren't working anymore. The pages doesn't exists on Github.
Can you provide us the correct links please?
I would like to fork this ROM.

I also have a few issues. (Other than 2 speakers and battery drain)
- When i use the camera and close it. No other app can use the camera anymore. Only after a reboot. Some applications says "Camera is busy" or something. Toggling flashlight also doesn't work then.
- Opening camera is slow
- Microphone isn't working.
- Auto brightness isn't working. With a lux meter and a flashlight the sensors reads only max 0.8lx
- In the multitask menu, the previews are black.

Does someone else have this problem too?

Thanks in advance!
 
Last edited:

HippoMan

Senior Member
May 5, 2009
1,632
482
Hippoland
Working on SM-T825C?

Does anyone know whether this ROM will work on the SM-T825C? It's the Chinese/Hong-Kong version, and it supports a SIM card (GSM LTE).

Thank you in advance.
.​
 
@Valera1978 The links to the sources aren't working anymore. The pages doesn't exists on Github.
Can you provide us the correct links please?
I would like to fork this ROM.

I also have a few issues. (Other than 2 speakers and battery drain)
- When i use the camera and close it. No other app can use the camera anymore. Only after a reboot. Some applications says "Camera is busy" or something. Toggling flashlight also doesn't work then.
- Opening camera is slow
- Microphone isn't working.
- Auto brightness isn't working. With a lux meter and a flashlight the sensors reads only max 0.8lx
- In the multitask menu, the previews are black.

Does someone else have this problem too?

Thanks in advance!

+1 for sources! :highfive:
 

Veritas06

Senior Member
Mar 17, 2008
598
36
v3ritas.tech
hello,
thank you very much @Valera1978 for your hard work and your unofficial lineage-15.1 build :)

Have you a link to the sources of the lineage-15.1 build for the T825 (device, vendor, kernrl)? The first post has broken links to the sourcetrees or very old for lineage-14.1. I would like to build my own rom with some modification and rr sources. Is was very helpful when i can use your sources.

Cu Frank

+1 for sources! :highfive:

@Valera1978 The links to the sources aren't working anymore. The pages doesn't exists on Github.
Can you provide us the correct links please?
I would like to fork this ROM.

I also have a few issues. (Other than 2 speakers and battery drain)
- When i use the camera and close it. No other app can use the camera anymore. Only after a reboot. Some applications says "Camera is busy" or something. Toggling flashlight also doesn't work then.
- Opening camera is slow
- Microphone isn't working.
- Auto brightness isn't working. With a lux meter and a flashlight the sensors reads only max 0.8lx
- In the multitask menu, the previews are black.

Does someone else have this problem too?

Thanks in advance!

+1 for updated sources.
 

Veritas06

Senior Member
Mar 17, 2008
598
36
v3ritas.tech
Last edited:

robsmith11

Member
Jul 20, 2018
48
17
I've installed this on my new SM-T825 and everything that I need is working great, especially my bluetooth keyboard and s pen for note taking.

Thanks for all of your work!
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone