[ROM][STABLE] LineageOS 18.0 [MI A3] [laurel_sprout]

Search This thread


Senior Member
android 10 gestures working on third party launchers?

Are you asking if Gesture navigation is available on third party launchers on this ROM? The answer is yes.

Android 11 has that feature enabled by default.

Well, Android 10 has it also since December 2019, when Google released a fix for that but, unfortunately, Xiaomi didn't base the code to a newer source...yet.


Apr 24, 2020
Are you going to apply for official maintainership once Lineage 18 is officially released ?


Oct 16, 2019
If I still want to use Google apps, if I am to flash NikGApps on this ROM, would the Google apps replace the Lineage apps?


Jul 21, 2019
The camera is limited to 12MP for some reason even though the A3 supports 48MP.
I tried a different camera app but got the same result.

Also, any attempt to flash Magisk (20.4 or 21.1) results in either a bootloop or soft brick.
Last edited:


Jul 20, 2016
Hi, does someone was able to use nikgapps stock work ? when i try to restore a backup from gmail user (on first start) i have a loop from lineage start logo and home screen


New member
Feb 20, 2021

I need help. I did all the instruction, every thing went fine till last point of Step 6

6 - We're on TWRP Recovery using slot B. Do this:

Install twrp-3.3.1-17-laurel_sprout-Installer-mauronofrio.zip
Reboot to Recovery
Format Data with "yes"
Install lineage ROM zip
Install twrp-3.3.1-17-laurel_sprout-Installer-mauronofrio.zip (yes, again...)
Reboot to Recovery

I hit Reboot Button and my MI A3 went of .. and never turned on again .. nothing possible anymore .. no fastboot modus, no charging .. just black .. Is there anytimgs I can do ?

Tank you very much in advance .. Hardy

I found this and finally it worked :)

- download and register MI FLASH PRO https://miflashpro.com/
- download Fastboot ROM https://xiaomifirmwareupdater.com/miui/laurel/
- download (Mi A3) prog_firehose_ddr_unbrick.elf https://www.leakite.com/xiaomi-programmer-firehose-files/

- check device manager - ports: qualcomm hs-usb qdloader 9008 (com3) - device is in EDL mode
- replace ROM/images/prog_firehose_ddr.elf with downloaded prog_firehose_ddr_unbrick.elf - fix for "Your Account is Unauthorized for this operation"
- open Mi Flash Pro/Mi Flash
- select path to ROM (can not have any space)
- select clean all
- select flash
if you are getting "cannot receive hello packet" or "cannot read from port com" it's probably EDL timeout or driver issue.
- unplug usb from phone, push power button for 40 sec, plug usb back to phone, refresh and flash
just pushing power button and waiting for disconnect/reconnect wasn't working..
just unplug/plug usb wasn't working..
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Step by step install procedure for LOS18

    1 - Turn your phone into fastboot mode (run adb reboot bootloader or shutdown the phone and turn it on again while pressing Power + Vol- keys)

    2 - On fastboot mode set a as the active slot by running the command:
    fastboot set_active a

    3 - Now, flash latest STOCK FASTBOOT ROM using flash_all.bat (or flash_all.sh if you're using Linux)

    4 - Wait for the installation to finish and, after seeing the welcome screen, go to fastboot mode again

    5 - Now run these commands:
    fastboot set_active b
    fastboot erase boot
    fastboot flash boot twrp-3.3.1-17-laurel_sprout_Android_10_mauronofrio.img
    fastboot reboot
    (keep pressing Vol+ key to force the phone into recovery mode)

    6 - We're on TWRP Recovery using slot B. Do this:
    Install twrp-3.3.1-17-laurel_sprout-Installer-mauronofrio.zip
    Reboot to Recovery
    Format Data with "yes"
    Install lineage ROM zip
    Install twrp-3.3.1-17-laurel_sprout-Installer-mauronofrio.zip (yes, again...)
    Reboot to Recovery​

    7 - Now we're on TWRP Recovery using slot A. Do this:
    Install NikGApps Core version. (This is optional! The ROM works fine without any GApps but if you want them, use CORE version!)
    Install Magisk (This is also optional! The ROM works fine without it but if you want it, get the MagiskR zip you'll find on the telegram support group!)
    Reboot to fastboot and run:
    fastboot flash dtbo dtbo.img
    fastboot reboot
    Your device will now reboot to System and you may enjoy LineageOS 18!


    • By doing this procedure you will have LineageOS 18 system installed only on slot A!
    • If your device fails to boot, you should just start all over again! Trust me, it's easier than trying other flashing methods.
    • You can now install a different Recovery if you like, for example, SHRP Recovery. Simply go to TWRP and flash SHRP installer zip.
    • You can, also, install a different Kernel. Check the Telegram support group, there are other kernels compatible with this ROM (I'm using No. 192 OSS Batt version, for instance).
    • All files mentioned on this post can be found on the Telegram support group (including latest ROM build, MagiskR version, twrp and dtbo.img)


     * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
     * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
     * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
     * Your warranty will be void if you tamper with any part of your device / software.
     * Same statement for XDA.

    LineageOS 18.0 based on Android 11.0

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


    - RIL
    - WiFi
    - Bluetooth.
    - Camera
    - Audio
    - Sensors
    - Flash
    - GPS
    - VoLTE
    - FOD (Fingerprint on display)
    - Face unlock.
    - DT2W.
    - Proximity in calls.
    - FBE.


    - You tell.


    1) Download ROM zip and Gapps (optional).
    2) Reboot to Recovery.
    3) Wipe Data, System, Cache.
    4) Format data. (It might work without this too but its recommended to format data to boot successfully. If stuck on splash or boot animation or reboots back to fastboot or recovery, format data)
    5) Flash ROM + Recovery installer (any as per your choice).
    6) Reboot to Recovery.
    7) Wipe cache.
    8) Reboot and enjoy.


    - The build is based on OSS vendor. Firmware is included in the ROM zip. No need to flash any firmware.
    - Fingerprint works fine with no flicker. (Accuracy is improved.)
    - Face unlock works.


    ROM :- LineageOS 18.0

    GAPPS :- GAPPS (optional)



    PayTM : [email protected]
    Paypal : http://paypal.me/pms2299
    GPay : [email protected]

    I can't build continuously on my laptop and I need a server to build. Consider donating for continuous support. I will be able to provide bug fixes sooner if I get a server. Please donate if you can. Thanks :)


    LineageOS Support group :- Telegram

    SOURCES :-


    XDA:DevDB Information
    LineageOS, ROM for the Xiaomi Mi A3

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x

    Version Information
    Status: Stable
    Current Stable Version: 18.0
    Stable Release Date: 2020-10-10

    Created 2020-10-10
    Last Updated 2020-10-10
    Can please someone build it with December Update??
    Anyone use this Rom as daily driver ? Any bugs ?
    Anyone use this Rom as daily driver ? Any bugs ?

    navigation thingie doesn't respect fullscreen apps sometimes and block some of my actions (I'm using gestures) and whatsapp freak out sometimes, some apps stop responding more frequently than stock