[ROM] Stock 14.1.G.2.257 deodexed, tweaked, zipaligned, flashable [17 oct]

Search This thread

krabappel2548

Inactive Recognized Developer
Nov 15, 2011
6,443
16,111
Lommel
I'm proud to present to you:
Flashable stock rom for Xperia Z1

== Information ==
- Latest stock rom
- Flashable zip
- Deodexed
- Zipaligned
- Added a few tweaks
- Debloated a little bit :)

== Download ==
Version for 14.1.G.2.257 fw:
Mega: Deodexed - tweaked 257 stock rom for CWM & TWRP

Version for 14.1.G.1526 fw:
Mega: Deodexed 526 stock rom v2 for CWM


== Installation ==
- Flash via CWM
- Flash SuperSu zip to be sure you are rooted
- [Optional] Clear cache and dalvik cache

== Extra ==
Enjoy this guys :)

If you like my work consider donating to me for my future Xperia devices!

== Changelog ==
== 12/09 v2 ==
- Updated updater-script
- Removed advanced stock kernel from zip​

== 11/09 v1 ==
- Released version of Taiwan 526 fw​
 
Last edited:

Mi|enko

Senior Member
Jul 15, 2006
1,559
171
Anybody that's flashed this via CWM getting a Status 7 abort due to challenges setting permissions?
 
Last edited:

krabappel2548

Inactive Recognized Developer
Nov 15, 2011
6,443
16,111
Lommel
Anybody that's flashed this via CWM getting a Status 7 abort due to challenges setting permissions?

I'll upload new version tonight with fixed flashing script :)

EDIT2: Uploaded, let me know if there are errors now.
If there are, try to boot into the rom and tell me if there are issues ;)
 
Last edited:
  • Like
Reactions: Mi|enko

Mi|enko

Senior Member
Jul 15, 2006
1,559
171
I'll upload new version tonight with fixed flashing script :)

EDIT2: Uploaded, let me know if there are errors now.
If there are, try to boot into the rom and tell me if there are issues ;)

This new version still gives a status 7 when setting permissions. Not sure what that's about. It's after the pieces of the ROM have technically been flashed, so it still boots. Just not sure what permissions you're trying to set, why it's failing, or what the downside is of whatever permissions are failing. Hope that makes sense.
 
  • Like
Reactions: 6E 65 76 69 6E

krabappel2548

Inactive Recognized Developer
Nov 15, 2011
6,443
16,111
Lommel
This new version still gives a status 7 when setting permissions. Not sure what that's about. It's after the pieces of the ROM have technically been flashed, so it still boots. Just not sure what permissions you're trying to set, why it's failing, or what the downside is of whatever permissions are failing. Hope that makes sense.

Oh ok, so it flashes and works but error.with permissions. I'll check them again tomorrow :p

Sent from my C6603 using xda app-developers app
 

swedan

Member
Feb 3, 2010
46
13
This new version still gives a status 7 when setting permissions. Not sure what that's about. It's after the pieces of the ROM have technically been flashed, so it still boots. Just not sure what permissions you're trying to set, why it's failing, or what the downside is of whatever permissions are failing. Hope that makes sense.

I got the permission error as well, but for me it won't boot. Just a good old bootloop. Wouldn't be an issue if not due to the fact that I can't enter recovery other than with adb :).

What fw were you on before flashing?
 

Mi|enko

Senior Member
Jul 15, 2006
1,559
171
I got the permission error as well, but for me it won't boot. Just a good old bootloop. Wouldn't be an issue if not due to the fact that I can't enter recovery other than with adb :).

What fw were you on before flashing?

The 526 ftf. Was just trying to switch to the deodexed version.
 

swedan

Member
Feb 3, 2010
46
13
After unlocking the camera can not be used
for Z1
Yeah I got this too. Can't use camera on stock (ftf) 518 or 526 after unlocking bootloader. Worked fine before. Would love if someone could test camera directly after unlocking bootloader from stock.
 

yeeson

Senior Member
May 2, 2010
668
113
Shanghai
No. Completely useless on my Z1 with ULBL. Doesn't matter if I use fw 518 or 526. But the camera on my my Xperia Z worked fine with ULBL.

Sent from my C6903 using Tapatalk 4

What does this mean?

---------- Post added at 12:51 PM ---------- Previous post was at 12:49 PM ----------

No. Completely useless on my Z1 with ULBL. Doesn't matter if I use fw 518 or 526. But the camera on my my Xperia Z worked fine with ULBL.

Sent from my C6903 using Tapatalk 4

To resolve them, the camera does not work after unlocking problem?
 

swedan

Member
Feb 3, 2010
46
13
What does this mean?

---------- Post added at 12:51 PM ---------- Previous post was at 12:49 PM ----------



To resolve them, the camera does not work after unlocking problem?

Not quite sure what you mean. But you said yourself that the camera didn't work after ULBL (unlocking bootloader), as I also experienced. If restoring TA works then that's a pretty crucial step for all who wants to ULBL.

Sent from my C6903 using Tapatalk 4
 

yeeson

Senior Member
May 2, 2010
668
113
Shanghai
Not quite sure what you mean. But you said yourself that the camera didn't work after ULBL (unlocking bootloader), as I also experienced. If restoring TA works then that's a pretty crucial step for all who wants to ULBL.

Sent from my C6903 using Tapatalk 4

ULBL (unlocking bootloader),Can't solve?:crying:
 

Top Liked Posts