• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][STOCK][D855][20A- LRX21M][OFFICIAL] Lollipop rooted ROM by skin1980

Status
Not open for further replies.
Search This thread

Stirlin

Senior Member
Aug 9, 2012
253
45

lx4520

Member
Jan 26, 2008
6
1
Hello,
great job in preparing this ROM.
I've installed successfully on my G3 but I have health that dropped 30% battery in 3.5 hours.
I'm checking anyway if I had problems with location (i'm not sure if was active or not).
Anyone experienced similar issues?

For those who has battery issue, there are many way in general discussion, i tried below:
1. Install titanium backup, uninstall as many as LG stuff, remember backup first.
2. Uninstall most google apps, as they come with the rom in system, u can install them later from play store.
3. Try battery calibrate apps.
4. Greenify.
hope it helps...
 

shreeram

Senior Member
Oct 26, 2010
110
9
Bengaluru
For those who has battery issue, there are many way in general discussion, i tried below:
1. Install titanium backup, uninstall as many as LG stuff, remember backup first.
2. Uninstall most google apps, as they come with the rom in system, u can install them later from play store.
3. Try battery calibrate apps.
4. Greenify.
hope it helps...

Tried everything and also tried to calibrate the battery manually(100%->Wipe battery Stats-> Complete Discharge). Still no joy :( . Back to kitkat.

Nevertheless, AWESOME ROM. Keep up the good work Dev :):highfive: :cool:
 

Stirlin

Senior Member
Aug 9, 2012
253
45
Um, I'll give it a whirl. I can see what the drain is.... Google Services every time.... And I have location turned off.
 

Stirlin

Senior Member
Aug 9, 2012
253
45
I removed all of the Google apps, flushed the cache for Google Services and then reinstalled what I needed. Seems OK at present. :thumbup:

Sent from my Transformer TF101 using XDA Free mobile app
 

two67

Senior Member
Mar 17, 2014
124
51
Oleiros, A Coruña
Oops.. for me the android system itself. And i suppose that the problem is with the base of lollipop itself and not LG. Am i right?
I think we can not trust on battery statistics on this Rom and lollipop. I have constantly 30-50% on Google services, 5-10% on screen with more than 4 hours SOT and 20% on phone with 5-20 minutes activation...

But battery life is not so bad in general, so I am not worried about that.
 

oktaya

Senior Member
Jun 21, 2012
120
27
What is the difference between this ROM (which I am using) and the Chupachups ROM from the same developer? The description seems to be very similar, stock LG G3 feel etc. So what's the difference?
 

gmbhneo

Senior Member
Sep 24, 2009
199
44
I really have to say that this is by far the most stable and fastest rom! Even the camera is working really smooth for me and the picture are amazing! (even better then original LG Cam)

THANK YOU SO MUCH for this awesome rom!
 

u1988

Senior Member
Dec 22, 2011
408
64
How can I flash KK MODEM with TWRP with and witout root only?
Can I flash with flashify App or only flash tot/kdz file after downgreat from 5.0 to 4.4.2?
 

Jangla

Senior Member
Oct 8, 2008
65
7
Since my first attempts at installing this ROM, I noticed that the file has been updated - I therefore had another attempt at an install yesterday but came across some weird behaviours I'm hoping the community will be able to help solve.

So, the install itself went perfectly normally. I went for a full factory reset before starting and once the ROM was flashed, the phone booted and apps began to download and install as you would expect.

Once everything was stable, I started to go into each of my core apps and sign in to their respective accounts. Initially everything looked great - apps were able to see my music on my SD card, wifi was working, mobile data was good.

That's when I started noticing some unusual things. After about an hour of looking around and checking a number of apps out, I found these few core issues:

1. Images in apps were not being shown. By this I mean that, for example, in Twitter no avatars or images on Tweets were showing. Same for Facebook, Feedly, Reddit etc. I thought this was pretty weird but no amount of clearing caches, resetting data or rebooting solved this.
2. I could not download anything from my Google Drive. Each attempt was greeted with a toast message telling me the download attempt failed and I should try again later. Again, no amount of reboots solved this.
3. LG's own apps wouldn't install. Things like Downloads app, Calculator app etc - all those ones in their Update Center, would look like they were installing - progress bar etc - but would reset to the uninstalled state on completion. No error shown.

These three things essentially forced me to restore my backup (again) and so I'm back to square one. Just to be clear, the Google Drive issue is not an issue with my account. Now I'm back to my old ROM, it all works fine.

Is anyone able to help sort this out? Seen anything similar?
 
Last edited:

archraziel

Senior Member
Feb 23, 2012
268
30
SP
Ok, so I have been using this rom for some time now, everything was fine. But just now, my phone stopped recognizing my sd card...any way to fix it?
 

Jangla

Senior Member
Oct 8, 2008
65
7
Anyone have this issue with the media notification - black text on a black background making it almost impossible to read?
 

Attachments

  • Screenshot_2014-11-26-14-54-04.jpg
    Screenshot_2014-11-26-14-54-04.jpg
    166.4 KB · Views: 943
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 225
    Hi all, i'm pleased to share my work with you.

    Here you have the latest official lollipop firmware for D855 ( v. 20A - LRX21M) packed in a zip flashable file.

    I made this because all of us want to keep the old bootloader that is - at the moment - the only one who accept the bumped TWRP provided us by team Codefire.

    I made also a step further and found a way to root this ROM.

    Here you go:

    First of all i suggest you to install the TWRP modded by me to allow the backup of the modem.
    Be sure you select also the modem partition before taking the backup. ( If you want to restore the backup then restore also the modem ;))

    1- download the two files and put them into the sdcard;

    2- reboot in recovery and do a factory reset;

    3- install the ROM and the supersu ZIP;

    4- reboot the device and enjoy your rooted Lollipop ROM.

    If you come from an earlier lollipop firmware you can dirty flash, it might work.

    I spend a lot of time developing this so if you think i deserve you can donate ( look at my sign ;) )

    DOWNLOAD

    SUPERSU flashable ZIP

    ROM


    MIRROR

    KK MODEM ( you need this only if you downgrade from lollipop to kitkat and you don't need if you backed up before with the modded TWRP recovery)

    DONATORS:( really tnx guys)

    GTMoraes, tobitege, shaboogen, pRo_lama, hnyuk49, rossonero82, spotlight79, TeamSlayr, Vegard Helland, Mishaal Almashan, Sagar Singh, PAPPL, ArubidCo, bigmupps

    CREDITS:
    teamcodefire, chainfire

    Changelog:
    - 13.11.2014 - updated to the official LRX21M - 20A ( poland FW )
    23
    Q&A

    What this ROM include?
    In the ROM zip you can find only the system, modem and kernel (bumped) image

    What do i need to flash this?
    You need only to have the TWRP recovery installed

    If i flash this i will lose the bumped recovery?
    Nope. The bootloader will not be changed.

    If i want go back to KK roms ( stock or AOSP) what i have to do?
    Just flash your ROM or restore a previous nandroid backup. But, after that, flash the zip with the KK modem you can find in the 1st post.

    I really need to flash the root files?
    Must i answer????

    Cannot write to internal SD?

    With adb or a terminal emulator do:
    Code:
    su
    restorecon -v -R /data/media

    Your statusbar and navbar are gone?
    This is a issue reported from some user.
    Try to format manually data in TWRP before install the rom.
    If this doesn't work try flashing the kdz of the H firmware ---> root ----> twrp ----> install this rom ( sperimental).

    Doesn't have the option to enable LTE?
    Go with a root browser to system/app/Lteconfigs/, click and install the apk, then reboot and you will have the option for LTE.
    8
    ROM Uploaded.... i dirty flash over the previous and all is ok.
    8
    @Skin1980: You definitely deserve some beers (or whatever you like :) ) 0F714082VL945954E
    THANK YOU!!

    Like i said in the other post really tnx. My wife and my childs are gonna kill me for the time spent on the PC!
    7
    How to flash

    My setup:
    D855 International version 32Gb, unlocked.
    Previous rom: AndroidNow HD 2.4

    How i flashed:
    I did a full system backup with my Titanium Backup, then I copied all files that are supposed to be flashed to my external SD.

    Entered recovery mode:
    1. Did a factory reset. (as said in 1st post)
    2. Flashed rom D85520A-lollipop-skin1980.zip (as said in 1st post)
    3. Flashed SU-beta BETA-SuperSU-v2.19.zip (as said in 1st post)
    4.a Flashed custom kernel D85520A-boot-rooted-bumped-skin1980.zip (as said in 1st post)
    4.b Reboot.

    Additional steps to restore Titanium backup:
    5. Install BusyBox from Google Play
    6. Install Titanium Backup Beta
    7. Reboot, all good.

    Rebooted, stuck on LG Logo for a few minutes, then it suddenly started to upgrade apps, and after that it was all great.
    Running smooth as ever!

    Please hit "Thank you" button if this helped you :D


    Only bug so far: when taking a screenshot, I'll get an error, but the image will appear at the gallery. The screenshot notification can't be dismissed however

    Sent from my LG-D855 using XDA Free mobile app

    Took screenshot of first install, worked fine. Just took another, worked fine. It saves, no errors, and I can dismiss it - Works as it should.

    The root not work. Any idea?

    Works great for me. You need a beta of Titanium Backup if that's the app that says that you don't have root. After installing the beta I could restore Android ID, SMS, MMS and everything else.

    Hah, i am not idi*t ))
    Nooo, after flash bumped rom 20a (from this thread) - i cant write\delete any files on phone memory,cant copy any files from pc to phone memorry, cant do screenshot on phone (notice - file corrupted) cant take a photo - default camera chose SD card, but if i can change to phone memorry - notice - not free memory (8gb free)

    SO - nooo privliages to write-delete on phone memory


    In 20a without root - allllll good. (flash kdz)

    I tried to take a photo to internal memory - works great.
    I tried to take a photo to external memory - works great.
    I trired to copy a file from external SD card to internal memory - works great.

    Pls could someone confirm that this rom works with the 32GB variant? Particularly the write problem on the internal memory

    If someone could take a screenshot and tell if there is no error, I would really appreciate.