[ROM][STOCK][FASTBOOT][OP8] Stock Fastboot ROMs for OnePlus 8

Search This thread
Thanks for responding. I forgot I asked that but I figured it out.
 
  • Like
Reactions: Nathan.7118391

kartheeksrm

Member
Mar 31, 2021
8
1
OnePlus 8
the device keeps getting into fastboot mode when I flash the android 11 and when I did the 10 it went into the qualcom crash dump mode. any suggestions or advice on how to move forward?
 
  • Like
Reactions: denson9874

Maxim Iac

Member
Jan 26, 2015
13
3
OnePlus 8
the file bat has a mistype I think, it tries to flash a opproduct but there is no such file in the directories, so I tried to rename product.img to opproduct.img but anyways It doesent boot after the entire process, goes only into fastboot
 

sawb

Member
Nov 23, 2014
5
0
After flashing this, script said success and tried to reboot. Now the phone is stuck at a black screen. Won't boot to fastboot, won't boot to recovery or anything. No vibration when plugging it in. Is there any way to recover from this or do I have a paperweight now?
 

KnowNadda

Member
Jul 16, 2014
36
7
Washington, DC
LG V20
LG V30
After flashing this, script said success and tried to reboot. Now the phone is stuck at a black screen. Won't boot to fastboot, won't boot to recovery or anything. No vibration when plugging it in. Is there any way to recover from this or do I have a paperweight now?

My OP8 was in a similar state a few days ago. I was able to use the MSM tool on my old Windows 10 laptop (USB 2.0 ports) despite the phone giving me no feedback, it showed in Win10 device manager.

I started MSM before connecting it and my laptop indicated no issue and it flashed as normal in a few minutes. Despite that I bought an EDL cable on eBay a few days ago. After flashing I realized my battery was quite low but I had spent hours trying to reboot it into EDL mode.
 
Aug 19, 2020
5
0
I completed the process but the phone boots on fastboot everytime, I tried to wipe data and cache from the recovery but it didn't help. What could I try? Thanks!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    Things are changing with the advent of project treble and seamless updates. OnePlus will no longer release ROMs flashable via recovery (either stock) because is no more needed. The updates will be done on the slot not used for example if you are using slot a the update will be installed on slot b and the slot b will be set as default. If you brick and you are in bootloop how you can restore the rom? You can't with Stock ROM you have, because the zip can be only installed via Update Engine, so what can you do? Flash a stock rom via fastboot. I have extracted all images from the stock zip and i have made a new zip with the Fastboot ROM with a flash-all.bat included. This will work only if your bootloader is unlocked. This will erase all your data and will wipe your internal storage.

    HOW TO FLASH
    This version is only for not branded devices
    Download the zip;
    Unpack the zip in a folder;
    Reboot the OnePlus 8 in fastboot-bootloader mode (Power and volume + and volume-);
    Connect the OnePlus 8 to PC;
    Run flash-all.bat flasher you need;
    Wait until the process end;
    The phone will automatically reboot.


    DOWNLOAD

    All roms on Sourceforge: https://sourceforge.net/projects/fastbootroms/files/OnePlus 8

    BRANDED PHONE
    For now branded device are not supported

    MANUAL FLASH: Windows - OSX - Linux

    If you want to manual flash these roms these are the commands (You need the latest sdk platform tools, you can find it here

    Is reccomended to format data or the rom cannot boot:
    Code:
    fastboot -w
    Others Commands to flash a fastboot rom
    Code:
    fastboot flash aop aop.img
    fastboot flash bluetooth bluetooth.img
    fastboot flash boot boot.img
    fastboot flash dsp dsp.img
    fastboot flash dtbo dtbo.img
    fastboot flash LOGO LOGO.img
    fastboot flash modem modem.img
    fastboot flash oem_stanvbk oem_stanvbk.img
    fastboot flash qupfw qupfw.img
    fastboot flash storsec storsec.img
    fastboot flash multiimgoem multiimgoem.img
    fastboot flash uefisecapp uefisecapp.img
    fastboot flash recovery recovery.img
    fastboot --disable-verity flash vbmeta vbmeta.img
    fastboot --disable-verity flash vbmeta_system vbmeta_system.img
    fastboot flash opproduct opproduct.img
    fastboot reboot fastboot
    fastboot flash system system.img
    fastboot flash vendor vendor.img
    fastboot flash product product.img
    fastboot reboot

    REMEMBER
    "Invalid sparce file format at header magic" is not an error, you need to wait a bit when you see that string, just wait.

    If the device automatically reboot in Stock Recovery mode don't reboot it and wait the flash end.

    These ROMs can't be used to update or downgrade your phone but just to restore your phone.

    If the rom seems doesn't start go in recovery stock and follow this guideline: English -> Wipe data and cache -> Erase everything.

    If you want to rebrand your phone from HydrogenOS to OxygenOS you can follow this guide: Rebrand Guide

    If you want you can use also my tool to flash Factory Images, unlock bootloader, flash twrp or to understand if the device is recognized: https://toolaio.tk/

    If you got some problems like write error or no partition, check this: https://forum.xda-developers.com/showpost.php?p=76658555&postcount=34

    DONATE LINK

    If you want to support this and others my projects please consider making a donation, thanks.

    5
    Hi guys, i'm here again to ask for your support, actually with android 10 Google introduced a lot of changing, from dynamic partitions to the new keymaster 4 encryption/decryption. Teamwin is working hard to update TWRP but they will still take some time. Currently some things already work but there are difficulties in bringing them to the OnePlus 8/8 Pro, for example decryption already works but creates some problems on the OnePlus devices. That's why I decided to create a Paypal moneybox to be able to bring you the latest updates in the shortest time possible. As I have previously done, I assure you of a support of at least 2 years (within the limits of my possibilities). In addition to the TWRP I will improve the fastboot roms and add OnePlus 8/8 Pro to my TOOL ALL IN ONE (and maybe I will also bring the RevengeOS). By getting hold of a OnePlus 8 or 8 Pro I will also be able to improve the TWRP for OnePlus 7T and 7T Pro.

    OnePlus 8/8 Pro PayPal MoneyBox: https://www.paypal.com/pools/c/8pfrIOL3Qa

    If you are unable to participate in the PayPal moneybox, you can make a normal donation (perhaps specifying that it is for the moneybox), however all private donations that I will receive for this or other projects will be included in the moneybox.

    Private PayPal Donations: https://www.paypal.me/MauronofrioTool
    3
    Hi, I was hoping someone could upload the fastboot files, or even just the boot.img file for the international 10.5.11 rom as I am stuck in fastboot after taking the OTA and flashing Magisk to the other slot.
    I'm pretty sure its because I had xXx rom module enabled.
    Any help would be appreciated.

    I will upload them in the next hours
    1
    bro thanks for fastboot room for oneplus 8,i flash your fastboot room 10.5.9 everthing ok,but i relocked to boot loader it the phone be correpted. what should i do ,
    please help me.

    Unlock it again
    1
    Did you get lucky with this mate? I've got the same issue and it looks like that my OP8P (Unbranded, Europe) is not jumping into the fastbootd mode but just tries to start up normally which brings me to Qualcomm crashdump mode.

    I think it really stumbles here:
    <...>
    Finished. Total time: 0.047s
    Rebooting into fastboot OKAY [ 0.002s]
    < waiting for any device >
    fastboot: error: Failed to boot into userspace fastboot; one or more components might be unbootable.

    Sending 'abl' (1996 KB) OKAY [ 0.057s]
    Writing 'abl' FAILED (remote: 'Flashing is not allowed for Critical Partitions')
    fastboot: error: Command failed
    <...>

    Anyone has overcome it please?

    Please help me to unbrick my miserable OP8P...

    You do realize that these are for the 8 and not the 8 pro right? Also you can put your phone into fastboot mode without a command. When I tried to use these for the first time I kept getting errors and it would not flash properly but I found a post where the user had to use large address aware to patch all of the exe's in the folder to work properly on a 64bit pc, which is pretty ridiculous that we even have to do that but it worked.