• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM] [Stock] J320A/J320AZ/J320AG deodex'd

Search This thread

danny8

Senior Member
Feb 14, 2012
667
159
Houston
FRP issue / Cannot get into ODIN either

I used Flashfire to install this ROM. I also added the step to perform a system wipe at the same time with Flashfire. It seemed to install OK with no errors. However, I did not remove my Google accounts from the phone before flashing or wiping. This seems like a mistake in retrospect.

For my installer options, I did not install any ATT or Samsung bloat, but I did choose to install KNOX and Xposed mod.

The new ROM successfully booted after ten minutes. However, I encountered the FRP "Not signed in" dialog. Whenever I click the "SET UP PHONE" button, I'm returned to the same dialog.

I am trying to perform the steps in the "disable frp lock" thread. I downloaded the engroot boot image, but I cannot seem to install it. I cannot get into ODIN. Any help would be appreciated. In the meantime I will try to start my phone into the ODIN screen.

UPDATE 1: I got to ODIN mode. I was holding down only two buttons, I also needed to press the home button. I flashed the engroot image, rebooted (to black screen), and issued the dd command. Still trying to get my phone booted correctly; I still have black screen. Will update.

UPDATE 2: I flashed ENG_BOOT_J320A_PG1.tar over the engroot image and rebooted. Phone seems OK now. Phew.
 
Last edited:

mcmiller6

New member
Mar 11, 2018
4
0
Phone In Loop During Setup After Flash

So I'm a little late to the party, but I'm trying to flash this ROM. I chose my carrier (AT&T), SuperSU, Busybox, Init.d, nothing from Samsung, Chrome & Drive from Google, and nothing from AT&T. My phone got hung up in a loop going through the set up. It was asking me to log in, but whenever I hit the button, it would disappear for a moment then reappear. Did I miss something that I should have checked off from Samsung or AT&T? Thank you for your help.
 

mcmiller6

New member
Mar 11, 2018
4
0
I need to know which ones you installed and which ones you left out.

Chose: Carrier (AT&T), SuperSU, Busybox, Init.d, Chrome & Drive from Google

Ignored: All Samsung Bloat (AllshareFileShare, *Client, *Server; BackupRestoreConfirmation;BasicDreams; BBCAgent; ChocoEUKor; CollEUKor; EasyLauncher2_Zero; EasymodeContactsWidget; EasyOneHand3; EasySetup; GalaxyApps_3xh; HancomOfficeViewer; Hearingdro_V4; MobilePrintSvc_Samsung; PartnerBookmarksProvider; PhotoTable; RoseEUKor; SamsungAccount_Hero; SamsungBilling; SamsungDLPService; SamsungSans; SCloudService; SecEmail_M; SecLiveWallpapersPicker; SecMemo3; SecSetupWizard2015; SmartcardManager; SmartcardService; SNS_v2; SOAgent; SPPPushClient_Prod; Stk; VoiceNote_4.0; Weather2016; WeatherWidget2016), remaining Google apps (ChromeCustomizations, Gmail2; GoogleBackupTransport; GoogleCalendarSyncAdapter; GoogleFeedback; GoogleTTS; Hangouts; Maps; Music2; Photos; talkback, Velvet; Videos; YouTube), all AT&T Bloat (Aab; AmazonInstaller_ATT; AmazonKindle_vpl_ATT, AmazonShopping_vpl_ATT; DeviceHelp; DigitalLocker_ATT; Directv_vpl_ATT; DriveMode_ATT; ECID-release_ATT; FamilyMap_vpl_ATT; FamilyUtility_ATT; FullscreenVPL_ATT; Lookout_ATT; MILK_US; MobileLocate_ATT; MyATT_ATT; Plenti_vpl_ATT; ready2Go_64_ATT; RemoteSupport_ATT; SecAcms; SecVVM; SmartLimits_ATT; SmartWifi_vpl_ATT; Telenav_vpl_ATT; Uber_vpl_ATT; UsageManager3; VideoTrimmer_Phone; WildTangent_ATT; Wispr_ATT; wssyncmldm; wssyncmlds; YPMobile_vpl_ATT), all Cricket bloat, all CSpire bloat.
 

S43suk3

Member
Nov 26, 2017
5
0
it doesn't look like you missed any important google apps, so I'm not sure but i think you should first try to clear the cache and wipe the data from recovery mode and then try it again. If that doesn't work than with Odin flash android 6.0.1 back on your phone and try to do the process again but this time, try it with the easysetup.apk from the Samsung bloatware
 

mcmiller6

New member
Mar 11, 2018
4
0
it doesn't look like you missed any important google apps, so I'm not sure but i think you should first try to clear the cache and wipe the data from recovery mode and then try it again. If that doesn't work than with Odin flash android 6.0.1 back on your phone and try to do the process again but this time, try it with the easysetup.apk from the Samsung bloatware

Sorry for the long time between responses. It takes me a while to find time to work on the phone. I appreciate the help. I tried what you said, multiple times, just to make sure and I ended up with the same problem each time. At this point, I'm just looking for a simple ROM. It's my old phone that I use to listen to music when I'm doing work around the house or mowing the lawn. If there's another suggestion for a bare-bones ROM, I'll give that a try. Thank you, again, for all your help.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Today i bring you the very first rom for our device.
    It's only stock, but the installer includes enough options to keep us happy for a while.

    The core installation includes a stripped down system menu with Google play and contacts. I also added, by default, the WiFi fix and hotspot mod. The rest of what you install is your choice.

    Aroma options:
    Choose which J320 you own
    Debloat (fully customizable)
    Deknox
    Install root
    Install busybox
    Install Init.d
    Install Xposed

    Bugs:
    None
    If you find any let me know, but if you do not wipe, please don't even report bugs.

    Link:
    Download

    Installation:
    Flashfire


    Enjoy
    -D
    3
    Can anyone -- or DamienMc, the creator -- post a review of how this ROM is working out? Brief or long; any type of review would be appreciated.

    Any feedback or commentary is welcome. Thank you for your consideration.

    I'm not going to review it (someone else can)
    But I used it heavily before I started work on something new.
    It's as stable as stock... cause it is stock ;) Nothing tweaked just the few add-ons to let you tweak it easier.

    About the bloat.
    I did notice I should have left Samsung account (and maybe billing) with the standard install. Because you can't use the theme store without them. But they're in 'bloat'.

    You can always install all the debloat options and have 100% deodex stock and edit to your liking.

    could it work on J320H?
    i know it's for 320A/Az but i want to try it:D

    Sorry bud, different chipset
    1
    I have AT&T Samsung Galaxy Express Prime GoPhone, J320A. Owned it for one week. It has been carrier-unlocked. I'm now using T-Mobile SIM. Seems to work OK. Only issue I can find is where the SIM status page does not show my phone number.
    I would appreciate pointers or maybe a place to look for installation steps. I assume I'll to need to root via Kingroot then replace with SuperSU (if possible). Then install FlashFire.​
    I have rooted and installed ROMs on other devices (Galaxy Exhibit, 2012 Nexus tablet, Moto G), but seemingly devices are more locked-down these days. I understand that TWRP is not available for this device and likely will not be.

    Last year, I bought a couple of inexpensive T-Mobile phones and "rooted" them with KingRoot which is still installed on those phones. (Not really thrilled about that.) I put rooted in quotes because it doesn't quite behave like a fully-rooted phone, IMO. I'm not very expert in these things, but I know how to follow steps and have used ODIN, TWRP, et cetera.

    I'm leery of working with these more locked-down phones. Am I being paranoid and/or incorrect about these matters?

    BTW, thanks for the ROM! I'm surprised there aren't more replies.

    Maybe this phone is not as popular as I think it should be. Maybe it's too low-spec for the tech-savvy crowd. I got mine for just $64 at Walmart online, but they've since raised the price to $79. Seems like a good deal, even at that price.

    I paid $15 to carrier-unlock it. I had to flash firmware (modem file?) before unlocking, then flash another file (restored modem?) after unlocking. I was following emailed instructions after the initial unlock procedure failed.
    1
    Here's the root thread
    https://forum.xda-developers.com/galaxy-j3-2016/how-to/root-samsung-sm-j320a-galaxy-express-t3573628
    There's a xposed module that does just that, never tried it tho, and of course it's not permanent.
    https://forum.xda-developers.com/ga...pp-sim-changer-change-registered-sim-t2106490

    I definitely like the phone and yeah, it's a good price.
    Being locked does hurt it tho. No easy recovery and no roms from source. The only thing we might get will be ported. And with no kernel, porting is a pain to track down problems... but i like a challenge ;)